14:01:17 <amoralej> #startmeeting RDO meeting - 2021-09-29
14:01:17 <opendevmeet> Meeting started Wed Sep 29 14:01:17 2021 UTC and is due to finish in 60 minutes.  The chair is amoralej. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:17 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:17 <opendevmeet> The meeting name has been set to 'rdo_meeting___2021_09_29'
14:01:22 <amoralej> #topic roll call
14:02:42 <rdogerrit> Ananya Banerjee proposed rdo-infra/ci-config master: Adds component criteria for master on c9 stream  https://review.rdoproject.org/r/c/rdo-infra/ci-config/+/35832
14:02:43 <jcapitao> o/
14:02:51 <amoralej> #chair jcapitao
14:02:51 <opendevmeet> Current chairs: amoralej jcapitao
14:03:47 <ykarel> o/
14:04:24 <amoralej> #chair ykarel
14:04:24 <opendevmeet> Current chairs: amoralej jcapitao ykarel
14:04:34 <amoralej> spotz, around?
14:04:49 <amoralej> ah, i think she wasn't available today
14:04:51 <amoralej> let's start
14:05:08 <amoralej> #topic Update about RDO Xena preparation
14:05:22 <amoralej> #link https://review.rdoproject.org/etherpad/p/xena-release-preparation
14:05:41 <amoralej> #info Yoga CloudSIG tags are created https://cbs.centos.org/koji/search?match=glob&type=tag&terms=*yoga*
14:05:59 <amoralej> #info tempest projects and non-openstack puppet modules bits are built
14:06:18 <jcapitao> we are waiting for RC1 puppet modules to be released
14:06:30 <jcapitao> M3 patch was merged a few hours ago https://review.opendev.org/c/openstack/releases/+/810891
14:06:36 <amoralej> is there any ongoing patch for it?
14:06:39 <amoralej> ah, ok
14:06:45 <jcapitao> nope for RC1 yet
14:06:50 <amoralej> we should get the puppet-swift fix
14:06:52 <amoralej> for xinetd
14:07:00 <amoralej> in rc1, it'd be cool
14:07:01 <jcapitao> yes hopefully
14:07:31 <rdogerrit> Ananya Banerjee proposed config master: Add the CentOS-9 container build job in periodic line  https://review.rdoproject.org/r/c/config/+/35817
14:08:02 <jcapitao> I asked to rename the buildtarget tag for Yoga CS8
14:08:06 <jcapitao> https://pagure.io/centos-infra/issue/463
14:08:27 <rdogerrit> Ananya Banerjee proposed rdo-jobs master: Adding pipeline and jobs for c9 stream  https://review.rdoproject.org/r/c/rdo-jobs/+/35831
14:08:56 <rdogerrit> Ananya Banerjee proposed config master: Add the CentOS-9 container build job in periodic line  https://review.rdoproject.org/r/c/config/+/35817
14:09:21 <jcapitao> otherwise we'll have to add conditional statement to handle Yoga release in our scripting tool
14:09:57 <amoralej> jcapitao, i left a comment
14:10:16 <amoralej> i'd prefer to keep consistent with other releases in cs8 and maintain el8
14:10:24 <ykarel> +1
14:11:04 <jcapitao> yes it'd be effortless for us
14:11:18 <jcapitao> thx for the comment
14:11:45 <spotz> amoralej: Morning!:)
14:11:59 <amoralej> hi spotz
14:12:09 <amoralej> sorry for pinging you :)
14:12:22 <amoralej> #chair spotz
14:12:22 <opendevmeet> Current chairs: amoralej jcapitao spotz ykarel
14:13:20 <spotz> amoralej: It's ook I was starting to wake up:)
14:13:27 <amoralej> spotz, btw, it may be a good time to create the etherpads for xena GA, announcncement and all that
14:13:58 <jcapitao> spotz: you're not in Seattle for OS Summit ?
14:14:21 <spotz> I can pull up the old ones and prepopulate
14:14:39 <spotz> jcapitao: I am! An Spenccer has some fans:)
14:16:00 <jcapitao> spotz: nice !
14:16:18 <amoralej> good
14:16:22 <amoralej> is it going well?
14:17:31 <amoralej> ok, let's continue with the topic
14:17:41 <amoralej> anything else to share jcapitao ?
14:18:05 <jcapitao> amoralej: that's all
14:18:13 <ykarel> jcapitao, amoralej wrt pipelines
14:18:53 <ykarel> do we still need both phase 1 and puppet promotion pipeline for xena, considering TripleO jobs will not be there for xena
14:19:18 <amoralej> mmm
14:19:53 <amoralej> good question
14:20:00 <amoralej> so we need puppet-promotion
14:20:02 <amoralej> for sure
14:20:09 <amoralej> and i think that will be it
14:20:17 <amoralej> as there will not be tripleo jobs
14:20:24 <amoralej> there is no point in doing rdo phase 1
14:20:28 <amoralej> wdyt?
14:20:44 <ykarel> yes i think the same, just need to update puppet promotion criteria to include packstack scenario002 and 003
14:21:24 <ykarel> and may also point current-tripleo-rdo and current-passed-ci to puppet-passed-ci in case someone looking for those links
14:21:56 <amoralej> yes
14:21:59 <amoralej> +1
14:22:12 <rdogerrit> Ananya Banerjee proposed config master: Add new pipeline for CentOS Stream 9  https://review.rdoproject.org/r/c/config/+/35817
14:22:26 <amoralej> #info there will be only one promotion pipeline for RDO Xena based on puppet and packstack jobs
14:22:49 <amoralej> #info current-tripleo-rdo and current-passed-ci will symlink to that puppet promotion
14:22:54 <amoralej> ykarel, jcapitao ^ is it clear?
14:23:04 <jcapitao> yes +1
14:23:05 <ykarel> yes looks fine
14:23:47 <amoralej> anything else wrt xena?
14:24:18 <ykarel> just that noticed requirements branch patch ready https://review.opendev.org/c/openstack/releases/+/810925
14:24:25 <ykarel> so it can be anytime this week
14:24:46 <amoralej> good
14:26:00 <ykarel> ok let's move to next
14:26:08 <jcapitao> we can move on yes
14:26:10 <amoralej> #topic Update about CentOS Stream 9
14:27:09 <amoralej> #info bootstrap for RDO- Trunk centos9-master is finished
14:27:25 <amoralej> #link https://trunk.rdoproject.org/centos9-master/report.html
14:28:18 <amoralej> #info adding support for CS9 in dib https://review.opendev.org/c/openstack/diskimage-builder/+/811392
14:28:49 <amoralej> so from RDO side, we are waiting for more cbs builds for rabbit and some opstool
14:29:10 <ykarel> and ceph to be tagged to -testing, or is already tagged?
14:29:21 <amoralej> lemme check again
14:29:38 <amoralej> not yet
14:29:49 <amoralej> other than that, not much progress
14:30:01 <amoralej> we are adding new package openstack-network-scripts
14:30:13 <amoralej> that's probably the more relevant in the last days
14:31:41 <amoralej> any question or something i missed related to cs9?
14:33:09 <amoralej> let's move to next topic
14:33:16 <ykarel> yeap
14:33:31 <amoralej> #topic Status of new dependencies process implementation
14:34:09 <amoralej> #info https://review.rdoproject.org/etherpad/p/c9-deps-automation
14:34:17 <amoralej> so, we've done good progress
14:34:35 <rdogerrit> Merged config master: Add new pipeline for CentOS Stream 9  https://review.rdoproject.org/r/c/config/+/35817
14:34:38 <amoralej> we have now all jobs required to validate and build deps from distgits
14:35:20 <amoralej> #link https://review.rdoproject.org/r/q/topic:%22new-deps%22+(status:open%20OR%20status:merged)
14:35:32 <jcapitao> good !
14:35:36 <amoralej> so, next steps are creating all the repos
14:35:44 <amoralej> https://review.rdoproject.org/r/c/config/+/35880
14:35:55 <amoralej> pushing latest content from git.centos.org
14:36:21 <amoralej> and finally review https://review.rdoproject.org/r/c/config/+/33518
14:36:34 <amoralej> and https://review.rdoproject.org/r/c/config/+/33504
14:36:47 <amoralej> also, we'll need to document the new process in www.rdoproject.org
14:37:39 <amoralej> also, i have doubts about what to do about branching
14:37:49 <amoralej> so, once we move to yoga tags
14:38:01 <amoralej> should we create c9s-yoga-rdo branch for all deps?
14:38:07 <amoralej> from c9s-xena-rdo
14:38:09 <amoralej> i'd say so
14:38:23 <ykarel> yes +1
14:39:52 <jcapitao> what would be the other way ?
14:39:58 <amoralej> just wait
14:40:02 <amoralej> and create them on demand
14:40:20 <amoralej> although if we plan to automate updates... we need to pre-create the branches
14:41:03 <amoralej> btw, i'd also like to check deps we have in cs9 compared with u-c
14:41:08 <amoralej> using jcapitao script
14:41:53 <jcapitao> in dashboard ?
14:41:57 <amoralej> yes
14:42:09 <amoralej> well, dashboard or running it ad-hoc for it
14:42:21 <amoralej> anyway, we should do a new dashboard for cs9
14:42:27 <jcapitao> I'll proposed another one yes
14:42:30 <amoralej> the one we have checks cs8, right?
14:43:33 <jcapitao> yes
14:44:11 <jcapitao> https://github.com/rdo-infra/rdo-dashboards/commit/86e16c9b98c55dea3c21b556fb0a2a25ce6b23af
14:44:24 <amoralej> ack
14:44:46 <amoralej> #action jcapitao to create a new dashboard for reporting deps status vs u-c in centos9-master
14:44:57 <amoralej> ok, let's move to open floor
14:45:03 <amoralej> #topic open floor
14:45:28 <amoralej> any volunteer to chair next week?
14:45:33 <ykarel> i can do it
14:45:43 <amoralej> #action ykarel to chair next week
14:46:03 <amoralej> anything for open floor?
14:47:04 <spotz> I put the wallaby rrelease up to give us a base for xena #link https://review.rdoproject.org/etherpad/p/xena-release-announcement
14:47:42 <amoralej> thanks spotz++
14:47:52 <amoralej> #link https://review.rdoproject.org/etherpad/p/xena-release-announcement
14:52:52 <amoralej> i'm closing the meeting
14:53:00 <amoralej> and giving you some minutes back
14:53:07 <amoralej> thanks all for joining
14:53:16 <jcapitao> thank you amoralej
14:53:23 <amoralej> #endmeeting