14:00:36 <ykarel> #startmeeting RDO meeting - 2021-10-13
14:00:37 <opendevmeet> Meeting started Wed Oct 13 14:00:36 2021 UTC and is due to finish in 60 minutes.  The chair is ykarel. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:37 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:37 <opendevmeet> The meeting name has been set to 'rdo_meeting___2021_10_13'
14:01:04 <ykarel> Add last minutes topic to https://etherpad.opendev.org/p/RDO-Meeting
14:01:10 <ykarel> #topic roll call
14:01:12 <jcapitao> o/
14:01:17 <ykarel> #chair jcapitao
14:01:17 <opendevmeet> Current chairs: jcapitao ykarel
14:01:30 <amoralej> o/
14:01:43 <ykarel> #chair amoralej
14:01:43 <opendevmeet> Current chairs: amoralej jcapitao ykarel
14:02:13 <spotz> o/
14:02:23 <ykarel> #chair spots
14:02:23 <opendevmeet> Warning: Nick not in channel: spots
14:02:23 <opendevmeet> Current chairs: amoralej jcapitao spots ykarel
14:02:42 <ykarel> #chair spotz
14:02:42 <opendevmeet> Current chairs: amoralej jcapitao spots spotz ykarel
14:04:11 <rdogerrit> Merged rdoinfo master: Rebuild ansible-collection-ansible-posix to 1.3.0  https://review.rdoproject.org/r/c/rdoinfo/+/36237
14:04:25 <ykarel> Ok let's start with topics
14:04:31 <ykarel> #topic Xena Updates
14:05:14 <ykarel> #info Xena GA builds(except TripleO) are tagged to -release and now available in CentOS mirrors
14:05:28 <ykarel> #link http://mirror.centos.org/centos/8-stream/cloud/x86_64/openstack-xena/
14:05:45 <ykarel> #info Puppet Promotion pipeline for Xena is created
14:05:55 <ykarel> #link https://jenkins-cloudsig-ci.apps.ocp.ci.centos.org/view/puppet-promotion-pipelines/view/Puppet%20Promotion%20Xena/
14:06:08 <ykarel> #info non-openstack puppet modules are unpinned for yoga
14:06:20 <ykarel> #info tempest and tempest plugins are being unpinned for yoga
14:06:29 <ykarel> #link https://review.rdoproject.org/r/c/rdoinfo/+/36230
14:06:51 <ykarel> jcapitao anything to add on ^?
14:07:30 <jcapitao> that's all yeah
14:07:51 <ykarel> okk good
14:07:52 <ykarel> For TripleO we need to follow up with TripleO Team for tags suitable for Xena, and once we have those we can work on TripleO bits and RDO xena release
14:08:26 <ykarel> ok That's it for xena updates
14:08:45 <ykarel> marios do you have any updates for ^?
14:09:13 <marios> ykarel: o/
14:09:15 <ykarel> i think i saw some discussion around this on TripleO meeting but didn't follow
14:09:20 <ykarel> #chair marios
14:09:20 <opendevmeet> Current chairs: amoralej jcapitao marios spots spotz ykarel
14:09:22 <marios> ykarel: was discussed in yesterday tripleo-ci meeting
14:09:41 <marios> ykarel: basically tripleo will be making a release soon for the repos
14:09:57 <ykarel> marios, ok Thanks, so sometime this week or early next week, right?
14:10:14 <marios> ykarel: not sure if it will happen this week, might be more like late next week or the one after
14:10:17 <marios> ykarel: ptg on monday
14:10:46 <marios> ykarel: but that is around the time tripleo would have branched anyway (always trailing the release by a few weeks)
14:10:55 <marios> ykarel: are you blocked on this somewhere? /me reads back
14:11:01 <ykarel> marios, ohkk keep us updated
14:11:17 <jcapitao> thanks marios
14:11:19 <ykarel> marios, so for announcing RDO release we waiting on TripleO bits
14:11:21 <marios> sure np
14:11:46 <spotz> We are just eliminating any confusion like from Wallaby release
14:11:46 <marios> ykarel: oh i see
14:12:05 <marios> ykarel: maybe you don't want to block on that ? can we word it like 'once those are available from tripleo we will make them known' or something
14:12:46 <ykarel> marios, we discussed in past that we will wait for TripleO bits until we announce the release
14:12:51 <marios> ykarel: k
14:13:10 <amoralej> kolla is also unreleased, right?
14:13:20 <ykarel> yes i think
14:13:43 <jcapitao> yep not released yet
14:13:43 <ykarel> that also trailing so releases later
14:14:08 <amoralej> yep
14:14:12 <marios> ykarel: i just pinged slagle about that in tripleo but if that is the only thing you are waiting for (i.e. the tags for tripleo) personally i wouldn't block on it
14:14:22 <spotz> Yeah none of the trailing deployment projects are released yet
14:14:40 <marios> ykarel: it is informational right? I mean it doesnt block the rdo release process on a technical level does it?
14:14:57 <marios> ykarel: but if you prefer to wait then it means it may not happen until after ptg as i said above.
14:15:18 <marios> ykarel: i am pretty sure in the past the rdo release was announced before the tripleo release...
14:15:45 <ykarel> from past couple of releases atleast we wait for TripleO
14:16:08 <ykarel> marios, The only issue i see in delaying TripleO is:- if there are dependencies in puppet projects which will not be backported to stable/xena
14:16:14 <ykarel> then we will have issues
14:16:31 <amoralej> marios only once, it's not a problem to wait a bit on tripleo
14:17:19 <marios> amoralej: ok
14:17:38 <mwhahaha> since tripleo isn't really releasing xena can't we just add a note saying there is no official tripleo release as part of the xena release?
14:17:41 <mwhahaha> and not bother waiting?
14:18:08 <mwhahaha> doesn't make sense to wait on a project that isn't releasing
14:18:09 <amoralej> mwhahaha, the initial plan was to create builds for the tags and include the notes in release notes
14:18:15 <mwhahaha> just don't
14:18:45 <mwhahaha> it never made sense when that was brought up either. it's better to say there is no official release for xena and move on with life
14:19:25 <spotz> As long as we have a working release I'm ok with that. If we need the tags and bits included then we need to wait
14:19:59 <mwhahaha> if puppet's been release we'd have at least one deployment tool
14:20:44 <amoralej> mwhahaha, so skipping tripleo from xena is an option, but according to conversations in the past, the plan was to include builds for the tags created after GA and including a note there will be no updates of patches during the entire xena cycle
14:20:57 <amoralej> if tripleo project prefers not to have any build in RDO in Xena
14:21:06 <mwhahaha> and i thought we were just going to take a promotion and call it done
14:21:07 <amoralej> it'd be an option
14:21:17 <mwhahaha> we've had multiple, just take the last one?
14:21:24 <amoralej> but that's not what whas discussed, or at least what i understood
14:21:29 <marios> if we make a release soon it would be good to just have that version as the 'base' xena tripleo bits
14:21:34 <marios> even if we dont have an actual xena
14:21:58 <spotz> Let's just wait for afterr the PTG if neccessary to get the bits
14:22:00 <mwhahaha> i had not heard about creating set of release tags
14:22:40 <ykarel> iirc it was on mailing list
14:22:49 <marios> mwhahaha: we put it in the spec too
14:22:51 <amoralej> "TripleO would no longer be able to deploy all versions of OpenStack. One idea that was brough forth in the discussions around this topic thus far, is that we can attempt to address this by designating a range of git tags as compatible with a particular OpenStack stable branch."
14:22:57 <amoralej> from https://specs.openstack.org/openstack/tripleo-specs/specs/xena/tripleo-independent-release.html
14:23:06 <mwhahaha> right git tags e.g. hashes from a last promotion
14:23:11 <marios> https://github.com/openstack/tripleo-specs/blob/master/specs/xena/tripleo-independent-release.rst#other-end-user-impact
14:23:37 <mwhahaha> if you actually meant cut a real release and have official tags (not git hashes) then we need to have someone assigned to do that
14:23:51 <amoralej> no
14:23:52 <marios> mwhahaha: i think we just need to make a release for all our repos
14:23:55 <amoralej> just tags on master branch
14:24:08 <mwhahaha> just tags on master == git hash right?
14:24:17 <marios> mwhahaha: and that will make tags i.e. when you release it tags that version in the repo
14:24:40 <mwhahaha> ok so someone just propose it
14:24:53 <marios> mwhahaha: yeah slagle said he would
14:24:54 <mwhahaha> like you san say you're waiting or just propose a release. anyone can do so
14:25:30 <marios> mwhahaha: sure i can do it i offered to already so waiting to see what slagle says
14:26:06 <mwhahaha> k i think we've wasted more time talking about it than just proposing it now
14:26:14 <spotz> heheh
14:26:15 <ykarel> :)
14:26:16 <marios> ;) not quite but sure ...
14:26:50 <marios> we can get that proposed ... i was more trying to understand if it is technical blocker or just informational
14:27:00 <marios> but if we are saying we need the tags to build the 'xena' versions for tripleo things
14:27:04 <marios> then it is technical
14:27:25 <marios> not just so we can provide a list of tags if someone brave will try tripleo for Xena
14:27:32 <ykarel> yes we need to do branching and builds for TripleO once tags are available
14:28:47 <mwhahaha> i just don't get why this is any different than our 3rd party puppet tags were we just specify a hash and that's what gets shipped. other than we want to create actual version numbers
14:29:09 <mwhahaha> seems like self inflicted over thinking
14:29:31 <mwhahaha> and if we arne't shipping xena containers with tripleo, it's actually pointless
14:29:31 <marios> mwhahaha: it kind of is that... it is trying to mitigate the 'we don't support xena' ...
14:29:40 <marios> mwhahaha: if you really want to you can use this as a base ...
14:30:24 <mwhahaha> right how is that any different that speficing a non-updated git hash which is exactly what we do for like other puppet modules
14:30:34 <marios> 'it kind of is that' i mean self inflicted over thinking but as i said it was just by way of mitigation for fallback against tripleo doesn't support  X
14:30:35 <mwhahaha> the realitiy is that we (tripleo) dont' support xena
14:30:54 <ykarel> i think for third party we don't have much control over tags and it's just more work we have to do in distgits for that
14:30:55 <mwhahaha> but that's exactly what we did with the spec
14:31:19 <ykarel> but for TripleO i think it's doable, considering those a xena release tags or yoga base tags
14:31:56 <amoralej> mwhahaha, marios so there will be a containers set for xena?
14:31:58 <mwhahaha> the truth is tripleo is going to pick supporteed versions going forward and xena isn't it. so we should convey that
14:32:08 <amoralej> or it's just the master ones closer to xena release?
14:32:16 <amoralej> created from master or stable/xena?
14:32:18 <mwhahaha> afaik no we won't
14:32:22 <mwhahaha> which is why this is moot
14:32:28 <marios> amoralej: no there is no xena build
14:32:31 <mwhahaha> someone would have to build there own
14:32:43 <mwhahaha> and you'd just specify the xena repos and call it good
14:32:49 <marios> amoralej: it would have to be something from master, or right use the X marked tripleo repos to build the containers
14:33:17 <amoralej> actually, that's what we'd test in promotion gating
14:33:35 <amoralej> creating container from xena builds and running some tripleo jobs
14:33:37 <amoralej> from those
14:34:03 <amoralej> i still think it's ugly to skip tripleo in two out of three rdo releases
14:34:20 <mwhahaha> that's what was agreed on in the spec basically to switch to independent
14:34:25 <amoralej> but at the end if tripleo project prefer not to release any package in xena
14:34:47 <amoralej> we'll release it without tripleo
14:35:00 <ykarel> +1
14:35:29 <amoralej> wrt having release numbers instead of just git hash, it's also a way to make it easy to mark commits as "last known good" for xena
14:35:35 <amoralej> and make rdo life easier
14:35:50 <amoralej> and, btw, we'll also need to pin xena RDO Trunk to those
14:35:52 <mwhahaha> so it's best to take all the hashes from a last promotion and use those
14:35:53 <amoralej> that was the plan
14:36:07 <mwhahaha> because those are the last known good
14:36:39 <amoralej> iiuc, the plan was to take the hashes from last promotion -> create git tags -> build packages
14:36:53 <mwhahaha> ok so who cna provide the last promotion?
14:36:59 <mwhahaha> cause that won't be slagle
14:37:18 <amoralej> if there is some reason not to create any numbered tags, can be created from commit hashes, said this, i prefer numbers and tarballs from tarballs.openstack.org
14:37:32 <amoralej> that's what we use for cloudsig builds
14:37:53 <mwhahaha> so if we want to get this done, we need the hashes from CI, someone (i, slagle, anyone) can propose a release with those and we merge it
14:37:54 <amoralej> i think tripleo-ci, that's why it was discussed in tripleo-ci meeting i guess
14:38:21 <mwhahaha> i thought that was going to be the process but we seem to be lacking names with these action items
14:38:30 <marios> mwhahaha: we can provide that np i mean promotions are happening pretty often lately
14:38:49 <mwhahaha> marios: please give me the last one and we'll just use that
14:38:53 <spotz> Do we maybe want to schedule some time at the PTG to discuss?
14:39:15 <mwhahaha> the next release would in theory be an actual release for tripleo so the process wouldnt' be this one
14:39:18 <marios> spotz: yeah might be worth some time on this perhaps on the last day if there is extra time
14:39:36 <mwhahaha> but yes we probably should be explicit about what to do in these intermediate releases as it seems to not be so clear on who/when
14:40:26 <ykarel> latest promotion https://trunk.rdoproject.org/centos8-master/current-tripleo/dc/db/dcdb019b4afae2823a876d19564194c4/
14:41:03 <ykarel> versions.csv contains commit hashes for all the packages including TripleO ones
14:41:23 <marios> thanks ykarel
14:41:48 <mwhahaha> thanks i'll propose a puppet-tripleo metadata update and get the release file together.
14:41:59 <ykarel> Thanks mwhahaha marios
14:42:56 <ykarel> #action mwhahaha will be proposing patch for TripleO xena tags
14:43:03 <ykarel> ok let's move to next topic
14:43:17 <ykarel> #topic PTG Reminder
14:43:37 <ykarel> spotz, it's yours ^
14:44:20 <spotz> Just a reminder the PTG is next week. Go to sessiions like it seems we need with TripleO:) Sign up for the social
14:44:20 <ykarel> #link https://eventyay.com/e/e7299da7
14:44:23 <spotz> #link  https://eventyay.com/e/e7299da7
14:44:40 <spotz> hehe even if it goes very badly we'll have a lot of fun
14:44:56 <spotz> So that's it on PTG
14:45:01 <spotz> #topic SWAG
14:45:38 <spotz> Everyone who contributed to Wallaby should have received an email with a code last night. If you didn't nd you contributed contact me, same if you have any issues.
14:47:24 <ykarel> yeap got the mail
14:47:41 <ykarel> and ordered too :)
14:48:23 <jcapitao> yeah me too :)
14:48:47 <ykarel> Ok i think that's on it, let's move to next
14:48:56 <ykarel> #topic chair for next week
14:49:00 <ykarel> any volunteer?
14:49:21 <jcapitao> I can take it
14:49:26 <ykarel> Thanks jcapitao
14:49:27 <spotz> FYI just propsed the released topic on the TripleO etherpad in case there is time
14:49:33 <ykarel> #action jcapitao to chair next week
14:49:34 <spotz> Do we want to skip for PTG?
14:50:55 <ykarel> #topic open floor
14:51:00 <ykarel> spotz, sorry didn't got, links please
14:51:19 <spotz> #link https://etherpad.opendev.org/p/tripleo-yoga-topics
14:52:16 <ykarel> ohkk got it now
14:52:49 <ykarel> would be helpful when preparing release announcement
14:54:44 <spotz> Just for clarity if they have time I figure it can't hurt for both teams to meet and just get a plan for going forward
14:55:50 <ykarel> i think it's mostly clear as bits are currently being tagged as planned and as mentioned in spec
14:55:57 <ykarel> but yes ok for everyone to be on same page
14:56:05 <ykarel> so there is no more confusion
14:56:15 <spotz> And if it dooesn't happen that's fine, too
14:56:21 <ykarel> yeap
14:57:16 <ykarel> we would just need to frame the release announcement to reflect TripleO + Xena situation whether at PTG or after it both fine
14:58:58 <ykarel> Ok we are almost at time, /me closes
14:59:01 <ykarel> Thanks everyone
14:59:07 <ykarel> #endmeeting