14:01:26 <jcapitao> #startmeeting RDO meeting - 2021-10-20
14:01:26 <opendevmeet> Meeting started Wed Oct 20 14:01:26 2021 UTC and is due to finish in 60 minutes.  The chair is jcapitao. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:26 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:26 <opendevmeet> The meeting name has been set to 'rdo_meeting___2021_10_20'
14:01:33 <amoralej> o/
14:01:37 <jcapitao> #topic roll call
14:02:33 <jcapitao> #chair amoralej
14:02:33 <opendevmeet> Current chairs: amoralej jcapitao
14:03:04 <ykarel> o/
14:03:53 <jcapitao> #chair ykarel
14:03:53 <opendevmeet> Current chairs: amoralej jcapitao ykarel
14:04:01 <jcapitao> spotz[m]: around ?
14:05:46 <jcapitao> let's start with our first and unique topic
14:06:00 <jcapitao> #topic Xena Updates
14:06:30 <spotz_> o/
14:06:40 <jcapitao> #chair spotz_
14:06:40 <opendevmeet> Current chairs: amoralej jcapitao spotz_ ykarel
14:06:44 <spotz_> grabbing ccoffee:)
14:06:54 <jcapitao> #info centos-release-openstack-xena rpm - we are waiting for the build and publish to extras
14:07:07 <jcapitao> so our centos-release-openstack-xena rpm should be shipped soon in -extras CentOS repo
14:07:37 <jcapitao> it's still not in -extra currently
14:07:47 <ykarel> i see it's build so just waiting on push
14:07:50 <ykarel> https://koji.mbox.centos.org/koji/buildinfo?buildID=19575
14:08:31 <jcapitao> good, should be tomorrow then
14:08:48 <jcapitao> by tomorrow at least
14:08:56 <ykarel> yes hope so
14:09:01 <jcapitao> #info TripleO bits are built and being tested
14:09:13 <jcapitao> #link https://review.rdoproject.org/r/c/rdoinfo/+/36340
14:09:29 <jcapitao> I see were hitting issue with registry, is that right ?
14:10:00 <ykarel> standalone jobs ran fine, but undercloud job neededed some work
14:10:18 <ykarel> as build_container_images not being tested yet with undercloud job
14:10:44 <ykarel> yes issues are related to build containers and settings for local registry
14:11:21 <ykarel> i am hoping current run will pass, and then will update patches by removing WIP
14:11:33 <amoralej> what kind of issues?
14:12:08 <amoralej> i mean, we should not fetch containers from registry
14:12:12 <amoralej> or push
14:12:14 <amoralej> right?
14:12:19 <ykarel> amoralej, local registry issues
14:12:25 <amoralej> ah, local one
14:12:28 <ykarel> yes
14:12:52 <amoralej> what's the difference between scenario001 and the rest?
14:12:54 <amoralej> 001 passed
14:13:08 <ykarel> amoralej, all standalone scenarios passed
14:13:19 <ykarel> just support was missing in undercloud containers job
14:13:26 <ykarel> for that adding with https://review.opendev.org/c/openstack/tripleo-quickstart-extras/+/814699
14:14:01 <amoralej> ah, sorry, i was looking at last execution that failed in standalone too
14:14:08 <ykarel> https://review.rdoproject.org/r/c/rdoinfo/+/36340/1#message-1de76ae94ec6932e0a728439db6574abe8ed0ea7
14:14:29 <amoralej> yes, i just saw it
14:14:31 <amoralej> thanks
14:14:53 <amoralej> it's worthy to wait for it to promote?
14:15:56 <ykarel> i think it's close to go green
14:16:18 <ykarel> but we can proceed without waiting for merge of upstream patches once we see green results
14:17:01 <amoralej> lgtm
14:17:04 <ykarel> tomorrow afternoon i think should be ready along with centos-release-openstack-xena rpm in extras repo
14:19:41 <jcapitao> let's see if that run goes green
14:20:25 <jcapitao> #info Situation of Xena in RDO is being documented in
14:20:32 <jcapitao> #link https://review.rdoproject.org/r/c/rdo-website/+/36342
14:21:08 <amoralej> i've proposed that review to collect information about tripleo on xena
14:21:11 <amoralej> please review
14:21:19 <amoralej> i'd like to get it published before announcement
14:21:31 <amoralej> so that we can link it
14:21:52 <jcapitao> good idea
14:22:08 <amoralej> i'm still testing the procedure to create container
14:22:08 <spotz_> Let's share that link in the PTG session later
14:22:21 <amoralej> ykarel has proposed some improvements
14:22:26 <amoralej> ack
14:22:29 <amoralej> good idea spotz_
14:22:47 <amoralej> i added tripleo ptl but good to do it in the meeting
14:23:00 <spotz_> They're doing CI and CS9 now, wish we were back to back with that
14:25:29 <jcapitao> maybe we could add the status of the first (and last) promotion (once done), to show that ooo bits have been tested at least once
14:26:53 <amoralej> the better place is the review
14:26:57 <amoralej> getting the results
14:27:10 <amoralej> yes, we can point to the review
14:27:25 <spotz_> jcapitao: were you thinking somewhere oon the website or something else?
14:27:27 <ykarel> yes review is the only place where we testing cloudsig bits
14:28:25 <ykarel> so can link that review
14:28:55 <jcapitao> spotz_: just the link pointing to the review in amoralej note
14:29:08 <ykarel> wrt promotion, tripleo was testing xena for full xena development cycle, it just didn't branched
14:29:27 <spotz_> jcapitao: Ahh ok was thinking if you wanted a 'permanent' notation for the release
14:30:04 <jcapitao> ykarel: worth to mention indeed
14:32:13 <jcapitao> I think we're done for this topic
14:33:06 <jcapitao> #topic Chair for next week
14:33:19 <amoralej> i can take it
14:33:34 <jcapitao> thanks amoralej
14:33:39 <spotz_> Thanks amoralej
14:33:46 <jcapitao> #action amoralej to chair next week
14:33:55 <jcapitao> #topic Open Floor
14:33:59 <jcapitao> and open floor
14:34:17 <ykarel> wrt c9 there was an annoucement some time back
14:34:20 <ykarel> [CentOS-devel] CentOS Stream 9 is available in CI infra for tenants/projects
14:34:22 <spotz_> Sign up for the escape room if you plan on attending, I need to buy passes this afternooon/eventing
14:34:31 <ykarel> #link https://lists.centos.org/pipermail/centos-devel/2021-October/077383.html
14:34:42 <amoralej> so we may start running jobs ther
14:34:48 <amoralej> maybe puppet promotion pipeline
14:34:52 <ykarel> yes
14:34:54 <amoralej> we run puppet-promotion in cico
14:34:55 <amoralej> right?
14:34:58 <ykarel> yes right
14:35:36 <ykarel> cico-workspace still need to be updated with new cicoclient to be able to request 9-stream node
14:36:01 <amoralej> ah, good point
14:36:02 <amoralej> right
14:36:18 <ykarel> so i guess since we managing cico-workspace-rdo ourself, can get it updated and move with new jobs
14:36:52 <amoralej> yes, has been cico-workspace updated to new client?
14:36:58 <amoralej> because is base image for ours
14:37:00 <amoralej> iirc
14:37:43 <ykarel> as per announcement cico-workspace not yet updated
14:38:39 <ykarel> hmm using cico-workspace as base
14:38:39 <ykarel> https://github.com/amoralej/centosci/blob/master/cico-workspace-rdo/Dockerfile
14:39:10 <amoralej> we may update the client if we know where is the code
14:39:51 <ykarel> http://mirror.centos.org/centos/7/infra/x86_64/infra-common/Packages/p/python-cicoclient-0.4.6-1.el7.noarch.rpm
14:41:34 <amoralej> yep, that's the good one
14:41:45 <amoralej> we can update our dockerfile
14:43:03 <ykarel> yes
14:43:15 <ykarel> current installed version is: python-cicoclient-0.4.5-1.el7.noarch
14:43:48 <jcapitao> where the image is stored ?
14:44:12 <amoralej> in quay
14:44:23 <amoralej> i create a project
14:44:36 <amoralej> created
14:45:16 <amoralej> https://quay.io/repository/rdoinfra/cico-workspace-rdo
14:46:24 <jcapitao> ok I see it now in jenkins config
14:46:52 <amoralej> jcapitao, you have permissions there
14:47:31 <jcapitao> in quay ?
14:48:45 <amoralej> yes
14:49:15 <jcapitao> right, I can log in
14:49:31 <jcapitao> let me build/push the image to test
14:49:44 <amoralej> we need to update the dockerfile to update the cicoclient
14:49:53 <jcapitao> yes got it
14:50:12 <jcapitao> I'll propose a PR in https://github.com/amoralej/centosci
14:50:21 <amoralej> ack
14:50:52 <jcapitao> thx
14:53:47 <ykarel> just to update undercloud job passed in current run
14:53:50 <ykarel> https://review.rdoproject.org/zuul/status#36340
14:54:09 <jcapitao> \o/
14:54:12 <amoralej> good
14:55:48 <jcapitao> #info Sign up for the escape room if you plan on attending
14:55:58 <jcapitao> #link https://eventyay.com/e/e7299da7
14:56:42 <jcapitao> I'm going to close the meeting
14:56:56 <amoralej> ack
14:56:59 <amoralej> thanks jcapitao !
14:57:06 <jcapitao> Thank you all
14:57:13 <jcapitao> #endmeeting