14:01:42 <ykarel> #startmeeting RDO meeting - 2021-11-10
14:01:42 <opendevmeet> Meeting started Wed Nov 10 14:01:42 2021 UTC and is due to finish in 60 minutes.  The chair is ykarel. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:42 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:42 <opendevmeet> The meeting name has been set to 'rdo_meeting___2021_11_10'
14:02:05 <ykarel> Please add last minute topics to agenda https://etherpad.opendev.org/p/RDO-Meeting
14:02:12 <ykarel> #topic roll call
14:02:49 <jcapitao> o/
14:03:01 <ykarel> #chair jcapitao
14:03:01 <opendevmeet> Current chairs: jcapitao ykarel
14:06:13 <amoralej> o/
14:06:20 <ykarel> #chair amoralej
14:06:20 <opendevmeet> Current chairs: amoralej jcapitao ykarel
14:07:48 <ykarel> spotz, you around?
14:07:52 <ykarel> Ok let's start
14:08:01 <ykarel> No topics in agenda
14:08:56 <amoralej> mmmm
14:09:06 <amoralej> let me add one
14:09:15 <ykarel> okk
14:09:32 <ykarel> #topic Backport support of cs9 in xena
14:10:03 <amoralej> I'm thinking in adding support for CS9 in RDO Trunk Xena
14:10:45 <amoralej> as the original plan was to include support in xena and backport to wallaby
14:11:04 <amoralej> so i think everything should be ready to create a dlrn builder for xena on cs9
14:11:11 <amoralej> we have deps in tags and so on
14:11:46 <amoralej> once we have support in xena we can consider backport to wallaby
14:11:54 <amoralej> do you think there may be some blocker for it?
14:11:57 <amoralej> i mean for xena on cs9
14:12:48 <jcapitao> I don't think so
14:13:03 <ykarel> yes xena should be fine
14:13:32 <ykarel> but for wallaby not sure if just cross tag will work
14:13:33 <amoralej> #action amoralej to create review to add centos9-xena rdo trunk builder
14:13:43 <amoralej> ykarel, because of deps versions?
14:13:54 <ykarel> amoralej, yes u-c version may have diverged much
14:14:03 <amoralej> yep
14:14:11 <amoralej> we'll see it in ci
14:14:15 <ykarel> yeap
14:14:27 <amoralej> i'd say to try to run ci with deps in xena
14:14:28 <amoralej> and see
14:14:39 <amoralej> as that's what we did in boostrap
14:14:49 <ykarel> so xena will just be RDO trunk, right? no release cloudsig?
14:15:52 <amoralej> i think so
14:15:58 <ykarel> okk
14:16:02 <ykarel> also all wallaby, xena and yoga will be both c8s and c9s?
14:16:16 <amoralej> yes in rdo trunk
14:16:16 <ykarel> we used to keep only 1 release as transition
14:16:20 <amoralej> cloudsig just one
14:16:24 <amoralej> that's my plan
14:16:45 <amoralej> so for cloudsig it will be yoga
14:16:55 <amoralej> the transition release
14:17:23 <ykarel> okk looks good
14:18:48 <jcapitao> so the plan haven't change since last time IIUC
14:19:37 <ykarel> #info wallaby, xena and yoga will have both c8s and c9s trunk repos
14:20:42 <amoralej> the initial plan was to support cs9 in xena since the beginning and be the transition release
14:20:50 <amoralej> but unfortunately it was too late
14:20:57 <amoralej> so we'll need to move one version ahead
14:21:03 <ykarel> #info For CloudSIG Yoga will be on both C8s and C9s
14:21:05 <amoralej> and support rdo trunk in both one more
14:21:41 <jcapitao> ah indeed
14:22:33 <ykarel> Anything else in this topic?
14:23:19 <amoralej> just, if someone can take a look to the issue with packstack
14:23:29 <amoralej> https://zuul.opendev.org/t/openstack/build/5ccf55695da34092999ba336409a93e6
14:23:33 <amoralej> problem with manila
14:23:41 <amoralej> third party jobs run fine
14:23:45 <amoralej> but fail in check pipeline
14:23:59 <amoralej> https://storage.bhs.cloud.ovh.net/v1/AUTH_dcaab5e32b234d56b626f72581e3644c/zuul_opendev_logs_5cc/816796/6/check/packstack-centos9s-integration-scenario001/5ccf556/logs/latest/manifests/173.231.255.102_controller.pp.log.txt
14:24:06 <amoralej> i spent some time debugging
14:24:11 <amoralej> but i'm not sure what's the problem
14:24:18 <ykarel> ahh so something with image?
14:24:46 <ykarel> upstream i think it's dib based, and thirdparty cloud image+ virt-customize
14:24:50 <amoralej> maybe
14:25:06 <amoralej> [1;31mError: /Stage[main]/Manila::Api/Manila_config[DEFAULT/osapi_share_listen]: Could not evaluate: invalid byte sequence in US-ASCII[0m
14:25:10 <amoralej> wit all manila_config
14:25:47 <ykarel> okk /me will also have a look
14:26:38 <ykarel> also some warnings warning: BOM with non-UTF encoding US-ASCII is nonsense
14:27:58 <amoralej> mmm right
14:28:04 <amoralej> maybe we should force the locale
14:28:05 <amoralej> just in case
14:28:18 <ykarel> yes worth a try
14:34:18 <ykarel> Ok let's move to next
14:34:42 <ykarel> #topic chair for next week
14:34:47 <ykarel> any volunteer?
14:36:31 <jcapitao> I'll be out next 2 weeks
14:37:25 <opendevreview> Alfredo Moralejo proposed x/packstack master: [WIP] Add centos-9-stream jobs  https://review.opendev.org/c/x/packstack/+/816796
14:39:16 <ykarel> ok i can chair next week too
14:39:25 <ykarel> #action ykarel to chair next week
14:41:53 <jcapitao> wrt Xena on CS8, no issues reported in RDO ML atm
14:42:16 <amoralej> i didn't get any feedback
14:45:03 <ykarel> Okk that's good
14:45:39 <ykarel> #topic open floor
14:45:42 <amoralej> btw, we are hitting https://lists.centos.org/pipermail/centos-devel/2021-November/077436.html
14:45:47 <amoralej> in cs9 today
14:45:52 <amoralej> chandankumar reported it
14:46:02 <ykarel> yes seems some mirrors are outdated
14:46:05 <amoralej> so, i'm not sure if all the cs9 jobs will fail
14:46:23 <ykarel> amoralej, only those using metalink seems affected
14:46:32 <ykarel> mirror.stream.centos.org looks fine
14:47:19 <chandankumar> amoralej: by using compose repo, it works fine
14:47:37 <ykarel> $ curl http://mirror.stream.centos.org/timestamp.txt
14:47:37 <ykarel> Wed 10 Nov 14:34:01 UTC 2021
14:47:45 <ykarel> $ curl http://ord.mirror.rackspace.com/centos-stream/timestamp.txt
14:47:45 <ykarel> Tue  9 Nov 22:24:01 UTC 2021
14:48:27 <ykarel> so in jobs gcc is being pulled from Appstream repo from mirrors with latest content
14:48:34 <ykarel> and libgcc from outdated ones
14:48:45 <amoralej> yep
14:48:53 <amoralej> let me check which servers
14:48:59 <amoralej> well, let's finish the mtg first
14:49:11 <ykarel> yes
14:49:23 <ykarel> so let's close than no more topics
14:49:32 <ykarel> Thanks all
14:49:35 <ykarel> #endmeeting