14:01:24 <amoralej> #startmeeting RDO meeting - 2022-01-26
14:01:24 <opendevmeet> Meeting started Wed Jan 26 14:01:24 2022 UTC and is due to finish in 60 minutes.  The chair is amoralej. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:24 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:24 <opendevmeet> The meeting name has been set to 'rdo_meeting___2022_01_26'
14:01:40 <amoralej> #topic roll call
14:01:45 <amoralej> who is around?
14:03:12 <PagliaccisCloud> O/
14:03:28 <amoralej> #chair PagliaccisCloud
14:03:28 <opendevmeet> Current chairs: PagliaccisCloud amoralej
14:03:45 <amoralej> spotz, kkula jcapitao[m] are you around?
14:03:56 <kkula> yes!
14:03:58 <jcapitao[m]> o/
14:04:03 <kkula> hello
14:04:16 <amoralej> #chair kkula jcapitao[m]
14:04:16 <opendevmeet> Current chairs: PagliaccisCloud amoralej jcapitao[m] kkula
14:05:19 <amoralej> feel free to add topics to https://etherpad.opendev.org/p/RDO-Meeting
14:05:28 <amoralej> i'll start with first ones
14:05:41 <amoralej> #topic introduce new RDOers
14:05:53 <amoralej> #info kkula join RDO team, welcome!!!
14:06:22 <amoralej> so, kkula will be contributing to RDO
14:06:32 <kkula> hi all RDOers!
14:06:46 <amoralej> i hope you have a nice onboarding :)
14:06:48 <jcapitao[m]> welcome kkula ! :)
14:07:00 <amoralej> and feel free to ask us anything you need
14:07:09 <spotz> Wellcome kkula!!!
14:07:31 <dpawlik> hey kkula!
14:08:29 <amoralej> ok, let's move on
14:08:53 <amoralej> #topic Devconf Meetup Friday at 17:00 UTC - https://www.devconf.info/cz/
14:09:01 <rdogerrit> Merged rdoinfo master: Promote CBS tags update for wallaby-8s-testing  https://review.rdoproject.org/r/c/rdoinfo/+/38150
14:09:09 <amoralej> spotz, stage is yours
14:09:21 <PagliaccisCloud> Welcome kkula!!!  ٩( ᐛ )و
14:09:48 <spotz> Please join in on Friday, opportunity to just hang out, answer any questions we might get and some SWAG giveouts from our stash:)
14:10:03 <rdogerrit> Douglas Viroel created rdo-jobs master: WIP - Adding multinode and build-images jobs def  https://review.rdoproject.org/r/c/rdo-jobs/+/38596
14:10:27 <spotz> That's it for that really:)
14:10:35 <rdogerrit> Douglas Viroel proposed rdo-jobs master: WIP - Adding multinode and build-images jobs def  https://review.rdoproject.org/r/c/rdo-jobs/+/38596
14:11:21 <amoralej> spotz, so RDO has some virtual booth?
14:11:22 <amoralej> or something?
14:11:31 <spotz> We have a 1 hour meetup slot
14:11:49 <spotz> The decision was no booths because it was supposed to be live but they'd have meetups
14:12:12 <amoralej> ok
14:12:24 <amoralej> meetup is in hopin platform too?
14:12:31 <amoralej> ah, i see it
14:12:32 <amoralej> good
14:12:40 <amoralej> https://devconfcz2022.sched.com/event/sjOE/rdo-meetup
14:12:49 <spotz> I suspect it'll be as quiet as a booth:( But It'll be nice to have some hangout space even virtually
14:12:59 <amoralej> yeah
14:13:05 <amoralej> good to meet there
14:13:21 <spotz> Yep
14:13:23 <amoralej> btw, it's a bit weird to do virtual events in saturday?
14:13:28 <amoralej> or it's just me :)
14:13:47 <amoralej> anyway
14:13:51 <rdogerrit> Merged openstack/ironic-python-agent-distgit victoria-rdo: openstack-ironic-python-agent-6.4.4-1  https://review.rdoproject.org/r/c/openstack/ironic-python-agent-distgit/+/38580
14:14:07 <spotz> I think because historically those are the days in person they kept them. Even FOSDEM will still have weekend stuff
14:15:17 <amoralej> #action everyone Join in virtual RDO Meetup on devconf.cz on friday! it's an opportunity to just hang out, answer any questions we might get and some SWAG giveouts from our stash :)
14:15:29 <amoralej> to get it into minutes :)
14:15:39 <spotz> :)
14:15:41 <amoralej> thanks spotz, let's move to next mtg
14:15:49 <amoralej> yeah, i thought the same about fosdem
14:16:17 <amoralej> #topic Dependencies update in Yoga
14:16:37 <amoralej> i think it'd be good to do a dependencies refresh at this time for Yoga
14:16:57 <amoralej> i've created https://review.rdoproject.org/etherpad/p/update-deps-yoga-cs9
14:17:13 <amoralej> and kkula will start working on it
14:17:31 <amoralej> so, you'll see reviews coming to the deps repos :)
14:17:50 <jcapitao[m]> ok good
14:17:52 <amoralej> #info https://review.rdoproject.org/etherpad/p/update-deps-yoga-cs9
14:18:28 <jcapitao[m]> should we wait for review to land in Fedora ?
14:18:31 <amoralej> #action kkula will work on updating dependencies for Yoga based on https://dashboards.rdoproject.org/report-uc-cs9
14:18:37 <amoralej> jcapitao[m], yes
14:18:44 <jcapitao[m]> or we can act in parallel ?
14:18:45 <amoralej> unless there is some special need
14:18:57 <jcapitao[m]> ok
14:19:06 <amoralej> i've asked kkula to start with the deps which are already updated in fedora
14:19:39 <jcapitao[m]> b/c sometime patches are dying opened
14:20:11 <jcapitao[m]> ok that should help us to catch up fast
14:20:36 <amoralej> yep
14:21:04 <amoralej> let's see how many can we update
14:21:22 <amoralej> btw, we'll try to build for cs8 from the same distgits
14:21:32 <amoralej> to align cs8 and cs9
14:21:57 <jcapitao[m]> ok
14:22:05 <amoralej> mmm i'm thinking if we may create a check job to do scratch build in cs8
14:22:10 <jcapitao[m]> and if it fails ?
14:22:15 <amoralej> from updates in cs9 branch
14:22:18 <amoralej> non-voting
14:22:26 <jcapitao[m]> ah yes
14:22:41 <jcapitao[m]> worth it to add it
14:23:42 <amoralej> #action add a new non-voting job deps-cbs-validate-cs8 to scratch build in cs8 BR from updates in c9s branches
14:25:01 <amoralej> btw, it could be a good oportunity to update https://www.rdoproject.org/documentation/requirements/#updating-a-requirement-in-rdo-cloudsig-repositories
14:25:14 <amoralej> and get it to the same level of adding a new one
14:25:18 <amoralej> with diagram and so on
14:25:23 <amoralej> kkula, ^ wdyt?
14:25:43 <amoralej> would you mind to update the procedure to update requirements?
14:25:54 <amoralej> no need to do it now
14:26:00 <spotz> Good idea, I'll also try to carve some time out to make sure we're up to date for saying stream, etc
14:26:03 <amoralej> but once you are familiar with the procedure
14:28:17 <amoralej> kkula, fyi website content is maintained using gerrit with markdown https://review.rdoproject.org/r/c/rdo-website/+/37937
14:28:24 <amoralej> that's a recent update from jcapitao[m]
14:28:34 <kkula> i'll take a look
14:29:13 <amoralej> anyway, i'd recomend you to do some deps updates to understand the process first and then update
14:29:30 <amoralej> next topic
14:29:37 <amoralej> #topic Move out puppet promotion pipeline from Jenkins to Zuul
14:29:40 <amoralej> that's from jcapitao[m]
14:30:12 <jcapitao[m]> as we've already did for CS9, we can move CS8 pipelines to zuul now
14:30:36 <jcapitao[m]> this will help us to prevent hitting CICO infra issue, hopefully
14:30:57 <jcapitao[m]> we're requesting too many nodes
14:31:40 <amoralej> we need to find out how to distribute the pipelines
14:32:03 <jcapitao[m]> in multiple phases you mean ?
14:32:18 <amoralej> i mean that, if we are adding 4 more pipelines+
14:32:26 <amoralej> each one runs 5 nodes
14:32:35 <amoralej> not to run all of them together
14:32:46 <jcapitao[m]> right
14:33:00 <amoralej> for the cs9 ones, i've used the tripleo pipelines
14:33:20 <amoralej> the ones they have for their promotions
14:33:45 <amoralej> i think they have more
14:33:53 <amoralej> let's discuss in the reviews
14:34:40 <jcapitao[m]> ack
14:35:41 <amoralej> that's it about this topic?
14:35:42 <jcapitao[m]> so I'll propose patches and handle the migration
14:36:00 <rdogerrit> Merged rdo-website master: Fix line breaks issue  https://review.rdoproject.org/r/c/rdo-website/+/38325
14:36:07 <amoralej> i guess, will be similar to cs8 ones, right?
14:36:49 <amoralej> btw, i think i still need to enable the one for centos9-wallaby
14:37:14 <jcapitao[m]> yes similar to cs9 ones
14:38:07 <jcapitao[m]> right, we did it for X, not yet for W
14:38:33 <amoralej> yep
14:38:40 <opendevreview> Alfredo Moralejo proposed x/packstack master: Move nova database connection config to nova::db  https://review.opendev.org/c/x/packstack/+/826476
14:39:00 <amoralej> #topic OIF Summit! CFP is open!!!
14:39:11 <amoralej> spotz, something to add?
14:39:46 <spotz> Please submit talks!
14:40:17 <amoralej> #link https://cfp.openinfra.dev/app/berlin-2022
14:40:19 <spotz> Would love to have an RDO presence in the talks and I'm also planning for a social and some sponsoring of the OPS Meetup
14:40:47 <spotz> Not sure what to submit reach out I've got tons of ideas:)
14:41:08 <spotz> Need a co-speaker cause you don't want to talk alone I'll do it or find you someone
14:41:32 <spotz> That's it:)
14:41:53 <amoralej> thans spotz
14:42:08 <amoralej> #topic CentOS Cloud SiG
14:43:13 <spotz> After last weeks meeting I talked with the Fedora Cloud SiG folks. CCentOS Cloud SiG will meet the second thursday of the month and Fedora Cloud SiG will meet the first and third so anyone who wants to participate in both can
14:43:40 <amoralej> nice
14:43:43 <spotz> The goal is that this move will grow the SiG beyond just RDO
14:44:03 <spotz> The 2 groups aren't a 1 to 1 matching on scope but that's ok
14:44:32 <spotz> We're also up for the newsletter:)
14:44:34 <amoralej> yeah
14:44:47 <amoralej> did you send patch for the calendar?
14:44:55 <amoralej> i mean https://www.centos.org/community/calendar/
14:44:55 <spotz> That's it for Cloud SiG I just wanted to bring it up here as we meet more often then the SiG
14:45:14 <spotz> Yeah patch was sent, we foound an issue with another SiG. I'll poke to get it merged
14:45:24 <amoralej> ack, good
14:45:32 <rdogerrit> Joel Capitao created config master: Add puppet-promotion jobs for Wallaby in openstack-periodic-daily  https://review.rdoproject.org/r/c/config/+/38597
14:45:33 <amoralej> thanks for arranging that
14:45:41 <spotz> I think we got sidetracked fixing that:)
14:45:45 <spotz> My pleasure
14:46:05 <amoralej> yeah, i remembered you sent the patch, that's why i asked :)
14:46:09 <spotz> https://github.com/CentOS/Calendar/pull/52
14:47:15 <amoralej> #topic chair for next week
14:47:27 <amoralej> next week is video call meeting
14:47:34 <amoralej> anyone willing to chair?
14:48:17 <spotz> I should be able to
14:48:37 <amoralej> #action spotz to chair next meeting
14:48:41 <amoralej> #topic open floor
14:48:49 <amoralej> anything else you'd like to share?
14:50:26 <jcapitao[m]> nothing else from me
14:50:35 <amoralej> ok, i'll give you some minutes back
14:50:39 <amoralej> thanks all for joining!
14:50:44 <amoralej> #endmeeting