14:01:42 <jcapitao[m]> #startmeeting  RDO meeting - 2022-02-09
14:01:42 <opendevmeet> Meeting started Wed Feb  9 14:01:42 2022 UTC and is due to finish in 60 minutes.  The chair is jcapitao[m]. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:42 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:42 <opendevmeet> The meeting name has been set to 'rdo_meeting___2022_02_09'
14:02:20 <jcapitao[m]> #topic roll call
14:03:00 <amoralej> o/
14:03:12 <jcapitao[m]> #chair amoralej
14:03:12 <opendevmeet> Current chairs: amoralej jcapitao[m]
14:03:19 <kkula> \o
14:03:35 <jcapitao[m]> #chair kkula
14:03:35 <opendevmeet> Current chairs: amoralej jcapitao[m] kkula
14:04:51 <jcapitao[m]> spotz__: are you around ?
14:07:35 <jcapitao[m]> I think we'll treat spotz 's topic at the end when she's available
14:07:41 <amoralej> yes
14:07:53 <jcapitao[m]> #topic Puppet promotion pipeline migration
14:08:01 <jcapitao[m]> let's go with first topic
14:08:17 <jcapitao[m]> #info CS8 master (Yoga) pipeline is now running on Zuul
14:08:34 <jcapitao[m]> RDO tenant
14:08:40 <jcapitao[m]> #link https://issues.redhat.com/projects/RDO/issues/RDO-22
14:09:20 <jcapitao[m]> https://review.rdoproject.org/zuul/builds?project=rdoinfo&pipeline=openstack-periodic-integration-stable3
14:09:33 <jcapitao[m]> first iteration occurred a couple of hours ago
14:09:48 <amoralej> good
14:09:57 <amoralej> i'm mergint the review in ci-config now jcapitao[m]
14:10:11 <jcapitao[m]> packstack jobs are failing but it's due to other issue being addressed upstream
14:10:16 <amoralej> if anything is merged before, the pipeline will be automatically enabled again
14:10:55 <jcapitao[m]> ah right
14:11:04 <PagliaccisCloud> O/
14:11:06 <jcapitao[m]> didn't think about it
14:11:19 <amoralej> jcapitao[m], actually, something has merged an hour ago
14:11:26 <amoralej> so probably it's enabled now
14:11:26 <jcapitao[m]> #chair PagliaccisCloud
14:11:26 <opendevmeet> Current chairs: PagliaccisCloud amoralej jcapitao[m] kkula
14:11:43 <amoralej> we need to disable, note that merging that in ci-config will not disable or remove it
14:11:51 <amoralej> we need to disable manually
14:11:51 <spotz__> o/ Sorry IRC on my work machine is messed up
14:12:17 <spotz__> Yeah for backup machines:)
14:12:50 <jcapitao[m]> amoralej: right, it's enabled again
14:13:01 <amoralej> actually it ran this morning
14:13:05 <jcapitao[m]> yeap I disabled it manually yesterday
14:13:31 <amoralej> i'm disabling it
14:13:50 <amoralej> done
14:14:04 <jcapitao[m]> so for next migration, we'll disable it manually, merge the patch and removing it in a row
14:14:42 <jcapitao[m]> thank you
14:14:50 <amoralej> i'm not sure if we can disable it via jjb
14:14:53 <amoralej> that'd be the best
14:15:07 <amoralej> first disable in jjb -> remove in jjb
14:15:12 <jcapitao[m]> #chair spotz__
14:15:12 <opendevmeet> Current chairs: PagliaccisCloud amoralej jcapitao[m] kkula spotz__
14:15:20 <jcapitao[m]> spotz__: no worries :)
14:15:26 <amoralej> we can keep the jobs in jenkins to maintain history for some time
14:16:53 <jcapitao[m]> ack let's do that way
14:17:16 <jcapitao[m]> that's all for this topic
14:17:19 <jcapitao[m]> any question ?
14:18:08 <spotz> I'll have to read back through but don't think so
14:18:25 <jcapitao[m]> let's move on then
14:18:35 <jcapitao[m]> #topic Build OpenStack Clients for CS9
14:19:17 <amoralej> Today, someone in #centos-stream asked about shipping clients for CentOS Streasm 9
14:20:31 <amoralej> ustrin> amoralej: we "officially" announced support for CS9 today and one of my cloudy colleagues was asking mainly about availability of the clients
14:20:51 <amoralej> #info community users have requested for availability of openstack clients for CS9
14:21:13 <amoralej> although our plan is to ship yoga for CS9
14:21:26 <jcapitao[m]> that's good news we have such a request
14:21:28 <amoralej> i'd say it'd makes sense to build clients for CS9
14:21:56 <amoralej> yes jcapitao[m] people uses it, most of the times, silence means it just works :)
14:22:14 <amoralej> so, i was thinking about building xena releases for cs9
14:22:22 <amoralej> tags are ready and so on
14:22:27 <amoralej> so it sholdn't be too hard
14:22:43 <amoralej> i think we could do the same clients we do in fedora
14:22:47 <amoralej> and promote them
14:23:03 <amoralej> it'd be like a one-shot
14:23:22 <amoralej> wdyt?
14:24:21 <spotz> I think if it's low effort or reusable effort it'd be a nice win to meet user needs
14:24:37 <jcapitao[m]> waiting for Yoga CS9 is too long ? as we'll have to build them in a few weeks
14:25:22 <amoralej> well, it's be almost two months i'd say
14:25:50 <jcapitao[m]> ah right
14:25:59 <spotz> Vs how long for Xena?
14:26:09 <jcapitao[m]> b/c we'll have to wait until GA
14:26:20 <josecastroleon> hi, i was about to say that? xena on CS9?
14:26:51 <amoralej> josecastroleon, so, you'd like to get xena clients for cs9, right?
14:27:03 <amoralej> no need of the full openstack, just clients?
14:28:05 <josecastroleon> I may need the full openstack later...
14:28:21 <josecastroleon> normally we don't do distro change + release at the same time
14:28:53 <amoralej> josecastroleon, it's not that easy because upstream proyects start working on new OS versions *after* it's released
14:29:13 <josecastroleon> that's fair
14:29:15 <amoralej> in this case, actually, we already have packages of xena for cs9 but are not signed
14:29:22 <amoralej> and not in centos mirrors
14:29:38 <amoralej> they are in "RDO Trunk" repos
14:30:05 <amoralej> i can show you how to install them
14:30:19 <amoralej> so that's one part of the reply :)
14:30:24 <amoralej> second part is
14:30:49 <amoralej> for clients, we may be able to ship them in centos mirrors, i think it may make sense
14:31:05 <amoralej> similar to what we do for fedora
14:31:15 <jcapitao[m]> yeah I think it worth it to ship them
14:31:17 <amoralej> that'd alleviate your issues?
14:31:35 <josecastroleon> yes on the client side
14:32:06 <josecastroleon> Would those packages at some point get signed and available on centos repos at a later time?
14:32:20 <amoralej> josecastroleon, the clients ones yes
14:32:25 <amoralej> that's my proposal
14:32:28 <amoralej> for server side...
14:32:34 <josecastroleon> server side
14:32:46 <amoralej> our plan is to wait for yoga
14:33:11 <josecastroleon> and have yoga supported on both cs8 and cs9?
14:33:11 <amoralej> https://releases.openstack.org/yoga/schedule.html
14:33:15 <amoralej> josecastroleon, yes
14:33:18 <amoralej> that's the plan
14:33:21 <josecastroleon> ok, great
14:33:28 <Eighth_Doctor> woot finally
14:33:36 * Eighth_Doctor grumbles about oftc
14:33:43 <amoralej> that will be at about mid april
14:34:01 <jcapitao[m]> #chair josecastroleon Conan Kudo
14:34:01 <opendevmeet> Warning: Nick not in channel: Conan
14:34:01 <opendevmeet> Warning: Nick not in channel: Kudo
14:34:01 <opendevmeet> Current chairs: Conan Kudo PagliaccisCloud amoralej jcapitao[m] josecastroleon kkula spotz__
14:34:33 <amoralej> josecastroleon, so, that'd will that plan work for you?
14:35:05 <spotz> josecastroleon: Keep in mind RDO is a trailing release we need all the other parts released before we can finalize our release
14:35:13 <josecastroleon> yes, then we can use the yoga release as the transition one
14:35:24 <josecastroleon> to cs9
14:35:26 <amoralej> yes, that's the idea
14:35:35 <josecastroleon> as we did with cc7 to cs8
14:35:37 <amoralej> josecastroleon, what deployment tool do you use?
14:35:38 <josecastroleon> as we did with c7 to cs8
14:35:57 <Eighth_Doctor> question: is there a reason the clients aren't in EPEL?
14:36:20 <amoralej> not duplicating with cloudsig
14:36:24 <Eighth_Doctor> it'd make it easier for the extended ecosystem of software that use OpenStack clients to depend on it
14:36:37 <Eighth_Doctor> for example, I maintain Buildbot in Fedora and EPEL, and I can't offer OpenStack support without them
14:36:45 <jcapitao[m]> #chair Eighth_Doctor
14:36:45 <opendevmeet> Current chairs: Conan Eighth_Doctor Kudo PagliaccisCloud amoralej jcapitao[m] josecastroleon kkula spotz__
14:37:03 <amoralej> ok, that's another topic Eighth_Doctor
14:37:09 <amoralej> let's close this one first, please
14:37:21 <josecastroleon> amoralej, puppet on some services
14:37:24 <josecastroleon> kubernetes on others
14:37:42 <amoralej> yeah, ok, that should be fine
14:37:42 <Eighth_Doctor> amoralej: I just got here, I don't know stuff :)
14:37:47 <Eighth_Doctor> but sure
14:37:48 <amoralej> np :)
14:38:17 <amoralej> #info RDO will build and ship OpenStack clients from yoga releases for CS9 in CloudSIG repos
14:38:27 <amoralej> i'm wondering if we should create separated tags...
14:38:40 <amoralej> to have a directory with openstackclient or something
14:38:53 <amoralej> to make it clear that it's just clients
14:39:04 <amoralej> or users may expect to get the full pack
14:39:17 <amoralej> wdyt?
14:39:33 <spotz> That might be a good idea
14:40:05 <amoralej> that'd inherit from cloud9s-openstack-yoga-testing and yoga-el8-build
14:40:10 <amoralej> to avoid double tagging
14:40:25 <josecastroleon> +1
14:40:26 <jcapitao[m]> yeah to be more explicit
14:40:29 <jcapitao[m]> +1
14:40:43 <Eighth_Doctor> given how many overrides the RDO repos typically ship, that's a good idea
14:40:43 <spotz> +1
14:41:03 <amoralej> #agreed to create separate CBS tags for cloud9s-openstackclient-yoga
14:41:35 <amoralej> wrt the list of packages, i think we can take it from fedora
14:41:40 <amoralej> i'd say
14:41:55 <jcapitao[m]> yes
14:41:55 <amoralej> jcapitao[m], you udpated fedora last times, iirc, we have that list?
14:42:06 <amoralej> ok
14:42:17 <jcapitao[m]> with rdopkg and some grepping
14:42:19 <amoralej> we'll rebuild from cbs srpms in cs8 i think
14:42:26 <Eighth_Doctor> mmm rdopkg :)
14:42:30 <amoralej> we can script it
14:42:49 <amoralej> ok, i think we have a plan :)
14:42:54 <spotz> And if anyone would like to learn to package...:)
14:43:06 <amoralej> yeah... actually
14:43:24 <amoralej> josecastroleon, would you or some colleague be interested in joining cloud sig? :)
14:43:37 <amoralej> it'd be a great oportunity, i think
14:43:49 <spotz> +2
14:44:33 <amoralej> we can onboard you
14:44:39 <PagliaccisCloud> ... I'd like to learn?
14:44:50 <amoralej> PagliaccisCloud, sure!
14:45:18 <amoralej> we may do a cloudsig onboarding session
14:45:45 <PagliaccisCloud> Sweet! Do you need more volunteers? I'll ask my work colleagues if they can lend a hand
14:46:10 <spotz> We can make an event out of it:)
14:46:34 <PagliaccisCloud> ٩( ᐛ )و
14:47:22 <amoralej> well, it needs some learning curve to get up to date
14:47:54 <josecastroleon> sure, i can try to help
14:48:31 <amoralej> so, i think it's good to have new blood onboard :)
14:48:40 <amoralej> josecastroleon, PagliaccisCloud i'll back to you after the mtg
14:48:49 <jcapitao[m]> :)
14:48:50 <amoralej> and will give you some doc links so that you can read
14:48:55 <spotz> Include me too:)
14:49:34 <amoralej> ok
14:49:55 <jcapitao[m]> ok maybe we can add extra topic proposed by Eighth_Doctor
14:50:00 <rdogerrit> Merged rdo-infra/ci-config master: Add $DISTRO_PATH to find release file for centosci  https://review.rdoproject.org/r/c/rdo-infra/ci-config/+/39181
14:50:14 <amoralej> #action amoralej to provide info to PagliaccisCloud and josecastroleon wrt to joining Cloud SIG
14:50:24 <amoralej> yes, now let's move to the other topic
14:50:30 <jcapitao[m]> #topic EPEL repos and RDO
14:50:54 <amoralej> let's be more specific, shipping clients in EPEL :)
14:51:26 <jcapitao[m]> #undo
14:51:26 <opendevmeet> Removing item from minutes: #topic EPEL repos and RDO
14:51:50 <jcapitao[m]> #topic Shipping clients in EPEL ?
14:52:02 <jcapitao[m]> better :)
14:52:38 <jcapitao[m]> reminder: 8 minutes left
14:52:41 <amoralej> as you know we had issues in the past mixing RDO and epel
14:53:19 <amoralej> and i wouldn't pursue the goal of mixing them so far
14:53:44 <amoralej> but iiuc what Eighth_Doctor is requesting is just to provide openstack clients in epel
14:53:56 <amoralej> as they are in fedora, it shouldn't be a problem
14:53:58 <Eighth_Doctor> yeah
14:54:15 <Eighth_Doctor> if you need all the OpenStack, RDO repos are there :)
14:54:23 <Eighth_Doctor> but the clients in EPEL would be massively helpful
14:54:24 <amoralej> we'd just keep rebuilding in epel when we update rawhide
14:54:45 <amoralej> so, from technical pov, i don't see any problem
14:54:55 <amoralej> unless we discover some issue with some specific dependency or something
14:54:57 <Eighth_Doctor> that approach is fine with me too
14:55:01 <amoralej> wich i don't foresee
14:55:09 <amoralej> now, wrt the work :)
14:55:17 <jcapitao[m]> we can give a shot
14:55:19 <amoralej> actually, there is an openstack-sig in fedora
14:55:27 <amoralej> which owns those packages
14:55:35 <amoralej> it'd be also helpful to get a hand there
14:55:47 <jcapitao[m]> +1
14:55:56 <Eighth_Doctor> you can ask for help from the epel-packagers-sig if you need it
14:56:07 <Eighth_Doctor> most of them hang out in #epel:fedoraproject.org
14:56:47 <Eighth_Doctor> https://docs.fedoraproject.org/en-US/epel/epel-packagers-sig/
14:56:49 <amoralej> Eighth_Doctor, so that group has build permissions on epel branch on all packages?
14:57:07 <Eighth_Doctor> they can request it as needed, yes
14:57:15 <amoralej> nice
14:57:24 <Eighth_Doctor> it's basically a group that helps out when things don't work out in the normal process
14:57:38 <Eighth_Doctor> they've been instrumental to filling out EPEL 9 so quickly in just three months
14:57:46 <amoralej> i see
14:57:53 <amoralej> make sense
14:58:02 <amoralej> one question
14:58:27 <amoralej> can you explain again
14:58:30 <amoralej> "<Eighth_Doctor> for example, I maintain Buildbot in Fedora and EPEL, and I can't offer OpenStack support without them"
14:58:43 <Eighth_Doctor> hm?
14:59:07 <amoralej> ah, https://buildbot.net/
14:59:11 <Eighth_Doctor> Buildbot's OpenStack orchestration support requires the OpenStack client libraries for Python
14:59:11 <amoralej> it's that, right?
14:59:20 <Eighth_Doctor> yes
14:59:31 <amoralej> i see the point
15:00:47 <amoralej> #action investigate what is needed to add openstack clients to fedora and evaluate if we need to involve epel-packagers-sig
15:01:06 <Eighth_Doctor> ehh?
15:01:07 <Eighth_Doctor> it's already in fedora
15:01:09 <amoralej> Eighth_Doctor, i can give you a date at this point, sorry, but we'll keep you updated
15:01:09 <Eighth_Doctor> you mean epel, right?
15:01:14 <amoralej> #undo
15:01:14 <opendevmeet> Removing item from minutes: #action investigate what is needed to add openstack clients to fedora and evaluate if we need to involve epel-packagers-sig
15:01:21 <amoralej> #action investigate what is needed to add openstack clients to epel and evaluate if we need to involve epel-packagers-sig
15:01:23 <amoralej> now :)
15:01:35 <jcapitao[m]> good
15:01:41 <amoralej> Eighth_Doctor, epel8 or 9? what's more urgent for you?
15:01:50 <Eighth_Doctor> epel9
15:01:57 <amoralej> mmm also, maybe adding them to epel would help josecastroleon
15:02:04 <Eighth_Doctor> I'm in the middle of upgrading my infra to EPEL 9
15:02:04 <amoralej> instead of pushing to sig
15:02:09 <Eighth_Doctor> err CentOS 9
15:02:19 <Eighth_Doctor> jumping from CentOS 7 :o
15:02:47 <amoralej> josecastroleon, ^ what if we ship openstack clients to epel9 instead of cloud sig?
15:04:01 <jcapitao[m]> two targets with one shot
15:04:21 <Eighth_Doctor> woot
15:04:36 <amoralej> we are over time
15:04:41 <jcapitao[m]> yep
15:04:41 <spotz> hehe
15:04:46 <josecastroleon> that's should be fine i guess
15:04:46 <amoralej> we'll keep discussing with josecastroleon later
15:04:53 <amoralej> i think we can close the topic
15:04:53 <jcapitao[m]> ok
15:05:02 <jcapitao[m]> let's move with last topic quickly
15:05:06 <jcapitao[m]> #topic CFP reminder
15:05:44 <jcapitao[m]> #link https://cfp.openinfra.dev/app/berlin-2022
15:06:12 <spotz> CFP closes today at 23:59 If you're thinking about it please submit. I've been encouraging not just OpenStack but CentOS and Kubernetes talks
15:06:27 <spotz> We can talk SWAG next week
15:06:40 <spotz> And that time is UTC
15:07:10 <jcapitao[m]> thank you spotz
15:07:22 <jcapitao[m]> #topic next week's chair
15:07:26 <spotz> Thank you ccan sorry about the technical issues
15:07:40 <jcapitao[m]> anyone's willing to chair next week ?
15:08:01 <PagliaccisCloud> Yo (unless anyone else wants to)
15:08:34 <spotz> We like to share:)
15:08:44 <jcapitao[m]> #action PagliaccisCloud to chair next week
15:08:48 <jcapitao[m]> thank you PagliaccisCloud :)
15:09:01 <jcapitao[m]> thank you everyone for the good discussion here
15:09:09 <jcapitao[m]> and sorry for the extra time
15:09:14 <josecastroleon> thanks all
15:09:20 <jcapitao[m]> I'm going to close the meeting
15:09:22 <jcapitao[m]> #endmeeting