14:01:52 <amoralej> #startmeeting RDO meeting - 2022-03-09
14:01:52 <opendevmeet> Meeting started Wed Mar  9 14:01:52 2022 UTC and is due to finish in 60 minutes.  The chair is amoralej. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:52 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:52 <opendevmeet> The meeting name has been set to 'rdo_meeting___2022_03_09'
14:01:59 <amoralej> #topic roll call
14:02:06 <rdogerrit> Merged openstack/os-brick-distgit xena-rdo: python-os-brick-5.0.2-1  https://review.rdoproject.org/r/c/openstack/os-brick-distgit/+/40239
14:03:21 <jcapitao[m]> o/
14:03:51 <kkula> o/
14:03:56 <amoralej> #chair jcapitao[m] kkula
14:03:56 <opendevmeet> Current chairs: amoralej jcapitao[m] kkula
14:07:14 <amoralej> ok, let's startu
14:07:32 <amoralej> #topic Status of RDO Yoga preparation
14:07:42 <amoralej> #link https://trello.com/c/D6EIA1ed/762-yoga-release-preparation
14:07:50 <PagliaccisCloud> O/
14:07:51 <amoralej> #link https://review.rdoproject.org/etherpad/p/yoga-release-preparation
14:07:55 <amoralej> #chair PagliaccisCloud
14:07:55 <opendevmeet> Current chairs: PagliaccisCloud amoralej jcapitao[m] kkula
14:08:19 <amoralej> #info RDO Trunk builder CentOS9 Yoga is mostly bootstrapped
14:08:32 <amoralej> jcapitao[m], all yours
14:08:40 <spotz_> O/
14:09:02 <amoralej> #chair spotz_
14:09:02 <opendevmeet> Current chairs: PagliaccisCloud amoralej jcapitao[m] kkula spotz_
14:09:03 <rdogerrit> Merged config master: Export TARGET as env var  https://review.rdoproject.org/r/c/config/+/40237
14:09:10 <josecastroleon> O/
14:09:33 <amoralej> #chair josecastroleon
14:09:33 <opendevmeet> Current chairs: PagliaccisCloud amoralej jcapitao[m] josecastroleon kkula spotz_
14:09:36 <jcapitao[m]> we're about to start building packages on CBS
14:10:04 <amoralej> jcapitao[m], so, as soon as the fixes in config are merged we can start, right?
14:10:18 <jcapitao[m]> yes
14:10:22 <amoralej> good
14:10:31 <amoralej> about the centos8 dlrn builder
14:10:42 <amoralej> how is the bootstrap?
14:10:53 <jcapitao[m]> it's ok
14:10:59 <jcapitao[m]> just one missing
14:11:12 <jcapitao[m]> python-networking-baremetal
14:11:19 <jcapitao[m]> but it's FTBFS
14:11:24 <rdogerrit> Merged config master: Install CS9 release and repos packages for CS9 builds  https://review.rdoproject.org/r/c/config/+/40249
14:11:30 <amoralej> yeah, similar situation as in cs9
14:11:47 <amoralej> #info RDO Trunk builder CentOS8 Yoga is mostly bootstrapped
14:12:10 <jcapitao[m]> there is a WIP patch https://review.opendev.org/c/openstack/networking-baremetal/+/832697
14:12:21 <amoralej> jcapitao[m], so, once we have cinder and cinderlib in cs9 we can enable crons
14:12:36 <amoralej> i think i will do a run-dlrn.sh --head-only to catch up
14:12:42 <amoralej> before enabling crons
14:12:57 <jcapitao[m]> right
14:13:02 <jcapitao[m]> for CS8 too then
14:13:49 <amoralej> yes
14:13:54 <jcapitao[m]> wrt reqcheck we are good I think
14:14:00 <amoralej> good
14:14:13 <amoralej> so we can start building in cbs
14:14:16 <amoralej> we have rc1
14:14:37 <amoralej> kkula, ^ you can probably coordinate with jcapitao to send the reviews to build in cbs
14:14:37 <jcapitao[m]> yes
14:14:40 <amoralej> wrt deps
14:14:58 <kkula> ok
14:15:01 <amoralej> is there any dep that we want to update before yoga ga?
14:15:17 <jcapitao[m]> the django one
14:15:37 <jcapitao[m]> https://review.rdoproject.org/r/c/deps/python-django/+/40202
14:15:43 <jcapitao[m]> I think it's priority
14:15:48 <amoralej> to 3x ?
14:16:11 <amoralej> ah, but there is 3.2.12 in fedora
14:16:28 <jcapitao[m]> yes as current one will enter in extended maintenance during yoga release IIRC
14:16:32 <amoralej> kkula, i misanderstood you today
14:16:33 <jcapitao[m]> isn't it kkula ?
14:17:21 <kkula> I think so
14:17:34 <amoralej> so, we also need to add asgiref
14:17:47 <jcapitao[m]> https://opendev.org/openstack/horizon/commit/8918bf751def72c2cf4fa5975645bc0ae54edb70
14:18:07 <amoralej> actually we had asgiref in cs8
14:19:27 <amoralej> ok, so let's add asgiref and whatever we need
14:19:30 <amoralej> to bump
14:20:12 <amoralej> kkula, you'll need to create the repo deps/python-asgiref
14:21:12 <kkula> yes, I think this part is covered by this doc https://www.rdoproject.org/documentation/requirements/#managing-openstack-requirements-in-rdo
14:21:36 <amoralej> yes, in regular cases, it's automated
14:21:44 <amoralej> after adding a dep to rdoinfo
14:21:51 <amoralej> but in this case, it's already in rdoinfo
14:21:59 <amoralej> so you need to send the review
14:22:12 <amoralej> let me look for an example
14:22:57 <amoralej> https://review.rdoproject.org/r/c/config/+/37831
14:23:21 <kkula> about your question if we want to update any deps before yoga - I still have some distigts to check, so I can't be sure that there are no more cases like horizon and django
14:23:36 <amoralej> we'll see as we do reqchecks
14:23:49 <amoralej> but we are running ci jobs on master
14:23:57 <amoralej> so none of them should be a blocker
14:24:20 <amoralej> kkula, and https://review.rdoproject.org/r/c/config/+/37832
14:24:30 <amoralej> so you need to send two reviews
14:24:32 <amoralej> in that order
14:24:50 <kkula> ok
14:26:00 <amoralej> so i think we can move to next topic?
14:26:44 <jcapitao[m]> yes I think we can move on
14:27:04 <amoralej> #topic EPEL9 Openstack clients bootstrap
14:27:18 <amoralej> #info https://review.rdoproject.org/etherpad/p/openstackclient-epel9
14:27:32 <jcapitao[m]> so the bootstrap is WIP
14:28:02 <jcapitao[m]> I think I built ~50% of them
14:28:28 <amoralej> good
14:28:42 <josecastroleon> nice
14:28:42 <jcapitao[m]> the effort is quite huge as most of projects don't have EPEL9 branch yet
14:29:07 <amoralej> mmm
14:29:20 <amoralej> what requires oslo-messaging?
14:29:26 <amoralej> i though we removed it from fedora?
14:32:17 <jcapitao[m]> hm dunno
14:32:21 <amoralej> anyway
14:32:23 <amoralej> not important
14:32:44 <amoralej> i see you need some pr
14:33:00 <jcapitao[m]> once done, I'll submit the build order list + patches to the EPEL team
14:33:11 <amoralej> yeah
14:33:23 <amoralej> maybe the can do the bootstrapping tricks
14:33:27 <amoralej> without pr
14:33:33 <amoralej> just direct push to distgits
14:34:13 <jcapitao[m]> yeah hopefully
14:35:09 <jcapitao[m]> I won't submit the patches
14:35:31 <amoralej> ok, let's discuss with them
14:35:35 <amoralej> but we need a clean list
14:35:43 <amoralej> of what's needed
14:35:47 <amoralej> and the order
14:35:58 <amoralej> without subpackages, just srpm names
14:36:33 <jcapitao[m]> yes that's the list starting at l.163
14:37:18 <amoralej> but that list is only what you already checked?
14:37:28 <amoralej> rebuilt from rawhide means it's already built?
14:37:33 <amoralej> in epel9?
14:38:28 <jcapitao[m]> it's the list of project I rebuild locally
14:38:44 <amoralej> ah, that's local
14:38:52 <amoralej> sorry, i missed that
14:39:05 <jcapitao[m]> nope it means I had to build it against EPEL9 from rawhide branch
14:39:29 <jcapitao[m]> in mock
14:39:39 <amoralej> ok, so let's build that and let's hand it over to the epel9 sig
14:39:40 <jcapitao[m]> and then I add the result in my local repo
14:39:50 <amoralej> got it n ow
14:39:56 <jcapitao[m]> yes
14:40:54 <amoralej> you can send prs for what is actually needed
14:41:09 <amoralej> as https://src.fedoraproject.org/fork/jcapitao/rpms/python-keystoneclient/c/e769ed49208ba1c32401ca9da8e2407152a143e1?branch=epel9
14:41:14 <amoralej> we can merge that
14:41:46 <jcapitao[m]> right
14:42:39 <amoralej> it's a bunch of stuff ...
14:43:04 <jcapitao[m]> yep ..
14:43:08 <amoralej> https://src.fedoraproject.org/fork/jcapitao/rpms/python-eventlet/c/6bbc8ed1328c682139272eb40e63e1453c9e0297?branch=epel9
14:43:14 <amoralej> https://src.fedoraproject.org/fork/jcapitao/rpms/python-sqlalchemy/c/7190fa61eb7287a9c504c88bddd541bb898be11e?branch=epel9
14:43:19 <amoralej> that's what i'm checking :)
14:43:41 <amoralej> i guess if we don't disable that we'll end up with hundreds
14:43:56 <jcapitao[m]> exactly :D
14:44:21 <amoralej> ok
14:44:25 <amoralej> good progress anyway
14:45:16 <amoralej> python3-rsd-lib
14:45:16 <amoralej> python3-rsdclient
14:45:25 <amoralej> we don't need those
14:45:46 <amoralej> also, we can skip python3-senlinclient
14:46:11 <amoralej> also note https://src.fedoraproject.org/rpms/python-osprofiler/
14:46:16 <amoralej> we removed it
14:46:29 <amoralej> and https://src.fedoraproject.org/rpms/python-oslo-messaging/
14:46:38 <amoralej> that will probably will save us some deps
14:47:34 <jcapitao[m]> ok I'll check for oslo-messaging
14:48:35 <amoralej> make sure the package exist in rawhide
14:49:15 <amoralej> also i'd say scciclient is not needed
14:49:59 <amoralej> and sushy...
14:50:09 <amoralej> i'm not sure
14:50:13 <amoralej> ok, we can discuss later
14:50:26 <amoralej> let's move on
14:50:29 <amoralej> to next topic
14:50:32 <jcapitao[m]> ok
14:50:37 <amoralej> #topic chair for next week
14:50:51 <amoralej> anyone wants to chair next week?
14:51:16 <jcapitao[m]> I can take it
14:51:27 <amoralej> #action jcapitao[m] to chair next week
14:51:31 <spotz_> Beat me to it:)
14:51:36 <amoralej> :)
14:51:46 <amoralej> #topic open floor
14:51:55 <amoralej> anything you'd like to share?
14:52:02 <spotz_> In my defense I’m PTO and on the phone
14:52:05 <amoralej> josecastroleon, the release rpm should be in the extras repos
14:52:07 <amoralej> :)
14:52:17 <amoralej> you shouldn't even be here then spotz_ !
14:52:32 <spotz_> If someone could share the correct SWAG link I’d appreciate it
14:52:55 <amoralej> lemme look
14:53:01 <spotz_> We’ll have a new spotted community member next week. Name pending:)
14:53:10 <josecastroleon> nice, we see it already in the mirror onsite
14:54:04 <amoralej> #action everyone to vote for Yoga Contributor SWAG on https://framadate.org/2K15Lz5whBuwR3Zf
14:54:09 <amoralej> spotz_, ^ that
14:55:12 <PagliaccisCloud> I was off making coffee, did we already talk about Open Infra announcements?
14:55:27 <PagliaccisCloud> Open Infra Summit* announcements
14:56:02 <amoralej> no we didn't
14:56:13 <amoralej> spotz_, ^ anyghing about summit ?
14:56:26 <spotz_> Yep thanks not in this meeting but schedule came out yesterday. Congrats!
14:56:44 <spotz_> I can’t tab complete names on the phone:(
14:57:26 <PagliaccisCloud> Yes! Congratulations to everyone who had a talk accepted ٩( ᐛ )و
14:57:43 <spotz_> Besides any outside RDO stuff, I’ll be looking for mentors for Git and Gerrit and Speed Mentoring which aren’t on the schedule yet
14:57:50 <amoralej> no problem spotz_, we can discuss nest ones
14:58:32 <rdogerrit> Ronelle Landy created rdo-infra/ci-config master: Temp exclude fs035 from wallaby c8  https://review.rdoproject.org/r/c/rdo-infra/ci-config/+/40256
14:58:53 <amoralej> so i think we can close?
14:58:59 <amoralej> we are almost out of time
14:59:04 <spotz_> And OPS meetup is still in the works so there might be speaking opportunities there. With the smaller facility and shorter summit even with making talks shorter there wasn’t room for all the great talks submitted
14:59:07 <amoralej> anything else before closing?
14:59:17 <spotz_> Thanks everyone!
14:59:42 <josecastroleon> thanks
15:00:21 <amoralej> #endmeeting