14:00:42 <amoralej> #startmeeting RDO meeting - 2022-05-20
14:00:42 <opendevmeet> Meeting started Wed Apr 20 14:00:42 2022 UTC and is due to finish in 60 minutes.  The chair is amoralej. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:42 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:42 <opendevmeet> The meeting name has been set to 'rdo_meeting___2022_05_20'
14:00:45 <spotz> Yeah I couldn't remember
14:00:50 <amoralej> #topic roll call
14:00:50 <spotz> o/
14:00:53 <amoralej> #chair spotz
14:00:53 <opendevmeet> Current chairs: amoralej spotz
14:01:33 <kkula> hi!
14:01:43 <amoralej> #chair kkula
14:01:43 <opendevmeet> Current chairs: amoralej kkula spotz
14:04:29 <amoralej> let's start with first topic
14:05:02 <amoralej> #topic Status of yoga release
14:05:17 <amoralej> #info Builds for CS9 are tested and pushed to the repos
14:05:30 <amoralej> #info Builds for CS8 are being testing right now
14:05:32 <spotz> Woohoo
14:05:40 <amoralej> i've been working in tripleo tests
14:05:57 <amoralej> and seems to be passing, i expect to get them pushed end of today or tomorrow
14:06:06 <amoralej> i'll also work on the announcement
14:06:12 <amoralej> i missed that, sorry spotz :(
14:06:37 <spotz> No worries amoralej
14:06:54 <amoralej> so i think we may be able to do the announcement on friday or monday
14:08:00 <spotz> I'd say we wait until Monday or Tuesday so it's not lost over the weekend
14:08:06 <amoralej> #info https://review.rdoproject.org/r/c/rdoinfo/+/42090 if anyone wants to check
14:08:09 <amoralej> yep
14:08:14 <amoralej> +1 to that plan
14:08:32 <amoralej> #agreed the announcement of RDO Yoga will be done on monday or tuesday next week
14:08:43 <spotz> That'll also give us time to get the blog ready
14:08:50 <amoralej> yep
14:10:05 <amoralej> so that's it wrt yoga
14:10:55 <amoralej> let me add a new topic
14:11:31 <amoralej> #topic Removal of support of CentOS Stream 8 in RDO Trunk master
14:11:55 <amoralej> #info RDO Zed will support only CentOS Stream 9
14:12:17 <amoralej> i'd like to start removing centos8 support from master
14:12:45 <amoralej> #info centos stream 8 will be removed from RDO Trunk (aka dlrn) for master soon
14:13:05 <amoralej> #action anyone using RDO on CS8 on master should be switching to CS9
14:13:12 <amoralej> tkajinam hrw ^
14:13:46 <amoralej> you think you'll be able to retire cs8 from master gates and replace them by cs9?
14:14:05 <hrw> amoralej: in Zed we move to cs9
14:14:22 <hrw> there is a set of isses but outside of CentOS
14:14:26 <amoralej> hrw, how far are you of the switch?
14:14:54 <hrw> amoralej: https://review.opendev.org/c/openstack/kolla/+/836664 shows
14:15:06 * hrw -> meeting
14:15:06 <spotz> Weren't we going to have one version that ran both?
14:15:13 <hrw> spotz: it was Yoga
14:15:16 <amoralej> #info https://review.opendev.org/c/openstack/kolla/+/836664
14:15:20 <spotz> Ahh ok
14:15:23 <amoralej> spotz, yes, yoga, as hrw said :)
14:15:43 <amoralej> thanks for the update hrw , i'll keep an eye
14:15:54 <amoralej> chandankumar, ^ also for you
14:16:06 <amoralej> i think there are some molecule jobs also on cs8 in tripleo
14:17:20 <amoralej> so, let's keep this topic open on next meetings
14:17:27 <amoralej> until we are able to get rid of it
14:18:29 <amoralej> i think that's it from my side
14:18:58 <amoralej> there are no more topics
14:19:08 <amoralej> so let's move to open floor
14:19:14 <amoralej> #topic open floor
14:19:29 <amoralej> anything that you'd like to share?
14:20:00 <tkajinam> amoralej, regarding usage of CentOS Stream 8 in puppet CI
14:20:12 <amoralej> ah, you are around :)
14:20:17 <amoralej> #chair tkajinam
14:20:17 <opendevmeet> Current chairs: amoralej kkula spotz tkajinam
14:20:40 <tkajinam> amoralej, I found one of the test framework we use (puppet_litmus) can't be migrated to c9s atm, because its dependent library, bolt is not yet compatible with Ruby 3
14:20:58 <amoralej> oh, damn
14:21:06 <amoralej> #undo
14:21:06 <opendevmeet> Removing item from minutes: #topic open floor
14:21:34 <tkajinam> there are a few patches already proposed to resolve that compatibility stuff but I'm still trying to understand what is required
14:21:47 <amoralej> #info bolt is not yet compatible with Ruby 3, which is blocking the migration of litmus jobs to CS9
14:22:46 <spotz> tkajinam: Is this something we could work to get in EPEL?
14:22:47 <tkajinam> so it'd be helpful if you can wait for that c8s retirement for a few weeks. the final option is to drop the job and rely on integration job but that removes test coverage and thus is not ideal
14:23:13 <tkajinam> spotz, no we are using gems instead of rpms to install these packages
14:23:31 <amoralej> tkajinam, yes, we can wait
14:23:45 <spotz> Ok
14:23:47 <tkajinam> we first need to fix problems in individual upstream repos
14:23:48 <tkajinam> eg. https://github.com/puppetlabs/bolt/pull/2987
14:24:22 <tkajinam> once they create a new release with such fixes then jobs would pull the new version via gems
14:24:58 <amoralej> tkajinam, is there any way to track the migration status?
14:26:31 <tkajinam> amoralej, I'll take time to consider that(at least will create etherpad to track the migration status) but at this moment it looks difficult for me to reproduce all test environment in my local
14:26:45 <tkajinam> so we need fix problems one by one in upstream CI until we get the job all green
14:26:48 <amoralej> ack, no problem
14:27:07 <amoralej> #info tkajinam is working on moving litmus jobs to CS9
14:27:11 <amoralej> thanks for the update
14:27:37 <tkajinam> np. it was quite timely because I found out that compatibility problem this morning :-)
14:28:28 <amoralej> good, just on time :)
14:29:37 <amoralej> #topic open floor
14:29:39 <amoralej> again
14:29:40 <amoralej> :)
14:29:53 <amoralej> anything else you want to discuss?
14:31:44 <spotz> Ducks are still in progress, Looing at doing the walking tour on Tuesday night and an RDO dinner on Thursday. Still working on all that
14:32:42 <spotz> So if you'll be in Berlin on Thursday night reach out to me, the place will probably have limited seating
14:34:50 <spotz> That's it for me
14:35:05 <rdogerrit> Dariusz proposed rdo-infra/ci-config master: Simplify results printing  https://review.rdoproject.org/r/c/rdo-infra/ci-config/+/41902
14:35:27 <amoralej> ok, if there is nothing else, i'll close the meeting
14:36:59 <spotz> Nothing RDO, we do need to plan the CentOS cloud Sig election
14:37:14 <amoralej> right
14:37:17 <amoralej> when is it?
14:37:29 <spotz> Should have been March:)
14:38:13 <amoralej> so may?
14:38:44 <spotz> We should email out at the least and get nominations. We can hold the vote at the May meeting. I'll run the meeting as you'll be out. No one showed last week for the April meeting, I did ask if anyone was there to run it if needed
14:39:10 <amoralej> ohk
14:39:31 <spotz> Of vote via Doodle(or equivalent) and announce at Mat and turn over running the meeting
14:39:43 <spotz> May meeting
14:40:13 <PagliaccisCloud> 0/
14:40:32 <amoralej> #chair PagliaccisCloud
14:40:32 <opendevmeet> Current chairs: PagliaccisCloud amoralej kkula spotz tkajinam
14:40:34 <spotz> Hey PagliaccisCloud
14:41:28 <spotz> Lets get the releae doe, we'll work on the SiG email and get it out before you leave. I'll work on the poll and final stuff while you're out
14:41:42 <amoralej> ok, good
14:41:50 <amoralej> lgtm spotz++
14:42:55 <amoralej> ok, i'm closing the meeting
14:43:02 <amoralej> i'll give you some minutes back
14:43:09 <hrw> spotz: which week you mention?
14:43:09 <amoralej> thanks all for joining
14:43:19 <spotz> Sounds good thanks amoralej and everyone!
14:43:44 <spotz> hrw OpenInfra Summit so June 6-9 in Berlin
14:43:59 <hrw> ah. have to get accept from my manager finally
14:44:01 <spotz> Unless you meant the Sig stuff
14:45:02 <spotz> hrw Nice!
14:45:20 <amoralej> #endmeeting