14:03:38 <amoralej> #startmeeting RDO meeting - 2022-06-22
14:03:38 <opendevmeet> Meeting started Wed Jun 22 14:03:38 2022 UTC and is due to finish in 60 minutes.  The chair is amoralej. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:03:38 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:03:38 <opendevmeet> The meeting name has been set to 'rdo_meeting___2022_06_22'
14:03:44 <amoralej> #topic roll call
14:03:49 <amoralej> #chair spotz
14:03:49 <opendevmeet> Current chairs: amoralej spotz
14:03:56 <amoralej> kkula, jcapitao[m] are you around?
14:04:04 <jcapitao[m]> o/
14:04:05 <kkula> yes
14:04:08 <kkula> o/
14:04:39 <amoralej> #chair jcapitao[m] kkula
14:04:39 <opendevmeet> Current chairs: amoralej jcapitao[m] kkula spotz
14:04:49 <amoralej> anyone else?
14:05:53 <amoralej> let's start with the first topic
14:06:36 <amoralej> #topic FTBFS from Fedora massive rebuild for f37 with python 3.11
14:06:42 <amoralej> in case you didn't see it
14:07:01 <amoralej> #info fedora is rebuilding all python packages for f37 with python 3.11
14:07:08 <amoralej> #info some packages are failing
14:07:19 <amoralej> we need to take care of actual failures
14:07:43 <amoralej> note that some of the failures are related with errors in dependencies
14:07:52 <amoralej> but we need to fix the one under openstack-sig
14:08:17 <jcapitao[m]> ok can we split the work ?
14:08:36 <amoralej> yep
14:08:54 <amoralej> let's create a etherpad to coordinate
14:09:26 <amoralej> https://review.rdoproject.org/etherpad/p/FTBFS-fedora-37
14:10:38 <amoralej> jcapitao[m], may you take care of mox3?
14:10:49 <amoralej> the best option for mox3 would be to retire it
14:10:53 <jcapitao[m]> yes
14:10:57 <jcapitao[m]> let's retire it
14:11:01 <spotz> Do we need to be keeping an eye on things as openstack-sig? Beyond tests and such?
14:12:19 <amoralej> you mean in fedora?
14:12:47 <amoralej> our main tasks on openstack-sig is updating packages on every new openstack coordinated release
14:12:57 <amoralej> and when there are failures
14:13:07 <amoralej> with new fedora or python versions
14:13:55 <jcapitao[m]> the ML mail https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/message/BEUJZTFNJQDLJRLJFRAM4RPNTTG2JICA/
14:14:15 <jcapitao[m]> and https://fedoraproject.org/wiki/Changes/Python3.11
14:14:16 <jcapitao[m]> FTR
14:14:57 <amoralej> but it's tricky
14:15:19 <amoralej> to find out when is an acutal issue in that package or when it's just waiting for fixing others
14:16:13 <spotz> Ok so there's no SiG activities like Cloud Sig, meetings, reports, etc
14:16:32 <amoralej> nop
14:16:49 <spotz> +!
14:16:55 <spotz> +1:)
14:17:04 <amoralej> :)
14:18:44 <amoralej> i've added to the etherpad the packages i know are currently failing and need to be fixed
14:18:50 <amoralej> there may be more
14:19:44 <jcapitao[m]> ok, I will look into BZ
14:19:48 <spotz> We can fix what we know and see what shows up next
14:21:05 <amoralej> yes, they do periodic massive rebuilds
14:21:31 <amoralej> so, en every build some of the builds are fixed and that fixes some
14:22:56 <amoralej> feel free to take the ones in "in the queue list" if you have some time
14:23:41 <amoralej> #info https://review.rdoproject.org/etherpad/p/FTBFS-fedora-37
14:26:16 <amoralej> what is unclear to me is if there is an updated list of failing packages now
14:26:24 <amoralej> ok, let's move on
14:26:49 <amoralej> #topic RDO CI jobs and CentOS CI changes
14:27:05 <amoralej> who onwns this?
14:27:12 <amoralej> jcapitao[m] ?
14:27:46 <jcapitao[m]> that was I'm looking for, the updated list
14:27:51 <jcapitao[m]> but haven't found it yet
14:27:55 <jcapitao[m]> yes it's me
14:28:39 <jcapitao[m]> I'm introducing the discussion here, even though it's CentOS CI change
14:28:56 <jcapitao[m]> but we can take decision for RDO jobs
14:29:17 <jcapitao[m]> #link https://lists.centos.org/pipermail/centos-devel/2022-June/120418.html
14:29:42 <amoralej> the question is if we need to use CentOS CI
14:30:00 <amoralej> currently we use it mainly because of oooq libvirt jobs
14:30:01 <jcapitao[m]> yes, as CentOS CI is going hardwareless
14:30:21 <amoralej> apevec rlandy ^
14:30:30 <jcapitao[m]> from our last migration etherpard https://review.rdoproject.org/etherpad/p/jenkins-migration
14:30:44 <amoralej> the short version is that, centos ci is moving to aws
14:30:46 <jcapitao[m]> we have 2 ppc64le jobs and 1 ooo libvirt job which is sequentialize in a pipeline
14:30:52 <amoralej> with limited bare metal option
14:31:12 <amoralej> i'd say ppc64le jobs are not longer used?
14:31:16 <jcapitao[m]> yes and we don't know exactly what is "limited"
14:31:19 <amoralej> jcapitao[m], are they passing or failing?
14:31:28 <jcapitao[m]> failing
14:31:33 <jcapitao[m]> since a while
14:31:48 <jcapitao[m]> so I don't know if it's still relevant
14:32:01 <amoralej> i'm pretty sure they are not
14:32:22 <amoralej> for https://jenkins-cloudsig-ci.apps.ocp.ci.centos.org/job/tripleo-upstream-containers-build-master-ppc64le/
14:32:29 <amoralej> it never passed in the new jenkins
14:32:38 <amoralej> for https://jenkins-cloudsig-ci.apps.ocp.ci.centos.org/job/tripleo-upstream-images-build-master-ppc64le/
14:32:50 <amoralej> last successful was 7months ago?
14:32:50 <jcapitao[m]> neither
14:34:02 <amoralej> i think the contributors that used to work on those jobs left
14:34:12 <amoralej> and there is no effort on making it work for ppc64le
14:34:41 <amoralej> and for oooq, i'd say the best option would be to get access to baremetal in some other infra and run it from zuul
14:34:55 <amoralej> so we can finally move out of this infra
14:35:20 <jcapitao[m]> agree
14:35:37 <jcapitao[m]> my thought was to request CentOS CI node from our Zuul
14:36:02 <amoralej> wdym ?
14:36:07 <jcapitao[m]> but, I think we can request node only from Jenkins in their openshift infra
14:36:08 <jcapitao[m]> IIRC
14:36:49 <amoralej> yes
14:37:15 <amoralej> if we want to consume centos ci infra we need to use the jenkins there
14:38:43 <jcapitao[m]> ok, so either we find another infra, or we continue with CentOS CI
14:39:20 <amoralej> yes
14:40:13 <amoralej> i think we'll need to continue the conversation with apevec about that
14:41:02 <jcapitao[m]> yes, let's sync after
14:41:05 <amoralej> anything else wrt this topic?
14:41:50 <jcapitao[m]> nope
14:42:29 <amoralej> #topic open floor
14:42:38 <amoralej> any topic you'd like to share?
14:44:40 <spotz> Hope to have news on the contributor item soon, I know the PO was sent but I haven't heard anything yet.
14:45:41 <amoralej> thanks for the update
14:45:51 <amoralej> #chair for next meeting
14:45:51 <opendevmeet> Warning: Nick not in channel: for
14:45:51 <opendevmeet> Warning: Nick not in channel: next
14:45:51 <opendevmeet> Warning: Nick not in channel: meeting
14:45:51 <opendevmeet> Current chairs: amoralej for jcapitao[m] kkula meeting next spotz
14:45:59 <amoralej> #topic chair for next meeting
14:46:06 <amoralej> any volunteer?
14:46:09 <spotz> hehe
14:46:10 <jcapitao[m]> I can take it
14:46:16 <spotz> Thanks jcapitao[m]
14:46:47 <amoralej> #action jcapitao will chair next meeting
14:47:06 <amoralej> if there are no more topics, i'll close the meeting and will give you some time back
14:47:11 <amoralej> 3 ...
14:47:13 <amoralej> 2 ...
14:47:17 <amoralej> 1 ...
14:47:34 <amoralej> thanks all for joining "
14:47:38 <amoralej> #endmeeting