14:00:42 <jcapitao[m]> #startmeeting RDO meeting - 2022-06-29
14:00:43 <opendevmeet> Meeting started Wed Jun 29 14:00:42 2022 UTC and is due to finish in 60 minutes.  The chair is jcapitao[m]. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:43 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:43 <opendevmeet> The meeting name has been set to 'rdo_meeting___2022_06_29'
14:00:54 <jcapitao[m]> #topic roll call
14:01:23 <kkula> o/
14:01:45 <jcapitao[m]> #chair spotz
14:01:45 <opendevmeet> Current chairs: jcapitao[m] spotz
14:02:46 <spotz> o/
14:02:55 <jcapitao[m]> oops
14:02:57 <jcapitao[m]> #chair kkula
14:02:57 <opendevmeet> Current chairs: jcapitao[m] kkula spotz
14:04:17 <amoralej> o/
14:04:54 <jcapitao[m]> #chair amoralej
14:04:54 <opendevmeet> Current chairs: amoralej jcapitao[m] kkula spotz
14:05:16 <jcapitao[m]> let's start with first topic
14:05:21 <jcapitao[m]> #topic FTBFS in fedora massive rebuilds for Fedora 37 with python 3.11
14:05:28 <jcapitao[m]> #link https://review.rdoproject.org/etherpad/p/FTBFS-fedora-37
14:05:53 <jcapitao[m]> I checked the list again
14:06:42 <jcapitao[m]> I mean the list published by Fedora folks
14:06:46 <amoralej> yeah
14:06:51 <jcapitao[m]> there is one remaining python-murano-pkg-check
14:06:58 <amoralej> some of them were not actual issues i think, but ok
14:07:17 <amoralej> i've reported the yappi one upstream
14:08:03 <jcapitao[m]> yes after some iteration it's ok for most of them
14:08:52 <amoralej> yep
14:10:12 <amoralej> unicodecsv, last release 2015 :(
14:10:31 <jcapitao[m]> ok, so almost good
14:10:37 <jcapitao[m]> murano-pkg-check is a bit tricky too
14:10:51 <amoralej> what's the problem with it?
14:11:09 <jcapitao[m]> at first it was just adding safe loader to yaml, but now I'm hitting other issue with mock
14:12:16 <amoralej> also very low activity
14:12:16 <amoralej> https://review.opendev.org/q/project:openstack/murano-pkg-check
14:12:29 <jcapitao[m]> when importing mock decoration helper it fails
14:12:33 <amoralej> but it seems maintained
14:12:44 <amoralej> we may report it upstream if needed
14:13:16 <jcapitao[m]> yeah I think I'm gonna report it
14:15:09 <jcapitao[m]> ah, for python-unicodecsv we have to retire it too I guess
14:15:28 <amoralej> it's not longer used?
14:15:33 <amoralej> i see we didnĀ”'t import it in cs9
14:17:43 <jcapitao[m]> it's not required by anything
14:19:22 <amoralej> then, i'd bet for retiring it
14:20:45 <amoralej> be careful
14:20:46 <amoralej> https://src.fedoraproject.org/rpms/python-registry/blob/rawhide/f/python-registry.spec#_30
14:20:48 <amoralej> jcapitao[m], ^
14:21:32 <amoralej> and https://src.fedoraproject.org/rpms/python-rows/blob/rawhide/f/python-rows.spec#_37
14:22:32 <jcapitao[m]> ah!
14:22:52 <jcapitao[m]> ok I'll dig in later
14:23:00 <amoralej> so, even if we don't use it in rdo
14:23:12 <amoralej> let's check if those actually need it
14:23:58 <jcapitao[m]> right
14:24:07 <jcapitao[m]> I'll check the codebase
14:24:24 <rdogerrit> Merged openstack/cinderlib-distgit yoga-rdo: python-cinderlib-4.2.0-1  https://review.rdoproject.org/r/c/openstack/cinderlib-distgit/+/43751
14:24:25 <rdogerrit> Merged openstack/cinderlib-distgit xena-rdo: Exclude mangling shebang  https://review.rdoproject.org/r/c/openstack/cinderlib-distgit/+/43753
14:25:19 <amoralej> it's drop in for standard csv
14:25:28 <amoralej> maybe it's not longer needed
14:25:30 <amoralej> i'm not sure
14:26:44 <spotz> If we drop and it's an issue will tests catch it? Or could we possibly mark it for deprecation and see who says something?
14:28:04 <amoralej> i think it will appear in next reports
14:28:12 <amoralej> of packages marked to be retired
14:28:19 <amoralej> but as we know who is using them
14:28:28 <amoralej> let's try to ping the maintainers directly
14:29:13 <spotz> +2
14:29:25 <amoralej> https://github.com/williballenthin/python-registry/blob/master/samples/amcache.py#L24
14:29:34 <amoralej> python-registry is also using it
14:31:10 <jcapitao[m]> ok let's ask them
14:31:33 <amoralej> both packages are from the same maintainer
14:31:57 <amoralej> and he's on #fedora-devel :)
14:32:01 <amoralej> so, it'll be easy
14:33:08 <rdogerrit> Merged openstack/cinderlib-distgit wallaby-rdo: Exclude mangling shebang  https://review.rdoproject.org/r/c/openstack/cinderlib-distgit/+/43757
14:33:29 <jcapitao[m]> yes he's very active
14:33:40 <amoralej> yep
14:34:10 <jcapitao[m]> any questions on this topic ?
14:35:17 <jcapitao[m]> let's move on
14:35:22 <jcapitao[m]> #topic next chair
14:35:31 <jcapitao[m]> any volunteers
14:35:40 <jcapitao[m]> ?
14:35:43 <jcapitao[m]> it will be video call though
14:36:15 <amoralej> i can take it
14:37:11 <jcapitao[m]> thanks amoralej
14:37:31 <jcapitao[m]> #action amoralej will chair the next meeting
14:37:44 <jcapitao[m]> #topic Open Floor
14:37:48 <tosky> thanks all the team for the work with keeping the packages up-to-date (like the countless times I've ask amoralej for a review), and special thanks today for jcapitao[m] for the help unblocking cinderlib
14:38:14 <amoralej> jcapitao++
14:40:01 <jcapitao[m]> I'm glad to help :)
14:40:07 <amoralej> and thanks tosky for being such a nice maintainer :)
14:40:32 <jcapitao[m]> yeah!
14:40:37 <spotz> Thank you tosky for coming here and saying thanks!
14:41:04 <spotz> I think we sometimes forget to say that enough
14:41:18 <amoralej> totally
14:42:26 <amoralej> wrt cs8 removal
14:42:33 <amoralej> once https://review.opendev.org/c/openstack/tripleo-ansible/+/839688/ is merged we'll be able to finally remove centos8 from master
14:43:47 <jcapitao[m]> great it's gating
14:43:52 <spotz> Nice
14:43:54 <amoralej> yep
14:44:37 <tosky> great!
14:45:40 <amoralej> finally :)
14:46:07 <jcapitao[m]> yeah :)
14:49:03 <amoralej> fyi, we'll need to bump python-setuptools_scm for centos8 to get gnocchi 4.4 branch working
14:49:20 <amoralej> i've been working with kkula about it
14:49:23 <amoralej> it's wip
14:51:06 <jcapitao[m]> ok
14:51:53 <jcapitao[m]> I'm going to close the meeting if nothing more to add
14:52:31 <amoralej> nothing from my side
14:53:11 <jcapitao[m]> let's close
14:53:14 <jcapitao[m]> #endmeeting