14:01:50 <spotz> #startmeeting RDO meeting - 2022-07-20
14:01:50 <opendevmeet> Meeting started Wed Jul 20 14:01:50 2022 UTC and is due to finish in 60 minutes.  The chair is spotz. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:50 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:50 <opendevmeet> The meeting name has been set to 'rdo_meeting___2022_07_20'
14:02:01 <spotz> #topic ROll Call
14:02:28 <amoralej> o/
14:02:34 <amoralej> i have a couple of topics
14:04:38 <kkula> o/
14:05:22 <spotz> #chair amoralej kkula
14:05:22 <opendevmeet> Current chairs: amoralej kkula spotz
14:05:36 <spotz> I moved them down from next week's area just wanted to be sure:)
14:05:53 <spotz> #topic Should we create centos9-master-head RDO Trunk repo ?
14:06:42 <amoralej> ah, ok
14:07:06 <amoralej> #info RDO Trunk builders centos8-master and centos8-master-head are stopped now
14:07:58 <spotz> Have we had any issues or are we good?
14:08:04 <amoralej> #info for CS9 we onle created centos9-master, which follows versions in upper-constraints.txt but we didn't create centos9-master-head followint master peaks
14:08:27 <amoralej> spotz, we are good, no news so far
14:08:31 <amoralej> no news == good news
14:08:49 <amoralej> so, my doubt is if we should create centos9-master-head chasing master
14:09:04 <amoralej> my feeling is that it wasn't providing much value
14:09:15 <amoralej> as we use centos9-master for ci and everything
14:09:40 <amoralej> the goal of centos9-master-head is to find issues before they reach upper-constraints
14:09:58 <amoralej> but i have doubts it's useful tbh
14:10:16 <amoralej> so i was thinking if we should create it or forget it
14:10:35 <amoralej> apevec ykarel ^ you have any opinion?
14:11:01 <amoralej> kkula spotz wdyt?
14:11:10 <spotz> Ok, in the meeting the TC had with folks from CentOS 2 weeks ago a theme sems to be to have a set timestamp so to speak of Stream to test again. Do you think that would be helpful?
14:11:44 <amoralej> you mean versioned centos repos?
14:11:45 <ykarel> amoralej, atleast it was useful when spec changes were needed for pinned libraries/clients
14:12:07 <amoralej> well, it's useful if we monitor it :)
14:12:14 <spotz> Sort of just so as ykarel just typed you have an idea of versions in it
14:12:24 <amoralej> and it also brings some false negatives
14:12:29 <ykarel> to know the upcoming changes earlier then at the time of -uc update
14:12:48 <ykarel> but yes i don't think it was used other than it
14:13:15 <spotz> I was thinking more froma known point of time what's in it if we then update and things start breaking
14:13:33 <amoralej> maybe it will be easier to monitor with our incoming great ftbfs dashboard :)
14:14:03 <amoralej> spotz, so, for RDO repos itself we have it, so i understand the problem is with centos repos
14:14:18 <spotz> correct
14:15:05 <amoralej> that's not something that centos provide, the provide some timestamped repos, but they don't have any commitment
14:15:12 <amoralej> on how much they will be stay around
14:15:29 <ykarel> yes and agree about false positives, so if it's takes much resources and maintenance can avoid it, it's already not running so good time to decide over it
14:15:54 <ykarel> as packaging issues can always be fixed at time of uc updates
14:15:55 <spotz> Right but if we could pul a set of repos and keep using that set on our side is my thought if we can, we may not be able to
14:16:10 <amoralej> ykarel, yep, we decided not to create it until we remove the centos8 one, so it's time to consider it
14:16:21 <amoralej> spotz, we may create a version + mirror mechanism
14:16:30 <spotz> +1
14:16:33 <amoralej> we tried not to do it in the past, actually :)
14:16:50 <amoralej> it can be problematic, as it's kind of "forking centos"
14:17:19 <amoralej> so, i.e. I'd be against recomending it for users or operators, for sure
14:17:46 <amoralej> i mean recommending to use some frozen repos that we take responsibility on
14:18:11 <spotz> Aleksandra has some ideas and we wouldn't patch it or anything just keep it for a few days after starting on the next 'fork' and if it goes well delete and if not compare and reprot what's broken to CentOS and get help
14:18:18 <amoralej> i.e. what if there is some issue which blocks promotion of new content and we con't push CVEs...
14:19:06 <spotz> We learned in Berlin at least one company is doing it actually not sue what they're doing for CVEs though
14:19:16 <ykarel> amoralej, ack
14:19:28 <amoralej> spotz, the best option for that would be that centos allows us to run CI jobs on their composes
14:19:31 <amoralej> before they push
14:19:50 <amoralej> so that we can provide feedback on content pending to be pushed
14:20:03 <amoralej> did that option appeared in the conversation?
14:20:09 <ykarel> iirc tripleo ci did some work in past to test composes?
14:20:16 <amoralej> yes
14:20:39 <spotz> Can always ask from the CLoud SIg:)
14:21:05 <ykarel> and those tests didn't catched the issues ?
14:21:11 <amoralej> but, if it's not providing feedback to centos team, it's not very useful, in some cases we can save some time
14:21:31 <amoralej> ykarel, i think we catched some, but it also has its own issues
14:21:41 <amoralej> actually, i think there is still the idea to create that
14:21:50 <ykarel> amoralej, ohkk
14:21:51 <amoralej> i mean, running regular ci jobs using official mirrors
14:22:08 <amoralej> but have a separated pipeline testing unpublished compose
14:22:26 <amoralej> chkumar|rover, ^ is that idea still around?
14:23:15 <amoralej> the problem with that is, we should also mirror sig content, etc...
14:23:23 <amoralej> or we may hit other issues
14:23:48 <amoralej> spotz, who participated in that meeting?
14:24:46 <spotz> apevac, bstinson, and Aleksandra. In hind site shold have invited jcapitao as SiG Chair and you but TC said they wanted CentOS vs RDO
14:25:33 <amoralej> ok
14:25:54 <amoralej> there was public minutes for the meeting?
14:26:46 <spotz> Recording hang on:)
14:26:52 <amoralej> ack :)
14:26:59 <spotz> #link https://www.youtube.com/watch?v=zeJG6Mujalo
14:27:23 <amoralej> good
14:27:25 <amoralej> thx
14:27:48 <amoralej> i'll watch it
14:28:22 <spotz> Sounds good, anything else on this topic or we'll move to your next
14:28:42 <amoralej> so, i'm not sure about centos9-master-head, tbh ...
14:29:23 <spotz> Why don't we table it until after you watch it. I won't be here next week though I'll be in Raleigh
14:29:42 <spotz> We can always have a quick discussion in channel or on the mailing list if needed
14:29:52 <amoralej> spotz, tbh i don't think one thing depends on the other
14:29:56 <spotz> Ok
14:30:09 <spotz> Does it hurt anything to create it?
14:30:15 <amoralej> i mean having centos9-master-head will not help to have that kind of version stamp
14:30:18 <amoralej> actually, not
14:30:25 <amoralej> it's just to save effort and resources
14:30:42 <amoralej> it may be a good oportunity for kkula to create her first dlrn builder :)
14:30:58 <spotz> Then it has purpose! kkula will do it!:)
14:31:06 <amoralej> as she's becoming our ftbfs master
14:31:13 <amoralej> after se became our deps master
14:31:15 <amoralej> :)
14:31:36 <spotz> Learning is a good reason to do it so decision made.
14:31:46 <amoralej> ok, lgtm
14:31:50 <amoralej> kkula, ^
14:31:55 <amoralej> i need your +1 :)
14:32:09 <kkula> ready to do the job!
14:32:15 <spotz> #info kkula will make the centos9-master-head branch. If anyone would like to learn how as well reach out to amoralej and kkula
14:32:28 <spotz> :)
14:32:43 <spotz> #yopic Docs: status of https://www.rdoproject.org/use/
14:33:08 <spotz> I have cleaned it up a few times but not recently
14:33:48 <amoralej> #topic Docs: status of https://www.rdoproject.org/use/
14:34:09 <amoralej> so, while reviewing a patch from jcapitao, i found some very old content
14:34:14 <amoralej> there
14:34:32 <PagliaccisCloud> O/ greetings everyone!
14:34:48 <spotz> Hey PagliaccisCloud
14:34:53 <amoralej> o/ PagliaccisCloud
14:35:55 <spotz> amoralej: Maybe make a trello with your findings and we'll work through the list?
14:35:58 <amoralej> so, i was thinking how much of that is useful, if we maintain it
14:36:33 <amoralej> as it was created by component owners, most of the times, it'd be probably good to discuss with them
14:36:34 <spotz> I think we should mauntain like the getting started or point to the upstream docs, which would leave us with only maintaining packstack
14:36:51 <amoralej> as i guess there are upstream docs which has similar, but updated, content
14:37:11 <amoralej> spotz, yes, that's exactly my thought
14:37:17 <spotz> Like the tripleo and tripleoquickstarts
14:37:20 <amoralej> yep
14:37:56 <amoralej> #agrees we should maintain like the getting started or point to the upstream docs which wuld leave us with only maintaining packstack
14:38:02 <amoralej> #agreed we should maintain like the getting started or point to the upstream docs which wuld leave us with only maintaining packstack
14:38:47 <spotz> Some of the other stuff we'll need to go through, I know even upstream we've gotten a little lazy about making sure the deployment stuff is uptodate for release
14:39:17 <spotz> I'll carve out some time for a look
14:39:52 <amoralej> yeah, we are lazy :)
14:39:55 <amoralej> btw
14:40:13 <amoralej> #info we got a new document for packagers https://www.rdoproject.org/documentation/package-building-overview/
14:40:16 <amoralej> thanks kkula !
14:40:43 <spotz> Do we have it linked in yet?:)
14:41:00 <amoralej> yes, it's in packagers main page
14:41:14 <amoralej> btw, i just learn something new, --verbose-build, cool
14:41:25 <amoralej> spotz, it's linked in https://www.rdoproject.org/documentation/rdo-packaging/
14:42:19 <spotz> Perfect!
14:42:51 <spotz> #action spotz will look at the page and see where we can link upstream, remove for out of date, etc
14:43:01 <spotz> So I don't forget:)
14:43:18 <spotz> Any thing else on this?
14:43:35 <amoralej> i also need to https://www.rdoproject.org/what/trunk-repos/
14:43:45 <amoralej> it still points to centos7
14:44:58 <spotz> #action amaralej to up date the trunk-repos page:)
14:45:35 <spotz> Maybe one meeting we do as a video working meeting and just go through docs?
14:45:51 <amoralej> or organize a docs day!
14:46:01 <amoralej> that'd be good, i thik
14:46:55 <amoralej> we can do video call session or something
14:47:17 <amoralej> but, we'd need to ensure the procuedure to run docs locally works fine in current fedora before
14:47:47 <spotz> Yeah, ok lets look at calendar dates and see what we can do. I'm traveling one week a month for the next few months but we'll find a date!
14:48:15 <spotz> I'm excited even if it might just be us:)
14:48:51 <amoralej> yes :)
14:48:52 <spotz> Ok anything else on this right now?
14:49:03 <amoralej> it's good to focus on docs one day
14:49:29 <kkula> I'll also take part with pleasure
14:51:05 <spotz> #action We will find a day and have a Docs Day!! All invited!
14:51:17 <spotz> Ok moving on as we have 9 minutes
14:51:24 <spotz> #topic Yoga SWAG
14:52:23 <spotz> I got an update and actually appreoved the markup during this meeting. Long story short the factory emailed the vendor for some clarification and that email got lost:( We're looking at August and we might be on the new fullfilment system about then but hoopefully won't delay things further
14:52:45 <spotz> #topic Next Week's chair
14:53:01 <spotz> Volunteers?:)
14:53:24 <amoralej> i can take it
14:53:37 <spotz> Thanks amoralej and the section is already created:)
14:53:58 <spotz> #topic Open Floor
14:55:23 <PagliaccisCloud> Did I miss convo about PTG plans? Will RDO have presence?
14:56:31 <spotz> I just started looking into that today, I haven't found anything yet for a social
14:56:59 <spotz> We're also just starting investigating whether to have atleast a small OPS Meetup precense
14:57:49 <spotz> So the answer is there will be something just don't know yet:) I did bring back the camera Rain used to do the interviews with but haven't tried to see if it even still works
14:59:24 <spotz> I'll put the PTG on the schedule for in 2 weeks, hopefully I'll have had time to research more
15:00:19 <spotz> And we're at time so thanks everyone for coming, PagliaccisCloud feel free to hit me up after the meeting to chat but honestly just started this morning.
15:00:25 <spotz> #endmeeting