14:12:48 <amoralej> #startmeeting RDO meeting - 2022-09-28
14:12:48 <opendevmeet> Meeting started Wed Sep 28 14:12:48 2022 UTC and is due to finish in 60 minutes.  The chair is amoralej. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:12:48 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:12:48 <opendevmeet> The meeting name has been set to 'rdo_meeting___2022_09_28'
14:12:55 <amoralej> my apologies
14:13:20 <amoralej> #chair spotz kkula jcapitao[m]
14:13:20 <opendevmeet> Current chairs: amoralej jcapitao[m] kkula spotz
14:13:28 <spotz> No worries:)
14:13:32 <amoralej> let's start with the first topic
14:14:06 <amoralej> #topic RDO Docs day retrospect
14:14:33 <spotz> So overall I think it went well, as expected it was mainly us but we did have one new person.
14:14:58 <jcapitao[m]> we have a website quite up-to-date
14:15:24 <amoralej> yep, we could atract one person and i think we will be able to involve some more even though didn't appear in rdo docs day
14:15:35 <spotz> I think next one we do I'll advertise a bit to see if we can't get more new people. I did let folks know there were still open issues so maybe we'll get everything done!
14:16:01 <spotz> Great work everyone!!
14:16:52 <amoralej> thanks!
14:17:11 <amoralej> i think it was a good proof that focusing in one think one day helps to move on old stuff
14:17:33 <jcapitao[m]> I was about to say the exact same thing
14:17:49 <jcapitao[m]> it's more efficient
14:18:00 <amoralej> yes
14:18:22 <amoralej> fyi, i asked security team to check the doc about keystone and networking about theirs content
14:18:40 <amoralej> i hope they will review it although it will take them some time
14:18:57 <spotz> Yeah and we can definitely do more Days in the future, for Docs, Bugs, or whatever
14:20:13 <amoralej> #info https://review.rdoproject.org/r/q/topic:docs-day
14:20:46 <amoralej> #info 10 reviews were created and merged
14:20:51 <amoralej> #undo
14:20:51 <opendevmeet> Removing item from minutes: #info 10 reviews were created and merged
14:20:56 <amoralej> #info 18 reviews were created and merged
14:21:20 <amoralej> anything else to add wrt docs day?
14:21:42 <spotz> Not from me
14:21:45 <jcapitao[m]> nope
14:22:12 <amoralej> ok, i'll move to the next topic
14:22:27 <amoralej> #topic RDO Zed preparation update
14:22:39 <amoralej> jcapitao[m] ...
14:23:14 <jcapitao[m]> we managed to build last RC1 bits
14:23:30 <jcapitao[m]> which were blocked because of oslo.db issue
14:23:54 <amoralej> we have the fixes for all known oslo.db issues, right?
14:24:20 <jcapitao[m]> yes
14:24:35 <amoralej> good
14:24:47 <jcapitao[m]> they are already built in zed-rdo
14:25:06 <jcapitao[m]> tempest plugins are almost built (missing ~2-3)
14:26:04 <jcapitao[m]> we are waiting for the puppet modules patch to be open upstream in order to pin and build non-os puppet modules
14:26:29 <amoralej> tkajinam ^ any idea when we may have releases for puppet modules?
14:28:39 <amoralej> apparently not ...
14:28:58 <jcapitao[m]> Zed GA is planned next week https://releases.openstack.org/zed/schedule.html
14:30:12 <amoralej> there is in-flight review to cut branch for requirements btw https://review.opendev.org/c/openstack/releases/+/858294
14:30:55 <amoralej> with that we can start moving tags to antelope
14:31:27 <amoralej> i assume we will continue using the friendly names for release tags and name  in RDO
14:31:47 <amoralej> antelope vs 2023.1
14:32:13 <spotz> I'm in favor of names:)
14:32:34 <jcapitao[m]> is 2023.1 used somewhere ?
14:32:35 <amoralej> me too
14:32:52 <amoralej> what i've seen is using both "2023.1 Antelope"
14:33:12 <amoralej> https://specs.openstack.org/openstack/nova-specs/specs/2023.1/
14:34:00 <kkula> names ++
14:34:04 <jcapitao[m]> ah
14:34:34 <amoralej> i don't know what upstream will use for branch names, etc...
14:34:42 <amoralej> spotz, is that decided?
14:34:47 <spotz> numbers
14:34:49 <amoralej> stable/antelope or stable/2021.1
14:34:51 <amoralej> mm
14:34:57 <amoralej> that may break automation then
14:35:01 <jcapitao[m]> mmh this might alter our tooling
14:35:04 <jcapitao[m]> yeah
14:35:18 <spotz> I'm the most pro-name person on the TC
14:36:15 <amoralej> :)
14:36:43 <amoralej> we'll need to handle it for next release
14:36:53 <amoralej> well, tags are now
14:37:20 <amoralej> but i'm definetively in favor of names, tbh, even if that makes us to fix some tooling
14:37:44 <amoralej> i guess using numbers with dots will also make us to patch tooling
14:38:06 <spotz> And we can still call it Antelope no matter what, I'm doing that upstream too:)
14:38:23 <amoralej> pro-names lobby
14:38:26 <amoralej> :)
14:39:16 <jcapitao[m]> better for marketing !
14:39:18 <amoralej> ok, i think that's it wrt zed preparation?
14:39:53 <jcapitao[m]> yep I have nothing else to add
14:40:08 <rdogerrit> Douglas Viroel proposed rdo-jobs master: DNM - Debugging FIPS nodeset  https://review.rdoproject.org/r/c/rdo-jobs/+/45028
14:40:20 <spotz> Just a reminder about the announcement doc
14:40:24 <spotz> #link https://review.rdoproject.org/etherpad/p/zed-release-announcement
14:41:58 <amoralej> #action RDOers to review RDO announcement in https://review.rdoproject.org/etherpad/p/zed-release-announcement
14:42:38 <amoralej> ok, next topic
14:43:09 <amoralej> #topic Problem with sqlalchemy i Wallaby on CentOS Stream 9
14:43:46 <spotz> Should Wallaby be on CS9?
14:43:49 <amoralej> #info CS9 has added a new package sqlalchemy-1.4 recently wich supersedes the 1.3 build that RDO ships for Wallaby
14:44:01 <amoralej> spotz, we have wallaby on CS8 and CS9
14:44:13 <amoralej> only RDO Trunk builds, not official builds
14:44:34 <spotz> Ahh ok, I was htinking Yoga was the crossover
14:45:10 <amoralej> yes, it's the "official" crossover as it's where we ship both in CloudSIG and RDO Trunk
14:45:26 <amoralej> but RDO Trunk wallaby is used by some projects as tripleo
14:45:52 <spotz> Got it
14:46:04 <spotz> Can we put an override in place or no?
14:46:10 <amoralej> #info sqlalchemy 1.4 has some non-backwards compatible changes compared to 1.3
14:46:35 <amoralej> yes, we'll have to put an override in the most "friendly" way we can
14:47:10 <amoralej> so, the current approach is to create a new package python-sqlalchemy13 which ships ansible-1.3
14:47:14 <amoralej> rename the package
14:47:48 <amoralej> and update the specs requiring < 1.4
14:47:50 <spotz> +1
14:49:15 <amoralej> that also would allow to install 1.4 in case that something requires it in a different container, i.e.
14:49:47 <amoralej> so i think it's better that bumping epoch which would be a full override forever
14:51:01 <jcapitao[m]> why shipping ansible-1.3 ?
14:51:05 <amoralej> i've created a scratch build in https://cbs.centos.org/koji/taskinfo?taskID=3026099 and i'm doing some basic testing
14:51:17 <amoralej> because openstack wallaby is not compatible with 1.4
14:51:47 <amoralej> u-c in wallaby is 1.3.24 and actually, it's not possible to backport all the required fixes to make it compatible with 1.4 upstream
14:51:54 <amoralej> in Wallaby
14:52:36 <amoralej> currently tripleo has a workaround with an excludes in the centos repo, but it's an extremely fragile fix
14:53:52 <amoralej> so i think it's better to update all the spec files and rename
14:54:38 <jcapitao[m]> ok got it
14:56:11 <amoralej> actually, at this point i think automatic deps are helping us
14:56:27 <amoralej> because some projects already cap max version
14:56:37 <amoralej> i need to check which ones
14:57:37 <amoralej> i'll open the open floor
14:57:41 <amoralej> #topic open floor
14:57:51 <amoralej> anyone is willing to chair next week?
14:58:19 <amoralej> ah, also we have this already https://review.rdoproject.org/r/c/openstack/barbican-distgit/+/44082/2/openstack-barbican.spec
14:59:53 <jcapitao[m]> ack
14:59:59 <jcapitao[m]> I'll take a look
15:00:05 <spotz> Just a note on the swag, do we care if the imprint is only one color? All the water bottles appear to be one color printing despite the preview showing full color
15:00:14 <jcapitao[m]> I can chair next meeting
15:00:22 <amoralej> no problem from my side spotz
15:00:30 <spotz> Next week is the video call, I should be able to
15:00:47 <jcapitao[m]> no problem for my side as well :)
15:01:02 <amoralej> spotz, jcapitao[m] volunteered first :)
15:01:11 <amoralej> or you need to open the call?
15:01:28 <spotz> Nope anyone from RH can:)
15:01:49 <amoralej> #action jcapitao[m] to chair next week
15:01:54 <amoralej> we are out of time
15:02:11 <amoralej> unless you have something else, i'm closing the mtg
15:02:34 <spotz> I'll set up a poll this week I hope for the swag, not rushing as I don't want it to sit with the Yoga stuff while we work on distribution
15:02:40 <spotz> Not me
15:03:11 <amoralej> ok, i'll close
15:03:17 <amoralej> sorry again for starting late
15:03:18 <jcapitao[m]> thanks !
15:03:23 <amoralej> #endmeeting