14:04:49 <amoralej> #startmeeting RDO meeting - 2022-10-26
14:04:49 <opendevmeet> Meeting started Wed Oct 26 14:04:49 2022 UTC and is due to finish in 60 minutes.  The chair is amoralej. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:04:50 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:04:50 <opendevmeet> The meeting name has been set to 'rdo_meeting___2022_10_26'
14:05:01 <amoralej> #chair jcapitao[m]
14:05:01 <opendevmeet> Current chairs: amoralej jcapitao[m]
14:05:08 <karolinku[m]> o/
14:05:14 <amoralej> #chair karolinku[m]
14:05:14 <opendevmeet> Current chairs: amoralej jcapitao[m] karolinku[m]
14:05:56 <amoralej> let's start thee first topic
14:06:02 <amoralej> feel free to add more
14:06:24 <amoralej> #topic Update about zed
14:06:54 <amoralej> #link https://issues.redhat.com/browse/RDO-38
14:07:19 <amoralej> #info Zed GA builds for non-TripleO packages are being pushed to mirrors http://mirror.stream.centos.org/SIGs/9-stream/cloud/x86_64/openstack-zed/
14:07:31 <amoralej> #info Zed GA builds for non-TripleO packages are being pushed to mirrors http://mirror.stream.centos.org/SIGs/9-stream/cloud/x86_64/openstack-zed/
14:08:09 <amoralej> #info tempest plugins are being unpinned for master
14:08:21 <amoralej> jcapitao[m], ^ this is what you meant, right?
14:08:49 <jcapitao[m]> yes sorry for master
14:09:09 <jcapitao[m]> I'll unpin non-os puppet modules as well
14:09:34 <jcapitao[m]> once the GA builds are pushed to mirror, we'll build the centos-release-openstack-zed RPM
14:10:11 <jcapitao[m]> I mean we'll ask for CentOS team to build and push it in extras repo
14:10:29 <amoralej> actually, we can do it
14:10:43 <amoralej> now we can build and push to the extras-common, right?
14:11:04 <amoralej> we don't depend on centos infra team anymore for release rpms
14:11:18 <amoralej> lemme double check, in case i'm confused
14:11:52 <jcapitao[m]> ah
14:11:53 <jcapitao[m]> https://cbs.centos.org/koji/buildinfo?buildID=38942
14:12:09 <amoralej> https://cbs.centos.org/koji/buildinfo?buildID=38942
14:12:12 <amoralej> yep, that
14:12:25 <amoralej> since cs9, we can manage them by ourselves
14:12:34 <jcapitao[m]> ok, I've never done it
14:12:44 <amoralej> it's just as any other cbs build
14:12:51 <jcapitao[m]> so we can push to extras tag
14:12:57 <jcapitao[m]> if we are part of a SIG ?
14:12:59 <amoralej> but just using extras9s-extras-common-* tags
14:13:46 <amoralej> i'm not sure if every sig member have access to it or just a group of representatives from each dfg
14:13:49 <amoralej> lemme check
14:15:03 <amoralej> yes, i think it's one per SIG
14:15:07 <amoralej> or something like that
14:15:11 <amoralej> i'm in :)
14:15:13 <rdogerrit> Merged rdo-jobs master: Remove fs1 ovb and image build jobs from wallaby centos8 line  https://review.rdoproject.org/r/c/rdo-jobs/+/45831
14:16:31 <amoralej> https://accounts.centos.org/group/sig-extras/
14:16:51 <amoralej> i've started reviewing https://review.rdoproject.org/etherpad/p/zed-release-announcement btw
14:17:12 <amoralej> feel free to review and edit
14:17:14 <jcapitao[m]> ook
14:18:40 <jcapitao[m]> also, I created the US https://issues.redhat.com/browse/RDO-38
14:19:03 <jcapitao[m]> ans sub tasks with description explaining the step
14:19:10 <jcapitao[m]> with some examples etc
14:19:28 <jcapitao[m]> if you can review the description
14:19:32 <amoralej> ok, good, so this is the new checklist
14:19:48 <amoralej> can this be used as a template for next ones?
14:19:52 <jcapitao[m]> yeah, for next release we'll just have to clone the ticket
14:19:57 <amoralej> you know if can be cloned?
14:19:57 <jcapitao[m]> yeah exactly
14:19:59 <amoralej> ah, good
14:21:10 <amoralej> trello checklist were more lightweight , but i guess we'll have to handle with jira
14:21:13 <amoralej> so good
14:21:41 <amoralej> maybe creating a task for tripleo packages?
14:22:08 <amoralej> given that it's usually a trailing task after initial promotin
14:22:17 <jcapitao[m]> yeah, in fact I'm creating the sub-tasks when realizing the task
14:22:38 <amoralej> good
14:22:38 <jcapitao[m]> so the OOO sub tasks will come in a few days
14:22:43 <amoralej> so we create it as we go
14:22:57 <amoralej> i understand subtasks are created empty when we clone it, right?
14:24:14 <jcapitao[m]> we should give a try
14:25:15 <jcapitao[m]> https://issues.redhat.com/browse/RDO-63
14:25:48 <jcapitao[m]> it's a clone
14:25:52 <jcapitao[m]> it works !
14:26:20 <amoralej> yep
14:26:24 <jcapitao[m]> but now I cannot remove them O:)
14:26:26 <amoralej> and subtasks are empty, so good
14:26:40 <amoralej> so, we have antelope preparation ticket? xD
14:26:41 <jcapitao[m]> do you have admin authorization ?
14:27:03 <jcapitao[m]> ah we could keep it indeed
14:27:23 <amoralej> better to remove it
14:27:26 <amoralej> if possible
14:27:32 <amoralej> i see an option to Archive it
14:27:39 <amoralej> no remove it
14:28:14 <jcapitao[m]> so you're admin I guess
14:28:20 <jcapitao[m]> as I can't see it
14:28:50 <amoralej> i can see it only in the initial story, not in subtasks
14:29:02 <amoralej> but i assume if i archive the story, all subtasks will also be archived
14:29:03 <amoralej> ...
14:30:32 <jcapitao[m]> can you test it ?
14:31:47 <amoralej> "Issue RDO-63 will be archived with 16 sub-tasks. After you archive this issue it will disappear from search results, the list of issues in projects, the dashboard, and reports. It will also be removed from Scrum and Kanban boards and backlog."
14:31:52 <amoralej> doint it
14:32:15 <amoralej> done
14:33:04 <jcapitao[m]> good
14:33:16 <jcapitao[m]> the process is validated :)
14:33:48 <amoralej> yep :)
14:34:04 <amoralej> so, bye bye trello for antelope
14:34:54 <jcapitao[m]> after many years of loyal service
14:34:55 <amoralej> anything else for this topic?
14:35:06 <jcapitao[m]> nope that's all
14:35:23 <amoralej> moving to next one
14:35:42 <amoralej> #topic Status update for RDO Trunk centos9-master-head builder
14:35:51 <amoralej> karolinku[m], ^
14:35:59 <amoralej> i think we have some progress for it
14:37:01 <amoralej> #info All FTBFS have been fixed and centos9-master-head is in consistent status now
14:37:18 <karolinku[m]> yep
14:37:29 <jcapitao[m]> \o/
14:37:33 <karolinku[m]> I will add centos9-master-head to ftbfs dashboard
14:38:30 <amoralej> #action karolinku[m] will add centos9-master-head to the report-ftbfs dashboard
14:38:41 <amoralej> ok, so that's finished
14:40:05 <amoralej> #topic Published update of rdopkg
14:40:56 <amoralej> #info rdopkg 0.15.1 release has been published with new features as --extra-repo option in clone action or information about releashe phase
14:41:34 <jcapitao[m]> it's 1.5.1 IIRC
14:41:51 <amoralej> #undo
14:41:51 <opendevmeet> Removing item from minutes: #info rdopkg 0.15.1 release has been published with new features as --extra-repo option in clone action or information about releashe phase
14:42:03 <amoralej> #info rdopkg 1.5.1 release has been published with new features as --extra-repo option in clone action or information about releashe phase
14:42:04 <amoralej> right
14:42:20 <amoralej> nice, i see you built it in fedora already
14:42:41 <amoralej> #info packages are available in epel9, and fedora 37 and 38
14:42:54 <jcapitao[m]> yes
14:42:59 <amoralej> maybe we could backpurt up to 35? (it's what i use :)
14:43:01 <jcapitao[m]> well it's in pending repos
14:43:14 <amoralej> yeah, it will end up in release soon i guess
14:44:04 <jcapitao[m]> or maybe we should update our Fedora systems :P
14:44:17 <amoralej> nah
14:44:19 <amoralej> lol
14:44:28 <jcapitao[m]> I'm running F35 as well x)
14:44:59 <amoralej> tbh, fedora upgrade process in last releases have worked like a charm
14:45:07 <amoralej> so it's probably good to update to 37
14:45:46 <jcapitao[m]> I'll give a try this WE
14:45:55 <jcapitao[m]> btw I noted your comment on https://review.rdoproject.org/r/c/gating_scripts/+/45644/6/buildsys-tags/validate_updates.sh
14:46:08 <jcapitao[m]> about the rdopkg release status:development
14:47:27 <amoralej> yep
14:48:34 <amoralej> the "status: development" may be any filter
14:48:42 <amoralej> based on releases keys
14:49:46 <rdogerrit> Ananya Banerjee proposed rdo-jobs master: Defines and adds sc10 kvm train to integration line  https://review.rdoproject.org/r/c/rdo-jobs/+/45824
14:49:50 <amoralej> although i think probably the only that makes sense is to search based on status
14:50:52 <rdogerrit> Ananya Banerjee created rdo-jobs master: Defines and adds sc10 kvm train to integration line  https://review.rdoproject.org/r/c/rdo-jobs/+/45848
14:51:07 <jcapitao[m]> what if we add new metadata attribute ?
14:51:12 <amoralej> wdym
14:51:48 <jcapitao[m]> I meant if there is a new attribute in the future
14:51:56 <amoralej> ah, that's what i mean
14:51:57 <jcapitao[m]> like status
14:52:02 <amoralej> to be able to look for anything
14:52:07 <amoralej> not specifically tied to status
14:52:14 <amoralej> as we have for rdopkg info
14:52:22 <jcapitao[m]> yeah
14:52:25 <rdogerrit> Ananya Banerjee proposed rdo-jobs master: Defines and adds sc10 kvm train to integration line  https://review.rdoproject.org/r/c/rdo-jobs/+/45848
14:52:27 <jcapitao[m]> +1 for the feature
14:52:28 <amoralej> we can do rdopkg info name:openstack-nova
14:52:33 <jcapitao[m]> I'll work on it
14:52:35 <amoralej> or upstream:xxxxx
14:52:43 <amoralej> or any attribute
14:53:16 <amoralej> actually, iirc in rdopkg info if we add more that one, it will filter with both
14:53:48 <amoralej> #topic open floor
14:53:57 <amoralej> who wants to chair next week?
14:54:07 <amoralej> it'v video mtg, btw
14:54:35 <jcapitao[m]> I might not be available next week
14:54:48 <karolinku[m]> I'll will also be on PTO
14:55:08 <amoralej> oh, it will be just me and maybe spotz then :)
14:55:17 <amoralej> #action amoralej will chair next week
14:55:37 <amoralej> we still have 5 minutes
14:55:43 <amoralej> anything else you'd like to discuss?
14:57:40 <jcapitao[m]> nothing else from my side
14:58:03 <karolinku[m]> nothing from me also
14:58:20 <amoralej> ok, i'm closing the meeting then
14:58:27 <amoralej> thanks both for joining
14:58:32 <amoralej> #endmeeting