14:07:10 <spotz> #startmeeting RDO meeting - 2022-11-16
14:07:10 <opendevmeet> Meeting started Wed Nov 16 14:07:10 2022 UTC and is due to finish in 60 minutes.  The chair is spotz. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:07:10 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:07:10 <opendevmeet> The meeting name has been set to 'rdo_meeting___2022_11_16'
14:07:14 <karolinku[m]> ready!
14:07:16 <spotz> #topic Roll Call
14:07:27 <spotz> #chair amoralej
14:07:27 <opendevmeet> Current chairs: amoralej spotz
14:08:36 <spotz> Looks like this might be a quick meeting
14:08:45 <spotz> #topic Zed Release
14:09:21 <spotz> Just wanted to thank amoralej for his hard work tracking down the Vitrage error we were seeing and getting that resolved so that we could release
14:09:37 <spotz> And thank you to all 57 contributors to the release!
14:09:55 <amoralej> \o/
14:09:58 <amoralej> one more!
14:10:06 <spotz> amoralej: anything you want to mention on this?
14:10:33 <amoralej> oh, should i have prepared a speech? ;)
14:10:40 <amoralej> not
14:10:46 <amoralej> i think that's it
14:10:55 <amoralej> now, let's get ready for Antelope!
14:11:30 <amoralej> i need to double check that we have all the automation ready for zed updates, btw
14:11:49 <amoralej> #action amoralej to check the automation is ready for zed release
14:12:05 <amoralej> other than that, i think zed is done
14:12:07 <spotz> #info Zed was released on November 14
14:12:14 <spotz> Sweet!
14:12:39 <spotz> #topic Switch RDO packages to pyproject macros
14:12:47 <spotz> I think I typed that right:)
14:12:56 <amoralej> yes, you did :)
14:13:23 <amoralej> so i think this will be one of our big initiatives for antelope
14:14:11 <amoralej> #info Some releases ago, Fedora switch to the new pyproject macros as the recommended way to build python packages
14:14:27 <amoralej> #link https://review.rdoproject.org/etherpad/p/pyproject-macros
14:14:44 <amoralej> i think this is good timing for us to move to them too
14:15:01 <spotz> Are there any reasons we need or assistance?
14:15:01 <amoralej> we have been using pyproject macros for CS9 for dependencies
14:15:25 <amoralej> you mean reasons for the change ?
14:15:55 <amoralej> i've tried to explain the rationale in the etherpad https://review.rdoproject.org/etherpad/p/pyproject-macros
14:16:26 <amoralej> but the main reasons is to be ready in case upstream projects start adopting PEP517 and pyproject.toml file
14:16:27 <spotz> ack not reasons! Resources!
14:16:36 <amoralej> ah, resources
14:16:52 <amoralej> well, my idea is to automate as much as possible
14:17:03 <amoralej> as we did in the past to move from python2 to python3
14:17:15 <amoralej> actually, this should be much simpler that the py3 transition
14:17:24 <spotz> I haven't had coffee yet:)
14:17:31 <amoralej> :)
14:17:41 <amoralej> so, i hope we can handle it
14:17:56 <spotz> Yeah the transition to py3 was put off as long as possible which only made it harder for everyone
14:18:15 <amoralej> yeah, that was hard
14:18:33 <amoralej> in this case the resulting packages should be exactly the same we have today
14:18:47 <spotz> Nice
14:18:54 <amoralej> just changing build tooling
14:19:13 <amoralej> and we may be able to simplify the spec files, we'll see
14:19:25 <karolinku[m]> yeah, but handling deps is challenging
14:19:34 <amoralej> yeah, that's the big question
14:20:02 <amoralej> if we prefer to stay with manual BRs
14:20:08 <amoralej> or switch to automatic ones
14:20:44 <amoralej> i'd like to take a couple or three different packages and use them to do a PoC about how to do it
14:20:53 <spotz> Automatic is always prefered but that might be a longer goal to achieve
14:21:04 <spotz> Good plan
14:21:14 <amoralej> yeah, the problem with automatic builddeps is how to manage exceptions
14:21:24 <amoralej> that i'm sure there will be
14:21:30 <amoralej> but ... we'll see
14:22:12 <amoralej> once we agree in what we want to do, we'll prepare some kind of script to automate the switch to the new macros as much as possible
14:22:19 <amoralej> i mean, automate sending the review
14:22:46 <spotz> Even if we only eventually get to being partially automatic I think that could help on the time of the team
14:22:54 <amoralej> yep
14:24:23 <spotz> Any thing else on this?
14:24:28 <amoralej> i'll do some more work on the etherpad the next couple of days but feel free to review and provide feedback on it
14:25:05 <amoralej> probably, next meeting we can review next steps
14:25:28 <spotz> WIll do
14:25:42 <amoralej> i think that's it about this topic
14:25:55 <spotz> Ok moving on
14:26:05 <spotz> #topic Next Chair
14:26:26 <spotz> Unless we want to surprise karolinku[m] it's one of us:)
14:26:28 <rdogerrit> Dariusz proposed rdo-infra/ci-config master: Prepare support for multiple OpenStack projects  https://review.rdoproject.org/r/c/rdo-infra/ci-config/+/46048
14:26:43 <rdogerrit> Dariusz proposed rdo-infra/ci-config master: Added support for multiple OpenStack projects  https://review.rdoproject.org/r/c/rdo-infra/ci-config/+/46050
14:27:26 <karolinku[m]> I can take it
14:27:52 <spotz> ha!
14:28:19 <spotz> #chair karolinku[m]
14:28:19 <opendevmeet> Current chairs: amoralej karolinku[m] spotz
14:28:31 <spotz> I think we're almost done though:)
14:29:20 <spotz> Anyone have anything else to bring up?
14:29:54 <spotz> I have reached out to the SCOS folks about the Cloud SiG report but haven't heard back, they might be out sick
14:30:23 <rdogerrit> Dariusz proposed rdo-infra/ci-config master: Added support for multiple OpenStack projects  https://review.rdoproject.org/r/c/rdo-infra/ci-config/+/46050
14:30:52 <rdogerrit> Dariusz proposed rdo-infra/ci-config master: Allow to deploy infra from git refspecs, e.g. specific gerrit changes  https://review.rdoproject.org/r/c/rdo-infra/ci-config/+/46072
14:31:52 <spotz> Ok if there's nothing else we can have 30 minutes back to our days!
14:31:58 <amoralej> ok, good!
14:32:03 <spotz> #endmeeting