14:00:50 <karolinku[m]> #startmeeting RDO meeting - 2023-01-18
14:00:50 <opendevmeet> Meeting started Wed Jan 18 14:00:50 2023 UTC and is due to finish in 60 minutes.  The chair is karolinku[m]. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:50 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:50 <opendevmeet> The meeting name has been set to 'rdo_meeting___2023_01_18'
14:01:00 <amoralej> o/
14:01:07 <spotz> o/
14:01:15 <spotz> Got distracted by the puppy:)
14:01:21 <jcapitao[m]> o/
14:01:38 <karolinku[m]> #chair amoralej spotz jcapitao
14:01:38 <opendevmeet> Warning: Nick not in channel: jcapitao
14:01:38 <opendevmeet> Current chairs: amoralej jcapitao karolinku[m] spotz
14:01:50 <karolinku[m]> this is a disctraction I want!
14:02:48 <spotz> hehe
14:03:05 <karolinku[m]> #chair jcapitao[m]
14:03:05 <opendevmeet> Current chairs: amoralej jcapitao jcapitao[m] karolinku[m] spotz
14:04:30 <karolinku[m]> so today's first topic is
14:04:35 <karolinku[m]> #topic RDO SWAG update
14:04:54 <spotz> All emails went out on Monday!
14:05:14 <amoralej> i already requested it :)
14:05:23 <amoralej> everything went smooth
14:05:26 <spotz> There were 3 batches, Yoga, Zed, and then a combined batch where the code will get a bundle of the Gym bag and water bottle
14:05:27 <jcapitao[m]> me too !
14:05:52 <spotz> Yeah even the code I used to test the water bottles (did not check out) worked out for the person:)
14:07:20 <spotz> I already got one thank you so hopefully everyone will order their item. Especially the gym bag love the Spenser version on that:)
14:08:30 <spotz> Antelope is up next and Ill put together a budget and see what we can do. Unless there is a strong demand or we ask for shirt sizes up front sized items result in a lot of left over
14:08:37 <amoralej> yep, it looks really cool
14:08:51 <spotz> That's it for SWAG
14:08:53 <amoralej> i'm willing to recevie it
14:09:45 <spotz> hehe
14:09:58 <spotz> #topic FOSDEM Update
14:10:19 <spotz> So where you ask does that left over SWAG go?
14:11:25 <spotz> To FOSDEM! So while I did get some keychains to give out at FOSDEM I'm also bringing the remaining Wallaby shirts to FOSDEM. 80+ shirts of various sizes. And they're a lot more when you see them in person!
14:12:35 <spotz> The day before FOSDEM is the CentOS COnnect there will be 2 Cloud SiG related talks. One CoreOS one and one from Karolina!
14:12:53 <spotz> There will be an OpenInfra Meetup on Saturday night
14:13:03 <spotz> #link https://www.meetup.com/brussels-openinfra-meetup-group/events/290894971/
14:13:46 <amoralej> karolinku[m]++
14:14:00 <spotz> And that's it for FOSDEM unless someone has anything? I will miss the video call that week due to travel
14:15:32 <spotz> #topic Events Calendar
14:16:00 <spotz> I went to add FOSDEM in the calendar and I'm not sure if we ported it to Gerrit. If we did I couldn't find the repo
14:18:01 <jcapitao[m]> mmmh I think it's a plugin
14:18:30 <spotz> On Github there was a repo called rh-events
14:20:00 <jcapitao[m]> Im checking how it's managed
14:20:08 <spotz> Thanks
14:20:36 <amoralej> it's a git submodule iirc?
14:20:41 <amoralej> from a different repo
14:20:57 <spotz> rh-events
14:21:29 <rdogerrit> Merged rdo-infra/ci-config master: INFRA: Deploy toolbox on CS9  https://review.rdoproject.org/r/c/rdo-infra/ci-config/+/45664
14:22:49 <jcapitao[m]> right
14:22:50 <jcapitao[m]> https://github.com/OSAS/rh-events
14:23:06 <amoralej> last commit is from 2020
14:23:10 <jcapitao[m]> so we should add a yaml file in 2023 directory
14:23:43 <jcapitao[m]> like https://github.com/OSAS/rh-events/blob/master/2020/RDO-TestDays.yml
14:24:14 <spotz> Yeah I was doing that and ran into an issue with git review:)
14:25:40 <spotz> So I guess the question is do we want to port the repo over?
14:26:40 <amoralej> is that repo only used by us?
14:26:57 <amoralej> it's OSAS so i guess it was used also for other projectgs?
14:27:06 <amoralej> maybe OSAS moves it to some other thing?
14:27:21 <amoralej> if it's used out of RDO i think it should be maintained in github
14:27:28 <spotz> There's nothing in there since 2020. There is a DevConfIN.yml file sitting there but not in a year
14:27:46 <amoralej> it may be good to ask OSAS too
14:28:06 <amoralej> we could move it to review.r.o o maybe even to the same rdo-website repo
14:28:13 <amoralej> but only for us
14:28:48 <spotz> Yeah it looks like the older years up to 2019 have a lot of files but then 2020 directory is just us and nothing until the 2023 one I was making. I did a git pull first
14:29:14 <spotz> I can ask around
14:29:16 <amoralej> it's pure yamls, right?
14:29:20 <amoralej> nothing else
14:29:20 <spotz> yeah
14:29:35 <amoralej> it should be easy to just make it part of rdo-website
14:29:48 <jcapitao[m]> yeah
14:30:26 <jcapitao[m]> in theory :)
14:30:52 <amoralej> :)
14:30:57 <amoralej> in theory
14:31:11 <amoralej> no changes are easy :)
14:31:14 <spotz> I just asked if anyone was using it on the OSPO channel. We'll see if we get any confirmations back or if they've moved on to something else. I think we might have the oldest website as we've never updated what it's running on
14:31:24 <amoralej> good
14:31:28 <spotz> That's it for me though
14:34:22 <karolinku[m]> do we move to another topic?
14:34:37 <spotz> Ok ovirt was the last group using it so we're good to bring our own version of it into gerrit
14:34:49 <spotz> I am seeing if there's an alternative we should use
14:35:35 <jcapitao[m]> ok, in the meantime I can propose a patch to have ours
14:35:35 <spotz> Yeah we're the only one's still using a static website:(
14:35:41 <spotz> Sweet thanks
14:36:24 <spotz> Ok yeah seems like that's what we'll need to use for now if we can get it over.
14:36:35 <spotz> karolinku[m]: Good to move on!
14:36:51 <karolinku[m]> #topic Switch to pyproject-rpm-macros
14:37:23 <jcapitao[m]> just a head up on how things are going on
14:37:43 <jcapitao[m]> I'm currently switching glance and oslo.config to pyproject-rpm-macros
14:38:20 <jcapitao[m]> it's not that easy to understand what's going behind the scene
14:38:45 <jcapitao[m]> I put some informations on the patches listed in the pad
14:39:01 <jcapitao[m]> https://review.rdoproject.org/etherpad/p/pyproject-macros
14:39:03 <rdogerrit> Yatin Karel created rdo-jobs master: [DNM] DLRN timeout bump  https://review.rdoproject.org/r/c/rdo-jobs/+/46657
14:39:44 <jcapitao[m]> we might have a blocker
14:39:48 <rdogerrit> Yatin Karel proposed openstack/neutron-distgit rpm-master: Run unit tests during neutron package build  https://review.rdoproject.org/r/c/openstack/neutron-distgit/+/46651
14:39:54 <jcapitao[m]> %pyproject_buildrequires macro does not handle pip constraint file
14:40:47 <jcapitao[m]> I put the command to reproduce the issue in the pad
14:41:32 <amoralej> less jcapitao[m] we don't want to use u-c
14:41:45 <amoralej> we just want to get what is in requirements.txt
14:41:48 <amoralej> as we do today
14:42:15 <amoralej> or test-requirements.txt if there are
14:42:39 <amoralej> the same that automatic deps does
14:43:11 <amoralej> actually that'd be better that what we have today as we are just doing BuildRequires: python-foo without any constraints
14:43:29 <amoralej> or maybe i'm missunderstanding
14:43:36 <rdogerrit> Eric Harney proposed openstack/cinder-distgit yoga-rdo: Remove cracklib-dicts requirement  https://review.rdoproject.org/r/c/openstack/cinder-distgit/+/46232
14:44:17 <rdogerrit> Eric Harney proposed openstack/cinder-distgit yoga-rdo: Remove cracklib-dicts requirement  https://review.rdoproject.org/r/c/openstack/cinder-distgit/+/46232
14:44:41 <jcapitao[m]> it depends on tox.ini
14:45:00 <jcapitao[m]> we can sed it to remove the u-c constraint file
14:45:19 <amoralej> ah, it's not that it doesn't honor the constraint
14:45:27 <amoralej> it fails to parse tox.ini ...
14:45:30 <amoralej> i got it now
14:46:43 <jcapitao[m]> in fact, there is not the mechanism implemented to cap the version against u-c
14:47:05 <amoralej> yeah, i just reproduced it
14:48:26 <amoralej> actually, we don't need the capping files here
14:48:27 <amoralej> mmm
14:48:38 <amoralej> the actual capping is what is the repos
14:49:09 <amoralej> one option would be to sed every -c line in deps
14:49:46 <amoralej> or .*TOX_CONSTRAINTS_FILE.*
14:51:07 <jcapitao[m]> yeah but isn't it dangerous ?
14:51:11 <jcapitao[m]> I mean we might ends up having versions that are not allowed
14:51:16 <amoralej> really not
14:51:28 <amoralej> think in what we do today
14:51:43 <amoralej> note this is not installing from pip or something like that
14:51:53 <jcapitao[m]> yes
14:51:55 <amoralej> it's just creating a list of BuildRequires
14:52:06 <amoralej> it will pull whatever is in the repos in the buildroot
14:52:22 <amoralej> actually, that will cap minimal versions from requirements.txt
14:52:26 <amoralej> at least
14:52:34 <amoralej> which is better to what we have today
14:52:47 <amoralej> which is jus BuildRequires: python3-whatever
14:53:03 <jcapitao[m]> right
14:53:17 <amoralej> we are responsible of adding to the repo the right versions
14:53:23 <amoralej> of libraries from uppper-constraints
14:53:29 <jcapitao[m]> that makes sense
14:53:36 <amoralej> and keeping "good" versions
14:54:03 <amoralej> actually, it we would add == from u-c
14:54:09 <amoralej> that'd be a problem
14:54:24 <amoralej> as we sometimes are not providing the exact versions in u-c for deps
14:55:19 <jcapitao[m]> ah right
14:55:52 <jcapitao[m]> this is too much hard-binding for us
14:56:03 <jcapitao[m]> do you think we should generate run-time deps automatically too ?
14:56:22 <amoralej> we are doing it already in cs9 iirc :)
14:56:28 <amoralej> lemme double check
14:56:37 <amoralej> ah no
14:56:45 <amoralej> because we are removing requirements.txt
14:56:52 <amoralej> we are doing it for deps
14:57:03 <jcapitao[m]> yes
14:57:15 <jcapitao[m]> we remove reqs.txt to handle them manually
14:57:19 <amoralej> yes
14:57:23 <amoralej> we may reconsider that
14:57:32 <amoralej> but i'm pretty sure will hit some issues
14:58:14 <amoralej> specially because requirements.txt contains optional requirements that we don't ship
14:58:15 <amoralej> iirc
14:58:32 <amoralej> it may be worthy to take a look and see if it's worthy
14:58:34 <jcapitao[m]> yes, I mean we'll end up adding several sed commands to do the same
14:58:55 <amoralej> there are a couple of cases which are tricky
14:59:18 <amoralej> 1. optional requirements that are in requirements.txt and we don't ship or don't want to make mandatory deps
14:59:36 <amoralej> there was some discussion about it upstream to move it to extras in setup.cfg
14:59:54 <amoralej> but i'm not sure if it was implemented
15:00:42 <amoralej> 2. cases where we provide versions < that the minimal versions. This is not usual but we sometimes do it, specially if we consume from RHEL
15:01:40 <jcapitao[m]> ok
15:01:43 <amoralej> wrt optional
15:01:43 <amoralej> https://github.com/openstack/tooz/blob/master/setup.cfg
15:01:51 <amoralej> this would be fine. i.e
15:02:07 <amoralej> requirements.txt has only the mandatory
15:02:33 <amoralej> actually in this case we would want to add dependencies for default drivers
15:02:35 <amoralej> as redis
15:03:22 <amoralej> https://github.com/rdo-packages/tooz-distgit/blob/rpm-master/python-tooz.spec#L59
15:03:50 <jcapitao[m]> ok I see
15:03:56 <jcapitao[m]> let's focus on the build deps for now
15:03:59 <amoralej> we even may use the extras macros to create +redis or +memcached
15:04:09 <amoralej> which would be closer to fedora
15:04:26 <amoralej> but would also disrupting compared with what we have today
15:04:28 <jcapitao[m]> yes this is handled in pyproject-rpm-macros
15:04:35 <jcapitao[m]> -x redis -x memcached
15:04:36 <amoralej> yes
15:04:38 <amoralej> exactly
15:05:19 <amoralej> the problem with that is that the deployment tools would need to adapt to install the new subpakcages
15:05:32 <amoralej> or maybe in the dependencies
15:05:48 <amoralej> tbh, i doubt it's worthy
15:06:04 <amoralej> but it may be good to discuss
15:06:13 <amoralej> wrt the new macros to build and install
15:06:18 <amoralej> you had any issue?
15:06:26 <amoralej> or didn't test it?
15:06:41 <jcapitao[m]> on the build part yes
15:06:45 <jcapitao[m]> but managed to make it work
15:07:10 <jcapitao[m]> https://review.rdoproject.org/r/c/openstack/glance-distgit/+/46574/2/openstack-glance.spec#49
15:07:22 <amoralej> uh
15:08:00 <amoralej> it'd be so cool if we can get rid of manual BR ....
15:08:06 <jcapitao[m]> we can discuss off-mtg
15:08:09 <amoralej> yes
15:08:12 <amoralej> we are out of time
15:09:36 <karolinku[m]> yes
15:09:48 <karolinku[m]> we can arrange a dedicated meeting
15:10:00 <rdogerrit> Merged config master: Update downstream trigger to fedora 36  https://review.rdoproject.org/r/c/config/+/46656
15:12:20 <rdogerrit> Julia Kreger created rdoinfo master: Consume latest Sushy patches  https://review.rdoproject.org/r/c/rdoinfo/+/46658
15:12:59 <amoralej> karolinku[m], jcapitao[m] yes, let's do a mtg to check details about this
15:13:27 <jcapitao[m]> 👍️
15:15:00 <karolinku[m]> ok
15:15:24 <karolinku[m]> does anyone hace sth else?
15:15:44 <karolinku[m]> (quickly)
15:17:13 <karolinku[m]> #agreed dedicatated meeting about macros will be set
15:17:15 <karolinku[m]> #endmeeting