14:01:14 <amoralej> #startmeeting RDO meeting - 2023-01-25
14:01:14 <opendevmeet> Meeting started Wed Jan 25 14:01:14 2023 UTC and is due to finish in 60 minutes.  The chair is amoralej. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:14 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:14 <opendevmeet> The meeting name has been set to 'rdo_meeting___2023_01_25'
14:01:28 <amoralej> who is around?
14:01:30 <amoralej> :)
14:01:35 <karolinku[m]> o/
14:01:57 <amoralej> #chair karolinku[m]
14:01:57 <opendevmeet> Current chairs: amoralej karolinku[m]
14:02:06 <spotz> o/
14:02:08 <jcapitao[m]> o/
14:03:51 <amoralej> #chair spotz jcapitao[m]
14:03:51 <opendevmeet> Current chairs: amoralej jcapitao[m] karolinku[m] spotz
14:04:16 <amoralej> #topic Switch to pyproject-rpm-macros
14:04:47 <amoralej> as we've mentioned in previous meetings we are exploring moving RDO specs to new pyproject macros
14:04:56 <amoralej> mainly jcapitao[m] has been working on it
14:05:47 <amoralej> there are some challenges we have seen that need further work, specially the ones related to automatic build and runtime deps
14:05:54 <amoralej> also to conditionalize BR
14:05:59 <amoralej> and related to list of files too
14:06:20 <amoralej> as we have no pressure at all to move to new macros
14:07:04 <amoralej> and final release for no n clients is approaching
14:07:30 <amoralej> i'd propose to keep investigating and working in poc
14:07:37 <amoralej> but not implement it in this cycle
14:08:00 <amoralej> but probably in next one
14:08:52 <amoralej> note that old macros will keep working while upstream project keep working with setup.py and don't move to pyproject.toml
14:09:47 <amoralej> afaik, there is not plans to move to pyproject.toml, or at least not soon
14:09:51 <amoralej> so i think we are good
14:10:04 <amoralej> wdyt?
14:10:25 <jcapitao[m]> maybe in next PTG moving to pyproject.toml will be discussed
14:10:51 <amoralej> yes, good point to see in next ptg releases team agenda
14:11:07 <amoralej> i haven't found anything documented in openstack docs
14:11:19 <jcapitao[m]> neither do I
14:13:06 <spotz> If it's not there and you think it needs to be discussed add it
14:13:30 <jcapitao[m]> but yeah, the window time is short to move all SPECs before next release preparation
14:13:39 <amoralej> #info we will continue analyzing the options to move to pyproject-rpm-macros but we likely will not implement it in RDO in antelope release
14:17:20 <amoralej> anyway, i think it's good to continue working on the PoC to make sure we know the path to migrate
14:17:24 <amoralej> when we have to
14:17:31 <spotz> Agreed
14:18:39 <amoralej> if there are no more questions on this
14:18:43 <amoralej> we can move to next topic
14:18:56 <spotz> Which will be really quick:)
14:18:59 <amoralej> #topic Community update - FOSDEM and SWAG
14:19:07 <amoralej> i got my swag! \o/
14:19:19 <spotz> This is more for anyone reading the logs
14:19:31 <karolinku[m]> I got it too, it's supercool:)
14:19:38 <spotz> Sweet!
14:19:41 <amoralej> and faster that i expected
14:20:10 <jcapitao[m]> I love the water bottle
14:20:19 <spotz> Ok FOSDEM is next week if you're in Belgium we are sharing a stand with CentOS in Hall H if you can help especially on Sunday please reach out or add a comment
14:20:21 <amoralej> i love the gym bag :)
14:20:39 <spotz> #link https://gitlab.com/CentOS/promo/centos-events/-/issues/3
14:20:56 <spotz> There sill be an OpenStack meetup on Saturday
14:21:06 <spotz> #link https://www.meetup.com/brussels-openinfra-meetup-group/events/290894971/
14:21:32 <spotz> As already being discussed SWAG letters went out for Yoga, Zed, and if you contributed to both!
14:22:13 <spotz> Yeah I knew mine would come quick but hapy to see they got to EMEA already. I think that points to the new storefront being an improvement!
14:23:02 <spotz> There will be Wallaby t-shirts at FOSDEM, karolinku[m] make sure you grab one:)
14:23:15 <spotz> Also keychains and stickers
14:24:09 <spotz> Next SWAG item we'll clear out will be the remaining 27 travel wallets. If there are any meetups interested let me know otherwise I'll probably take them to Devconf
14:24:09 <karolinku[m]> spotz: sure!
14:25:01 <spotz> If everyone claims their gym bag those will be gone, there might be a few water bottles after all codes are used
14:25:26 <spotz> And that's it for the Community Update if no questions
14:27:04 <amoralej> thanks spotz for arranging all this swag!
14:27:35 <spotz> You're welcome, thanks everyone who contributes!!!
14:27:35 <amoralej> btw
14:27:47 <amoralej> a reminder that karolinku[m] is giving a talk in centos connect
14:28:12 <amoralej> thanks karolinku[m] for keeping rdo/cloudsig name active in connect!
14:28:19 <jcapitao[m]> yea thank you !
14:28:39 <spotz> CoreOS is also speaking so great CLoudSiG coverage!
14:28:39 <amoralej> let's move to open floor
14:28:46 <amoralej> #topic open floor
14:29:02 <amoralej> we have merged the change to move events to rdo-website
14:30:38 <amoralej> and apparently it's still working :)
14:30:49 <amoralej> so, at least it didn't explode
14:31:10 <amoralej> mmm
14:31:13 <amoralej> we should update https://www.rdoproject.org/events/edit/
14:31:32 <amoralej> i missed that part in the review
14:31:37 <jcapitao[m]> not yet
14:32:19 <jcapitao[m]> the new base code is not yet push in production server
14:33:00 <amoralej> ah
14:33:03 <jcapitao[m]> but we can add the new event though
14:33:16 <spotz> Ok I'll give it a shot later and we can see if it blows up:)
14:34:17 <amoralej> we can make it if we try hard enough :D
14:35:15 <amoralej> anything else you want to share?
14:35:55 <spotz> Not me
14:36:13 <spotz> Oh chair for next week?
14:36:18 <jcapitao[m]> I'm ok too
14:36:19 <amoralej> ah, right
14:36:22 <jcapitao[m]> I can take it
14:36:33 <amoralej> #action jcapitao to chair next week meeting
14:36:48 <amoralej> it's feb 1st so will be video call
14:37:12 <spotz> I'll be traveling so will miss it
14:38:04 <amoralej> but we can join your gmeet?
14:38:11 <amoralej> or we need to use a different one?
14:41:38 <amoralej> we'll figure out :)
14:41:51 <amoralej> so if you don't have more topics
14:41:58 <amoralej> i think i can close the mtg
14:42:56 <spotz> Yeah as long as you log in from your RH account anyone can start it
14:43:04 <spotz> TC used to borrow it
14:43:51 <amoralej> ok, we'll use it then
14:43:53 <amoralej> thanks spotz
14:44:01 <amoralej> i'm closing the mtg
14:44:05 <amoralej> thanks all for joining!
14:44:08 <amoralej> #endmeeting