14:02:01 <amoralej> #startmeeting RDO meeting - 2023-02-08
14:02:01 <opendevmeet> Meeting started Wed Feb  8 14:02:01 2023 UTC and is due to finish in 60 minutes.  The chair is amoralej. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:01 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:01 <opendevmeet> The meeting name has been set to 'rdo_meeting___2023_02_08'
14:02:17 <amoralej> o/
14:02:24 <amoralej> #topic roll call
14:02:29 <jcapitao[m]> o/
14:02:37 <amoralej> #chair jcapitao[m]
14:02:37 <opendevmeet> Current chairs: amoralej jcapitao[m]
14:03:39 <karolinku[m]> o/
14:04:04 <amoralej> #chair karolinku[m]
14:04:04 <opendevmeet> Current chairs: amoralej jcapitao[m] karolinku[m]
14:05:47 <amoralej> ok, i'll start with the first topic
14:06:05 <amoralej> #topic antelope is coming
14:06:21 <amoralej> #link https://releases.openstack.org/antelope/schedule.html
14:06:50 <amoralej> #info this week is final release for non-client libraries
14:07:10 <amoralej> #info next week is requirements freeze
14:07:35 <amoralej> so we are again in release prep cycle
14:08:11 <amoralej> so it can be a good moment if you have any ideas about improvements or changes
14:08:34 <amoralej> this release we'll take some advantage on the changes done by jcapitao[m]
14:08:47 <amoralej> to consume release from rdoinfo instead of hardcoding
14:08:52 <amoralej> in some jobs
14:09:03 <amoralej> we need to keep an eye on it
14:09:10 <jcapitao[m]> yes indeed
14:09:32 <jcapitao[m]> I'm trying to remind what we could improve
14:10:43 <karolinku[m]> we can improve script for branching
14:10:47 <jcapitao[m]> maybe the tools and scripts, to put them in a container toolbox
14:11:20 <jcapitao[m]> and standardize the upgrade process
14:11:50 <amoralej> ok, let's go one by one
14:12:09 <amoralej> 1. improve script for branching, can you elaborate a bit more?
14:12:57 <karolinku[m]> I think now its not even merged in repo
14:13:19 <amoralej> you mean the one to find out hashes to create distgit branches?
14:13:26 <karolinku[m]> yes
14:13:35 <amoralej> ok, good
14:13:45 <karolinku[m]> i can take care of this
14:13:56 <amoralej> nice
14:14:05 <amoralej> good to have all the scripts in releng repo
14:14:14 <karolinku[m]> I think we hae now possibility to list projects to branching
14:14:41 <karolinku[m]> by rdopkg
14:14:47 <amoralej> #action karolinku[m] will propose improvements on distgit branching automation
14:14:52 <amoralej> mmm
14:15:23 <amoralej> like checking what's already branched and so on?
14:16:32 <amoralej> currently we have rdopkg and scripts/tools in releng project, as rdo_projects script
14:16:53 <amoralej> it'd be great to improve automation and see what fits where
14:17:01 <karolinku[m]> i need to dig for it, I used it once - it is Joel's feature
14:17:07 <amoralej> ah, ok
14:17:10 <amoralej> so nice
14:17:15 <amoralej> next one
14:17:31 <amoralej> 2. maybe the tools and scripts, to put them in a container toolbox
14:17:35 <amoralej> interesting
14:17:45 <jcapitao[m]> mmh
14:17:58 <amoralej> i had never thought about it, but it may be a good thing
14:18:29 <karolinku[m]> what would be an advantage of such approach?
14:18:31 <amoralej> having a container with all the tools we usually need properly ready
14:18:33 <jcapitao[m]> yes in order to have all the tools in the user PATH
14:18:53 <amoralej> in my case, at least, i don't have releng installed in my laptop
14:19:11 <jcapitao[m]> without having to pip install them in virtualenv
14:19:11 <amoralej> i create a virtualenv every time that i need it
14:19:25 <amoralej> usually i do when a new release approaches
14:19:45 <amoralej> so, having a container ready may be an advantadge
14:19:53 <karolinku[m]> ah. right. I still have the same one
14:19:58 <amoralej> with all the scripts, variables file deployed etc...
14:20:53 <jcapitao[m]> exactly
14:20:59 <amoralej> we'd have to map ssh config and keys from the host
14:21:00 <jcapitao[m]> we should create a repo to host the Containerfile
14:21:04 <jcapitao[m]> with Gerrit config etc
14:21:16 <amoralej> so that we can send reviews, etc...
14:21:37 <jcapitao[m]> and Zuul CI/CD jobs to build test and push it on Quay registry
14:21:58 <jcapitao[m]> yeah all secrets mounted as volume
14:22:05 <amoralej> exactly
14:22:36 <amoralej> my suggestion is to start by creating a Dockerfile that we can build and use
14:22:44 <amoralej> with instructions in README file
14:23:07 <amoralej> once we have that, we can automate building and pushing to a registry
14:23:13 <jcapitao[m]> right, let's start with a MVP
14:23:18 <karolinku[m]> i like it!
14:23:27 <jcapitao[m]> I can take care of it :)
14:24:36 <jcapitao[m]> I mean just the kick off
14:24:43 <amoralej> #action jcapitao will create a rdo-tools container that we can use to simplify the reldel work
14:24:48 <amoralej> good :)
14:25:19 <amoralej> 3. and standardize the upgrade process
14:25:21 <amoralej> wdym ?
14:26:20 <jcapitao[m]> it's a followup of the container toolbox
14:27:07 <jcapitao[m]> so, when we say "we need to branch the project"
14:27:39 <jcapitao[m]> we'll tell someone (in doc for instance) to use that specific command
14:27:52 <jcapitao[m]> which will do the job
14:28:27 <jcapitao[m]> the specific command which is available in the toolbox
14:29:08 <jcapitao[m]> in fact
14:29:43 <jcapitao[m]> I was wondering whether we should document the process or not
14:30:44 <jcapitao[m]> but as the process is constantly evolving
14:31:01 <amoralej> sorry, i'm not following you
14:31:51 <amoralej> you mean the entire branch process, reqcheck, branching etc... in a command?
14:32:43 <karolinku[m]> or you mean standarize entire release process?
14:32:44 <jcapitao[m]> no no sorry
14:32:45 <jcapitao[m]> yes the entire release process
14:32:49 <jcapitao[m]> like a release roadmap
14:33:01 <jcapitao[m]> to do this action, run this command
14:33:19 <jcapitao[m]> for all the action during the release process
14:33:32 <jcapitao[m]> of course we can't automatize/script all the actions
14:33:56 <amoralej> so, your proposal is to standardize and document better the process
14:34:01 <amoralej> right?
14:34:10 <jcapitao[m]> yes somehow :)
14:34:28 <karolinku[m]> good idea. its is gonna be my third release and the only thing I can relay on is our past jira/trello cards
14:35:13 <amoralej> how would you propose to implement it?
14:35:22 <amoralej> docs? tooling improvement?
14:36:26 <jcapitao[m]> both
14:36:39 <karolinku[m]> I would start from docs
14:36:44 <jcapitao[m]> the doc describing the roadmap
14:37:30 <jcapitao[m]> and tooling improvment in order to not put complex commands in doc
14:37:56 <jcapitao[m]> complex command which might change in the future
14:38:14 <amoralej> we have an old and basic page
14:38:38 <amoralej> it was like, high level workflow
14:38:54 <amoralej> i understand you want something more detailed and easy to follow
14:39:26 <jcapitao[m]> yes
14:39:27 <amoralej> https://www.rdoproject.org/documentation/branching/
14:40:10 <amoralej> ok, so i think it'd be good to get feedback about it from karolinku[m] as the latest RDOer to arrive
14:40:28 <amoralej> so probably a task for both :)
14:40:36 <amoralej> is it ok?
14:41:05 <karolinku[m]> as many feedback as you want :D
14:41:05 <amoralej> my mind is maybe too contaminated of the current workflow to think in something different :)
14:41:07 <jcapitao[m]> good
14:41:27 <jcapitao[m]> well me too :D
14:41:42 <amoralej> less that me, i think :)
14:41:50 <karolinku[m]> what I mean, that i dont think we do have any documantation about release at all
14:41:51 <jcapitao[m]> for sure :)
14:42:05 <karolinku[m]> like even high-level one
14:42:08 <amoralej> we could do a mtg about it once we have some ideas
14:43:19 <amoralej> #action jcapitao[m] and karolinku[m] to document the workflow from new releases
14:43:21 <jcapitao[m]> alright
14:43:25 <amoralej> is it fine?
14:43:34 <jcapitao[m]> yup
14:43:50 <amoralej> anything else wrt antelope?
14:44:13 <karolinku[m]> nope
14:44:27 <jcapitao[m]> we're good I think
14:44:40 <amoralej> i think we can wait until next week to create jira ticket etc... so that we have some time to consider changes
14:44:55 <amoralej> but we don't have much time, tbh, so let's start soon
14:45:28 <jcapitao[m]> right
14:45:44 <amoralej> #topic open floor
14:46:14 <amoralej> any topic you want to discuss?
14:46:46 <amoralej> karolinku[m], you know if your talk in CentOS Connect is being published in youtube or somewhere?
14:47:30 <karolinku[m]> yes, there is
14:47:39 <karolinku[m]> https://www.youtube.com/watch?v=AOd0MJBm9ZM
14:48:16 <karolinku[m]> i'm there about 1:32h
14:48:18 <amoralej> but that's the entire stream, you know if they plan to publish per-talk videos?¿
14:48:46 <karolinku[m]> ah, I don't know
14:51:28 <amoralej> i'm looking for the url with the right time to put a link :)
14:52:38 <amoralej> #info you can see karolinku[m] presentation about RDO in CentOS Connect in https://youtu.be/AOd0MJBm9ZM?t=5543
14:53:04 <amoralej> yep, i think that works
14:53:23 <amoralej> did you get any feedback about RDO worthy to share?
14:54:28 <karolinku[m]> I got feedback that rdoinfo idea (centralized info of all projects) is great
14:55:04 <amoralej> good
14:55:26 <amoralej> ok, if there are not other topics, i'll ask for volunteer to chair next week and close the mtg
14:55:35 <karolinku[m]> I can take it
14:55:47 <amoralej> #action karolinku[m] will chair next meeting
14:56:26 <amoralej> ok, i'm closing the meeting
14:56:33 <amoralej> thanks both for joining!
14:56:39 <amoralej> #endmeeting