14:03:04 <karolinku[m]> #startmeeting RDO meeting - 2023-02-15
14:03:04 <opendevmeet> Meeting started Wed Feb 15 14:03:04 2023 UTC and is due to finish in 60 minutes.  The chair is karolinku[m]. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:03:04 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:03:04 <opendevmeet> The meeting name has been set to 'rdo_meeting___2023_02_15'
14:03:39 <amoralej> o/
14:03:49 <spotz> o/
14:04:08 <karolinku[m]> #chair:  amoralej spotz
14:04:08 <opendevmeet> Warning: Nick not in channel: :
14:04:08 <opendevmeet> Current chairs: : amoralej karolinku[m] spotz
14:04:57 <jcapitao[m]> o/
14:05:32 <karolinku[m]> #chair jcapitao[m]
14:05:32 <opendevmeet> Current chairs: : amoralej jcapitao[m] karolinku[m] spotz
14:06:23 <karolinku[m]> I'll give you a moment to update agenda if needed
14:07:52 <spotz> karolinku[m]: Did you give a FOSDEM update last week or do we still need that?
14:08:19 <karolinku[m]> wdym FOSDEM update?
14:09:44 <karolinku[m]> let's go back to it on openfloor
14:09:56 <karolinku[m]> #topic How to manage TripleO deprecation
14:10:46 <dasm> o/
14:11:24 <amoralej> #info TripleO informed they are deprecating all branches after Wallaby
14:11:28 <amoralej> #link https://lists.openstack.org/pipermail/openstack-discuss/2023-February/032083.html
14:11:31 <karolinku[m]> #chair dasm
14:11:31 <opendevmeet> Current chairs: : amoralej dasm jcapitao[m] karolinku[m] spotz
14:12:26 <amoralej> in terms of RDO that means we will be retiring tripleo packages from the repos
14:13:38 <amoralej> my proposal is to maintain tripleo packages in RDO Trunk master while there are tripleo jobs running
14:14:36 <amoralej> but remove them from antelope repos as soon as we can
14:14:43 <dasm> what's going to happen to zed pachages. is it decided with TC?
14:14:52 <jcapitao[m]> or maybe setting a 6/12 months depreciation ?
14:15:00 <amoralej> for the time being, we will be keeping packages in zed
14:15:16 <amoralej> at least until it's clear what's happening with zed branches
14:16:18 <amoralej> tbh i didn't heard back from TC
14:16:26 <amoralej> the recomendation for zed
14:16:49 <amoralej> currently, i'd say the most important is to decide what to do with antelope, as we will be preparing the release shortly
14:17:01 <amoralej> s/important/urgent/
14:17:34 <amoralej> and apparently, it seems clear there will not be branches nor tags for antelope
14:19:05 <spotz> I would have assumed there would be tags for Antelope but nothing for Bobcat
14:19:48 <dasm> based on the email, my understanding was: no more tags after zed, with the intention to remove zed.
14:19:50 <amoralej> i understood there will not be in antelope, lemme reread it
14:19:55 <amoralej> yeas
14:20:14 <amoralej> that's also my understanding
14:20:59 <spotz> Ok and it's true Antelope releases after the announcement was made
14:22:04 <jcapitao[m]> amoralej: re: but remove them from antelope repos as soon as we can - you mean after antelope branching ?
14:22:17 <amoralej> yes
14:23:03 <amoralej> so, i think the best option for us is not create antelope branches for tripleo packages
14:23:18 <amoralej> so, no builds in cloudsig antelope
14:23:19 <jcapitao[m]> so we'd build commit release ?
14:23:34 <amoralej> no, we wouldn't build anything in cloudsig
14:23:50 <amoralej> and retire it from rdo-trunk as soon as we create new tags for bobcat in rdoinfo
14:24:14 <amoralej> as we may need to provide tripleo packages for master branch for some short time, afaik
14:24:47 <amoralej> my understanding is that there will be some jobs running in master
14:24:53 <marios> from ci side, we will continue to run jobs for master and zed for some time
14:24:59 <marios> just reduced set
14:25:07 <marios> like container builds, and scenario standalones
14:25:26 <amoralej> #info TripleO-CI will continue to run some jobs for master and zed for some time
14:25:44 <amoralej> #info TripleO CI will not run jobs for antelope
14:25:51 <amoralej> marios ^ is that correct?
14:26:19 <marios> amoralej: cant sign off on the antelope bit as i heard some rumours about antelope vs zed ... but for the first bit yes
14:26:34 <marios> and we *currently(* have 0 plans to put down ci for antelope
14:27:12 <amoralej> #undo
14:27:12 <opendevmeet> Removing item from minutes: #info TripleO CI will not run jobs for antelope
14:27:13 * marios joins call in 3 mins so will be slower to respond
14:28:11 <amoralej> #info TripleO CI currently has no plans to run CI on antelope
14:30:06 <amoralej> so, i'd plan the release based on current information
14:30:25 <jcapitao[m]> amoralej: IIUC you want to retire them in rdo-trunk for *antelope*  as soon as we create new tags for bobcat in rdoinfo (which will be master), is that correct ?
14:30:35 <amoralej> exactly
14:31:08 <jcapitao[m]> okk sound good to me
14:31:13 <amoralej> so, initially we will have tripleo packages as we will bootstrap centos9-antelope based on antelope-uc
14:31:26 <amoralej> once we move master to boobcat-uc
14:31:46 <amoralej> and recreate antelope tag, we will remove the undesired packages
14:31:59 <amoralej> that'd be my plan
14:32:19 <jcapitao[m]> got it +1
14:32:28 <amoralej> so we maintain the packages on rdo-trunk master but not in antelope
14:33:14 <amoralej> and a later point, once/if master branch is finally EOLed, removing them from master
14:33:41 <jcapitao[m]> that way we'll be able to still provides OOO packages in master if someone wants to pursue OOO development
14:33:50 <amoralej> all this plan is based on the current situation, if someone steps up to maintaing the projects upstream, we can maintain them, of course
14:33:57 <amoralej> yes
14:34:28 <amoralej> actually, we always can reconsider if the upstream situation changes
14:34:40 <amoralej> anre re-add packages in that case
14:35:14 <amoralej> i.e. if needed we could always add the packages to antelope tags
14:35:59 <jcapitao[m]> CI might breaks in the meantime though
14:36:08 <jcapitao[m]> but yeah
14:37:33 <karolinku[m]> #info RDO maintain the packages on rdo-trunk master but not in antelope, while on later point, once/if master branch is finally EOLed, removing them from master
14:38:11 <amoralej> s/the packages/the TripleO packages/
14:38:28 <amoralej> master and zed
14:39:51 <karolinku[m]> #undo
14:39:51 <opendevmeet> Removing item from minutes: #info RDO maintain the packages on rdo-trunk master but not in antelope, while on later point, once/if master branch is finally EOLed, removing them from master
14:40:11 <karolinku[m]> #info RDO maintains TripleO packages on rdo-trunk master but not in antelope, while on later point, once/if master branch is finally EOLed, removing them from master
14:40:23 <amoralej> good
14:40:41 <karolinku[m]> is it all in this topic?
14:40:45 <amoralej> nop :)
14:41:06 <amoralej> second question is what "TripleO packages" means
14:41:08 <karolinku[m]> ah, we are after half time
14:41:13 <amoralej> yes :)
14:41:40 <amoralej> if you check the packages in tripleo component, there are some packages we still want to maintain in RDO
14:41:49 <amoralej> as puppet modules, heat, etc..
14:41:56 <amoralej> and i have doubts for others
14:42:19 <amoralej> so we need to think how to redistribute packages in other components
14:42:57 <amoralej> i'd put all puppet-* to a new component puppet in antelope
14:43:21 <amoralej> for the rest we'll need to figure out
14:43:42 <jcapitao[m]> +1 for puppet component
14:44:57 <jcapitao[m]> heat mistral zaqar
14:45:06 <jcapitao[m]> to figure it out
14:45:23 <jcapitao[m]> and kolla
14:45:28 <amoralej> also we need to check if make sense to provide the ansible roles
14:45:43 <amoralej> and os-*
14:46:04 <amoralej> the entire list of packages in tripleo component is in https://review.rdoproject.org/etherpad/p/antelope-release-preparation
14:46:15 <karolinku[m]> I like the idea of  new component
14:46:24 <amoralej> i'll send a mail to the ML with a poposal for antelope
14:46:34 <jcapitao[m]> ok
14:47:17 <amoralej> #action amoralej will send a mail to RDO MLs with a proposal for tripleo-related packages in Antelope
14:47:47 <amoralej> we'll need to provide per-release components
14:47:49 <amoralej> btw
14:48:01 <amoralej> i think we already tested it in the passt, so there should be no problem
14:48:24 <amoralej> so, i think we are done with this topic
14:48:26 <amoralej> from my side
14:48:57 <amoralej> sorry for cannibalizing the mtg
14:49:23 <jcapitao[m]> :D
14:49:45 <jcapitao[m]> good for me too
14:50:02 <spotz> No worries, that's what it's here for
14:50:25 <rdogerrit> Artom Lifshitz proposed openstack/placement-distgit rpm-master: Bump wsgi_intercept test requirement to match upstream  https://review.rdoproject.org/r/c/openstack/placement-distgit/+/47055
14:50:58 <amoralej> so we can move on to next topic
14:51:07 <rdogerrit> Artom Lifshitz proposed openstack/placement-distgit zed-rdo: Bump wsgi_intercept test requirement to match upstream  https://review.rdoproject.org/r/c/openstack/placement-distgit/+/47057
14:51:19 <karolinku[m]> #topic antelope status
14:51:30 <rdogerrit> Artom Lifshitz proposed openstack/placement-distgit yoga-rdo: Bump wsgi_intercept test requirement to match upstream  https://review.rdoproject.org/r/c/openstack/placement-distgit/+/47058
14:51:53 <amoralej> #info a jira issue has been created to track antelope release preparation https://issues.redhat.com/browse/RDO-84
14:52:07 <amoralej> and jcapitao[m] has started doing stuff :)
14:52:38 <jcapitao[m]> yeah
14:52:53 <jcapitao[m]> we're going to start reqchecking
14:53:04 <amoralej> i've created the initial etherpad but didn't add the packages yet
14:53:14 <jcapitao[m]> and bootstrapping the DLRN builder
14:53:14 <amoralej> we can start rechecking libraries and clients i think
14:53:25 <amoralej> let's distribute the load among the team
14:53:27 <karolinku[m]> my faaaaavourite part <3
14:53:32 <amoralej> lol
14:53:46 <amoralej> yeah, it's very enjoyable :)
14:53:46 <jcapitao[m]> :D
14:54:18 <amoralej> let's add them to the etherpad and distribute it
14:54:30 <amoralej> btw, i'll move the tripleo part to a new etherpad
14:54:32 <jcapitao[m]> yep we'll sync off mtg
14:54:38 <jcapitao[m]> ok
14:54:40 <amoralej> or we will have too much on it
14:54:42 <amoralej> yes
14:55:04 <karolinku[m]> im working on brmaching script
14:55:16 <amoralej> including reqcheck ?
14:55:29 <karolinku[m]> and I think the feature of "not" tripleo" will be handy
14:55:40 <karolinku[m]> no no, without reqcheck
14:55:53 <amoralej> #info RDO will update the definition of done for cloudsig release based only on puppet and packstack job
14:56:12 <amoralej> ok, so we can start doing reqchecks anyway
14:56:14 <amoralej> good
14:56:51 <amoralej> we are almost finishing, i think we can move to next topic
14:57:06 <amoralej> and we will coordinate about antelope post-mtg
14:57:36 <karolinku[m]> #topic Retiring glare
14:57:44 <jcapitao[m]> #link https://lists.rdoproject.org/archives/list/dev@lists.rdoproject.org/thread/PVXIRURCMONAWLNSUN2PP6FDOROCDURQ/
14:57:54 <jcapitao[m]> #link https://review.rdoproject.org/r/c/rdoinfo/+/47036
14:58:06 <jcapitao[m]> so we're proposing to retire glare and its client
14:58:39 <jcapitao[m]> the discussion is opened on ML and the review itself of course
14:59:11 <jcapitao[m]> that's it for this topic I think
14:59:35 <karolinku[m]> #topic  FOSDEM report
15:00:28 <spotz> Just wanted to report back that Cloud Sig had 2 talks at CentOS Connect one from Karolina and one from Christian and Alessandro both went well I thought.
15:01:18 <spotz> Over at FOSDEM itself we gave out all the SWAG I'd bought and it was nice seeing some of the older bags being carried around through out the weekend and even someone wearing a t-shirt
15:01:24 <spotz> That's it if no questions
15:01:41 <amoralej> did you get any feedback about RDO ?
15:02:21 <spotz> We got lots of What is RDO, so we'll need a rollup or a handout next time. But we didn't get any I thought OpenStack was dead questions:)
15:02:33 <karolinku[m]> #info CloudSig had 2 talks at CentOS Connect
15:04:16 <spotz> That's it for me
15:04:34 <amoralej> :)
15:04:52 <karolinku[m]> #topic Next Chair
15:05:12 <jcapitao[m]> I can take it
15:05:29 <karolinku[m]> #action jcapitao[m] is chairing next week
15:05:57 <karolinku[m]> quickly #topic Open Floor
15:06:40 <amoralej> i found a new cool tool this week
15:06:41 <amoralej> https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/message/QFXUGMRGHGEIID77IEHNIS5XES6RI3GR/
15:06:43 <amoralej> fedrq
15:06:50 <amoralej> take a look if you have a chance
15:07:15 <amoralej> i'll be sending a patch to add support to query cloudsig repo too
15:07:32 <amoralej> so, from a single tool we can query fedora, centos and cloudsig
15:07:44 <amoralej> which is pretty convenient for us
15:08:10 <amoralej> it may go to the rdo-toolbox
15:08:24 <karolinku[m]> #link https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/message/QFXUGMRGHGEIID77IEHNIS5XES6RI3GR/
15:08:26 <amoralej> ah, and i started using rdo-toolbox
15:08:48 <amoralej> which is a pretty cool way of using rdo scripts and tools
15:09:13 <jcapitao[m]> interesting fedrq
15:09:58 <amoralej> note we can do stuff like, what packages depends for any of the subpackages of other one
15:10:01 <amoralej> and stuff like that
15:10:30 <amoralej> jcapitao[m], wrt rdo-toolbox, did you include the scripts in releng repo in the container?
15:10:45 <jcapitao[m]> yeah that's good value
15:11:18 <jcapitao[m]> we can't provides shell scripts with setuptools :(
15:11:27 <jcapitao[m]> only python script
15:11:33 <amoralej> ah
15:11:33 <amoralej> ok
15:11:47 <jcapitao[m]> so right now, I added the dir script in $PATH
15:11:53 <amoralej> wfm
15:12:41 <jcapitao[m]> btw maybe I should add it in RDO cgit and Gerrit
15:14:17 <amoralej> yes, i'd say so
15:14:30 <amoralej> we could add it in releng project? or create a new one
15:15:07 <jcapitao[m]> right
15:15:14 <jcapitao[m]> let's add it in releng
15:18:02 <karolinku[m]> if thats all, I will close the mtg
15:19:40 <karolinku[m]> #endmeeting