14:00:03 <spotz_> #startmeeting RDO meeting - 2023-03-08
14:00:03 <opendevmeet> Meeting started Wed Mar  8 14:00:03 2023 UTC and is due to finish in 60 minutes.  The chair is spotz_. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:03 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:03 <opendevmeet> The meeting name has been set to 'rdo_meeting___2023_03_08'
14:00:09 <amoralej> o/
14:00:12 <spotz_> #topic ROll Call
14:00:25 <spotz_> #chair amoralej
14:00:25 <opendevmeet> Current chairs: amoralej spotz_
14:01:19 <karolinku[m]> o/
14:01:43 <spotz_> #chair karolinku[m]
14:01:43 <opendevmeet> Current chairs: amoralej karolinku[m] spotz_
14:02:04 <spotz_> I would fix my name but it might break the bot:)
14:02:16 <amoralej> :)
14:02:17 <rdogerrit> Karolina Kula proposed openstack/cinderclient-distgit antelope-rdo: python-cinderclient-9.3.0-1  https://review.rdoproject.org/r/c/openstack/cinderclient-distgit/+/47532
14:02:38 <jcapitao[m]> o/
14:02:58 <spotz_> #chair jcapitao[m]
14:02:58 <opendevmeet> Current chairs: amoralej jcapitao[m] karolinku[m] spotz_
14:03:13 <spotz_> Ok let's get started
14:03:21 <spotz_> #topic Update about Antelope preparation
14:04:16 <karolinku[m]> bootstraping is done
14:04:18 <rdogerrit> Daniel Pawlik proposed config master: [microshift] Add name param for include_role  https://review.rdoproject.org/r/c/config/+/47533
14:05:34 <amoralej> #info RDO Trunk Antelope bootstrap is finished
14:05:55 <amoralej> #link https://trunk.rdoproject.org/centos9-antelope/report.html
14:06:00 <amoralej> #link https://trunk.rdoproject.org/centos9-antelope/report.html
14:06:06 <jcapitao[m]> good job karolinku o/
14:06:09 <amoralej> karolinku[m], ^ is this correct?
14:07:03 <spotz_> woohoo!
14:07:12 <karolinku[m]> why? sth wrong about it?
14:08:23 <amoralej> no no, i just was looking for confirmation about my info and link notes :)
14:09:01 <karolinku[m]> then yes, corrent :)
14:09:03 <amoralej> as you are the one that did it :)
14:09:10 <spotz_> That's how I read it but then wasn't sure:)
14:09:16 <karolinku[m]> enabling cron and ftbfs are ongoing reviews
14:09:59 <jcapitao[m]> also we have reqchecked the core projects
14:10:28 <jcapitao[m]> and are building libs and clients projects on CBS
14:11:20 <jcapitao[m]> #info the core projects are reqchecked
14:11:53 <jcapitao[m]> #info the clients and libs projects are currently being built on CBS
14:12:32 <amoralej> there are RC1 releases for most of the core packages too
14:12:33 <amoralej> https://review.opendev.org/q/project:openstack/releases+file:antelope+rc1
14:12:47 <amoralej> so we can start building them once we have libs and clients
14:13:00 <rdogerrit> Merged rdoinfo master: Promote ansible-packaging-1-9.1.1 to antelope el9s-build tag  https://review.rdoproject.org/r/c/rdoinfo/+/47518
14:13:06 <jcapitao[m]> yes
14:13:31 <jcapitao[m]> we'll try to catch up by friday hopefully
14:14:18 <amoralej> i'm also trying to bump all the external ansible collections before antelope ga
14:14:19 <amoralej> https://review.rdoproject.org/r/q/topic:ansible-collections-update
14:14:34 <amoralej> to match last releases in fedora
14:15:35 <amoralej> #info we will update and test latest external ansible collections from Fedora in Antelope
14:15:54 <rdogerrit> Merged openstack/horizon-distgit rpm-master: Requirements sync for Antelope  https://review.rdoproject.org/r/c/openstack/horizon-distgit/+/47517
14:16:10 <jcapitao[m]> wrt non-openstack puppet modules
14:16:52 <jcapitao[m]> can we pin them now ?
14:17:07 <amoralej> i'd say so
14:17:17 <jcapitao[m]> I don't remember last statement on this topic
14:17:19 <amoralej> tkajinam ^
14:17:43 <amoralej> i think we can pin non-openstack puppet modules to currently promoted versions in puppet-promotion pipeline
14:18:39 <jcapitao[m]> ok let's pin it then
14:19:45 <rdogerrit> Merged config master: Add tagging for container copy  https://review.rdoproject.org/r/c/config/+/47528
14:20:32 <jcapitao[m]> I think that's it for this topic
14:21:31 <spotz_> #topic DLRN rpm maintenance in Fedora
14:21:32 <jcapitao[m]> seems review.r.o is down
14:22:07 <amoralej> wfm
14:22:48 <jcapitao[m]> I HTTP/503 during 2 min but now it's back
14:22:53 <amoralej> #info There is FTBFS for dlrn rpm in fedora https://bugzilla.redhat.com/show_bug.cgi?id=2171470
14:23:12 <amoralej> i'd say root cause is python-sh update in fedora
14:23:17 <amoralej> the known issue
14:23:24 <amoralej> https://kojipkgs.fedoraproject.org//work/tasks/497/98450497/build.log
14:23:59 <amoralej> jpena was asking me if we want to maintain it in fedora
14:24:21 <amoralej> as we are installing it from code
14:24:38 <amoralej> so, i think we have two questions
14:24:49 <amoralej> 1. Do we want to maintain dlrn package in fedora?
14:25:09 <amoralej> 2. if yes, what do wi do with the existing FTBFS?
14:25:13 <rdogerrit> Daniel Pawlik proposed config master: [microshift] Add name param for include_role  https://review.rdoproject.org/r/c/config/+/47533
14:25:39 <amoralej> and 3. maybe someone of us may be the main admin as jpena is not so involved in the project now
14:25:40 <spotz_> On #2 do we have to do anything with it?
14:26:02 <amoralej> well, fix the code or skip the tests, i think
14:26:30 <amoralej> karolinku[m] checked about this issue and i think it only affects to unit tests, not runtime, but fixing it is no trivial
14:26:37 <amoralej> am i correct?
14:28:00 <karolinku[m]> checking
14:28:23 <amoralej> removing the pin on sh module in dlrn
14:28:33 <amoralej> what woudl we need?¿
14:29:46 <karolinku[m]> yes, this is exactely the issue with 1.14.3
14:29:47 <spotz_> Ok so it sounds like 1 and 2 are needed?
14:29:52 <amoralej> https://softwarefactory-project.io/r/c/DLRN/+/25878
14:29:53 <karolinku[m]> *sh version 1.14.3
14:30:00 <amoralej> yep
14:30:03 <spotz_> And 3 sounds like a good idea regardless
14:30:48 <karolinku[m]> we may or pin to 1.14.2 or fix tests but it will take time and effort, so not be right now
14:30:49 <amoralej> if we decide to remove it from fedora (1), we can ignore 2 and 3 :)
14:30:57 <amoralej> we can't pin in rpm
14:31:01 <jcapitao[m]> for my point of view, as we don't leverage the use of this RPM from Fedora, I think there is no strong reason to maintain it
14:31:07 <amoralej> as we use the python-sh included in fedora
14:31:24 <amoralej> so we need to make it work with latest package in fedora
14:31:43 <amoralej> there are other ways as bundling sh in dlrn but we will not do that
14:32:25 <spotz_> If we move it from Fedora where would it go?
14:32:35 <amoralej> nowhere :)
14:32:40 <amoralej> without rpm
14:32:46 <amoralej> we'd keep installing from pypi
14:32:53 <jcapitao[m]> in the other hand, building against rawhide forces us to keep the code updated
14:32:54 <amoralej> or source repo, which is what we do it today
14:32:58 <amoralej> yes
14:33:25 <amoralej> so, having it in fedora has two advantadges, getting it tested with new python versions early, which is good
14:33:25 <spotz_> I think there's value on keeping it in Fedora beyond just the code but ties to the community as well
14:33:41 <amoralej> and also we'd be ready if at some point we decide to move to rpm based deployments
14:33:47 <amoralej> which wouldn't be a bad thing, tbh
14:34:12 <amoralej> but we'd need to commit to keep it working
14:34:52 <amoralej> also, is good oportunity if anyone wants to own more packages in Fedora :)
14:35:24 <jcapitao[m]> yeah
14:36:13 <jcapitao[m]> so if we commit to keep it working, then I think we need to use it in our CI jobs at least as you mentioned amoralej
14:36:32 <karolinku[m]> well, since I worked with evallespi on DLRN I can engage to it
14:36:51 <amoralej> but then we need to be more consistent in maintaining it updated
14:36:58 <amoralej> create more frequent releases, etc...
14:37:29 <karolinku[m]> to create new releses, some development should be done, not only necessary fixes :)
14:37:53 <amoralej> actually bugfix releases are intenede to ship only bug fixes :)
14:39:14 <amoralej> actually, since latest tag we have new features, so we may create 0.26.0 now
14:39:47 <amoralej> so, karolinku[m] would you be interested in becoming main admin for it?
14:40:11 <karolinku[m]> yes, but with help:)
14:40:20 <amoralej> yeah, sure :)
14:40:29 <amoralej> actually the package is currently in openstack-sig too
14:40:54 <spotz_> :)
14:40:56 <amoralej> so, it's more a matter of commitment that permissions or users
14:41:19 <spotz_> Do we need to get the SiG list updated?
14:41:31 <amoralej> we can as evallesp, dunno if he's also fedora packager and if he's interested on becaming co-maintaier
14:41:42 <amoralej> no, i think karolinku[m] is already on the group
14:41:55 <amoralej> but we may ask jpena to make karolinku[m] main admin
14:43:37 <amoralej> short term, we should update the version and maybe skip tests or ignore results
14:43:55 <amoralej> if it stays in ftbfs for more time, it will be automatically orphaned
14:45:24 <jcapitao[m]> we have ~6 weeks left
14:46:19 <rdogerrit> Merged config master: [microshift] Add name param for include_role  https://review.rdoproject.org/r/c/config/+/47533
14:46:44 <jcapitao[m]> we'll save it !
14:47:42 <spotz_> hehe
14:49:46 <spotz_> So who's reaching out to jpena?
14:50:06 <amoralej> #agreed we will maintain the dlrn package in fedora
14:50:26 <amoralej> #action amoralej to reach out jpena and ask to add karolinku[m] as main admin
14:50:35 <amoralej> it's besides me right now :)
14:50:44 <amoralej> s/it/he/
14:50:59 <spotz_> :) Hey jpena!
14:51:07 <amoralej> xD
14:51:41 <rdogerrit> Merged openstack/oslo-privsep-distgit antelope-rdo: python-oslo-privsep-3.1.0-1  https://review.rdoproject.org/r/c/openstack/oslo-privsep-distgit/+/47531
14:51:44 <amoralej> #action karolinku[m] et all to fix current FTBFS and update dlrn package in fedora
14:52:31 <amoralej> so i think that's it wrt this topic
14:53:20 <spotz_> #topic Next Week's chair
14:53:53 <jcapitao[m]> I can take it
14:54:11 <spotz_> Thanks jcapitao[m] and the agenda entry is created already
14:54:23 <spotz_> #topic Open Floor
14:54:28 <spotz_> Anyone have anything?
14:55:31 <amoralej> wrt ansible-core
14:56:12 <amoralej> in case you didn't see it, tripleo is hitting an issue with last update of ansible-core in centos stream 9
14:56:19 <amoralej> which was rebuilt on python 3.11
14:56:22 <amoralej> that's breaking tripleo
14:56:31 <rdogerrit> Merged openstack/cinderclient-distgit antelope-rdo: python-cinderclient-9.3.0-1  https://review.rdoproject.org/r/c/openstack/cinderclient-distgit/+/47532
14:56:42 <amoralej> https://bugs.launchpad.net/tripleo/+bug/2007659
14:56:47 <apevec> amoralej: for a weird reason but ok...
14:56:53 <amoralej> :)
14:57:20 <amoralej> tripleo pinned to previous build and merged a fix in tripleoclient
14:57:31 <apevec> actually no reason in the CS9 commit https://gitlab.com/redhat/centos-stream/rpms/ansible-core/-/merge_requests/30
14:57:56 <amoralej> now they are trying to unpin and test it with ansible-core/python3.11, collection update is part of it
14:58:01 <apevec> but in bz it was like "b/c _upstream_ python 3.9 goes EOL" which does not apply for RHEL9 system python 3.9
14:58:06 <rdogerrit> Merged openstack/barbicanclient-distgit antelope-rdo: python-barbicanclient-5.5.0-1  https://review.rdoproject.org/r/c/openstack/barbicanclient-distgit/+/47524
14:58:43 <apevec> do we have all related reviews in one gerrit topic?
14:58:52 <amoralej> https://review.rdoproject.org/r/q/topic:ansible-collections-update
14:59:32 <amoralej> my doubt is what to do for wallaby, if updating all of them or cherry-pick all the required ones
14:59:42 <amoralej> i'll ask tripleo team
15:01:28 <apevec> yeah they're main consumer but I'd say let's keep all collections updated, not sure why they were kept pinned
15:01:52 <apevec> if we cherrypick, it's unique mix
15:02:07 <amoralej> well, sagi used to take care of updates
15:02:36 <apevec> Sagi is not involved w/ openstack anymore
15:02:40 <amoralej> yes
15:02:48 <amoralej> that's what i meant :)
15:02:56 <rdogerrit> Merged rdoinfo master: Add typepy, tcolorpy and mbstrdecoder as dep  https://review.rdoproject.org/r/c/rdoinfo/+/47526
15:03:08 <apevec> so yes, let TripleO decide but I'd strongly suggest updating all together w/ latest upstream releases
15:03:12 <amoralej> i think when he moved updating it went to nowhere land
15:03:28 <amoralej> we probably can test the unpin upstream review with a temporary repo
15:03:37 <amoralej> including all the updates
15:03:48 <apevec> yes let's do that
15:06:37 <spotz_> FYI we're at 6 minutes over. Anything else on this topic?
15:06:40 <apevec> ok let's do the summary for the minutes and close the meeting?
15:06:54 <amoralej> not from my side
15:07:34 <apevec> #info proceed with https://review.rdoproject.org/r/q/topic:ansible-collections-update and get TripleO feedback
15:07:35 <spotz_> Ok so it looks like we're going to unpin upstream and see if we're all good now?
15:07:43 <spotz_> :)
15:07:55 <apevec> ah not sure this got into minutes, not chair?
15:08:07 <spotz_> #info proceed with https://review.rdoproject.org/r/q/topic:ansible-collections-update and get TripleO feedback
15:08:19 <amoralej> btw apevec https://softwarefactory-project.io/r/c/software-factory/sf-infra/+/27702
15:08:23 <spotz_> Just to be safe:) Ok closing us out
15:08:31 <spotz_> #endmeeting