14:00:19 <jcapitao[m]> #startmeeting RDO meeting - 2023-03-15
14:00:19 <opendevmeet> Meeting started Wed Mar 15 14:00:19 2023 UTC and is due to finish in 60 minutes.  The chair is jcapitao[m]. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:19 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:19 <opendevmeet> The meeting name has been set to 'rdo_meeting___2023_03_15'
14:00:34 <jcapitao[m]> #topic Roll Call
14:01:19 <jcapitao[m]> feel free to add your topics in https://etherpad.opendev.org/p/RDO-Meeting
14:01:34 <karolinku[m]> o/
14:02:38 <jcapitao[m]> #chair karolinku
14:02:38 <opendevmeet> Warning: Nick not in channel: karolinku
14:02:38 <opendevmeet> Current chairs: jcapitao[m] karolinku
14:05:36 <jcapitao[m]> undo
14:07:11 <jcapitao[m]> #undo
14:07:11 <opendevmeet> Removing item from minutes: #topic Roll Call
14:07:20 <jcapitao[m]> damn
14:07:30 <karolinku[m]> :D
14:07:36 <jcapitao[m]> #topic Roll Call
14:07:45 <jcapitao[m]> #chair karolinku
14:07:45 <opendevmeet> Current chairs: jcapitao[m] karolinku
14:08:31 <jcapitao[m]> weird
14:08:59 <jcapitao[m]> I think Matrix and OFTC networks are unsynced
14:09:23 <rdogerrit> Merged openstack/magnum-ui-distgit antelope-rdo: openstack-magnum-ui-12.0.0-0.1.0rc1  https://review.rdoproject.org/r/c/openstack/magnum-ui-distgit/+/47805
14:09:26 <karolinku[m]> if you talk about "nick name not in channel", it's about [m] at the end
14:09:57 <rdogerrit> Merged openstack/trove-dashboard-distgit antelope-rdo: openstack-trove-ui-20.0.0-0.1.0rc1  https://review.rdoproject.org/r/c/openstack/trove-dashboard-distgit/+/47807
14:10:58 <amoralej> o/
14:11:30 <amoralej> o/
14:11:56 <jcapitao[m]> #chair amoralej
14:11:56 <opendevmeet> Current chairs: amoralej jcapitao[m] karolinku
14:12:08 <rdogerrit> Merged openstack/tacker-distgit antelope-rdo: openstack-tacker-9.0.0-0.1.0rc1  https://review.rdoproject.org/r/c/openstack/tacker-distgit/+/47808
14:12:23 <jcapitao[m]> #chair karolinku[m]
14:12:23 <opendevmeet> Current chairs: amoralej jcapitao[m] karolinku karolinku[m]
14:13:12 <jcapitao[m]> sorry for the delay
14:13:25 <jcapitao[m]> let's start with first topic
14:13:56 <amoralej> yep
14:13:56 <jcapitao[m]> spotz_: ping if you're around
14:14:02 <jcapitao[m]> #topic Antelope release preparation update
14:14:06 <spotz> o/
14:14:12 <jcapitao[m]> #link https://issues.redhat.com/browse/RDO-84
14:14:21 <jcapitao[m]> #chair spotz
14:14:21 <opendevmeet> Current chairs: amoralej jcapitao[m] karolinku karolinku[m] spotz
14:14:24 <spotz> Sorry split between meetings and lost track of time
14:14:36 <jcapitao[m]> no worries :)
14:14:41 <jcapitao[m]> #info non-OpenStack puppet modules are built
14:14:51 <jcapitao[m]> #info core projects are almost built (still a few missing)
14:15:06 <jcapitao[m]> #info tempest projects are going to be built
14:15:45 <jcapitao[m]> #info next step is to branch OpenStack puppet modules
14:16:19 <jcapitao[m]> there is not yet puppet Antelope GA patch opened upstream
14:16:34 <amoralej> i've just asked in #puppet-openstack about ETA for it
14:16:46 <jcapitao[m]> ok
14:16:54 <amoralej> let's see if tkajinam has any estimation
14:17:45 <amoralej> "probably Mar 22 or 23"
14:17:59 <amoralej> so, next week
14:18:12 <rdogerrit> Daniel Pawlik proposed config master: DNM [microshift] Add dnsmasq service  https://review.rdoproject.org/r/c/config/+/47810
14:18:15 <jcapitao[m]> ok
14:18:25 <spotz> Week after that is the virtual PTG FYI
14:18:27 <jcapitao[m]> let's branch our puppet projects, so our bot will propose the patches
14:18:46 <amoralej> maybe we will be able to release close to PTG this time
14:19:42 <jcapitao[m]> mmh we can make it if promotion goes well :)
14:20:46 <jcapitao[m]> #info RDO will move to new bobcat branches and apply tripleo removal reorg
14:21:22 <rdogerrit> Daniel Pawlik proposed config master: [microshift] Add dnsmasq service  https://review.rdoproject.org/r/c/config/+/47810
14:21:30 <jcapitao[m]> speaking of tripleo reorg
14:21:38 <amoralej> an update about puppet " I'll complete that in the week of March 27th."
14:21:44 <amoralej> so it will be a bit later
14:21:57 <amoralej> requirements project is already branched
14:22:04 <amoralej> so we can move master to bobcat now
14:22:25 <rdogerrit> Daniel Pawlik proposed config master: [microshift] Add dnsmasq service  https://review.rdoproject.org/r/c/config/+/47810
14:22:25 <amoralej> we have some dependency update in-flight?
14:23:08 <jcapitao[m]> I don't think so
14:23:27 <jcapitao[m]> I still need to remove setuptools_scm from el9s-build repo
14:23:30 <amoralej> ok, then we should be good to cut bobcat tags
14:24:32 <jcapitao[m]> ok
14:24:47 <jcapitao[m]> speaking of tripleo reorg, we also need ansible-role-openstack-operations and ansible-pacemaker in order to build python-metalsmith
14:24:56 <amoralej> ah, right, i've seen it
14:25:08 <amoralej> mmmm we should check with the baremetal team
14:25:19 <amoralej> to see if that's actually needed or not
14:25:48 <jcapitao[m]> https://github.com/rdo-packages/metalsmith-distgit/blob/rpm-master/python-metalsmith.spec#L93-L103
14:26:00 <jcapitao[m]> yeah need to check if this subpackage ^ is still needed
14:26:46 <amoralej> pacemaker is chained dependency?=
14:27:55 <tkajinam> I don't expect ansible-pacemaker is required by collections-openstack or metalsmith...
14:28:26 <amoralej> but you mentioned before
14:28:45 <amoralej> sorry,  jcapitao[m] mentioned
14:29:18 <jcapitao[m]> https://github.com/rdo-packages/ansible-role-openstack-operations-distgit/blob/rpm-master/ansible-role-openstack-operations.spec#L37
14:29:35 <amoralej> we should check the actual code
14:29:35 <tkajinam> sorry hexchat crashed
14:29:37 <amoralej> np
14:29:43 <tkajinam> ah, ok it seems ansible-role-openstack-operations requires it
14:29:45 <tkajinam> not colections-openstack
14:29:53 <amoralej> yep, that
14:31:16 <jcapitao[m]> metalsmith -> ansible-role-openstack-operations -> ansible-pacemaker
14:31:21 <amoralej> so, iuuc we need to maintain ansible-role-openstack-operatons for metalsmith and that pulls ansible-pacemaker
14:31:32 <jcapitao[m]> that's the chained dep
14:31:40 <jcapitao[m]> exactly
14:31:47 <tkajinam> we have to check it with ironic team
14:31:56 <tkajinam> ansible-role-openstack-operations is part of TripleO's governance so will be retired unless it is taken over
14:33:00 <amoralej> stevebaker[m], ^ when you have a chance
14:34:05 <jcapitao[m]> ok, I hope we'll find a way
14:34:12 <amoralej> sure, we will :)
14:34:26 <tkajinam> I'll double check it with stevebaker[m] but my rough guess is that was mistake
14:34:35 <amoralej> let's dig a bit on the code to see if the role is actually used
14:34:36 <tkajinam> https://github.com/rdo-packages/metalsmith-distgit/commit/52d7a64efd75800fe03b22de86fc4d0442e3adcc
14:34:46 <amoralej> yeah, it may be just a mistake or a leftover
14:34:53 <tkajinam> but what is imported comes from collections-openstack iiuc
14:35:42 <jcapitao[m]> ah ! ok let's see
14:35:53 <rdogerrit> Daniel Pawlik proposed config master: [microshift] Add dnsmasq service  https://review.rdoproject.org/r/c/config/+/47810
14:35:55 <jcapitao[m]> #link https://review.rdoproject.org/etherpad/p/antelope-release-announcement
14:36:01 <amoralej> https://github.com/openstack/metalsmith/blob/master/metalsmith_ansible/ansible_plugins/modules/metalsmith_instances.py#L22-L24
14:37:13 <jcapitao[m]> yeah, so looks like a leftover indeed
14:38:07 <jcapitao[m]> I just copy/paste the antelope release announcement link to fill out
14:38:24 <amoralej> https://opendev.org/openstack/ansible-collections-openstack/src/branch/master/plugins/module_utils/openstack.py#L161
14:38:28 <spotz> The one I just made?
14:38:37 <jcapitao[m]> initialialized by spotz I guess :)
14:38:43 <jcapitao[m]> yes
14:38:45 <spotz> hehe
14:39:13 <rdogerrit> Takashi Kajinami proposed openstack/metalsmith-distgit rpm-master: Fix the wrong package name in dependencies  https://review.rdoproject.org/r/c/openstack/metalsmith-distgit/+/47811
14:39:14 <spotz> I figured if we were starting to talk release we should have one to start working with:)
14:40:27 <amoralej> sure, this time we'll need to include something about tripleo removal
14:40:36 <spotz> Yeah
14:41:12 <jcapitao[m]> right
14:41:50 <jcapitao[m]> let's move to next topic which is connected to this one
14:41:53 <jcapitao[m]> #topic TripleO deprecation status
14:42:05 <jcapitao[m]> #link https://lists.openstack.org/pipermail/openstack-discuss/2023-March/032663.html
14:43:03 <amoralej> #info TC statement is that tripleo master branches will be deprecated and zed set to 'supported but no maintainers'
14:43:44 <amoralej> from RDO PoV, i think we should keep tripleo packages in rdo-trunk and existing packages in cloudsig
14:43:48 <amoralej> for ZED
14:44:15 <rdogerrit> Merged config master: [microshift] Add dnsmasq service  https://review.rdoproject.org/r/c/config/+/47810
14:44:19 <amoralej> we may send a mail alerting that there will probably not be new releases in Zed release
14:44:24 <amoralej> in RDO
14:45:05 <amoralej> for master, i think we can start removing tripleo jobs we have to gate changes in rdo for anything after wallaby
14:45:10 <spotz> Yeah
14:46:06 <amoralej> #info RDO will remove TripleO jobs from gates or periodic pipelines for releases newer that wallaby
14:46:24 <jcapitao[m]> okk
14:46:46 <spotz> We did have a few TripleO tag releases after Wallaby though right?
14:47:03 <amoralej> yes
14:47:26 <amoralej> actually we had one set of tags for every release since xena
14:47:39 <amoralej> that's what we are shipping in cloudsig repos
14:47:53 <spotz> Ahh ok
14:48:32 <rdogerrit> Chandan Kumar proposed config master: Include setup_dnsmas play in microshift_openstack playbook  https://review.rdoproject.org/r/c/config/+/47812
14:49:19 <amoralej> in zed, it was supposed that there may be new releases or at least supported from stable/zed branches
14:50:25 <rdogerrit> Merged openstack/gnocchi-distgit antelope-rdo: gnocchi-4.5.0-1  https://review.rdoproject.org/r/c/openstack/gnocchi-distgit/+/47809
14:50:31 <amoralej> as mentioned before, for antelope we can remove tripleo packages as part of the switch to bobcat
14:50:53 <amoralej> for master we will do the same once jobs are finally removed from upstream master branches too
14:51:25 <jcapitao[m]> yep
14:51:34 <jcapitao[m]> the plan sounds good
14:52:22 <jcapitao[m]> I think that's it for this topic ?
14:53:10 <spotz> Yeah
14:53:30 <jcapitao[m]> let's move
14:53:50 <jcapitao[m]> there are no more topics in agenda
14:53:51 <jcapitao[m]> for today
14:53:58 <jcapitao[m]> #topic Next Week's chair
14:54:05 <amoralej> o/
14:54:25 <rdogerrit> Merged config master: Include setup_dnsmas play in microshift_openstack playbook  https://review.rdoproject.org/r/c/config/+/47812
14:54:35 <jcapitao[m]> #action amoralej to chair next week
14:54:55 <jcapitao[m]> thanks amoralej!
14:55:12 <jcapitao[m]> #topic Open Floor
14:55:29 <jcapitao[m]> if anyone have anything to add
14:57:03 <amoralej> not from my side
14:57:54 <spotz> not me
14:59:19 <jcapitao[m]> ok I'm gonna close the meeting
14:59:23 <jcapitao[m]> #endmeeting