14:02:18 <jcapitao[m]> #startmeeting RDO meeting - 2023-03-29
14:02:18 <opendevmeet> Meeting started Wed Mar 29 14:02:18 2023 UTC and is due to finish in 60 minutes.  The chair is jcapitao[m]. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:18 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:18 <opendevmeet> The meeting name has been set to 'rdo_meeting___2023_03_29'
14:02:26 <jcapitao[m]> #topic roll call
14:02:35 <jcapitao[m]> https://etherpad.opendev.org/p/RDO-Meeting
14:02:45 <jcapitao[m]> you can add your topics in this pad
14:04:18 <spotz_> o/
14:04:18 <amoralej> o/
14:04:39 <jcapitao[m]> #chair spotz_ amoralej
14:04:39 <opendevmeet> Current chairs: amoralej jcapitao[m] spotz_
14:05:29 <jcapitao[m]> karolinku: are you around ?
14:05:47 <amoralej> (i'm in another meeting, so just i'm half here ... )
14:06:42 <jcapitao[m]> ask GPT-4 to answer on your behalf :)
14:07:28 <jcapitao[m]> let's start with first topic
14:07:31 <jcapitao[m]> #topic Antelope release preparation update
14:07:41 <jcapitao[m]> #link https://issues.redhat.com/browse/RDO-84
14:07:50 <jcapitao[m]> #link https://issues.redhat.com/browse/RDO-84
14:08:06 <jcapitao[m]> #info we are waiting for the OpenStack puppet modules to be released
14:08:15 <jcapitao[m]> #link https://review.opendev.org/c/openstack/releases/+/878731
14:08:27 <jcapitao[m]> #link https://review.opendev.org/c/openstack/releases/+/878731
14:08:29 <jcapitao[m]> the upstream patch is opened
14:08:40 <jcapitao[m]> once merged, our bot will submit the patches automatically
14:09:56 <jcapitao[m]> then we'll be able to promote the builds up to -release tag
14:10:19 <jcapitao[m]> then the content will be available in https://mirror.stream.centos.org/SIGs/9-stream/cloud/x86_64/
14:11:09 <jcapitao[m]> it reminds be that we need to edit https://review.rdoproject.org/etherpad/p/antelope-release-announcement
14:11:14 <jcapitao[m]> #link https://review.rdoproject.org/etherpad/p/antelope-release-announcement
14:15:02 <spotz_> Yeah there's a few things on the announcement, features, addressing the retirement of TripleO and then new and current contributors
14:16:30 <spotz_> I went through the release notes for a press release so have some points, not everyone had release notes those
14:17:34 <jcapitao[m]> ah good!
14:18:20 <jcapitao[m]> I think that's it for this topic
14:18:45 <spotz_> And I just added them to the etherpad so we can edit, delete, or add but have something to start with
14:18:49 <spotz_> yep
14:19:21 <rdogerrit> Merged rdo-website master: Point Cloud SIG meeting link to sigs.c.o/cloud  https://review.rdoproject.org/r/c/rdo-website/+/47872
14:19:37 <jcapitao[m]> I see them
14:20:04 <jcapitao[m]> let's move to the second and last topic of the agenda
14:20:17 <jcapitao[m]> #topic rdopkg RFE - should we output the repo provider ?
14:20:24 <jcapitao[m]> #link https://issues.redhat.com/browse/RDO-115
14:21:00 <jcapitao[m]> I opened this US in order to describe the RFE properly
14:22:34 <spotz_> I'm assuming you're leaning to the main solution and not the distrepos one?
14:23:29 <jcapitao[m]> yeah, but I prefer to get feedback before making the changes
14:24:15 <spotz_> I'm assuming more pros then cons of the other method?:)
14:24:51 <amoralej> what's repo provider ?
14:25:04 <jcapitao[m]> so when you have a chance, you can leave a comment on this US
14:25:05 <jcapitao[m]> it's low prio though
14:25:25 <amoralej> i'll check later, thanks jcapitao[m] for creating the ticket
14:27:22 <jcapitao[m]> spotz_: yeah actually those two attributes are bound, so it's arbitrary choice
14:27:27 <rdogerrit> Marios Andreou proposed rdo-jobs master: Adds network_isolation false for data-plane-adoption job  https://review.rdoproject.org/r/c/rdo-jobs/+/48023
14:28:34 <jcapitao[m]> amoralej: trunk or cloudsig as repo provider (maybe not the right terminology here)
14:28:37 <spotz_> Ok I'll let you all doing the work decide then if it's equal vs reminding to choose the better/easier method:)
14:29:24 <jcapitao[m]> yeah let's give some time :)
14:29:30 <jcapitao[m]> moving to next topic
14:29:44 <jcapitao[m]> #topic next chair
14:30:05 <jcapitao[m]> #action karolinku to chair next week
14:31:05 <jcapitao[m]> we've switched chairing today
14:31:28 <jcapitao[m]> #topic open floor
14:32:10 <spotz_> I'll be PTO next week!
14:32:27 <jcapitao[m]> me too ! :)
14:32:30 <spotz_> PTG is going on this week and so far all the sessions I've attended have been very productive
14:32:58 <amoralej> i can take it
14:33:08 <jcapitao[m]> is there some big news ?
14:33:11 <amoralej> mmm next week is easter
14:34:08 <jcapitao[m]> amoralej: karolinku will chair (we switch chairing today)
14:34:54 <amoralej> i just saw, sorry, i was reading bottom-up
14:34:55 <amoralej> :(
14:35:03 <spotz_> No real big news. Monday worked on the Diversity Survey and CoC revamp, then the TC/Leadership session. Yesterday went to the Nova Operators session and OopenStack-Ansible. Today planning on attending operator sessions
14:35:23 <spotz_> amoralej: I do the same thing when catching up:)
14:36:27 <jcapitao[m]> no worries !
14:37:06 <spotz_> The rest of the week for me will be TC sessions
14:37:29 <jcapitao[m]> okk
14:37:47 <jcapitao[m]> also, there is currently an effort to build OpenStack on Fedora
14:37:57 <jcapitao[m]> https://github.com/LecrisUT/Fedora-openstack
14:38:24 <jcapitao[m]> based on RDO distgit repos
14:39:02 <lecris[m]> Help is appreciated on that btw :D
14:39:29 <jcapitao[m]> yeah that's what I was about to say :)
14:39:40 <amoralej> lecris[m], i see you used rpm-master branch
14:40:01 <jcapitao[m]> I'll be on PTO next week, but I'll take a deeper look afterward
14:40:07 <amoralej> note that branch is ready for dlrn, so there is no version and release
14:40:27 <amoralej> i guess you want that, so i'd recomend to use antelope-rdo or zed-rdo branches
14:40:44 <jcapitao[m]> +1
14:40:50 <lecris[m]> Indeed, I am going through these and adding the version and release so that it will work in packit workflow
14:41:03 <lecris[m]> Also modernizing the spec files
14:42:05 <spotz_> I'm excited by the effort, let me know what I can do on the communication/community side of things. I'm also good at breaking things and documenting it:)
14:42:15 <jcapitao[m]> will packit replace the version in the spec file on-the-fly ?
14:44:51 <lecris[m]> Yes and maybe. If it is included in the upstream source, then it will automatically set to latest tagged version or git describe. In the dist-git method I am not sure, I am still trying to understand the workflow there.
14:45:51 <lecris[m]> For automation, including .packit.yaml and webhooks would be preferred, but there needs more development to hook it with launchpad, gitea and gerrit.
14:46:32 <jcapitao[m]> for sure
14:46:45 <amoralej> our specs in stable branches hast last tagged version on each upstream stable branch too, so that should lead you to same releases
14:47:57 <jcapitao[m]> yeah could be easier to use latest stable branch for bootstrap
14:48:20 <jcapitao[m]> I'll close the mtg but we can continue off-mtg
14:48:47 <lecris[m]> amoralej: Oh, it's replaced in `Version:`?
14:49:32 <lecris[m]> Although it doesn't make much difference since I still want to go through them one-by-one to modernize to use %pyproject_buildrequires for example
14:50:21 <jcapitao[m]> yeah in Version and Release to
14:50:21 <jcapitao[m]> too
14:50:22 <jcapitao[m]> #endmeeting