14:00:42 <jcapitao[m]> #startmeeting RDO meeting - 2023-04-19
14:00:42 <opendevmeet> Meeting started Wed Apr 19 14:00:42 2023 UTC and is due to finish in 60 minutes.  The chair is jcapitao[m]. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:42 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:42 <opendevmeet> The meeting name has been set to 'rdo_meeting___2023_04_19'
14:00:47 <jcapitao[m]> it's meeting time !
14:01:07 <rdogerrit> Merged openstack/ansible-collections-openstack-distgit wallaby-rdo: Explicitely require openstack-ansible-core in EL9  https://review.rdoproject.org/r/c/openstack/ansible-collections-openstack-distgit/+/48347
14:01:32 <jcapitao[m]> #topic Roll Call
14:02:17 <karolinku[m]> o/
14:02:44 <rdogerrit> Merged openstack/tripleo-validations-distgit wallaby-rdo: Revert "Removing check stage for the package build"  https://review.rdoproject.org/r/c/openstack/tripleo-validations-distgit/+/48059
14:02:47 <amoralej> o/
14:03:00 <jcapitao[m]> #chair karolinku amoralej
14:03:00 <opendevmeet> Warning: Nick not in channel: karolinku
14:03:00 <opendevmeet> Current chairs: amoralej jcapitao[m] karolinku
14:04:16 <spotz> o/
14:04:38 <jcapitao[m]> #chair spotz
14:04:38 <opendevmeet> Current chairs: amoralej jcapitao[m] karolinku spotz
14:07:17 <jcapitao[m]> let's start with first and unique topic of the agenda today
14:07:24 <jcapitao[m]> #topic Antelope release
14:07:43 <jcapitao[m]> #info Antelope was released on April 18
14:07:59 <jcapitao[m]> #link https://lists.rdoproject.org/archives/list/dev@lists.rdoproject.org/thread/JUWA4D6E3522AQQCPV46ZGXI5DFV3TDE/
14:08:10 <jcapitao[m]> #link https://lists.rdoproject.org/archives/list/dev@lists.rdoproject.org/thread/JUWA4D6E3522AQQCPV46ZGXI5DFV3TDE/
14:08:29 <spotz> We were one day off with the notice from the first RDO release 10 years ago!
14:09:17 <jcapitao[m]> happy birthday RDO !!
14:09:40 <amoralej> oh, nice!
14:10:03 <amoralej> how many releases ?
14:10:04 <spotz> I think we should be really proud of that! I'm tempted to talk to tiger about maybe doing a different image for the contributor SWAG
14:10:13 <spotz> First was grizzly
14:10:42 <spotz> give me a sec to count should be 20 I suspect
14:11:03 <jcapitao[m]> 21 releases if we count from g to a
14:11:09 <amoralej> our baby is growing... :)
14:11:12 <spotz> Yep 21 with Grizzly
14:12:16 <spotz> So let me talk to Tiger, besides not getting a food type storage item I haven't looked for the contributor SWAG yet
14:12:38 <spotz> I have started looking at Ducks for summit though:)
14:13:11 <jcapitao[m]> +1 for the custom image !
14:14:43 <spotz> I know Tiger is busy getting artwork done for RH Summit but I'll get this on his list to discuss when he's done with those
14:15:10 <amoralej> nice
14:15:14 <jcapitao[m]> ok
14:15:34 <amoralej> it'd be cool to get a 10th aniversary special edition
14:17:01 <spotz> I wish I would have known about the 20 releases too. Thanks to apevec we know about the first release date though:)
14:17:29 <amoralej> :)
14:17:46 <amoralej> i guess he was already around
14:20:13 <spotz> hehe
14:20:14 <jcapitao[m]> I think that's all for this topic
14:20:32 <spotz> Ok I did drop Tiger an email to think on it but that we'd wait for him to be free
14:20:35 <spotz> Yep
14:20:37 <rdogerrit> Merged openstack/tripleoclient-distgit wallaby-rdo: Revert "Ignore unit tests when building tripleoclient"  https://review.rdoproject.org/r/c/openstack/tripleoclient-distgit/+/48061
14:20:39 <jcapitao[m]> I'll take care of the tempest unpinning after the mtg
14:21:03 <jcapitao[m]> thanks
14:21:15 <jcapitao[m]> #topic Next Chair
14:21:25 <jcapitao[m]> who's willing to chair next week ?
14:22:16 <karolinku[m]> I can take it
14:23:01 <spotz> Thanks karolinku[m]
14:23:57 <jcapitao[m]> #action karolinku will chair next week
14:24:00 <jcapitao[m]> thank you
14:24:10 <jcapitao[m]> #topic open floor
14:26:32 <amoralej> fyi, i sent a patch to support cloudsig repo in osa
14:26:57 <amoralej> https://review.opendev.org/c/openstack/openstack-ansible-openstack_hosts/+/880473
14:27:05 <amoralej> i still need to fix it
14:27:13 <amoralej> but i hope to get it working
14:27:17 <spotz> Nice, I saw noonedeadpunk had -1, I'll peek as well once any concerns are resolved
14:28:55 <amoralej> yep, i just was side tracked
14:28:59 <amoralej> but i'll retake it
14:32:06 <jcapitao[m]> amoralej: so osa is supporting RDO with the Trunk repos currently ?
14:32:29 <amoralej> yes
14:32:45 <amoralej> osa supports both source and distro installation
14:33:02 <amoralej> when working in distro, they use trunk in ci at least
14:33:13 <jcapitao[m]> okk
14:33:21 <amoralej> actually, current default when you use centos9 + distro is trunk zed
14:34:53 <apevec> oog so we could add OSA to our release criteria!
14:35:05 <apevec> s/oog/ooh/
14:35:37 <apevec> I thought they dropped installing from distro pkgs completely
14:35:55 <amoralej> i'd like to be able to run osa ci jobs
14:36:01 <amoralej> apevec, nop, kolla dropped it
14:36:09 <amoralej> but not osa
14:36:25 <apevec> heh I mix the two
14:36:35 <amoralej> although source installation support is more widely supported and tested
14:37:21 <spotz> I think this is good for us if we can get it working
14:37:38 <amoralej> yeah
14:37:47 <amoralej> we will :)
14:38:02 <jcapitao[m]> :D
14:38:12 <apevec> <amoralej> "i guess he was already around" <- FTR I indeed was, even pre-RDO when we were building in EPEL
14:39:13 <amoralej> wow :)
14:39:17 <apevec> it was Portland Summit where we formally announced RDO as a project
14:40:00 <spotz> We missed doing something special for the 20th release but I'll try to get something for 10th birthday!
14:40:43 <noonedeadpunk> apevec: well, we were thinking about it, but I standed ground that it's good to have distro option:)
14:41:22 <noonedeadpunk> though we defenitely don't have much deployments with distro at the moment, and not much interested parties to get this path evolved.
14:41:36 <noonedeadpunk> Only limited amount of services are currently supported.
14:44:21 <noonedeadpunk> but at very least base services are covered and it's quite straightforward to enroll more services if needed
14:47:03 <amoralej> my position is that, if osa decides to support distro packages with RDO, i'd like to make sure it works as smooth as possible and in the opposite way, testing osa is a good way to validate distro packages works as expected
14:47:34 <amoralej> i see the value of using distro packages vs source, but or course, i'm a distro maintainer :)
14:48:33 <spotz> hehe
14:48:47 <noonedeadpunk> I'd like ppl to be able to choose between opionated methods :D
14:48:50 <amoralej> and i understand supporting two deployment models has bigger effort that maintaining one
14:49:30 <noonedeadpunk> And it could be as simple as non-default is less popular as always
14:49:40 <amoralej> yeah, sure
14:50:08 <noonedeadpunk> It actually doesn't cost as lot lately, was slightly more turbulent with py2/py3 stuff, but it's not the case anymore
14:50:10 <amoralej> i agree, giving multiple options is always good
14:52:56 <noonedeadpunk> One thing I'd love to raise though more with TC hat on, and that is release naming. As since Antelope OpenStack tries to use date-released versions as main identifier (ie 2023.1 for Antelope, 2023.2 for Bobcat). Thus, all branches are named stable/2023.1 etc.
14:53:53 <spotz> I know we did call it 2023.1 Antelope in the release at least once:)
14:54:26 <amoralej> yep, for the official name i think we should stick to both
14:54:29 <noonedeadpunk> well, repos/packages are called antelope from what I got from your email?
14:54:34 <amoralej> as in https://releases.openstack.org/
14:54:46 <amoralej> wrt repo
14:55:23 <noonedeadpunk> sec, I will find document :)
14:55:26 <amoralej> actually, we used name probably because of habit,
14:55:40 <amoralej> but also, note the deliverables directory is using antelope upstream
14:55:46 <amoralej> https://github.com/openstack/releases/tree/master/deliverables
14:55:52 <amoralej> so i understand both are used
14:56:42 <noonedeadpunk> https://governance.openstack.org/tc/reference/release-naming.html
14:57:30 <amoralej> so, your proposal is to use only date based release for repo names?
14:57:40 <amoralej> and centos-release-openstack-<release> ?
14:57:45 <noonedeadpunk> so release names are more marketing/transition thing that will go away in the future
14:58:05 <spotz> I doubt they're going away but go on:)
14:58:50 <noonedeadpunk> actually yes. I've raised topic for TC discussion for the next week regarding this topic.
14:59:02 <jcapitao[m]> I'll close the mtg notes but we can follow the discussion
14:59:06 <jcapitao[m]> #endmeeting