14:02:57 <karolinku[m]> #startmeeting RDO meeting - 2023-04-26
14:02:57 <opendevmeet> Meeting started Wed Apr 26 14:02:57 2023 UTC and is due to finish in 60 minutes.  The chair is karolinku[m]. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:57 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:57 <opendevmeet> The meeting name has been set to 'rdo_meeting___2023_04_26'
14:03:07 <karolinku[m]> #topic roll call
14:03:14 <amoralej> i just added a topic
14:03:20 <karolinku[m]> #chair spotz amoralej
14:03:20 <opendevmeet> Current chairs: amoralej karolinku[m] spotz
14:03:53 <karolinku[m]> #topic Progress on pyproject macros adoption
14:04:34 <amoralej> #link https://review.rdoproject.org/etherpad/p/pyproject-macros
14:04:55 <amoralej> last days i've been playing with new set of macros, including fully automated requires and buildrequires
14:05:06 <amoralej> i've added comments in that etherpad
14:05:14 <spotz_> o/ to be official
14:05:33 <amoralej> i still need to work a bit more on that but, my initial findings are
14:06:25 <amoralej> #info not found any big blocker which prevents us of moving to pyproject macros and fully automated req and brs
14:06:34 <amoralej> so, i think it's feaseable
14:07:08 <amoralej> #info some part of the switch can be scripted but it will need careful package-by-package work
14:07:33 <amoralej> so, the effort to do it will be important, i still need to estimate the effort to do it
14:08:11 <amoralej> i think it can help us in the long term as it will ease spec maintenance
14:08:34 <amoralej> i.e. we will not need our massive reqcheck once per release \o/
14:08:54 <amoralej> actually rdopkg reqcheck wouldn't make sense anymore if we automate requires
14:09:10 <karolinku[m]> that would be amazing
14:09:24 <amoralej> yep
14:09:48 <amoralej> also, when a new dep is added upstream, it will be automatically in rdo too
14:10:06 <amoralej> the cost of that is, we may get some unneeded deps
14:10:40 <spotz_> WIll python 3.8 vs 3.9 affect any of this? Apparently that was why the gates have been broken lately
14:11:00 <amoralej> spotz_, nop, actually we are full 3.9 now
14:11:09 <amoralej> i saw some updates were reverted
14:11:30 <spotz_> Ok, yeah TC channel had a meeting before the meeting trying to sort it out
14:11:36 <spotz_> yesterday
14:11:37 <amoralej> i think i merged the revert in rdo too to follow u-c
14:11:46 <amoralej> although we are not affected by the issue
14:12:14 <amoralej> yeah https://review.rdoproject.org/r/c/rdoinfo/+/48369
14:12:16 <spotz_> Ok just checking
14:12:48 <amoralej> https://review.rdoproject.org/r/c/rdoinfo/+/48369/comments/840e4ab5_e796395a
14:12:52 <amoralej> it's tooz
14:13:30 <amoralej> so, feel free to review the etherpad and provide feedback
14:13:38 <amoralej> we will continue discussing the topic next weeks
14:13:56 <amoralej> but i'd like to make a decission of moving/not-moving during bobcat cycle soon
14:14:00 <amoralej> so that we have time
14:14:27 <spotz_> I'm not seeing a reason not to but yeah let's getting input from everyone
14:15:23 <amoralej> the main is consider if the effort is worthy, it will be important effort
14:15:34 <amoralej> and at the end, we have working packages
14:16:14 <amoralej> and explicit requires (vs automatic) is good from a requirements explicit control pov
14:16:28 <amoralej> but yeah, i'd be on favor of going for it
14:17:06 <amoralej> i've created also a job that may help us in the transition to identify if the switch is introducing or missing dependencies on each review
14:17:08 <amoralej> https://review.rdoproject.org/r/c/rdo-jobs/+/48365
14:17:22 <amoralej> that would compare deps pre-patch and post-patch
14:21:30 <amoralej> i think taht's it about the topic
14:21:45 <karolinku[m]> ok
14:22:30 <karolinku[m]> #info decision about moving will be probably done in bobcat cycle
14:22:55 <karolinku[m]> no other topics on agenda, so
14:23:00 <karolinku[m]> #topic Next chair
14:24:15 <karolinku[m]> who would like to chair next week? I'll be out
14:24:27 <spotz_> I have a training class so will most likely miss next week
14:25:09 <spotz_> It's the video call, if we need to skip that's fine but we should note it in the email with today's log
14:25:42 <amoralej> i can take it
14:26:02 <spotz_> Thanks amoralej
14:26:11 <karolinku[m]> #action amoralej is chairing mtg next week
14:26:29 <karolinku[m]> #topic Open Floor
14:26:44 <spotz_> I have the agenda section for next week up already:)
14:27:02 <amoralej> cool
14:30:52 <karolinku[m]> are we ready to close the mtg?\
14:31:27 <spotz_> I think so
14:32:05 <amoralej> yep
14:32:10 <amoralej> nothing else from my side
14:32:38 <karolinku[m]> #endmeeting