14:00:40 <amoralej> #startmeeting RDO meeting - 2023-05-24
14:00:40 <opendevmeet> Meeting started Wed May 24 14:00:40 2023 UTC and is due to finish in 60 minutes.  The chair is amoralej. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:40 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:40 <opendevmeet> The meeting name has been set to 'rdo_meeting___2023_05_24'
14:00:47 <amoralej> #topic rollcall
14:01:15 <karolinku[m]> o/
14:01:29 <amoralej> #chair karolinku[m]
14:01:29 <opendevmeet> Current chairs: amoralej karolinku[m]
14:01:53 <jcapitao[m]> o/
14:02:47 <amoralej> #chair jcapitao[m]
14:02:47 <opendevmeet> Current chairs: amoralej jcapitao[m] karolinku[m]
14:04:21 <amoralej> spotz_, are you around?
14:04:30 <spotz_> o/
14:04:32 <spotz_> :)
14:04:39 <amoralej> #chair spotz_
14:04:39 <opendevmeet> Current chairs: amoralej jcapitao[m] karolinku[m] spotz_
14:04:40 <amoralej> :)
14:04:48 <spotz_> I'm either early or late if I'm not chairing:)
14:04:54 <amoralej> :)
14:05:08 <amoralej> first topic is yours
14:05:17 <amoralej> #topic Summits update
14:06:11 <spotz_> So RH Summit is taking place this week. There is no one there from RDO but the CNCF area of Community Central is handing out some new RDO hex stickers featuring Spenser
14:07:31 <spotz_> For OpenInfra Summit we will have a duck in a kayak as the area is known for kayaking. We'll have our normal stickers and any left over hex stickers from RH SUmmit. I've only seen the proof so kind of excited to see how they came out
14:09:31 <spotz_> I am working through some issues to have an Ice Cream social about a 15 minute walk distance from the conference center on Wednesday night 6:30-7:30 or 8:00. On Thursday night we'll have a contributor dinner. I know it's not ideal as folks may have already left but it's a short summit so it's the best I could do in regards to having something larger.
14:11:17 <amoralej> you know if sessions of summit are streamed online?
14:11:18 <spotz_> Kinda Summit related, I know Tiger has been swamped doing artwork for RH Summit, but IF he gets the new 10yr anniversary Antelope artwork to me in time I might see if we can quickly remove the release name and make a quick run of 10yr Anniversary stickers.
14:11:42 <spotz_> I don't think there will be livestreaming but many will be recorded
14:12:16 <amoralej> ok, yep, we can see them later in youtube channel i guess
14:12:55 <spotz_> There will be 1 or 2 rooms with streaming capability for use during the PTG to include remote participants but those cane only be booked for shorter time frames. Though I doubt anyone is looking to book a room for the entire day as the summit and forum will also be taking place
14:13:11 <amoralej> the agenda is published if anyone wants to look for interesting talks https://vancouver2023.openinfra.dev/a/schedule
14:14:06 <spotz_> That is still missing the extended Forum sessions for Thursday but otherwise I believe is complete
14:15:14 <spotz_> Any other questions about Summit? I do one add one thing about Antelope contributor SWAG as I did mention the artwork I'm waiting on
14:15:32 <spotz_> I do want to add.. I can't type this morning:)
14:15:52 <amoralej> too early :)
14:15:57 <spotz_> hehe
14:16:30 <amoralej> no mmore questions from me
14:16:50 <jcapitao[m]> nor from me thank youu
14:16:56 <spotz_> Ok for the Antelope Contributor item I a looking at getting backpacks. I know we had the gym bahs for Yoga so it might be a bit close for another bag, but I figured it would be a nice anniversary item
14:17:27 <amoralej> +1
14:18:38 <jcapitao[m]> sweet
14:19:25 <spotz_> So that's where we're at, I've seen a few I like within our budget but I need the new artwork before going forward with seeing what's really available in the numbers we'd need
14:19:50 <spotz_> That's it from me
14:20:24 <amoralej> thanks spotz_
14:20:50 <amoralej> #topic TripleO removal in RDO Trunk Master
14:21:22 <amoralej> tripleo is officially deprecated now upstream so i think it's time to remove it from RDO Trunk Master
14:21:48 <amoralej> as discussed with TripleO CI team, all the periodic pipelines have been removed from zed and master
14:22:05 <amoralej> and no more reviews should be sent to master branches
14:22:28 <amoralej> so i think we are on time to announce the removal and do it during next week
14:23:40 <jcapitao[m]> okk
14:24:03 <jcapitao[m]> we can point to the tripleo thread in openstack-discuss ML
14:24:51 <amoralej> #info tripleo is officially deprecated upstream, and pipelines removed
14:24:56 <amoralej> #link https://lists.openstack.org/pipermail/openstack-discuss/2023-March/033080.html
14:25:26 <amoralej> #link https://review.opendev.org/c/openstack/governance/+/877132
14:26:15 <amoralej> #info tripleo packages will be removed from RDO Trunk Master repo during the next week
14:26:38 <amoralej> for removal we should follow the same process we follow for Antelope
14:26:46 <amoralej> so i expect it will be smooth
14:27:31 <jcapitao[m]> the process you mention the other day ?
14:28:04 <jcapitao[m]> 1. remove tripleo jobs from master -> 2. remove packages from RDO -> 3. remove code upstream
14:28:05 <amoralej> i don't remember what i mentioned the other day ... :(
14:28:13 <jcapitao[m]> :D
14:28:45 <amoralej> mostly a backport of https://review.rdoproject.org/r/c/rdoinfo/+/47883 for bobcat anc bobcat-uc
14:29:36 <jcapitao[m]> ah yes it's part of 2.
14:30:02 <jcapitao[m]> but before we need to remove the tripleo jobs
14:30:11 <amoralej> i think we already did
14:30:27 <amoralej> iirc karolinku[m] removed the tripleo jobs, at least execution
14:30:36 <amoralej> but i'd say even job definitions ...
14:30:42 <amoralej> are we still running any tripleo job?
14:31:15 <karolinku[m]> I don't remember. I remember leaving master job declarations
14:31:51 <amoralej> mmm i remember you were reparenting jobs, wasn't that to remove the master ones? i'm not sure
14:32:17 <amoralej> https://review.rdoproject.org/r/c/rdo-jobs/+/47959
14:33:09 <amoralej> https://review.rdoproject.org/r/c/rdo-jobs/+/47959/12/zuul.d/rdoinfo-jobs.yaml
14:33:46 <amoralej> i'd say we are good
14:33:58 <amoralej> but anyway, good to double check
14:34:16 <jcapitao[m]> yeah, sorry I'm not sure
14:34:37 <jcapitao[m]> there were https://review.opendev.org/c/openstack/os-net-config
14:34:59 <jcapitao[m]> but not RDO zuul jobs
14:35:03 <amoralej> https://review.rdoproject.org/r/q/topic:tripleo_jobs_cleanup that's we cleaned
14:35:11 <amoralej> ah, but that's upstream, right
14:35:50 <amoralej> actually, apparently they will not remove those jobs quickly, simply there will be no new reviews in master branches iiuc
14:36:10 <amoralej> will remove master branches but not very soon, i'd say
14:36:19 <amoralej> anyway, that's upstream
14:36:24 <jcapitao[m]> okk
14:37:33 <amoralej> for zed, i'd say to maintain the packages while we can
14:38:10 <amoralej> so for ftbfs as https://review.rdoproject.org/r/c/openstack/tripleo-ipa-distgit/+/48668/ , let's pin to latest commit
14:38:11 <jcapitao[m]> until it starts to fail ?
14:38:36 <amoralej> while practical, i'd say :)
14:38:51 <amoralej> i don't expect many issues from packaging side
14:39:03 <jcapitao[m]> yeah that's a good trade-off I'd say
14:40:50 <amoralej> so, that's it wrt this topic, i think
14:44:09 <amoralej> #topic open floor
14:44:20 <amoralej> someone to chair next week?
14:44:30 <jcapitao[m]> I can take it
14:44:31 <karolinku[m]> I can take it
14:44:52 <amoralej> uh just one second :)
14:44:57 <spotz_> Thanks jcapitao[m] and karolinku[m]:)
14:45:07 <amoralej> first wins? :)
14:45:24 <spotz_> Yep:)
14:45:30 <jcapitao[m]> :D
14:45:35 <jcapitao[m]> I can take the next one though
14:45:38 <amoralej> #action jcapitao will chair next week
14:46:09 <amoralej> any other topic you'd like to share?
14:46:21 <karolinku[m]> I have one wrt last documentation
14:46:41 <amoralej> ok, stage is yours
14:46:43 <karolinku[m]> https://review.rdoproject.org/r/c/rdo-website/+/48604
14:47:06 <karolinku[m]> amoralej suggested to intergrate it into the chapter about repositories
14:47:15 <karolinku[m]> lemme find the link
14:47:27 <amoralej> right https://www.rdoproject.org/what/repos/
14:48:14 <amoralej> or integrate this into yours, i'd like to have a single page with the info about repos
14:49:10 <karolinku[m]> so, I wanted to ask if that idea is ok for you, folks?
14:51:31 <spotz_> Shoot lost where I opened the first link hang on:)
14:53:47 <jcapitao[m]> I like the single-page organization as well
14:53:51 <spotz_> They both deal with repos to some extent but the new doc is more of an indepth lead in. What about crosslinking between the 2? But leaving the main link where karolinku[m] put it?
14:54:21 <spotz_> Making them 1 isn't a bad idea, but we might lose people just looking for how to set up a repo
14:55:11 <amoralej> ok, works for me
14:57:17 <amoralej> may you add a link into your doc pointing to the old doc?
14:57:33 <jcapitao[m]> it's subjective I'd say, I like single page with html anchors
14:57:53 <jcapitao[m]> but it can be to much monolithic
14:58:06 <jcapitao[m]> and not straigthforward
14:58:45 <karolinku[m]> I like idea of just having links to other topic
14:58:46 <amoralej> yeah, both can work
14:58:56 <karolinku[m]> because if fact they are covering stuff on different levels
14:59:46 <karolinku[m]> so, are we agree to just add link to docs about repo?
14:59:57 <spotz_> It's kind of why folks put a TLDR on top but in this case the longer info would be at the start:)
15:00:11 <jcapitao[m]> works for me too
15:00:38 <spotz_> yeah
15:01:09 <amoralej> +1 to just add a a link
15:01:10 <karolinku[m]> and longer documet discourage people from reading ;D
15:01:38 <spotz_> Yep
15:01:54 <amoralej> my point is that, it'd be good that users know what they are using before start using it
15:02:15 <amoralej> and not blindly enable the first repo which is in the doc :)
15:03:09 <amoralej> but i also see your point
15:05:05 <spotz_> Trust me most would just skim through it too to get going:)
15:05:56 <amoralej> :D
15:06:07 <jcapitao[m]> xD
15:06:20 <amoralej> let's just add a link
15:06:29 <amoralej> buuut... could it be at the beginning ?
15:06:32 <amoralej> :)
15:06:54 <amoralej> you can find more details about the different RDO repos in bla bla bla
15:07:01 <spotz_> In proper rder of learning the new stuff should be first
15:07:06 <spotz_> order of...
15:09:41 <amoralej> so, that's it?
15:09:57 <amoralej> we are 9 minutes out of time
15:11:24 <amoralej> karolinku[m], so i think we have the way to go, right?
15:12:53 <karolinku[m]> yes
15:13:06 <amoralej> ok, then i'm closing the meeting
15:13:08 <karolinku[m]> all from me
15:13:14 <amoralej> thanks all for joining!
15:13:23 <jcapitao[m]> thanks amoralej
15:13:31 <amoralej> #endmeeting