14:01:07 <karolinku[m]> #startmeeting RDO meeting - 2023-06-14
14:01:07 <opendevmeet> Meeting started Wed Jun 14 14:01:07 2023 UTC and is due to finish in 60 minutes.  The chair is karolinku[m]. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:07 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:07 <opendevmeet> The meeting name has been set to 'rdo_meeting___2023_06_14'
14:01:24 <amoralej> o/
14:01:40 <karolinku[m]> # topic roll call
14:01:54 <karolinku[m]> #topic roll call
14:02:08 <karolinku[m]> #chair amoralej
14:02:08 <opendevmeet> Current chairs: amoralej karolinku[m]
14:02:15 <jcapitao[m]> o/
14:02:28 <karolinku[m]> #chair jcapitao
14:02:28 <opendevmeet> Warning: Nick not in channel: jcapitao
14:02:28 <opendevmeet> Current chairs: amoralej jcapitao karolinku[m]
14:03:43 <evallesp_> #chair evallesp
14:03:48 <evallesp_> #chair evallesp_
14:04:49 <karolinku[m]> hello evallesp_!
14:04:58 <karolinku[m]> #chair evallesp_
14:04:58 <opendevmeet> Warning: Nick not in channel: evallesp_
14:04:58 <opendevmeet> Current chairs: amoralej evallesp_ jcapitao karolinku[m]
14:05:22 <evallesp> I had two sessions, please try without the "_"
14:05:52 <karolinku[m]> #chair jcapitao[m] evallesp
14:05:52 <opendevmeet> Current chairs: amoralej evallesp evallesp_ jcapitao jcapitao[m] karolinku[m]
14:07:21 <karolinku[m]> ok, lets move to first topic
14:07:46 <karolinku[m]> #topic spec upgrade script - update
14:08:03 <karolinku[m]> #link https://review.rdoproject.org/r/c/rdo-infra/releng/+/48871
14:08:37 <karolinku[m]> so, the scirpt needs some minor adjustments, but main func are implemented, its ready for a review
14:08:45 <amoralej> good
14:09:11 <amoralej> i'll check, there is some regex black magic that i need to check :)
14:09:39 <karolinku[m]> maybe I should provide some comments for that
14:09:45 <karolinku[m]> I will add it
14:10:16 <jcapitao[m]> thanks
14:10:32 <jcapitao[m]> so we can start to the migration ?
14:11:15 <amoralej> i also think we can add some more automate replacements as for replacing sphinx-build or stestr by macros as in https://review.rdoproject.org/r/c/openstack/glance-distgit/+/46574/4/openstack-glance.spec
14:11:31 <amoralej> i'll comment in the script
14:11:57 <karolinku[m]> what needs to me worked in the scirpt: fixing %files and %check
14:12:03 <rdogerrit> Alfredo Moralejo proposed rdo-jobs master: Create two non-voting jobs to compare requires and BRs from latest trunk  https://review.rdoproject.org/r/c/rdo-jobs/+/48365
14:12:30 <jcapitao[m]> ah yes sorry
14:13:19 <karolinku[m]> I will work on it more tomorrow, then on Friday and Monday im on DevConf
14:13:35 <amoralej> karolinku[m], do you mind if we take it over during those days?
14:14:19 <amoralej> i mean, on friday and monday
14:14:21 <jcapitao[m]> I was wondering whether or not we should list the files (i.e rpm -qlp) at the end of your jobs amoralej
14:14:22 <amoralej> if needed
14:14:31 <amoralej> mmmm
14:14:49 <amoralej> so comparing list of files, right?
14:15:03 <jcapitao[m]> I usually do it when migrating Fedora openstack-sig pkgs SPECs
14:15:16 <amoralej> similar to compare-deps you mean?
14:15:22 <jcapitao[m]> yes
14:15:34 <amoralej> ok, lgtm
14:15:44 <amoralej> will you create a new job for it ?
14:15:57 <jcapitao[m]> to ensure we don't miss nothing or to spot suspicious changes
14:15:59 <amoralej> or prefer to do it as part of one of the new compare ones?
14:16:56 <jcapitao[m]> mmmh maybe as part of one of them
14:17:38 <amoralej> if we do it as part of one of them, we need to make very clear why the job fails
14:18:20 <jcapitao[m]> right
14:18:24 <jcapitao[m]> so another job then
14:18:25 <amoralej> so, you can send a patch on top of https://review.rdoproject.org/r/c/rdo-jobs/+/48365 adding or modifying
14:18:48 <jcapitao[m]> ok I'll propose PS
14:18:49 <amoralej> tbh, i'm not sure, from one side, a new job means building the package again...
14:19:05 <amoralej> jcapitao[m], no, let's keep it in a separated review
14:19:08 <amoralej> not a new PS
14:19:11 <karolinku[m]> #topic jobs to compare requires and BRs from latest trunk
14:19:25 <jcapitao[m]> ah sorry
14:19:30 <jcapitao[m]> yes on top of your patch
14:19:31 <amoralej> so it's easier to review
14:19:35 <jcapitao[m]> ok
14:19:35 <jcapitao[m]> yeah
14:19:52 <karolinku[m]> #link  https://review.rdoproject.org/r/c/rdo-jobs/+/48365
14:20:13 <amoralej> i've prepared a new etherpad for coordination once we start implementing it btw https://review.rdoproject.org/etherpad/p/pyproject-macros-coordination
14:20:41 <karolinku[m]> sorry, any action planned wrt CI jobs?
14:21:43 <amoralej> jcapitao[m] will implement file list comparison for rpms before and after the patch in a ci job
14:22:49 <karolinku[m]> #action jcapitao[m] will implement file list comparison for rpms before and after the patch in a ci job
14:24:22 <jcapitao[m]> ack for the etherpad
14:24:59 <jcapitao[m]> could we give priority on client ?
14:25:38 <jcapitao[m]> as I'll have to build them on EPEL9 soon
14:26:16 <amoralej> ok
14:26:39 <amoralej> but note these specs are for bobcat so we will not update fedora specs up to bobcat GA
14:26:52 <amoralej> or you planned to push it before that?
14:29:20 <jcapitao[m]> I think I will have to sync before bobcat GA, to avoid doing twice the job (i.e rebasing patch)
14:29:29 <jcapitao[m]> but not sure yet
14:29:52 <jcapitao[m]> it depends on how fast the required dep lands on EPEL9
14:30:06 <jcapitao[m]> so no worries for now
14:31:07 <amoralej> but we can't backport this to antelope
14:31:18 <amoralej> i mean, we shouldn't
14:33:19 <jcapitao[m]> mmh
14:33:39 <jcapitao[m]> you mean antelope version of clients in Fedora ?
14:34:31 <amoralej> yes
14:34:51 <amoralej> so, what i mean is that, if we want these patches to be pushed to fedora
14:35:15 <amoralej> we usually sync from last released branches in RDO
14:35:17 <jcapitao[m]> ah
14:35:20 <jcapitao[m]> why shouldn't we ?
14:35:48 <jcapitao[m]> yes
14:36:14 <amoralej> actually, the idea of moving pyproject to bobcat was to not affect antelope, i'd say this is a too big change to do post-ga
14:36:46 <amoralej> stable branches should be stable :)
14:37:20 <jcapitao[m]> right
14:37:47 <jcapitao[m]> let's not overcomplicate the sync process
14:38:19 <jcapitao[m]> I'll wait for bobcat GA to use pyproject macros on EPEL ;)
14:38:57 <amoralej> the other option would be to backport this change to antelope versions in fedora only, not rdo
14:39:08 <amoralej> but i don't know if that's worthy tbh
14:39:34 <amoralej> as you said, that'd complicate the sync process
14:40:17 <jcapitao[m]> no let's not do it, we have other more important tasks
14:40:36 <amoralej> we can figure out as we go, anyway
14:42:25 <jcapitao[m]> right, it'll be a long run :)
14:44:10 <amoralej> 236 packages long :)
14:44:29 <karolinku[m]> 236/3
14:44:31 <amoralej> anyway i think we should prioritize libs and clients
14:44:37 <amoralej> yep :)
14:44:49 <ncuxo> is there a production deployment documentation for rdo for openstack antilope
14:46:00 <amoralej> ncuxo, unfortunately not
14:46:34 <ncuxo> so rdo is not meant for production use?
14:48:05 <amoralej> ncuxo, we are in a meeting now, would you mind to continue this discussion a bit later ?
14:48:14 <ncuxo> sure
14:48:17 <amoralej> thanks
14:50:24 <amoralej> so, are we done with this topic?
14:50:24 <karolinku[m]> #topic openfloor
14:50:49 <jcapitao[m]> I think so
14:51:02 <amoralej> evallesp, may we merge https://softwarefactory-project.io/r/c/DLRN/+/28584 ? we need it for the new jobs for pyproject macros
14:51:14 <evallesp> I think so
14:51:30 <evallesp> does it make sense to merge it right now?
14:51:52 <evallesp> merging
14:52:23 <amoralej> yes, i think it shouldn't hurt
14:52:47 <amoralej> i hope i will not break your other reviews :)
14:52:54 <jcapitao[m]> 👍️
14:53:00 <evallesp> :)
14:53:31 <jcapitao[m]> :D
14:53:39 <jcapitao[m]> speaking of breaking CI
14:53:40 <jcapitao[m]> https://softwarefactory-project.io/r/c/software-factory/sf-infra/+/28587
14:54:19 <amoralej> \o/
14:54:25 <jcapitao[m]> it's merged, if you notice something suspect on CI
14:54:48 <amoralej> i'll send a patch to upstream devstack to remove my workaround of wget+rpm
14:55:00 <amoralej> the change is applied now?
14:56:08 <jcapitao[m]> yes I checked
14:56:22 <amoralej> nice
14:56:35 <jcapitao[m]> where are the FIPS enabled jobs ?
14:56:56 <amoralej> there are fips enabled job in neutron and in tripleo
14:57:18 <amoralej> in neutron it uses devstack and it's in experimental and periodic pipelines
14:57:25 <amoralej> i'll test it with experimental
14:57:50 <jcapitao[m]> okk
14:58:16 <jcapitao[m]> could you point to me the link after rechecking the job please ?
14:59:29 <amoralej> sure
14:59:57 <jcapitao[m]> thanks
15:00:22 <jcapitao[m]> just last topic to bring
15:00:27 <jcapitao[m]> I just remembered sorry
15:00:36 <jcapitao[m]> Fedora is rebuilding on py3.12
15:00:46 <jcapitao[m]> they want to ship f39 with py3.12
15:01:37 <amoralej> do we have ftbfs issues?
15:01:41 <jcapitao[m]> if we spot failures during the rebuild, we'll have to propose changes upstream
15:01:46 <jcapitao[m]> not yet
15:01:54 <amoralej> wrt fips https://review.opendev.org/c/openstack/neutron/+/884279 is the dnm review we used to test devstack last time
15:02:09 <amoralej> neutron-ovs-tempest-fips job is centos
15:02:23 * amoralej crosses fingers for 3.12
15:02:33 <jcapitao[m]> thanks
15:02:46 <jcapitao[m]> yeah hopefully
15:03:04 <amoralej> i've seen some packages already reported successful builds, let's see
15:03:37 <jcapitao[m]> yup
15:03:44 <jcapitao[m]> that's it from me
15:07:37 <amoralej> nothing else from my side
15:08:20 <karolinku[m]> sorry, we are ahaead of time
15:08:23 <karolinku[m]> last thing
15:08:27 <karolinku[m]> #topic next chair
15:08:41 <jcapitao[m]> I can take it
15:08:59 <karolinku[m]> #action jcapitao[m] is chairing next week
15:09:05 <karolinku[m]> #endmeeting