14:00:12 <jcapitao[m]> #startmeeting RDO meeting - 2023-06-21
14:00:12 <opendevmeet> Meeting started Wed Jun 21 14:00:12 2023 UTC and is due to finish in 60 minutes.  The chair is jcapitao[m]. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:12 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:12 <opendevmeet> The meeting name has been set to 'rdo_meeting___2023_06_21'
14:00:34 <jcapitao[m]> #topic roll call
14:00:42 <karolinku[m]> o/
14:01:03 <amoralej> o/
14:02:55 <jcapitao[m]> #chair karolinku[m] amoralej
14:02:55 <opendevmeet> Current chairs: amoralej jcapitao[m] karolinku[m]
14:05:54 <jcapitao[m]> spotz_ may join later as she's got a conflict
14:06:02 <jcapitao[m]> let's start with first topic
14:06:11 <jcapitao[m]> #topic CloudSIG testing repo are GPG signed
14:06:33 <jcapitao[m]> #info CloudSIG packages from testing repo are GPG signed
14:06:40 <jcapitao[m]> #link https://pagure.io/centos-infra/issue/1174
14:07:02 <jcapitao[m]> #link https://pagure.io/centos-infra/issue/1174
14:07:11 <jcapitao[m]> #link https://lists.rdoproject.org/archives/list/dev@lists.rdoproject.org/thread/ZBOSCEMQ55OKBY7K4Q233MWO73APF5DF/
14:07:22 <jcapitao[m]> #link https://review.rdoproject.org/r/q/topic:test-signed-packages-from-testing
14:07:52 <jcapitao[m]> I tested them with the reviews ^
14:08:53 <jcapitao[m]> the question now is do we want to enable gpgcheck by default for testing repo ?
14:09:16 <amoralej> you mean in rdo-release and centos-release-openstack- packages?
14:09:47 <jcapitao[m]> in centos-release-openstack-* packages sorry
14:10:24 <jcapitao[m]> I'm in favor to let as-is
14:10:56 <amoralej> i think enabling it is good
14:12:14 <amoralej> we had issues with signed packages in testing repo some days ago but i think it's fixed
14:12:32 <amoralej> so given that we have the option, we should enable it imo
14:12:41 <spotz_> o/
14:14:04 <jcapitao[m]> ok makes sense
14:14:20 <jcapitao[m]> karolinku: do you have an opinion ?
14:15:04 <karolinku[m]> +1 for enabling
14:16:11 <jcapitao[m]> ok let's enable it then
14:17:01 <jcapitao[m]> #agreed to enable gpgcheck on testing repo for centos-release-openstack-* packages
14:17:17 <jcapitao[m]> #chair spotz_
14:17:17 <opendevmeet> Current chairs: amoralej jcapitao[m] karolinku[m] spotz_
14:17:46 <jcapitao[m]> welcome back spotz_ :)
14:17:56 <spotz_> Thanks:)
14:18:34 <jcapitao[m]> #action jcapitao to enable gpgcheck on testing repo for centos-release-openstack-* packages
14:19:27 <jcapitao[m]> I think that's it for this topic, any questions ?
14:20:18 <amoralej> nop from my side
14:20:48 <spotz_> nope
14:21:04 <karolinku[m]> no
14:22:02 <jcapitao[m]> let's move to the next topic
14:22:13 <jcapitao[m]> #topic Status on specs modernization (pyproject-rpm-macros)
14:23:09 <amoralej> i added that
14:23:55 <amoralej> so, to summarize, new jobs are ready to be reviewed and merged, right?
14:24:41 <amoralej> https://review.rdoproject.org/r/c/rdo-jobs/+/48899 and https://review.rdoproject.org/r/c/rdo-jobs/+/48910
14:24:57 <amoralej> jcapitao[m], i'd like to test the compare-files job with a spec changes that shows failure
14:25:41 <jcapitao[m]> I also proposed https://review.rdoproject.org/r/c/rdo-jobs/+/48934
14:25:58 <amoralej> maybe removing some file in one of the DNM reviews
14:26:28 <amoralej> so rpmlint complains with SPDX ?
14:26:52 <jcapitao[m]> actually we have one failure in https://logserver.rdoproject.org/13/48913/9/check/DLRN-rpmbuild-centos9-compare-files/1c5298c/job-output.txt
14:27:04 <jcapitao[m]> it's currently running https://review.rdoproject.org/r/c/openstack/oslo-log-distgit/+/48913
14:27:29 <jcapitao[m]> yeah rpmlint in our buildroot doesn't recognize SPDX license
14:28:24 <amoralej> probably because of old version or something, ok
14:28:46 <jcapitao[m]> yep
14:29:18 <amoralej> good, wrt the compare-files, thanks, that's what i was looking for
14:29:18 <jcapitao[m]> I used latest versions of upgrade_spec scripts to edit https://review.rdoproject.org/r/c/openstack/oslo-log-distgit/+/48913
14:29:24 <jcapitao[m]> works like a charm
14:29:28 <amoralej> great
14:29:40 <amoralej> i've left some comments about -tests
14:30:09 <amoralej> so, the good part is that, all requirements in test-requirements are automatically added in a extra option "test"
14:30:16 <amoralej> no need to tweak setup.cfg
14:30:27 <jcapitao[m]> ah!
14:30:29 <jcapitao[m]> really ?
14:30:44 <amoralej> yep, i checked it
14:30:46 <jcapitao[m]> with pbr ?
14:30:54 <amoralej> yes, and i think also setuptools
14:31:08 <jcapitao[m]> that's great news!
14:31:13 <amoralej> you can test it with "pip install oslo.log[test]"
14:31:37 <amoralej> or checking the requires.txt file in the dist-info directory after doing setup.py build
14:32:05 <jcapitao[m]> I'll check how it's done
14:32:41 <jcapitao[m]> and what about my proposal of obsoleting -test subpackage in +test subpkg ?
14:33:09 <jcapitao[m]> I managed to put the test files in +test + the requirements
14:33:29 <amoralej> yeah
14:33:37 <amoralej> that'd be the way
14:33:44 <amoralej> obsolete + provides
14:33:47 <amoralej> or only provides
14:34:05 <jcapitao[m]> rpm -qlp https://logserver.rdoproject.org/13/48913/9/check/DLRN-rpmbuild-centos9/1a20ea5/buildset/centos9/current/python3-oslo-log+tests-5.2.0-0.20230621134232.eaf6089.el9.noarch.rpm
14:34:05 <amoralej> tbh, i still have doubts about the complexity
14:34:23 <jcapitao[m]> rpm -qp --obsoletes https://logserver.rdoproject.org/13/48913/9/check/DLRN-rpmbuild-centos9/1a20ea5/buildset/centos9/current/python3-oslo-log+tests-5.2.0-0.20230621134232.eaf6089.el9.noarch.rpm
14:34:42 <jcapitao[m]> rpm -qp --requires https://logserver.rdoproject.org/13/48913/9/check/DLRN-rpmbuild-centos9/1a20ea5/buildset/centos9/current/python3-oslo-log+tests-5.2.0-0.20230621134232.eaf6089.el9.noarch.rpm
14:35:12 <amoralej> you think that can be automated?
14:35:32 <amoralej> i was thinking if we may do that in a second step
14:35:39 <jcapitao[m]> in upgrade_spec script you mean ?
14:35:41 <amoralej> yes
14:36:06 <jcapitao[m]> yes it is, I already have an idea
14:36:24 <amoralej> so, it'd be moving from -tests to +test + provides/obsoletes
14:36:37 <jcapitao[m]> when you say "complexity", it'a about the switch or the SPEC file being more complex ?
14:36:50 <amoralej> both
14:36:50 <jcapitao[m]> yes, exactly
14:37:32 <jcapitao[m]> IMO the only complexity I see is the addition of upgrade path operation
14:37:47 <amoralej> 1. i'm afraid we'll have different approaches to -tests packages declaration in different specs
14:37:54 <jcapitao[m]> on the other hand, the test requirements will be handled automatically
14:37:58 <amoralej> that will make it harder to automate
14:38:37 <amoralej> yes, but... at the same time missing requirements in a -test subpackage is currently a not-blocking thing
14:38:57 <amoralej> mostly because we don use/test them
14:39:07 <amoralej> making them automatic can lead to ftbfs
14:39:13 <jcapitao[m]> you made a point
14:39:53 <amoralej> i.e. upstream adds a new package which is not in deps or something
14:40:15 <amoralej> we may get a ftbfs and need to override
14:40:22 <jcapitao[m]> then we'll have to add a sed command to remove it
14:40:30 <amoralej> tbh, probably we will hit the issue also with automatic BRs
14:40:59 <amoralej> yes, but means ftbfs + manual task
14:41:08 <jcapitao[m]> so the question is do we want to maintain -test subpkg up-to-date
14:41:39 <jcapitao[m]> or keep the status quo ?
14:42:46 <amoralej> exactly :)
14:43:31 <amoralej> actually, we may make the question broader and consider if we should get rid of the -tests subpackages entirely
14:44:03 <amoralej> that's why i was thinking in doing this in a 2nd step
14:44:07 <jcapitao[m]> I think you're right that's something we should do after the switch to pyproject macros
14:44:16 <jcapitao[m]> yeah
14:44:50 <amoralej> it may be good to ask the community in rdo MLs
14:45:03 <amoralej> at least if anyone is using them
14:45:16 <amoralej> we are pretty blind in that
14:45:26 <jcapitao[m]> yeah good idea
14:45:30 <karolinku[m]> I think asking is good idea
14:45:55 <jcapitao[m]> let's ask to the community
14:46:33 <jcapitao[m]> amoralej: do you want to write the mail ?
14:46:58 <amoralej> so, you think that we should move this to a new activity "reconsider -tests subpackage" separated from "pyproject-rpm-macros implementation" ?
14:47:09 <jcapitao[m]> I can write it though
14:47:39 <jcapitao[m]> yes it'd be better IMHO
14:47:39 <amoralej> ok, but if we decide to separate it, then let's lower priority vs pyproject stuff
14:48:07 <jcapitao[m]> yeah ofc
14:49:50 <jcapitao[m]> #info we'll reconsider -tests subpackage after the pyproject-rpm-macros implementation
14:51:26 <jcapitao[m]> spotz_: do you have time to give feedback of Summit ?
14:51:35 <jcapitao[m]> as we have 10 min left
14:51:35 <spotz_> Yep!
14:51:56 <jcapitao[m]> great, go ahead
14:51:57 <spotz_> #topic OpenInfra Summit recap
14:52:16 <jcapitao[m]> #topic Summit update
14:52:23 <jcapitao[m]> #undo
14:52:23 <opendevmeet> Removing item from minutes: #topic Summit update
14:53:16 <spotz_> There were 750 people in attendance in Vancouver. At least 100 people had to pull out the last week due to Visa issues. The number could be higher from people who didn't contact the Foundation
14:53:52 <spotz_> We had 58 people attend the RDO Ice Cream Social at Soft Peaks and 22 people who attended the RDO Contributors dinner at Steamworks
14:55:03 <spotz_> Forum and talk sessions were well attended with some good discussions. PTG not many projects signed up for slots due to not having a majority in attendance but it looked like some good discussions were taking place.
14:55:51 <spotz_> All ducks found homes, I did grab some for the 3 of you though not sure how I'll get them to you
14:56:02 <jcapitao[m]> that's huge numbers
14:57:56 <jcapitao[m]> I read some PTG summaries in openstack-discuss ML
14:58:09 <spotz_> Yeh I was happy with our turnout to the RDO stuff
14:58:15 <jcapitao[m]> looks like there were good discussions yeah
15:00:04 <amoralej> that was a good participation in community activities!
15:00:07 <amoralej> cool!
15:00:13 <jcapitao[m]> great spotz_ thank you for the hard work 👍️
15:01:05 <spotz_> My pleasure:)
15:01:26 <amoralej> what's the next big event?
15:02:57 <spotz_> The FOundation isn't sure. The Regional events have been very popular so they will definitely do more of those, they might do something around FOSDEM. I'm hoping we'll still have one global event so we don't fragment even if we know it'll be smaller
15:04:45 <amoralej> good
15:05:42 <jcapitao[m]> sorry, we're out of time
15:05:53 <amoralej> sure, let's go on
15:05:57 <jcapitao[m]> last think
15:06:01 <jcapitao[m]> #topic next chair
15:06:27 <jcapitao[m]> who's willing to chair next week ?
15:06:35 <amoralej> i can take it
15:07:00 <jcapitao[m]> #action amoralej will chair next week
15:07:05 <jcapitao[m]> thanks amoralej
15:07:18 <jcapitao[m]> I'm going to close the meeting
15:07:32 <jcapitao[m]> thank you all for joining
15:07:39 <jcapitao[m]> #endmeeting