14:01:08 <karolinku[m]> #startmeeting RDO meeting - 2023-07-12
14:01:08 <opendevmeet> Meeting started Wed Jul 12 14:01:08 2023 UTC and is due to finish in 60 minutes.  The chair is karolinku[m]. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:08 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:08 <opendevmeet> The meeting name has been set to 'rdo_meeting___2023_07_12'
14:01:12 <rdogerrit> Merged config master: Set the elastic connection to export on opensearch.rdoproject.org  https://review.rdoproject.org/r/c/config/+/49225
14:01:36 <jcapitao[m]> o/
14:01:49 <karolinku[m]> #topic roll call
14:01:59 <karolinku[m]> #chairs jcapitao[m]
14:05:15 <amoralej> o/
14:06:28 <spotz[m]> o/
14:06:55 <karolinku[m]> #chair amoralej spotz jcapitao[m]
14:06:55 <opendevmeet> Current chairs: amoralej jcapitao[m] karolinku[m] spotz
14:08:12 <karolinku[m]> lets start with one and only topic
14:08:32 <karolinku[m]> #topic Status on specs modernization (pyproject-rpm-macros)
14:10:09 <jcapitao[m]> we have sent patches for all the libs
14:10:26 <amoralej> cool!
14:10:40 <jcapitao[m]> we still need to adjust some of them
14:10:58 <karolinku[m]> or verify if still maintained...
14:11:23 <jcapitao[m]> yes ..
14:11:33 <amoralej> we have 75 packages merged
14:12:12 <amoralej> + 24 under review
14:12:15 <jcapitao[m]> some networking ones have the latest patch committed ~2-3 years ago
14:13:18 <amoralej> yep, karolinku[m] has proposed removal of one
14:13:30 <amoralej> it's good to review current status and see what can we clean up
14:16:20 <jcapitao[m]> yes
14:16:37 <jcapitao[m]> next step are clients
14:16:41 <amoralej> yep
14:17:12 <amoralej> let's work in getting all the ones in https://review.rdoproject.org/r/q/topic:pyproject-rpm-macros+branch:rpm-master+status:open passing ci at least
14:17:42 <karolinku[m]> I think we should close all libs reviews before moving forward
14:18:44 <jcapitao[m]> ok let's clean it
14:19:22 <amoralej> yep, let's not accumulate too much tech debt before progressing
14:20:43 <jcapitao[m]> it can be overwhelming sometimes :)
14:21:25 <amoralej> yep :)
14:21:48 <amoralej> but i think we have done a good number of them already
14:23:36 <amoralej> final release for non-clients is aug 24
14:24:13 <amoralej> so i think we are good enough to do stop for some days after libraries if you want
14:24:25 <amoralej> if you need some refresh days
14:25:29 <karolinku[m]> good idea, but i'd like to close mine reviews before
14:25:40 <amoralej> yeah, i mean after all clients are merged
14:25:46 <amoralej> not clients sorry, libraries
14:26:09 <jcapitao[m]> hmm 24 of august is pretty close I'd say
14:26:49 <jcapitao[m]> well ~30 pkgs is doable by then
14:26:54 <amoralej> i think we still can take two or three "pyproject-free" days :)
14:27:47 <jcapitao[m]> right ;D
14:28:57 <rdogerrit> Merged rdoinfo master: Remove VMWare NSX plugin  https://review.rdoproject.org/r/c/rdoinfo/+/48794
14:29:26 <karolinku[m]> ok, anything else in this topic?
14:30:47 <amoralej> ^ we can forget about vmware ones :)
14:31:10 <amoralej> nothing else from my side
14:31:24 <spotz[m]> Hehe
14:31:45 <jcapitao[m]> nothing else from me too on this topic
14:32:30 <amoralej> i was on pto last week, so i can take all the client ones in return :)
14:33:58 <jcapitao[m]> nah, otherwise it will kill the PTO effect too fast :)
14:34:11 <karolinku[m]> that's too much for one man!
14:34:51 <karolinku[m]> ok, let's go to another topic
14:35:14 <karolinku[m]> #topic   F39 py3.12 FTI/FTBFS
14:35:36 <amoralej> ah, right, i've seen bz showing up
14:36:05 <jcapitao[m]> we have bunch of FTI and FTBFS
14:36:21 <amoralej> also some related to sphinx update as https://bugzilla.redhat.com/show_bug.cgi?id=2221968
14:37:03 <jcapitao[m]> yes for the FTBFS is because of the remove of setuptools support in sphinx
14:37:04 <jcapitao[m]> https://github.com/sphinx-doc/sphinx/pull/11363
14:37:29 <jcapitao[m]> but we are using sphinx-build for most of them so should be ok
14:37:39 <amoralej> mmm moving to %tox based macros would be good
14:37:52 <jcapitao[m]> #link https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/BI3TYWJFMSCW4RMWI3FUYPRWZWWI4G7E/
14:37:55 <amoralej> tracker for sphinx relates is in https://bugzilla.redhat.com/show_bug.cgi?id=2188968
14:38:18 <jcapitao[m]> amoralej: yes I mean, the one are filing are those still using 'python3 setup.py build_sphinx'
14:38:32 <amoralej> jcapitao[m], do we have a list of real issues wrt to 3.12 ?
14:38:55 <jcapitao[m]> #link https://review.rdoproject.org/etherpad/p/F39FTI-py3.12
14:38:56 <jcapitao[m]> I created this pad
14:39:17 <jcapitao[m]> from the BZ  request https://bugzilla.redhat.com/buglist.cgi?cmdtype=runnamed&list_id=13257353&namedcmd=PYTHON3.12
14:39:44 <amoralej> great, thanks
14:39:52 <amoralej> dlrn, let's just remove it
14:40:39 <amoralej> so, should we divide the bz between us three
14:41:01 <karolinku[m]> I should remove it long time ago
14:41:04 <karolinku[m]> (dlrn)
14:41:23 <jcapitao[m]> most of them depends on flake8 pycodestyle
14:41:32 <amoralej> yep, i see https://bugzilla.redhat.com/show_bug.cgi?id=2220224
14:42:39 <jcapitao[m]> we can divide yes
14:45:14 <amoralej> ok, let's add our name to the ones we plan to handle in the etherpad
14:47:06 <jcapitao[m]> good
14:48:23 <jcapitao[m]> not an ideal period for us this bump to py3.12 :S
14:48:28 <karolinku[m]> do we have any deadline to fix it?
14:48:38 <jcapitao[m]> 30 days IIRC
14:48:39 <amoralej> well, before they are removed from fedora :)
14:49:11 <amoralej> but at least while we have external blockers i expect we are not added to the list
14:49:32 <karolinku[m]> well, I can say that im testing their patiene with dlrn for quite a time now xD
14:50:01 <karolinku[m]> but it's not blocking anything ofc
14:50:44 <jcapitao[m]> amoralej: ah maybe, needs to confirm but I expect it too, because some work needs to be done upstream
14:50:58 <jcapitao[m]> karolinku: ah it's FTBFS ? or FTI ?
14:51:15 <amoralej> anyway, in some cases we can probably avoid the dependency in flake
14:51:18 <amoralej> i'll check
14:51:18 <karolinku[m]> dlrn is FTBFS
14:52:19 <jcapitao[m]> okk
14:52:50 <karolinku[m]> we have 8 minutes left
14:53:03 <karolinku[m]> ready for open floor?
14:53:56 <amoralej> yep
14:54:19 <karolinku[m]> #topic open floor
14:54:41 <spotz[m]> Received the proof asked if it was possible to make a change
14:56:48 <jcapitao[m]> spotz: about the embroidery ?
14:57:29 <spotz[m]> Yeah it’s hard to see the red letters
14:57:42 <spotz[m]> On the black backpack
14:58:30 <amoralej> ah, i didn't know what you were talking about :)
14:58:56 <jcapitao[m]> ah right
14:59:03 <spotz[m]> Sorry
14:59:09 <jcapitao[m]> so no embroidery possible ?
15:00:17 <rdogerrit> Joel Capitao proposed openstack/oslo-messaging-distgit rpm-master: Switch to pyproject-rpm-macros  https://review.rdoproject.org/r/c/openstack/oslo-messaging-distgit/+/49057
15:01:23 <spotz[m]> No we’ll have embroidery Judy hoping they can add some white under the letters
15:02:29 <spotz[m]> Just not Judy:)
15:02:40 <karolinku[m]> we are out of time, so who is willing to chair next mtg?
15:03:21 <jcapitao[m]> spotz: okk cool :)
15:03:22 <amoralej> i can take it
15:03:43 <karolinku[m]> #action amoralej is chairing next week
15:04:01 <rdogerrit> Joel Capitao proposed openstack/novajoin-distgit rpm-master: Switch to pyproject-rpm-macros  https://review.rdoproject.org/r/c/openstack/novajoin-distgit/+/49227
15:04:55 <karolinku[m]> ok, im closing the meeting
15:05:06 <amoralej> thanks karolinku[m] for chairing!
15:05:11 <jcapitao[m]> thank you karolinku !
15:05:13 <karolinku[m]> #endmeeting