14:00:55 <jcapitao[m]> #startmeeting RDO meeting - 2023-07-26
14:00:55 <opendevmeet> Meeting started Wed Jul 26 14:00:55 2023 UTC and is due to finish in 60 minutes.  The chair is jcapitao[m]. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:55 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:55 <opendevmeet> The meeting name has been set to 'rdo_meeting___2023_07_26'
14:01:40 <spotz[m]> o/
14:01:44 <jcapitao[m]> #topic roll call
14:02:16 <amoralej> o/
14:03:33 <jcapitao[m]> #chair spotz amoralej
14:03:33 <opendevmeet> Current chairs: amoralej jcapitao[m] spotz
14:05:40 <jcapitao[m]> the topics are on https://etherpad.opendev.org/p/RDO-Meeting
14:05:50 <jcapitao[m]> we have 2 topics today
14:05:58 <jcapitao[m]> #topic Update about pyproject-rpm-macros
14:06:02 <jcapitao[m]> let's start with first one
14:06:40 <jcapitao[m]> #info clients are being migrated
14:07:24 <jcapitao[m]> #info 132 packages out of 236 have been merged
14:07:52 <amoralej> i've just started sending reviews for core projects, btw
14:07:58 <amoralej> we will see how that goes
14:07:59 <jcapitao[m]> we are half way through the migration
14:08:10 <amoralej> more than half! :
14:08:12 <amoralej> :)
14:08:23 <jcapitao[m]> ah !
14:08:29 <spotz[m]> woohoo
14:08:37 <jcapitao[m]> we have entirely migrated the clients
14:08:49 <jcapitao[m]> lemme correct the mtg info
14:08:52 <jcapitao[m]> #undo
14:08:52 <opendevmeet> Removing item from minutes: #info 132 packages out of 236 have been merged
14:08:58 <jcapitao[m]> #undo
14:08:58 <opendevmeet> Removing item from minutes: #info clients are being migrated
14:09:19 <jcapitao[m]> #info the clients projects are migrated
14:09:40 <jcapitao[m]> #info the core projects are being migrated
14:09:56 <jcapitao[m]> #info 132 packages out of 236 have been merged
14:10:12 <jcapitao[m]> better now
14:14:26 <jcapitao[m]> we are at steady pace
14:15:01 <amoralej> yep, i think we are doing well
14:15:18 <jcapitao[m]> it's like an endurance race ;)
14:15:33 <amoralej> right :)
14:16:15 <spotz[m]> I think it's a lot of progress!
14:16:17 <jcapitao[m]> I hope it will save us time in the future, and we'll not hit FTBFS more frequently than today
14:18:05 <amoralej> at least all the reqchecks of release preparation
14:18:15 <jcapitao[m]> right !
14:18:16 <amoralej> that's my motivation :)
14:18:28 <jcapitao[m]> I forgot about it !
14:18:43 <jcapitao[m]> that's enough :)
14:18:48 <amoralej> yep
14:19:28 <jcapitao[m]> btw we have remove the reqcheck job after the migration
14:19:37 <amoralej> yes
14:19:47 <jcapitao[m]> actually we can already remove it
14:20:08 <amoralej> i was writing the same :)
14:20:15 <amoralej> let's get rid of it
14:20:25 <jcapitao[m]> ack
14:20:57 <jcapitao[m]> #action jcapitao to get rid of rdopkg-reqcheck job
14:21:26 <jcapitao[m]> we'll save some CI resources
14:22:18 <jcapitao[m]> anything else on this topic I may have missed ?
14:22:52 <amoralej> not from my side
14:23:17 <jcapitao[m]> let's move to next topic
14:23:20 <jcapitao[m]> #topic Status on fedora update of python to 3.12
14:23:57 <amoralej> so, that's more to ask
14:24:14 <amoralej> jcapitao[m], we are just waiting on external issues, right?
14:24:27 <jcapitao[m]> yep, https://bugzilla.redhat.com/show_bug.cgi?id=2223081 still pending
14:24:38 <amoralej> some packages are affected by an issue in pythong-greenlet and the oslo-log one that come to my mind
14:25:15 <amoralej> it's hard to be up to date with so many bz opened and closed automatically
14:26:57 <amoralej> btw, we also have a problem with blockdiag, it does not support the latest version of pillow and it seems upstream is not responding
14:26:59 <jcapitao[m]> yep.. with the notification email storm
14:27:09 <amoralej> it's used upstream in some documentation projects
14:27:19 <amoralej> i thing it has been orphaned in fedora
14:27:46 <amoralej> and may break upstream doc building if pillow is updated in u-c upstream
14:28:05 <jcapitao[m]> ah!
14:28:40 <jcapitao[m]> is it https://github.com/python-pillow/Pillow ?
14:29:11 <amoralej> yes
14:29:17 <amoralej> but the problem is in blockdiag
14:29:24 <jcapitao[m]> ah sorry
14:29:31 <amoralej> does not support pillow=10.0
14:30:44 <amoralej> https://github.com/blockdiag/blockdiag/pull/171
14:30:51 <jcapitao[m]> well blockdiag is used widely by network packages, so I guess a solution will be found at Openstack level
14:31:13 <jcapitao[m]> ultimately a fork
14:31:23 <amoralej> or looking for an alternative
14:31:27 <amoralej> dunno
14:31:34 <jcapitao[m]> yep
14:31:56 <jcapitao[m]> wrt Yappi the PR was closed https://github.com/sumerc/yappi/pull/139
14:32:44 <jcapitao[m]> but only required by oslo-service, so ..
14:34:51 <amoralej> it's test only requirement ?
14:35:15 <jcapitao[m]> run-time :/
14:36:47 <amoralej> mmm a profiler
14:36:58 <jcapitao[m]> yep written in C
14:37:22 <amoralej> wouldn't it be good to make it optional import?
14:37:28 <jcapitao[m]> with multipthreading capabilities
14:38:37 <amoralej> ok
14:38:52 <amoralej> so, you can just report it as an issue, i mean problem with 3.12
14:39:15 <amoralej> or send the PR yourself if you think you have a good way to make it work
14:40:16 <jcapitao[m]> yep will do but need to spend some time to fully understand the in & out of the software
14:41:42 <amoralej> i've spent hours today trying to make blockdiag work with pillow 10.0 but still failing one test .. :(
14:42:32 <jcapitao[m]> damn
14:43:13 <jcapitao[m]> well, that's what looks like living on edge with Fedora 0:)
14:43:59 <amoralej> yes :)
14:44:08 <amoralej> it's demanding
14:44:11 <jcapitao[m]> even my daiqui patch was not merged
14:44:12 <jcapitao[m]> https://github.com/Mergifyio/daiquiri/pull/74
14:44:52 <amoralej> you push it to the distgit, right?
14:44:53 <jcapitao[m]> I guess they don't want to because py3.12 is still in beta
14:45:13 <jcapitao[m]> yep I applied the patch at distgit level
14:47:44 <jcapitao[m]> to summarize we have to keep working on yappi, oslo.log and blockdiag, right ?
14:48:27 <amoralej> i'm also watching other blockers as python-gevent
14:50:07 <jcapitao[m]> ok
14:50:58 <jcapitao[m]> I think that's it for this topic
14:51:05 <amoralej> yep
14:51:41 <jcapitao[m]> let's move on
14:51:43 <jcapitao[m]> #topic next chair
14:52:08 <jcapitao[m]> karolinku proposed earlier to chair next week
14:52:41 <jcapitao[m]> #action karolinku to chair next week
14:52:53 <jcapitao[m]> #topic open floor
14:56:56 <spotz[m]> I'll be out the next 2 meetings
14:57:10 <amoralej> good
14:57:13 <jcapitao[m]> ack
14:57:16 <amoralej> enjoy your PTO then!
14:57:57 <jcapitao[m]> one more week for me :)
14:58:04 <jcapitao[m]> ah it's Flock event
14:58:17 <spotz[m]> Yeah and then PTO
15:00:30 <jcapitao[m]> ok enjoy it ! :)
15:01:04 <jcapitao[m]> I'm gonna close the meeting
15:01:05 <jcapitao[m]> #endmeeting