#rdo: RDO meeting - 2023-09-13

Meeting started by karolinku[m] at 14:03:30 UTC (full logs).

Meeting summary

  1. RDO bobcat 2023.2 preparation (karolinku[m], 14:06:20)
    1. https://issues.redhat.com/browse/RDO-135 (jcapitao[m], 14:07:58)
    2. https://review.rdoproject.org/r/q/topic:bobcat-branching (jcapitao[m], 14:08:09)
    3. https://review.rdoproject.org/etherpad/p/bobcat-release-preparation (jcapitao[m], 14:08:19)
    4. the clients and libs are built (jcapitao[m], 14:08:34)
    5. RC1 bits are WIP upstream (jcapitao[m], 14:08:55)
    6. https://review.opendev.org/q/topic:bobcat-rc1-deadline (jcapitao[m], 14:09:14)

  2. Stop RDO Trunk repos for centos8-[train,ussuri,victoria] ? (karolinku[m], 14:13:33)
    1. projects are EOLing stable branches specially for train, but also ussuri and victoria (amoralej, 14:14:15)
    2. TripleO CI team is removing all the TripleO jobs running stable/train code (amoralej, 14:19:26)
    3. the proposal is to stop the RDO Trunk Train builder after CI team confirms jobs are not longer running. By then, we will maintain the repos in the server in its latest status for a couple of weeks (amoralej, 14:21:30)
    4. after removing Train we will also follow the same process for Ussuri and Victoria (amoralej, 14:22:39)

  3. Changing puppet modules management for non-openstack modules (from chasing trunk to upstream Puppetfile) (karolinku[m], 14:39:12)
    1. RDO has been following master trunk commits for non-openstack puppet modules, while upstream puppet openstack modules have been following latest tags via puppetfile which has lead to issues from time to time (amoralej, 14:52:19)
    2. RDO has mechanism to pin puppet modules to known good hashes when having issues but following the same tags as upstream would reuse upstream tests and would be more consistent with the approach we follow for python libraries with upper-constraints file (amoralej, 14:53:58)
    3. in order to avoid downgrades from the current packages, we could pin to latest promoted hashes in puppet promotion pipeline and implement automation to compare the versions in upstream puppetfile and rdoinfo. Only if version in puppetfile is > rdoinfo pin, send a review to update it. initially we'd maintain the latest known good versions, but when p-o-i moves ahead we will converge over time without downgrade (amoralej, 14:56:20)
    4. ACTION: amoralej to send the pin review for puppet modules (amoralej, 14:58:53)

  4. next chair (karolinku[m], 15:07:14)
    1. ACTION: amoralej is chairing next week (karolinku[m], 15:08:16)

  5. open floor (karolinku[m], 15:08:24)


Meeting ended at 15:10:01 UTC (full logs).

Action items

  1. amoralej to send the pin review for puppet modules
  2. amoralej is chairing next week


Action items, by person

  1. amoralej
    1. amoralej to send the pin review for puppet modules
    2. amoralej is chairing next week


People present (lines said)

  1. amoralej (64)
  2. jcapitao[m] (35)
  3. karolinku[m] (16)
  4. rlandy_ (12)
  5. opendevmeet (7)
  6. spotz[m] (6)
  7. rdogerrit (5)
  8. spotz (0)


Generated by MeetBot 0.1.4.