14:00:44 <amoralej> #startmeeting RDO meeting - 2023-09-20
14:00:44 <opendevmeet> Meeting started Wed Sep 20 14:00:44 2023 UTC and is due to finish in 60 minutes.  The chair is amoralej. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:44 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:44 <opendevmeet> The meeting name has been set to 'rdo_meeting___2023_09_20'
14:00:51 <amoralej> #topic roll call
14:01:35 <jcapitao[m]> o/
14:01:44 <karolinku[m]> o/
14:01:47 <amoralej> #chair jcapitao[m] karolinku[m]
14:01:47 <opendevmeet> Current chairs: amoralej jcapitao[m] karolinku[m]
14:03:49 <amoralej> let's start with the first topic
14:04:01 <amoralej> #topic RDO bobcat 2023.2 preparation
14:04:20 <amoralej> #link https://review.rdoproject.org/r/q/topic:bobcat-branching
14:04:34 <amoralej> #link https://issues.redhat.com/browse/RDO-135
14:05:01 <amoralej> who wants to update the status?
14:06:16 <amoralej> #info builds for RC1 packages have been created for projects which have released
14:06:18 <jcapitao[m]> all the RC1 bits are built except Nova and Heat
14:06:28 <amoralej> is there any issue with those tow?
14:06:36 <amoralej> any known issue?
14:06:42 <jcapitao[m]> https://review.opendev.org/q/topic:bobcat-rc1-deadline+status:open
14:06:54 <spotz[m]> o/
14:07:13 <amoralej> #chair spotz[m]
14:07:13 <opendevmeet> Current chairs: amoralej jcapitao[m] karolinku[m] spotz[m]
14:07:15 <jcapitao[m]> they want to include recent patches
14:07:24 <amoralej> they have ptl approved so i guess they must be about to merge
14:07:41 <amoralej> #info Ceph has been updated in bobcat to Reef version
14:07:44 <jcapitao[m]> yeah sounds like
14:07:56 <jcapitao[m]> and also https://review.opendev.org/q/topic:bobcat-missing-stable-branches
14:08:02 <jcapitao[m]> same story
14:08:19 <jcapitao[m]> they wants to cut branches from more recent hash
14:08:40 <amoralej> ok
14:08:54 <jcapitao[m]> so still waiting
14:09:03 <amoralej> ok
14:09:20 <jcapitao[m]> maybe we can prepare the puppet modules
14:09:33 <amoralej> wrt ceph, the switch is done, we didn't hit any issue other that adding epel is required
14:09:47 <jcapitao[m]> adding epel ?
14:09:53 <amoralej> yes :(
14:10:13 <jcapitao[m]> enabling EPEL as a repo ?
14:10:32 <amoralej> see https://review.rdoproject.org/r/c/rdo-infra/ansible-role-dlrn/+/49997/3/files/centos9-master-uc-dlrn-deps.repo
14:10:40 <amoralej> storage sig now requires epel packages
14:10:59 <jcapitao[m]> damn
14:11:03 <amoralej> yep
14:11:06 <karolinku[m]> meh
14:11:11 <amoralej> my request was to add it with lower priority
14:11:25 <karolinku[m]> any option for workaround?
14:11:27 <amoralej> so that, any package in RDO repos wins EPEL even if it has newer
14:11:46 <amoralej> that's the workaround i got
14:12:02 <amoralej> so, with that, only packages which are not in other repos are pulled from epel
14:12:48 <amoralej> there is no much more that we can do from our side, unless we persuade storage sig to build deps and not depend on epel
14:13:26 <jcapitao[m]> yep I understand
14:14:54 * jcapitao[m] trying to foresee the complications
14:14:55 <amoralej> for bobcat release, we may add it as documentation
14:15:23 <amoralej> and not add ceph repo dependency in the release rpm
14:15:49 <karolinku[m]> that's for case for packages we already got, but probably we will have to add new ones
14:15:53 <jcapitao[m]> ah that's another workaround :)
14:15:53 <amoralej> or put some documentation asking to add it manually only for ceph cases
14:15:58 <jcapitao[m]> I mean mitigation
14:16:10 <jcapitao[m]> yeah +1
14:17:15 <jcapitao[m]> I'm thinking about the deps we have in EPEL9
14:17:26 <amoralej> karolinku[m], may you elaborate on your point?
14:18:19 <amoralej> so for deps which are in RDO and EPEL, priority should do the trick and always pull RDO one
14:18:33 <amoralej> that may cause issues to ceph at some point
14:19:03 <karolinku[m]> I assume that set of epel packages is wider that RDO's
14:19:03 <amoralej> but also the oposite, pulling from EPEL packages that we ship may cause issues to us :)
14:19:09 <amoralej> exactly
14:19:45 <amoralej> actually, adding epel in delorean-deps.repo may hide dependencies missing in RDO at build time
14:19:52 <amoralej> is that what you mean?
14:20:12 <karolinku[m]> im thinking about the case, when package need sth from epel which we don't have
14:20:35 <amoralej> so, if the pacakge is ceph, that's ok, it's storage sig decission
14:20:46 <amoralej> for other packages, it'd be an issue
14:20:47 <amoralej> yes
14:21:26 <karolinku[m]> so, im afraid it will be more often issue, as storage SIG grows
14:21:28 <amoralej> i'm not sure about the best way to mitigate
14:22:08 <karolinku[m]> because using epel is a new "door" for exotic packages
14:22:16 <amoralej> yes, it is
14:23:22 <amoralej> another option may be to add includepkgs with only the exact packages that we want to allow to be pulled from epel
14:23:22 <jcapitao[m]> we should make fail build jobs when there are no-storage SIG dep pulled in the buildroot
14:23:51 <amoralej> how ?
14:23:58 <jcapitao[m]> edit: no-storage SIG dep pulled from EPEL9
14:24:00 <amoralej> i don't see an easy way to do it
14:24:17 <jcapitao[m]> yeah ..
14:24:51 <jcapitao[m]> your solution sounds better
14:25:18 <amoralej> so priority + indludepkgs https://man7.org/linux/man-pages/man5/yum.conf.5.html
14:26:00 <karolinku[m]> +1
14:26:04 <amoralej> can be tricky if storage sig changes dependences often
14:26:29 <jcapitao[m]> yeah but less complex
14:26:52 <amoralej> but it's probably less risky that allowing to pull anything not in RDO repos from EPEL
14:27:12 <jcapitao[m]> agreed
14:27:17 <amoralej> ok, i'll try to create the list
14:28:03 <amoralej> #action amoralej to find the exact list of dependencies for Ceph from EPEL and add includepkgs to epel config in delorean-deps.repo
14:28:45 <amoralej> anything else about this topic?
14:28:58 <jcapitao[m]> wrt puppet modules
14:29:03 <amoralej> ah, right
14:29:58 <jcapitao[m]> with the new process, we should build non-os and os puppet modules at the same time
14:30:09 <jcapitao[m]> when upstream cut the branch, right ?
14:30:24 <amoralej> yes
14:30:34 <amoralej> btw, it seems puppetfile is ahead of our pins now https://review.opendev.org/c/openstack/puppet-openstack-integration/+/895124
14:31:05 <amoralej> so we have a case to test our WIP automation :)
14:31:17 <karolinku[m]> definitely
14:32:19 <amoralej> next topic?
14:33:15 <jcapitao[m]> yes I think that's all
14:33:25 <karolinku[m]> yep
14:33:26 <amoralej> Stop RDO Trunk repos for centos8-[train,ussuri,victoria]
14:33:32 <amoralej> #topic Stop RDO Trunk repos for centos8-[train,ussuri,victoria]
14:34:08 <amoralej> #info component and integration promotion lines have been stopped
14:34:13 <amoralej> #info https://review.rdoproject.org/r/q/topic:train-teardown
14:34:44 <amoralej> so i think we can stop building new packages
14:34:59 <amoralej> rlandy_ ^
14:36:25 <amoralej> also, we can stop puppet pipelines for T, U, V
14:37:20 <rlandy_> yes
14:37:27 <amoralej> thanks!
14:37:31 <rlandy_> removed train lines yesterday
14:37:42 <rlandy_> will remove check/gate shortly
14:37:55 <amoralej> also we can stop and remove puppet promotion pipelines for T, U, V
14:38:01 <rlandy_> that patch is under review by CI team and upgrades (FFU)
14:38:08 <amoralej> yeah, no problem with that
14:38:31 <amoralej> but as there are no promotions, we don't need any new package, right?
14:38:35 <amoralej> just current status of the repos
14:38:45 <amoralej> that should be enough, i guess
14:39:03 <amoralej> #info puppet promotion pipelines will be stopped for train, ussuri, victoria
14:39:42 <amoralej> #info DLRN builders will be stopped for T,U,V, no new packages will be built
14:40:13 <amoralej> #info current repos will stay for now in the RDO Trunk server for T,U,V
14:41:14 <jcapitao[m]> damn, Train was my first release as a RDO folk, time flies
14:41:21 <amoralej> :)
14:41:45 <amoralej> that means we have maintained it for a long time! :)
14:42:31 <jcapitao[m]> yeah looong time :)
14:42:32 <amoralej> we will send a mail announcing the plans for T, U, V to the RDO mailing lists
14:43:32 <amoralej> i think that's it for this topic
14:43:39 <amoralej> #topic open floor
14:43:46 <amoralej> anything else you want to share?
14:44:08 <amoralej> ah, first, any volunteer to chair next week?
14:45:43 <jcapitao[m]> I can take it !
14:46:31 <amoralej> #action jcapitao will chair next week
14:46:36 <amoralej> thanks jcapitao[m] !
14:46:42 <amoralej> anything else?
14:48:06 <jcapitao[m]> nothing else from me
14:48:51 <karolinku[m]> nothing
14:49:09 <spotz[m]> Just a heads up gor fosdem in feb
14:49:42 <spotz[m]> And CentOS Connect
14:49:43 <amoralej> there will be also centos connect?
14:49:51 <amoralej> good
14:50:15 <amoralej> so, start thinking in your proposals for talks! :)
14:50:51 <jcapitao[m]> ack
14:51:08 <amoralej> https://fosdem.org/2024/news/2023-09-18-stands-cfp/
14:51:14 <amoralej> or centos ones
14:51:53 <amoralej> ok, i'm closing the meeting
14:52:00 <amoralej> thank you all for joining!
14:52:09 <spotz[m]> Thank you!
14:52:16 <amoralej> #endmeeting