14:01:11 <karolinku[m]> #startmeeting RDO meeting - 2023-10-11
14:01:11 <opendevmeet> Meeting started Wed Oct 11 14:01:11 2023 UTC and is due to finish in 60 minutes.  The chair is karolinku[m]. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:11 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:11 <opendevmeet> The meeting name has been set to 'rdo_meeting___2023_10_11'
14:01:51 <karolinku[m]> #topic rollcall
14:02:11 <jcapitao[m]> o/
14:02:58 <amoralej> o/
14:03:10 <karolinku[m]> #chair jcapitao[m] amoralej
14:03:10 <opendevmeet> Current chairs: amoralej jcapitao[m] karolinku[m]
14:04:39 <karolinku[m]> the one and only topic for today is
14:04:44 <karolinku[m]> #topic RDO bobcat 2023.2 preparation
14:05:25 <jcapitao[m]> #link https://review.rdoproject.org/r/q/topic:bobcat-branching
14:05:33 <spotz[m]> o/
14:05:33 <jcapitao[m]> #link https://issues.redhat.com/browse/RDO-135
14:05:42 <karolinku[m]> #chair spotz
14:05:42 <opendevmeet> Warning: Nick not in channel: spotz
14:05:42 <opendevmeet> Current chairs: amoralej jcapitao[m] karolinku[m] spotz
14:05:55 <jcapitao[m]> #info non-openstack puppet modules are built
14:06:15 <jcapitao[m]> #info we are waiting for https://review.opendev.org/c/openstack/releases/+/897428 to be merged
14:07:54 <jcapitao[m]> one thing to discuss
14:08:05 <jcapitao[m]> it's about the EPEL enabling
14:08:59 <jcapitao[m]> for Ceph Reef I mean
14:09:58 <amoralej> yep
14:10:04 <jcapitao[m]> we'll have to tell the end user to manually enabling it with the includepkgs directive ? or do we have an alternative ?
14:10:20 <amoralej> that's what i would do
14:10:39 <amoralej> add instructions about how to enable epel repo with includepkgs
14:11:11 <amoralej> actually, i think it will be required in all installations
14:11:13 <spotz[m]> And just the one CEph package or more?
14:11:22 <amoralej> as it will be required for cinder, right?
14:12:17 <amoralej> the other option may be to add epel-release as a dependency of centos-release-openstack-bobcat
14:12:51 <amoralej> and instruct about how to add includepkgs and priority
14:13:29 <spotz[m]> I can write it if you all have notes
14:13:36 <jcapitao[m]> I'd vote for the former
14:15:09 <jcapitao[m]> because, in the latter option, if the instruction are not followed (i.e includepkgs), the end user ends up with an installation with bunch on EPEL pkgs (not sure the installation will work)
14:15:52 <amoralej> yes, that's also my preference
14:17:30 <amoralej> unless we directly ship a .repo config for epel with our options
14:17:55 <amoralej> but we'd need to include the gpgkey in the release rpm, which i don't like too much
14:18:39 <jcapitao[m]> we'll have to in either case
14:18:53 <amoralej> wdym ?
14:19:24 <jcapitao[m]> in rdo-release RPM we are providing the SIG GPG pubkey
14:19:39 <amoralej> but not the epel one
14:20:01 <amoralej> if we just ask the user to manually install epel-release we don't need to
14:21:00 <jcapitao[m]> right
14:21:32 <amoralej> tbh for rdo-release ... it'd be probably better to ship the config
14:21:48 <amoralej> i was thinking more in centos-release-openstack-bobcat
14:21:52 <jcapitao[m]> totally agree
14:22:16 <jcapitao[m]> I think in rdo-release RPM we should ship it
14:22:22 <jcapitao[m]> with the EPEL GPG pubkey
14:23:02 <jcapitao[m]> but for centos-release-openstack-bobcat, ask the end user to do the operation manually
14:24:32 <amoralej> actually, now it's the same situation with crb repo
14:24:36 <amoralej> requires manual enablement
14:28:07 <jcapitao[m]> right
14:30:29 <rdogerrit> Joel Capitao proposed rdo-infra/ansible-role-weirdo-puppet-openstack master: Use Ceph Reef for Bobcat  https://review.rdoproject.org/r/c/rdo-infra/ansible-role-weirdo-puppet-openstack/+/50450
14:30:36 <karolinku[m]> do we have any deadline to make a decision about it?
14:31:40 <amoralej> when we create release rpms :)
14:31:54 <karolinku[m]> heh, so... now ;]
14:32:03 <amoralej> i've just check that python bindings for ceph, python3-rbd and python3-rados do not require epel
14:33:08 <amoralej> mmm although in p-o-i it was pulling packages from it
14:33:21 <amoralej> i'm not sure if we may be able to deploy in non-ceph cases without it, tbh
14:33:24 <amoralej> probably yes
14:33:44 <amoralej> ah, we deploy radosgw iirc
14:35:53 <amoralej> and ceph itself, ok, so we'd only need it when coinstalling it with ceph
14:37:42 <amoralej> so, i'd vote for just documenting it in some of the rdo install docs
14:38:11 <amoralej> one option for rdo-release would be to add the config but with the repo disabled by default
14:40:56 <jcapitao[m]> and enabling it for ceph scenarios ?
14:41:16 <amoralej> exactly
14:41:42 <jcapitao[m]> sounds fair
14:42:06 <karolinku[m]> agree
14:45:55 <karolinku[m]> let me write some "agreed"s
14:48:26 <karolinku[m]> #agreed Ceph Reef will need to have manually enabled EPEL repo with includepkgs, which will be documented in RDO's docs
14:51:07 <karolinku[m]> #agreed for rdo-release RPM config will be probably shipped
14:51:20 <karolinku[m]> anything else? in notes or in this topic?:)
14:51:40 <spotz[m]> And you all will provide notes and I'll provide a draft patch of it:)
14:51:58 <amoralej> i'm reviewing the release announcement
14:52:22 <amoralej> i'm adding some notes but will probably require some rewording
14:57:53 <karolinku[m]> #topic open floor
14:58:20 <karolinku[m]> does anyone would like to chair next week?
14:58:32 <amoralej> i can take it
14:59:05 <karolinku[m]> #action amoralej will chair next mtg
15:00:15 <karolinku[m]> #endmeeting