14:00:36 <amoralej> #startmeeting RDO meeting - 2023-10-18
14:00:36 <opendevmeet> Meeting started Wed Oct 18 14:00:36 2023 UTC and is due to finish in 60 minutes.  The chair is amoralej. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:36 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:00:36 <opendevmeet> The meeting name has been set to 'rdo_meeting___2023_10_18'
14:00:49 <amoralej> please add your topics to https://etherpad.opendev.org/p/RDO-Meeting
14:02:15 <amoralej> #topic roll call
14:02:31 <jcapitao[m]> o/
14:02:51 <spotz[m]> o/
14:02:57 <amoralej> #chair jcapitao[m] spotz[m]
14:02:57 <opendevmeet> Current chairs: amoralej jcapitao[m] spotz[m]
14:05:19 <amoralej> #topic RDO bobcat 2023.2 preparation
14:05:31 <amoralej> #link https://review.rdoproject.org/r/q/topic:bobcat-branching
14:05:43 <amoralej> #link https://issues.redhat.com/browse/RDO-135
14:06:02 <amoralej> we are doing the last tasks for RDO bobcat release
14:06:14 <amoralej> i think we have all packages built, right?
14:07:06 <jcapitao[m]> we are missing kolla
14:07:12 <amoralej> is it released ?
14:07:32 <jcapitao[m]> nope
14:07:33 <spotz[m]> I don’t think so
14:07:58 <amoralej> technically it's not release criteria, as it is not needed for p-o-i or packstack jobs
14:08:08 <amoralej> so we may publish it
14:08:26 <jcapitao[m]> we are also missing networking-l2gw-tempest-plugin and novajoin-tempest-plugin
14:08:32 <amoralej> and we only ship the part to build containers ...
14:08:38 <amoralej> that can be follow up
14:08:40 <amoralej> mmm
14:08:47 <amoralej> l2gw is needed for p-o-i iirc
14:09:45 <jcapitao[m]> I need to double check why it was not proposed by our bot
14:10:49 <amoralej> it may be missing tags
14:13:01 <jcapitao[m]> I'll check after
14:16:07 <amoralej> we can crosstag python-networking-l2gw-tests-tempest-0.1.0-3.82e3d07git.el9s
14:16:26 <amoralej> there has been only one commit and is not relevant for code, only ci adjustment
14:16:27 <jcapitao[m]> mmmh
14:16:32 <jcapitao[m]> ah ok
14:18:11 <amoralej> for novajoin-tests-tempest we probably need to build from commit snapshot
14:18:24 <amoralej> but that probably can be follow-up
14:18:58 <amoralej> so, missing pieces for GA are:
14:19:14 <amoralej> 1- crosstag l2gw-tests-tempest to -testing
14:19:26 <amoralej> 2- promote to -release
14:19:41 <amoralej> 3- build centos-release-openstack-bobcat
14:19:56 <amoralej> 4- finish announcement review
14:20:03 <amoralej> actually
14:20:23 <amoralej> 4- get the new doc about ceph and epel merge
14:20:33 <amoralej> 5- finish announcement review
14:20:41 <amoralej> anything else?
14:20:55 <jcapitao[m]> https://review.rdoproject.org/r/c/rdo-jobs/+/50578
14:21:08 <jcapitao[m]> and that's it
14:21:21 <jcapitao[m]> then there will be followup
14:21:32 <jcapitao[m]> adding monitoring
14:21:55 <jcapitao[m]> unpin tempest plugins
14:22:02 <amoralej> merging rdo-jobs repo
14:22:13 <amoralej> merging rdo-jobs review
14:22:30 <jcapitao[m]> ah, this time we'll not have to unpin non os puppet modules
14:22:37 <amoralej> wrt unpin tempest plugins, that's more 1st post-task :)
14:22:42 <amoralej> ah, right!
14:22:54 <spotz[m]> A few highlights are added to the announcmeent:)
14:23:06 <amoralej> we need to check in which cases we are falling back to master and manage them
14:23:41 <amoralej> looks great
14:23:59 <amoralej> please, review my additions, i don't trust my wording :)
14:24:32 <amoralej> i've added a comment about automated deps as that was our big achievement during this release
14:25:04 <jcapitao[m]> nice
14:26:04 <amoralej> jcapitao[m], i've left a couple of comments in https://review.rdoproject.org/r/c/rdo-website/+/50577/
14:26:25 <jcapitao[m]> just read them
14:26:29 <jcapitao[m]> thank you
14:26:49 <jcapitao[m]> much better with --setopt
14:26:50 <amoralej> i tested the commands in a container but please test them just in case
14:26:59 <amoralej> config-manager syntax is tricky
14:26:59 <rdogerrit> Merged rdo-jobs master: Create weirdo jobs to gate promotion to bobcat-release  https://review.rdoproject.org/r/c/rdo-jobs/+/50578
14:27:07 <jcapitao[m]> ok I will
14:27:20 <rdogerrit> Joel Capitao proposed rdoinfo master: Promote RDO Bobcat GA builds to the CloudSIG repo  https://review.rdoproject.org/r/c/rdoinfo/+/50576
14:28:04 <jcapitao[m]> ^ I guess it will fail b/c I need to enable epel in ansible-role-weirdo-puppet-opensack for scenarion 1 and 4
14:28:30 <amoralej> and also i expect it may fail because of missing l2gw-test-tempest ?
14:28:45 <amoralej> i'd say one p-o-i scenario installs it
14:28:47 <jcapitao[m]> yeah
14:28:54 <amoralej> although, i'm not totally sure tbh
14:29:17 <jcapitao[m]> but I want to check if there is another issue before
14:29:26 <amoralej> sure, np
14:30:01 <amoralej> so, i think that's it wrt this topic?
14:31:00 <jcapitao[m]> yep
14:32:16 <amoralej> #topic open floor
14:33:07 <amoralej> is there any topic you'd like to share?
14:33:40 <amoralej> next week is ptg
14:34:51 <amoralej> there is topic about removing centos9 support from devstack in qa call
14:34:52 <amoralej> https://etherpad.opendev.org/p/oct2023-ptg-qa
14:34:59 <amoralej> fyi, if interested in joining
14:36:38 <jcapitao[m]> nothing else to bring on my side
14:39:07 <amoralej> then i will close the mtg
14:39:18 <amoralej> thanks for joining!
14:39:21 <amoralej> ah
14:39:27 <amoralej> chair for nextg meeting!
14:39:41 <jcapitao[m]> I can take it
14:39:53 <amoralej> #action jcapitao to chair next week
14:40:07 <amoralej> thanks jcapitao[m] !
14:40:11 <amoralej> #endmeeting