14:01:54 <jcapitao[m]> #startmeeting RDO meeting - 2024-02-14
14:01:54 <opendevmeet> Meeting started Wed Feb 14 14:01:54 2024 UTC and is due to finish in 60 minutes.  The chair is jcapitao[m]. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:54 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:54 <opendevmeet> The meeting name has been set to 'rdo_meeting___2024_02_14'
14:01:56 <jcapitao[m]> it's meeting time
14:02:14 <amoralej_> o/
14:02:16 <jcapitao[m]> please add your topic in https://etherpad.opendev.org/p/RDO-Meeting
14:03:12 <jcapitao> #topic roll call
14:03:20 <karolinku[m]> o/
14:03:41 <jcapitao> #chair amoralej karolinku[m]
14:07:17 <jcapitao> ok let's start with first topic
14:07:23 <jcapitao> #topic Moving from RHBZ to Jira
14:07:53 <amoralej> I added that
14:08:34 <amoralej> #info RDO is moving the activity tracking to https://issues.redhat.com/projects/RDO/
14:09:02 <amoralej> #info a new component has been created for packstack, all packstack issues should be reported to RDO jira project now
14:10:11 <amoralej> we should include it in packstack README file i think
14:10:19 <jcapitao> +1
14:10:42 <amoralej> there is some info in https://wiki.openstack.org/wiki/Packstack btw
14:11:14 <amoralej> I'm not sure how is that maintained
14:12:00 <amoralej> apparently i can update it
14:12:28 <jcapitao> #action RDO core team to edit packstack documentation to set RDO JIRA as new issue tracker
14:13:13 <spotz[m]> o/ Sorry I'm late had a quick impromptue meeting
14:13:32 <jcapitao> #chair spotz[m]
14:13:40 <jcapitao> hey spotz
14:13:44 <amoralej> i just updated https://wiki.openstack.org/wiki/Packstack#Bugs so it seems to work :)
14:14:11 <jcapitao> oh nice !
14:14:13 <jcapitao> it was quick
14:14:41 <amoralej> yep, just wiki direct edit
14:14:56 <karolinku[m]> huh, no code kept
14:15:10 <jcapitao> ahh ok
14:17:21 <amoralej> i guess any authenticated user can edit it
14:17:26 <amoralej> so, it's done :)
14:18:22 <spotz[m]> clicked through for me but I might be logged in
14:18:53 <jcapitao> do we still want to add JIRA reference in packstack README ?
14:19:00 <jcapitao> https://github.com/redhat-openstack/packstack/
14:19:35 <jcapitao> well there is a link redirecting to https://wiki.openstack.org/wiki/Packstack
14:19:39 <jcapitao> so it should be ok
14:19:43 <spotz[m]> Yeah there should be how to report a bug
14:19:55 <amoralej> yep, i think that'd be good
14:20:37 <jcapitao> ok, so I keep the action I put in meeting notes
14:21:35 <amoralej> #info a banner has been added to bugzilla.redhat.com for RDO product bugs with message "RDO tickets are now tracked in Jira https://issues.redhat.com/projects/RDO/issues/ "
14:21:54 <spotz[m]> Good work!
14:22:02 <amoralej> so, from now on, requests should be reported in jira
14:22:19 <jcapitao> https://issues.redhat.com/browse/RDO-240 FTR
14:22:58 <amoralej> i've added to epic "Migration to Jira" :)
14:23:45 <jcapitao> good
14:23:47 <spotz[m]> Do we have all the tags we need?
14:23:59 <amoralej> you mean components ?
14:24:35 <spotz[m]> Maybe, let me click the link again:)
14:24:40 <amoralej> we have created three components
14:24:48 <amoralej> https://issues.redhat.com/projects/RDO?selectedItem=com.atlassian.jira.jira-projects-plugin:components-page
14:24:50 <spotz[m]> Or labels
14:25:37 <amoralej> yeah, so there are two different things, component and labels, components are more project-admin think, while label are any text, and created under demand
14:25:42 <spotz[m]> I don't know if we need everything that an internal project has but we might want what we had in Bugzilla
14:26:17 <amoralej> in bugzilla we had one component per package (hundreds of them), i think we don't need that much
14:26:18 <jcapitao> actually we reproduced the same component we had in BZ
14:26:40 <jcapitao> I mean the used one
14:26:52 <amoralej> for new packages, i think a label new-package would be appropiate
14:27:01 <amoralej> or something similar
14:27:32 <jcapitao> under contenido comp ?
14:27:37 <amoralej> yes
14:27:49 <jcapitao> WFM
14:27:57 <spotz[m]> Just looked at the components so I'm definitely talking labels like a First Issue, etc
14:28:15 <amoralej> yes, that'd be good
14:28:16 <jcapitao> +1
14:28:44 <jcapitao> we definitely need "easy finx" kind of label
14:28:48 <jcapitao> fix*
14:29:27 <spotz[m]> Maybe a docs one too, not sure which others we might need
14:30:08 <amoralej> actually, we were discussing if docs should be a component or a label
14:30:35 <amoralej> we thought a label may be enough
14:31:47 <spotz[m]> If you can do it outside of the current components it should be a component if it only applies to components a label
14:32:47 <amoralej> labels and components are  unrelated, you can assign a ticket to only one component and the labels you want
14:33:13 <amoralej> and there is no restrictions, i mean, labels can be applied to any ticket on any component
14:33:21 <amoralej> i'm not sure if that's the question
14:33:27 <spotz[m]> But can you have an issue with no component?
14:33:30 <amoralej> yes
14:33:43 <amoralej> most of the tickets we currently have have no component
14:33:52 <amoralej> as we created them just today :)
14:33:54 <karolinku[m]> I would use labels as general grouping, as sth which is jist a label (not very important) so I thin for docs should be rather component
14:34:18 <karolinku[m]> we discover components just today :D
14:34:25 <amoralej> i'd like to see if we can create some kind of kanban or report by labels or components
14:35:11 <karolinku[m]> good point
14:36:34 <amoralej> actually, it seems we can assign more that one component to an issue
14:36:52 <amoralej> https://issues.redhat.com/browse/RDO-13?jql=project%20%3D%20RDO%20AND%20component%20%3D%20maquinaria
14:37:13 <amoralej> that's list of issues to one component, i.e.
14:37:19 <amoralej> i just added one to test
14:37:39 <amoralej> ah, there we can also list by label
14:38:10 <amoralej> https://issues.redhat.com/browse/RDO-181?jql=project%20%3D%20RDO%20AND%20labels%20%3D%20RDO-TRUNK-INFRA
14:38:20 <rdogerrit> mathieu bultel proposed openstack/os-diff-distgit rpm-master: Add os-diff specfile for rdo-package  https://review.rdoproject.org/r/c/openstack/os-diff-distgit/+/51560
14:38:27 <amoralej> label:RDO-TRUNK-INFRA
14:39:55 <amoralej> i've just created a favorit filter "RDO-TRUNK-INFRA issues" , i'm not sure if that's just visible for me or for the project
14:40:17 <jcapitao> I can see it too
14:40:51 <jcapitao> personnally, I think we should create doc comp
14:40:57 <spotz[m]> Where in Jira?
14:41:21 <jcapitao> and keep label to increase flexibility if we want to group some issues together
14:41:32 <jcapitao> like we do in Gerrit
14:41:58 <amoralej> works for me
14:42:08 <amoralej> i mean, adding a new documentation component
14:42:13 <karolinku[m]> yeah, like we can have different kind of docs in one compnent
14:42:19 <karolinku[m]> so we can differ them by labels
14:42:42 <amoralej> ok, go ahead and create it, you should be able to do it
14:43:04 <amoralej> spotz[m], in https://issues.redhat.com/issues/?jql=
14:43:17 <amoralej> there is "Favorite Filters" in the left pannel
14:43:27 <amoralej> i see "RDO-TRUNK-INFRA issues"
14:43:39 <amoralej> that's what i created, you see it or just me?
14:44:07 <spotz[m]> Ahh I was looking in jira:) btw I’m not logged and could see everything in RDO which is good
14:44:19 <amoralej> yep
14:45:17 <jcapitao> https://issues.redhat.com/projects/RDO?selectedItem=com.atlassian.jira.jira-projects-plugin:components-page
14:45:57 <jcapitao> 15 min left
14:47:00 <amoralej> yep
14:47:12 <jcapitao> amoralej: is there something else for this topic ?
14:47:18 <amoralej> wrt bz triage, we have done some progress but still in progress
14:47:42 <amoralej> we will keep working on it ansynchronously and will report next week
14:48:01 <jcapitao> I cleaned the "Package Review" comp
14:48:07 <amoralej> let me put some number
14:48:27 <jcapitao> 3 leftovers but sill active
14:48:44 <jcapitao> os-diff cyborg and edpm-ansible
14:48:50 <amoralej> #info the number of open bz to RDO component is 254
14:49:05 <jcapitao> in distribution comp you mean ?
14:49:06 <amoralej> it was > 300 yesterday i think
14:49:12 <amoralej> in all comps
14:49:20 <jcapitao> ah!
14:49:40 <jcapitao> that's a good progress
14:49:41 <amoralej> https://bugzilla.redhat.com/buglist.cgi?bug_status=NEW&bug_status=ASSIGNED&bug_status=__open__&columnlist=product%2Ccomponent%2Cassigned_to%2Cbug_status%2Cshort_desc%2Cchangeddate%2Cbug_severity&list_id=13414005&order=summary%2C%20&product=RDO&query_format=advanced
14:50:05 <amoralej> actually, 253 right now, one has been closed :)
14:50:27 <jcapitao> I'll keep working on the CVEs async
14:50:40 <amoralej> ok, let's sync jcapitao as i'm also working on it
14:50:55 <jcapitao> ok
14:51:00 <jcapitao> let's move to next topic
14:51:04 <karolinku[m]> anything left besides CVE's?
14:51:34 <jcapitao> #topic RDO Caracal 2024.1 preparation
14:51:55 <spotz[m]> Wow it's that time already
14:51:57 <jcapitao> karolinku[m]: I didn't check the other BZ tbh
14:52:25 <amoralej> how fast it runs
14:52:28 <jcapitao> so this week is R-6
14:52:29 <karolinku[m]> ok, we can sync later
14:52:35 <jcapitao> #link https://releases.openstack.org/caracal/schedule.html
14:52:58 <amoralej> so one of the priorities now should be to handle all the dep updates we have in gerrit
14:53:05 <jcapitao> #info it's R-6 - Final release for non-client libraries
14:53:46 <amoralej> https://review.rdoproject.org/r/q/branch:c9s-caracal-rdo+status:open
14:53:58 <amoralej> 53
14:54:01 <jcapitao> +1 for the deps
14:54:08 <jcapitao> #link https://issues.redhat.com/browse/RDO-208
14:54:23 <jcapitao> we should split the work to address that
14:54:32 <karolinku[m]> omg
14:54:49 <amoralej> yep
14:55:11 <karolinku[m]> let's create a ticket! :D as share the work
14:55:45 <spotz[m]> hehe
14:56:15 <amoralej> i have the list of reviews
14:56:28 <amoralej> i can paste it in somewhere (etherpad)? to distribute
14:56:33 <jcapitao> WFM
14:56:46 <karolinku[m]> ok
14:56:51 <jcapitao> otherwise the DLRN bootstrap can be started next week I'd say, wdyt ?
14:57:29 <amoralej> as soon as libs are released and frozen
14:58:05 <jcapitao> starting Feb 26 then
14:58:07 <amoralej> https://review.rdoproject.org/etherpad/p/caracal-deps-updates
14:58:25 <jcapitao> so we can focus on dep update
14:58:34 <amoralej> i'll just split in three similar groups by order
14:59:11 <jcapitao> #info the DLRN bootstrap for Caracal will start around Feb 26
14:59:23 <jcapitao> thanks amoralej
15:00:10 <jcapitao> I take last group
15:00:12 <jcapitao> #topic chair next week
15:00:14 <spotz[m]> #link https://review.rdoproject.org/etherpad/p/caracal-deps-updates
15:00:43 <jcapitao> who's willing to chair next week ?
15:00:51 <karolinku[m]> I can take it
15:01:00 <jcapitao> #action karolinku[m] to chair next week
15:01:07 <jcapitao> thanks karolinku[m]
15:01:44 <jcapitao> and we are out of time !
15:01:47 <spotz[m]> Thanks karolinku
15:02:19 <jcapitao> the JIRA topic was too verbose :D
15:02:32 <jcapitao> I'm gonna close the meeting
15:02:34 <jcapitao> #endmeeting