14:02:45 <amoralej> #startmeeting RDO meeting - 2024-02-21
14:02:45 <opendevmeet> Meeting started Wed Feb 21 14:02:45 2024 UTC and is due to finish in 60 minutes.  The chair is amoralej. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:45 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:02:45 <opendevmeet> The meeting name has been set to 'rdo_meeting___2024_02_21'
14:03:22 <amoralej> #topic roll call
14:03:29 <karolinku[m]> o/
14:03:43 <amoralej> #chair karolinku[m] spotz[m]
14:03:43 <opendevmeet> Current chairs: amoralej karolinku[m] spotz[m]
14:03:45 <spotz[m]> o/
14:03:51 <jcapitao[m]> Io/
14:05:01 <amoralej> #chair jcapitao[m]
14:05:01 <opendevmeet> Current chairs: amoralej jcapitao[m] karolinku[m] spotz[m]
14:05:13 <amoralej> let's start with the first topic
14:05:38 <amoralej> #topic Upstream Yoga is in unmaintained status, what about in RDO ?
14:05:56 <amoralej> #link https://releases.openstack.org/index.html
14:06:03 <amoralej> who added it?
14:06:10 <jcapitao[m]> me
14:06:22 <amoralej> go ahead
14:06:46 <jcapitao[m]> should we treat it as extended maintenance in RDO ?
14:07:18 <jcapitao[m]> currently in automation we treat maintained and extended_maintenance release equally
14:07:27 <amoralej> yes
14:07:43 <amoralej> actually, iiuc unmaintained is like a new name for EM
14:08:00 <amoralej> branches are renamed but still opened for patches
14:08:14 <jcapitao[m]> e.g https://github.com/rdo-infra/review.rdoproject.org-config/blob/master/playbooks/rdoinfo/upper-constraints-update/run.yaml#L19
14:08:20 <amoralej> so, i'd keep trunk running on it as we did for EM
14:09:11 <amoralej> i'd stick to extended_maintanance name in rdoinfo
14:09:30 <jcapitao[m]> IIUC unmaintained is kind of EM for SLURP releases
14:09:48 <jcapitao[m]> +1 to set as "extended_maintanance" in RDO
14:10:59 <jcapitao[m]> to avoid changing tooling for smth which is not that much relevant for RDO point of view
14:11:27 <amoralej> exactly
14:11:49 <rdogerrit> Karolina Kula proposed deps/python-autobahn c9s-caracal-rdo: WIP: Update to 23.6.2  https://review.rdoproject.org/r/c/deps/python-autobahn/+/51285
14:12:37 <jcapitao[m]> ok I'll propose the rdoinfo change then
14:13:03 <amoralej> also we should remove yoga from maintained cloudsig releases in https://www.rdoproject.org/rdo/release-cadence/
14:13:55 <jcapitao[m]> right
14:13:56 <amoralej> also, we should set xena as em in the doc
14:14:15 <jcapitao[m]> alright
14:14:43 <jcapitao[m]> I'll propose the changes alongside that rdoinfo patch
14:14:51 <amoralej> #info Yoga is in unmaintained status upstream
14:15:34 <amoralej> #info CloudSIG repo for RDO Yoga will not receive more fixes or updates and will not be tested anymore
14:16:15 <amoralej> #info RDO Trunk repo for RDO Yoga will keep running and building patches that are merged in unmaintained/yoga branch
14:16:33 <amoralej> ^ is meeting minutes enough or we should send a mail about it?
14:17:48 <jcapitao[m]> hmmm I'd say meeting minutes are enough as it's regular policy
14:18:37 <spotz[m]> Maybe when we email out say something like check below for important info. #info I think shows up in the log snippet we email
14:19:22 <amoralej> ok
14:19:35 <amoralej> good ideas
14:19:39 <amoralej> next topic?
14:19:50 <jcapitao[m]> FTR https://issues.redhat.com/browse/RDO-248
14:20:00 <jcapitao[m]> and that's it yes
14:20:13 <amoralej> #topic Remove trunk data for Train, Ussuri and Victoria
14:20:20 <amoralej> jcapitao[m], ^ that's what you meant, right?
14:20:44 <jcapitao[m]> right
14:20:45 <amoralej> #link https://issues.redhat.com/browse/RDO-169
14:21:16 <amoralej> so, the only reason to not have deleted them is the user who sent the mail to ML, right?
14:21:39 <jcapitao[m]> re [rdo-users] CentOS 7 Packages
14:21:42 <jcapitao[m]> yes
14:22:34 <jcapitao[m]> I think we can at least remove all except centos7-master
14:23:01 <amoralej> it was centos7-master or centos7-train ?
14:23:04 <amoralej> what he was using?
14:23:18 <jcapitao[m]> based on his email https://trunk.rdoproject.org/centos7-master/current-passed-ci/
14:23:34 <amoralej> right
14:23:41 <amoralej> https://lists.rdoproject.org/archives/list/users@lists.rdoproject.org/thread/HJ6UFKFJDO2JX3AN4ANIAMMMACOFFIXN/
14:24:04 <amoralej> i already proposed several times that he should mirror it locally
14:24:28 <amoralej> it's more than 2 months ago
14:24:30 <amoralej> ...
14:24:41 <amoralej> for sure, we can remove everything but that one
14:26:16 <jcapitao[m]> yep...
14:26:18 <spotz[m]> If it's possible let's leave it but say it will be removed on x date and can't be extended further
14:26:34 <jcapitao[m]> +1
14:26:40 <amoralej> March the 1st ?
14:26:49 <jcapitao[m]> setting a deadline might help
14:27:26 <spotz[m]> That's only a week, give him atleast 2 or up to 4
14:27:51 <spotz[m]> your choice
14:28:01 <jcapitao[m]> yeah March 15th ?
14:28:15 <amoralej> ok
14:28:53 <jcapitao[m]> but I'll remove the other trunk datas in the meantime
14:28:57 <spotz[m]> works for me
14:29:27 <amoralej> ok
14:30:06 <amoralej> #info repos in https://trunk.rdoproject.org/centos7-master/ will be removed on March the 15th. This date can not be extended further
14:30:23 <jcapitao[m]> you want me to communicate the deadline in the ML thread amoralej  ?
14:30:31 <amoralej> #info the rest of repos for train/ussuri/victoria will be removed in the next days
14:30:46 <spotz[m]> yeah makes sense to keep that together
14:30:55 <amoralej> ok, let's reply in that thread
14:31:45 <amoralej> i will reply
14:31:47 <amoralej> next topic
14:31:54 <amoralej> #topic RDO Caracal 2024.1 preparation
14:32:43 <spotz[m]> I pulled over the Bobcat release announcement to give us a start on that
14:33:02 <spotz[m]> #link https://review.rdoproject.org/etherpad/p/caracal-release-announcement
14:33:07 <amoralej> #link https://review.rdoproject.org/etherpad/p/caracal-release-announcement#L111
14:33:15 <amoralej> sorry, duplicated :)
14:33:17 <amoralej> #undo
14:33:17 <opendevmeet> Removing item from minutes: #link https://review.rdoproject.org/etherpad/p/caracal-release-announcement#L111
14:33:44 <amoralej> #link https://issues.redhat.com/projects/RDO/issues/RDO-208
14:34:06 <spotz[m]> I was helping:)
14:34:07 <amoralej> we are almost done with dependencies updates
14:34:11 <amoralej> thanks :)
14:34:51 <amoralej> https://review.rdoproject.org/r/q/topic:deps-uc-update+status:open
14:35:03 <amoralej> other than that, i think next week we can start creating the new builder
14:35:17 <spotz[m]> Nice!
14:36:02 <jcapitao[m]> yes next week is M3
14:36:19 <jcapitao[m]> 2 weeks after it's RC1
14:36:22 <jcapitao[m]> https://releases.openstack.org/caracal/schedule.html
14:37:26 <amoralej> good
14:37:57 <amoralej> also, once clients are released, we can create branches for libs and clients
14:38:05 <amoralej> and no reqcheck ... :)
14:39:23 <jcapitao[m]> yeah !
14:39:44 <jcapitao[m]> thanks pyproject-rpm-macros
14:39:50 <amoralej> :)
14:40:23 <amoralej> anything else to discuss wrt this topic ?
14:41:33 <jcapitao[m]> nope that's it from me
14:41:54 <amoralej> #topic OpenInfra events
14:42:04 <amoralej> #info PTG 8-12 April 2024
14:42:19 <amoralej> #link https://ptg2024.openinfra.dev/?_ga=2.102896896.169964397.1708372315-92231857.1702575652
14:42:31 <amoralej> #info OpenInfra Days Sweden 7 May 2024 Volvohallen, Gothenburg, Sweden
14:42:40 <spotz[m]> Thanks!
14:42:42 <amoralej> #link https://oideurope2024.openinfra.dev/
14:42:54 <amoralej> #link CfP https://docs.google.com/forms/d/e/1FAIpQLSfCvmgoq_9cqIDxz2K3ZI5dPZvsUSaaksGJpVEKt-6U89Udzg/viewform
14:43:08 <amoralej> #info OpenInfra Days Turkiye 20 May 2024 Albert Long Hall Cultural Center, Boğaziçi University, Istanbul, Turkiye
14:43:20 <amoralej> #link https://openinfraturkiye.org.tr/event-registration/
14:43:38 <amoralej> #link https://openinfraturkiye.org.tr/call-for-presentations
14:43:50 <amoralej> #info Switzerland Meetup 6 June 2024 CERN, Geneva, Switzerland
14:44:00 <amoralej> #link https://indico.cern.ch/event/1376907/
14:44:21 <amoralej> good :)
14:44:35 <amoralej> something to add wrt events?
14:44:52 <spotz[m]> Ok so there are 4 OpenInfra events currently open with registration. The virtual PTG and then OpenInfra Days Sweden and Turkiye which also have CFPs and will be in person. Switzerland Meetup will also be in person and can be registered for but no CFP yet. Switzerland is at CERN and has a very limited capacity so if you're thinking of goin you should register sooner vs later
14:45:03 <jcapitao[m]> no Paris yet ?
14:46:12 <spotz[m]> I thought they had signed the contract but not yet, it will be in May and it's about 30-45 minutes outside the city, I don't reember the town name but I think it had a University
14:47:04 <spotz[m]> We have dates for Germany but no registration or CFP info on that one yet. I figured as I have links to share I'd keep adding them to the meeting.
14:47:08 <jcapitao[m]> okk
14:48:24 <amoralej> thanks for sharing
14:49:01 <rdogerrit> Merged deps/python-autopage c9s-caracal-rdo: Update to 0.5.2  https://review.rdoproject.org/r/c/deps/python-autopage/+/51286
14:49:14 <spotz[m]> My pleasure, and some of these might be close enough for folks to attend:)
14:49:31 <amoralej> not for me, but maybe for jcapitao[m]
14:49:41 <jcapitao[m]> in Paris for sure
14:49:56 <spotz[m]> I haven't heard of a Spain one, not sure if there's a meetup group
14:50:29 <amoralej> it used to exist years ago, but i don't think it's active anymore
14:51:17 <rdogerrit> Merged deps/python-importlib-metadata c9s-caracal-rdo: Update to 6.8.0  https://review.rdoproject.org/r/c/deps/python-importlib-metadata/+/51297
14:51:47 <amoralej> anyone is willing to chair next week?
14:52:09 <jcapitao[m]> I can take it
14:52:23 <amoralej> #action jcapitao[m] will chain next week
14:52:27 <amoralej> #topic open floor
14:52:32 <amoralej> anything you'd like to share ?
14:52:36 <spotz[m]> Thanks jcapitao
14:53:53 <jcapitao[m]> nothing else from me
14:54:04 <spotz[m]> I'm good too!
14:54:26 <amoralej> ok, so i'm closing the mtg
14:54:31 <amoralej> thank you all for joining!
14:55:01 <spotz[m]> Thanks for leading amoralej and thanks everyone for joining!
14:55:05 <amoralej> #endmeeting