14:01:30 <karolinku[m]> #startmeeting RDO meeting - 2024-04-10
14:01:30 <opendevmeet> Meeting started Wed Apr 10 14:01:30 2024 UTC and is due to finish in 60 minutes.  The chair is karolinku[m]. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:30 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:01:30 <opendevmeet> The meeting name has been set to 'rdo_meeting___2024_04_10'
14:01:35 <amoralej> o/
14:02:04 <karolinku[m]> #chair amoralej spotz
14:02:04 <opendevmeet> Warning: Nick not in channel: spotz
14:02:04 <opendevmeet> Current chairs: amoralej karolinku[m] spotz
14:02:16 <rdogerrit> Joel Capitao proposed config master: Remove validate-dependencies-rebuilds and rebuild-fedora-dependencies  https://review.rdoproject.org/r/c/config/+/52777
14:02:37 <jcapitao[m]> o/
14:02:49 <karolinku[m]> #chair jcapitao
14:02:49 <opendevmeet> Current chairs: amoralej jcapitao karolinku[m] spotz
14:05:13 <karolinku[m]> #topic RDO Caracal 2024.1 preparation
14:07:39 <jcapitao[m]> there is no updates since last week
14:07:55 <jcapitao[m]> we built the final releases
14:08:12 <spotz[m]> woohoo?
14:08:38 <karolinku[m]> #info final releases are built
14:08:58 <jcapitao[m]> we promoted them very them recently https://review.rdoproject.org/r/c/rdoinfo/+/52774
14:10:01 <jcapitao[m]> but we are waiting for the puppet module to be released in order to be able to promote GA build in -release tag
14:10:15 <spotz[m]> So what are we looking at timeline wise?
14:10:43 <jcapitao[m]> hopefully end of next week I'd say
14:10:46 <amoralej> tkajinam ^ any expected timeline for puppet modules Caracal release ?
14:11:15 <tkajinam> I'll proposed a release this week. am still waiting for a few patches and have been packed by PTG session, sorry
14:11:24 <spotz[m]> Nice!
14:11:30 <amoralej> thanks tkajinam++ !
14:12:02 <jcapitao[m]> no worries thanks
14:13:13 <jcapitao[m]> amoralej: wrt https://issues.redhat.com/browse/RDO-232 - the tagging operation in extras9s-extras-common-testing is done manually by an authenticated and authorized cloudsig user right ?
14:13:44 <amoralej> yes
14:15:23 <jcapitao[m]> mmh I should try then (once repo populated ofc)
14:15:39 <jcapitao[m]> IIRC last time I tried but didn't work
14:17:27 <amoralej> mmm we should be able to find group members
14:17:50 <jcapitao[m]> https://accounts.centos.org/group/sig-cloud/ ?
14:18:46 <amoralej> that's for cloudsig, i mean for extras repo
14:19:04 <amoralej> there is a specific group for the users that can build and tag in extras tags
14:19:07 <spotz[m]> There's also OKD and other folks in there don't forget
14:19:28 <amoralej> they wanted to have one person per sig, i think
14:19:45 <amoralej> note that any build in those tags are added by default to all centos servers
14:20:17 <amoralej> https://accounts.centos.org/group/sig-extras/
14:20:17 <spotz[m]> 1 admin yes though we have 2 + me
14:20:59 <amoralej> if you want, jcapitao as chair can replace me
14:21:07 <jcapitao[m]> ah okk that's why
14:21:21 <jcapitao[m]> no it's ok as it is now
14:21:23 <amoralej> lorbus is also there
14:21:49 <spotz[m]> We should have elections, we've been doing those in March the last 2 years
14:22:10 <amoralej> oh, two years already!
14:22:19 <amoralej> time run fast
14:22:26 <jcapitao[m]> I'll build the centos-release-openstack-caracal RPM and let you tag it in extras tag
14:22:54 <jcapitao[m]> yeah definitely ..
14:22:57 <spotz[m]> I giess this will be the third one since we cleaned up and rebooted the SiG
14:25:29 <karolinku[m]> is that all in this topic?
14:25:55 <jcapitao[m]> I think so yes
14:26:40 <spotz[m]> Just a reminder as we get closer to the release the announcement needs to be completed
14:27:16 <karolinku[m]> contrubutor list? or just review?
14:28:00 <amoralej> i'd say both
14:28:08 <amoralej> content and contributor lists
14:28:30 <spotz[m]> Contributor lists, the highlights section and review. I can grab the general highlights but if there's things special for our release we want to mention we have that part
14:28:39 <amoralej> we need to add something about the inactive projects we have retired
14:28:57 <spotz[m]> Last I checked the general highlights weren't updated as it was way before release
14:30:12 <spotz[m]> Probably grab 1 or 2 from cinder, glance, keystone, nova, neutron, manila, and both the horizon ones
14:32:20 <karolinku[m]> #topic How to handle CentOS stream 8 EOL
14:32:33 <karolinku[m]> #link https://blog.centos.org/2023/04/end-dates-are-coming-for-centos-stream-8-and-centos-linux-7/
14:33:43 <amoralej> so, i CentOS Stream is going EOL in end of may
14:34:26 <amoralej> my current question is, specifically, about RDO Trunk repos for wallaby, xena and yoga in CentOS 8
14:35:08 <amoralej> my intention is to remove them by that date
14:35:23 <amoralej> and leave only CS9 ones
14:36:56 <karolinku[m]> what else can we do?
14:37:01 <jcapitao[m]> +1
14:37:05 <karolinku[m]> keep EOL builds?
14:37:09 <amoralej> we could yes
14:37:20 <amoralej> keep the repos available in the server for some time
14:37:28 <amoralej> with latest status
14:37:41 <jcapitao[m]> I think we should announce now in ML
14:37:53 <amoralej> yes
14:37:54 <karolinku[m]> I would vote for removing
14:38:01 <jcapitao[m]> I mean the whole timeline
14:38:31 <amoralej> so that users who are willing to keep using them have time to copy it locally
14:38:45 <jcapitao[m]> to avoid the situation we had with C7 and let the community time to organize/anticipate
14:38:53 <jcapitao[m]> yes exactly
14:39:05 <amoralej> well, for that we also announced it with time ... :)
14:39:17 <amoralej> but yeah, let's do our part
14:39:44 <jcapitao[m]> right
14:39:54 <jcapitao[m]> let me check the notice period we gave
14:40:21 <spotz[m]> Just be prepared to have to keep something around or reinstated like last time
14:40:32 <karolinku[m]> #info we will inform on ML about date of Centos8 repos removal
14:41:02 <karolinku[m]> #undo
14:41:02 <opendevmeet> Removing item from minutes: #info we will inform on ML about date of Centos8 repos removal
14:41:59 <karolinku[m]> #info RDO Trunk repos for wallaby, xena and yoga on CentOS 8 will be removed due to EOL. There will be anouncement on mailing list about exact time.
14:42:27 <amoralej> actually, I'd like to stop the centos8 builders slightly before, one week or so
14:42:47 <amoralej> note that those three are in unmaintained status
14:43:46 <jcapitao[m]> we gave 8 weeks period notice for C7 which was pretty good
14:45:29 <jcapitao[m]> right, so not a big deal to stop before then
14:45:31 <amoralej> yep, i think it'd be good to announce this asap
14:46:16 <jcapitao[m]> dunno if there is that much activity in unmaintained branches
14:48:09 <jcapitao[m]> https://review.opendev.org/q/branch:unmaintained/wallaby+status:merged+-owner:infra-root@openstack.org
14:48:17 <jcapitao[m]> https://review.opendev.org/q/branch:unmaintained/xena+status:merged+-owner:infra-root@openstack.org
14:48:24 <jcapitao[m]> not that much
14:48:49 <amoralej> https://review.opendev.org/q/branch:unmaintained/yoga+status:merged
14:49:07 <spotz[m]> There shouldn't be, so we should be able to shut the builds early
14:49:08 <jcapitao[m]> yeah I was looking at yoga
14:49:13 <jcapitao[m]> there are much more patches
14:49:30 <amoralej> probably less in two months ...
14:50:22 <karolinku[m]> #topic open floor
14:50:43 <karolinku[m]> next RDO Guard is karolinku
14:50:55 <karolinku[m]> who wants to chair next week?
14:52:21 <amoralej> i can take it
14:52:40 <karolinku[m]> #action amoralej is chairing next week
14:53:44 <karolinku[m]> do we have anything else to discuss?
14:54:58 <amoralej> who will do the announcement for centos EOL ?
14:55:06 <karolinku[m]> I can
14:55:44 <amoralej> thanks karolinku[m] !
14:56:55 <karolinku[m]> #endmeeting