14:05:41 <jcapitao[m]> #startmeeting RDO meeting - 2024-06-26
14:05:41 <opendevmeet> Meeting started Wed Jun 26 14:05:41 2024 UTC and is due to finish in 60 minutes.  The chair is jcapitao[m]. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:05:41 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:05:41 <opendevmeet> The meeting name has been set to 'rdo_meeting___2024_06_26'
14:05:46 <jcapitao[m]> #topic Roll Call
14:05:59 <jcapitao[m]> #chair karolinku spotz
14:05:59 <opendevmeet> Warning: Nick not in channel: karolinku
14:05:59 <opendevmeet> Warning: Nick not in channel: spotz
14:05:59 <opendevmeet> Current chairs: jcapitao[m] karolinku spotz
14:06:11 <spotz[m]> o/
14:06:30 <jcapitao[m]> #chair karolinku[m] spotz[m]
14:06:30 <opendevmeet> Current chairs: jcapitao[m] karolinku karolinku[m] spotz spotz[m]
14:08:51 <jcapitao[m]> #topic Wallaby, Xena, Yoga and Zed Trunk builders teardown ?
14:09:26 <jcapitao[m]> I summarized the topic in https://issues.redhat.com/browse/RDO-303
14:09:33 <spotz[m]> Zed EOL already?
14:09:52 <jcapitao[m]> it's in unmaintained status
14:10:04 <jcapitao[m]> so to be clear, this a poll
14:11:38 <jcapitao[m]> nothing decided for the moment
14:12:01 <karolinku[m]> the discussion started around p-o-i
14:12:33 <jcapitao[m]> upstream p-o-i CI is in bad state currently for the unmaintained releases
14:12:46 <karolinku[m]> because xena and wallaby CI jobs there were based on centos8 which is EOL now
14:12:52 <spotz[m]> We actually talked a little about the CS8 stuff in the TC meeting yesterday
14:14:10 <spotz[m]> I think it's safe to retire though 2, Yoga and Zed we'd need to really look at the effort involved. Maybe this would be a good place to get some contributions to help get them running on CS9
14:14:22 <karolinku[m]> so, we have 3 options... (full message at <https://matrix.org/_matrix/media/v3/download/matrix.org/NsLTARVhUQeExGNKDOwyvyAE>)
14:14:25 <spotz[m]> s/though/those/
14:16:48 <jcapitao[m]> with option 2 we would possibly merge broken code that will be caught by RDO CI, which would be tricky to fix and test
14:17:29 <spotz[m]> I think we do 1, but see if 3 is possible with help
14:19:30 <jcapitao[m]> yeah, IMHO we should try to fix Yoga and Zed at least
14:19:41 <jcapitao[m]> zed is ok https://review.opendev.org/c/openstack/puppet-openstack-integration/+/920099
14:20:07 <karolinku[m]> but, tbh, 2 or 3 means for us that we would have to become a maintainers of unmaintained branches in p-o-i
14:20:22 <karolinku[m]> because except us noone is interested in it
14:21:41 <jcapitao[m]> right
14:22:50 <jcapitao[m]> other solution is to remove p-o-i coverage, and stick with packstack only
14:24:02 <spotz[m]> I’m mentally thinking of the folks we keep having to put repos back up and how this would affect that
14:26:01 <jcapitao[m]> if we got some help it would be manageable, I don't expect big changes in those unmaintained branches that would require puppet module or p-o-i changes
14:26:21 <jcapitao[m]> we can give a try for Yoga and Zed I'd say
14:27:09 <jcapitao[m]> but for Wallaby and Xena that are based on CS8 upstream, we might get rid of them
14:29:59 <spotz[m]> So maybe we put out we’re going to retire wallaby and Xena. And to move yoga and zed we need help
14:34:24 <jcapitao[m]> ok let's write down something to raise this point
14:35:11 <jcapitao[m]> #info Wallaby and Xena may be retired in the following months but we're asking community if anyone is still interested in building the eventual patches for those releases
14:36:12 <spotz[m]> and assistance migrating to cs9:)
14:36:21 <jcapitao[m]> #info RDO is asking for help to maintain Yoga and Zed in puppet-openstack-integration
14:37:33 <jcapitao[m]> let's see we have any feedback from the community
14:38:57 <jcapitao[m]> let's move to next topic
14:39:07 <jcapitao[m]> #topic Webpage review
14:39:39 <jcapitao[m]> #link https://github.com/rdo-infra/rdo-mkdocs-website
14:39:50 <jcapitao[m]> #link https://rdo-infra.github.io/rdo-mkdocs-website/
14:40:15 <spotz[m]> Need to get you a better Spenser:)
14:40:51 <karolinku[m]> probably! I found only this one
14:41:13 <karolinku[m]> make it transparent with imagemagick
14:41:37 <spotz[m]> Cn we change the shade of red or are we locked to that one by the theme? I know we discussed different names, I think I owe you those
14:42:03 <karolinku[m]> yes, the color and gradient is fully customizable
14:42:13 <karolinku[m]> let me point it
14:42:44 <spotz[m]> Ok I know we have a code for the maroon we use
14:43:01 <karolinku[m]> color: https://github.com/rdo-infra/rdo-mkdocs-website/blob/master/docs/stylesheets/extra.css#L2
14:43:28 <spotz[m]> Ok I'll look for it or ask Tiger for it before he goes on PTO next week
14:49:08 <spotz[m]> So to be clear, updates to wording and grammar should be done here and it's not in gerrit yet? But for like meeting updates we're still going through the old site.
14:49:08 <spotz[m]> Just so I'm working in the right place:)
14:49:13 <jcapitao[m]1> s/synced/mirrored/
14:49:14 <jcapitao[m]1> this repo is syned to Github repo https://github.com/rdo-infra/rdo-mkdocs-website
14:49:14 <jcapitao[m]1> it will be managed in https://review.rdoproject.org/r/q/project:rdo-infra/rdo-mkdocs-website
14:51:07 <spotz[m]> Ok so where would you like me to work?:)
14:52:02 <karolinku[m]> the naming
14:52:14 <karolinku[m]> I remember "factory" was sth to discuss
14:52:33 <karolinku[m]> and also - the content and the sequence of topics
14:55:24 <spotz[m]> Ok I got it cloned - git clone https://review.rdoproject.org/r/rdo-infra/rdo-mkdocs-website  in cse anyone else wants to clone to contribute
14:56:06 <jcapitao[m]1> 👍️
14:58:13 <jcapitao[m]1> IMHO factory is a good wording, but I'm not an expert in english vocabulary :)
14:58:54 <jcapitao[m]1> spotz: do you think we can get this merge and migrate next week ?
14:59:10 <jcapitao[m]1> with new spencer and color change ?
14:59:58 <jcapitao[m]1> we're out of time
15:00:24 <jcapitao[m]1> I'll close the meeting but we can continue the discussion
15:00:25 <spotz[m]> Will do my best
15:00:46 <jcapitao[m]1> #topic Next RDO watcher is jcapitao
15:01:00 <jcapitao[m]1> ack
15:01:12 <jcapitao[m]1> #topic Next Chair
15:01:23 <jcapitao[m]1> who's willing to chair next week ?
15:02:48 <karolinku[m]> i will be on PTO
15:03:07 <spotz[m]> Video call, I potentially have a conflict at the half unless it's canceled
15:03:27 <spotz[m]> Do we want to do a quick check in or cancel?
15:03:28 <jcapitao[m]1> alright, I'll chair it
15:03:44 <jcapitao[m]1> #action jcapitao will chair next week
15:03:52 <spotz[m]> If it's just us it'll be quick:)
15:03:59 <jcapitao[m]1> amoralej will be back ;)
15:04:06 <spotz[m]> Sweet
15:04:26 <jcapitao[m]1> #endmeeting
15:04:27 <spotz[m]> Sounds like a plan! Thanks for leading today too
15:05:21 <jcapitao[m]1> thank you for joining !
15:05:52 <jcapitao[m]1> looks like we don't have the meetbot logs :(
15:07:32 <karolinku[m]> oh no:(
15:08:02 <jcapitao[m]1> ah, it's because the IRC server sees me as jcapitao[m]1
15:08:12 <jcapitao[m]1> according to https://meetings.opendev.org/meetings/rdo_meeting___2024_06_26/2024/rdo_meeting___2024_06_26.2024-06-26-14.05.log.txt
15:08:43 <jcapitao[m]1> #endmeeting