13:59:48 <amoralej> #startmeeting RDO meeting - 2024-07-17
13:59:48 <opendevmeet> Meeting started Wed Jul 17 13:59:48 2024 UTC and is due to finish in 60 minutes.  The chair is amoralej. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:59:48 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:59:48 <opendevmeet> The meeting name has been set to 'rdo_meeting___2024_07_17'
14:00:14 <amoralej> #topic roll call
14:01:22 <spotz[m]> o/
14:01:51 <jcapitao[m]> o/
14:01:58 <amoralej> #chair spotz[m] jcapitao[m]
14:01:58 <opendevmeet> Current chairs: amoralej jcapitao[m] spotz[m]
14:02:23 <amoralej> you can add your topics to https://etherpad.opendev.org/p/RDO-Meeting
14:04:55 <spotz[m]> topic added
14:05:13 <amoralej> #topic Fedora rebuild with python 3.13
14:05:27 <amoralej> there is ongoing rebuild of python packages with 3.13 in fedora
14:05:47 <karolinku[m]> o/
14:05:48 <amoralej> check if you still have any ftbfs or fail to install BZ assigned related to it
14:05:59 <amoralej> #chair karolinku[m]
14:05:59 <opendevmeet> Current chairs: amoralej jcapitao[m] karolinku[m] spotz[m]
14:06:24 <amoralej> there is known issue with python-eventlet and python-logutils that i'm aware
14:07:08 <amoralej> i've unblocked most (or all) the openstack client packages, but check if any of the packages that you managed is blocked and if it can be unblocked
14:08:31 <amoralej> that's it for that topic
14:09:11 <jcapitao[m]> do you have the BZ filter ?
14:09:44 <amoralej> not one that i can trust in, tbh
14:10:03 <amoralej> i've been filtering by bugs with needinfo tag assigned to one of us
14:10:36 <amoralej> but i'm not sure how to check all the bugs where openstack-sig or one of us is admin or comaintainer
14:11:07 <amoralej> or even better, any package that we import as dependency in rdo
14:11:11 <amoralej> that'd be nice
14:11:19 <jcapitao[m]> I searched with "F41FailsToInstall"
14:11:19 <jcapitao[m]> assigned to me
14:11:31 <jcapitao[m]> I have python-only oslo-db and python-pecan
14:11:46 <amoralej> yeah, pecan is blocked by logutils
14:11:55 <amoralej> oslo-db, we don't import that one, right?
14:12:00 <amoralej> that's in openstack-sig ?
14:12:22 <amoralej> mmm it is
14:12:34 <amoralej> any client depends on oslo-db ?
14:13:16 <jcapitao[m]> I don't think so
14:13:22 <jcapitao[m]> maybe we can retire it
14:13:31 <amoralej> eventlet seems to be just test-requirement
14:13:41 <amoralej> not mandatory runtime one, so we may be able to skip it
14:14:22 <amoralej> https://github.com/openstack/oslo.db/blob/master/requirements.txt
14:14:29 <amoralej> let's try to disable it as BR
14:15:11 <amoralej> apparently there is a parameter TEST_EVENTLET that we can set to 0 to skip eventlet testing https://github.com/openstack/oslo.db/blob/a59dba4479f9f391b63901b847d25a77093a460a/oslo_db/tests/__init__.py#L20
14:17:29 <jcapitao[m]> ok I'll take care of it
14:18:50 <amoralej> so, that's it
14:18:54 <amoralej> let's move to next topic
14:19:10 <amoralej> #topic     SWAG update
14:20:00 <amoralej> spotz[m], that's yours
14:25:28 <amoralej> i guess spotz[m] is not available now, let's move to next topic
14:25:34 <amoralej> #undo
14:25:34 <opendevmeet> Removing item from minutes: #topic SWAG update
14:25:56 <amoralej> #info amoralej will be RDO guard next week
14:26:12 <amoralej> is anyone willing to chair next week?
14:26:27 <karolinku[m]> I can take it
14:26:32 <spotz[m]> So basically the vendor has been a bit slow in communication, I was trying to have things in production by July 1. Unfortunately that didn't happen and they need color codes from us but Tiger is on PTO for the month. I've asked if they code us the same colors as the backpacks as they have those and I'm waiting for an answer
14:26:43 <amoralej> #action karolinku[m] will chair next week
14:26:50 <amoralej> #topic     SWAG update
14:26:52 <spotz[m]> s/code/could/
14:27:26 <spotz[m]> So that's where we are on SWAG, it might actually be cold by the time we get them:(
14:27:45 <amoralej> :)
14:27:50 <amoralej> so just in time
14:28:26 <amoralej> thanks for the update
14:28:31 <amoralej> #topic open floor
14:28:42 <amoralej> any other topic you'd like to share ?
14:28:45 <spotz[m]> Did folks see the thread on the ML?
14:29:01 <amoralej> which one?
14:29:21 <spotz[m]> Please hold:)
14:29:41 <amoralej> sure :)
14:29:54 <spotz[m]> https://lists.rdoproject.org/archives/list/dev@lists.rdoproject.org/thread/HPSSLR4A6VG5RQEZO5VC3IJVDTS2LQ4S/
14:30:12 <jcapitao[m]> ah yes
14:30:12 <spotz[m]> Caracal bug that someone patched
14:30:23 <jcapitao[m]> a patch was submitted upstream
14:30:32 <jcapitao[m]> so the automation will do the job once merged
14:31:09 <amoralej> yeah, once it's in a release, it'd be built
14:31:16 <jcapitao[m]> but someone already replied in the Openstack ML
14:31:41 <amoralej> https://review.opendev.org/c/openstack/releases/+/924299
14:31:43 <rdogerrit> Daniel Pawlik proposed config master: Add workaround for machineconfigpool degradation when CRC 2.36 or lower  https://review.rdoproject.org/r/c/config/+/53817
14:32:18 <jcapitao[m]> wrt git-review issue on EL9, I handled it c.f https://bugzilla.redhat.com/show_bug.cgi?id=2280367
14:32:41 <spotz[m]> Ok perfect just checking:)
14:32:55 <amoralej> i just replied
14:33:06 <jcapitao[m]> it should land in stable repo next week, we'll just have to update trunk builder
14:33:25 <amoralej> good
14:33:54 <amoralej> so you are now comaintainer for git-review, right ?
14:34:08 <jcapitao[m]> yep
14:34:21 <amoralej> good
14:34:34 <amoralej> we will have faster responses now, i guess :)
14:35:03 <amoralej> you tested if fixes the bug we hit, right?
14:35:16 <jcapitao[m]> it depends ;)
14:35:26 <amoralej> :)
14:35:27 <jcapitao[m]> I haven't tested it yet
14:35:40 <jcapitao[m]> I just checked that the release built contains the fix
14:35:56 <amoralej> ok, i'll do a quick test later
14:36:19 <jcapitao[m]> ack
14:39:12 <amoralej> any other topic ?
14:39:24 <spotz[m]> not from me
14:39:55 <karolinku[m]> nop
14:39:59 <jcapitao[m]> not from me neither
14:40:41 <amoralej> so, i will close the meeting and will give you some minutes back
14:40:44 <amoralej> thanks for joining!
14:40:52 <amoralej> #endmeeting