14:06:40 <karolinku[m]> #startmeeting RDO meeting - 2024-11-20
14:06:40 <opendevmeet> Meeting started Wed Nov 20 14:06:40 2024 UTC and is due to finish in 60 minutes.  The chair is karolinku[m]. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:06:40 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:06:40 <opendevmeet> The meeting name has been set to 'rdo_meeting___2024_11_20'
14:06:54 <karolinku[m]> #chair jcapitao spotz
14:06:54 <opendevmeet> Warning: Nick not in channel: jcapitao
14:06:54 <opendevmeet> Warning: Nick not in channel: spotz
14:06:54 <opendevmeet> Current chairs: jcapitao karolinku[m] spotz
14:08:44 <karolinku[m]> #topic  Devstack dependencies for CS10
14:09:39 <jcapitao[m]> #link https://issues.redhat.com/browse/RDO-377
14:09:45 <jcapitao[m]> #info CS10 dependencies for devstack are available (except for Ceph still WIP)
14:09:55 <jcapitao[m]> #link https://trunk.rdoproject.org/centos10-master/delorean-deps.repo
14:10:07 <spotz[m]> Great job!
14:10:08 <jcapitao[m]> #info RDO is working on adding support of CS10 in DIB and nodepool in order to test CS10 support in DevStack
14:10:24 <jcapitao[m]> #link https://review.opendev.org/c/openstack/diskimage-builder/+/934045
14:10:42 <jcapitao[m]> #link https://issues.redhat.com/browse/RDO-386
14:12:34 <jcapitao[m]> wrt Ceph kkeithle is still waiting for some deps to land in EPEL10
14:12:35 <jcapitao[m]> https://bugzilla.redhat.com/show_bug.cgi?id=2313795
14:12:50 <jcapitao[m]> https://bugzilla.redhat.com/show_bug.cgi?id=2324160
14:13:52 <jcapitao[m]> they are runtime deps
14:14:03 <jcapitao[m]> but Ceph itself is already built https://cbs.centos.org/koji/taskinfo?taskID=4293073
14:15:03 <jcapitao[m]> and shipped https://mirror.stream.centos.org/SIGs/10-stream/storage/x86_64/ceph-squid/ but still not installable
14:16:05 <karolinku[m]> DIB image build has virtualization architecture issues
14:17:24 <jcapitao[m]> yes, we have 2 issues
14:17:54 <jcapitao[m]> first one is that CS10 needs v3 x86_64 microarch CPU to run fully
14:18:24 <jcapitao[m]> which is not the case for main opendev CI/CD hardware
14:18:44 <jcapitao[m]> so we are now testing with the nested-virt label
14:19:38 <jcapitao[m]> and we are hitting the second issue that devstack infra (on which we launch our CS10 image with Nova) is in bad state
14:19:52 <jcapitao[m]> so the job is failing
14:21:12 <jcapitao[m]> btw karolinku I doubted you last PS will work, because the env var should be define for the devstack infra, not inside the CS10 image
14:21:58 <karolinku[m]> yes, I know, just a shot before figuring out how to inject it in devstack
14:22:20 <karolinku[m]> tbh I'm not sure this is possible from this repo
14:22:42 <jcapitao[m]> okk, it's not that obvious..
14:22:55 <jcapitao[m]> yeah that was my interrogation yesterday
14:23:11 <karolinku[m]> it should be placed in local.conf for devstack
14:24:19 <jcapitao[m]> right, but who knows how/where to update this file
14:24:52 <spotz[m]> Anyone running devstack should know local.conf
14:24:55 <karolinku[m]> let's not trash mtg logs with debugging
14:26:08 <jcapitao[m]> ok, that's it for this topic
14:28:02 <spotz[m]> Ok and I just added events
14:28:25 <karolinku[m]> #topic events
14:28:43 <spotz[m]> Figured I'd get our premeeting discussion in the log:)
14:29:08 <spotz[m]> OpenInfra NA will be March 6-7, 2025 in Pasadena, CFP is closed
14:30:26 <spotz[m]> Our combined stand with CentOS and OKD did not get selected for FOSDEM but I am planning on submitting an OpenStack BoF. CentOS Connect will be October 30-31 right before FOSDEM and the CFP is open.
14:30:50 <spotz[m]> OpenInfra Summit is slated for Europe in 2025, still working on when and where
14:30:52 <karolinku[m]> what is BoF?
14:31:49 <spotz[m]> Birds of a Feather, so a relaxed chat session
14:35:04 <spotz[m]> That's it for me
14:36:12 <karolinku[m]> ok
14:36:31 <karolinku[m]> #action Next RDO watcher is karolinku
14:36:46 <karolinku[m]> who would like to chair next meeting?
14:37:34 <spotz[m]> I took next week off
14:38:05 <jcapitao[m]> I can take it
14:38:18 <jcapitao[m]> enjoy your PTO spotz !
14:39:12 <spotz[m]> Thanks, I need to start taking time off
14:40:37 <karolinku[m]> #action Next Chair is jcapitao
14:40:46 <karolinku[m]> #topic openfloor
14:42:58 <jcapitao[m]> I have nothing to add
14:43:09 <jcapitao[m]> for the watch status, everything is fine
14:43:49 <jcapitao[m]> just one update needed recently
14:43:51 <jcapitao[m]> https://src.fedoraproject.org/rpms/python-dogpile-cache/pull-request/9
14:44:05 <jcapitao[m]> waiting for Fedora PR to be merged
14:44:25 <jcapitao[m]> https://review.rdoproject.org/r/c/rdoinfo/+/55506/comments/9c9422bd_ede51109
14:44:33 <karolinku[m]> and this update cames from promotions?
14:46:13 <jcapitao[m]> it cames from upstream requirements patch being merged
14:47:38 <jcapitao[m]> https://review.opendev.org/c/openstack/requirements/+/935049
14:49:27 <karolinku[m]> ack
14:49:49 <karolinku[m]> #endmeeting