14:06:15 <karolinku[m]> #startmeeting RDO meeting - 2025-02-12
14:06:15 <opendevmeet> Meeting started Wed Feb 12 14:06:15 2025 UTC and is due to finish in 60 minutes.  The chair is karolinku[m]. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:06:15 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
14:06:15 <opendevmeet> The meeting name has been set to 'rdo_meeting___2025_02_12'
14:06:26 <karolinku[m]> i'm chair today
14:06:44 <spotz[m]> We have a volunteer:)
14:08:30 <karolinku[m]> #topic roll call
14:08:48 <spotz[m]> o/
14:08:53 <jcapitao[m]> o/
14:09:16 <zaq> o /
14:10:04 <karolinku[m]> #chair jcapitao spotz zaq
14:10:04 <opendevmeet> Warning: Nick not in channel: jcapitao
14:10:04 <opendevmeet> Warning: Nick not in channel: spotz
14:10:04 <opendevmeet> Current chairs: jcapitao karolinku[m] spotz zaq
14:11:52 <karolinku[m]> ok, first topic
14:12:13 <karolinku[m]> #topic C10 progress
14:12:55 <karolinku[m]> process of building dependency in C10 is done now
14:13:18 <karolinku[m]> so first batch of promotion was introduced today
14:13:29 <jcapitao[m]> well, not really done but almost
14:13:47 <karolinku[m]> yeah, there are always some leftovers
14:13:52 <jcapitao[m]> I decided to submit first batch to parallelize the work
14:14:23 <jcapitao[m]> I hope I won't hit a RDO project missing a dep at the very beginning :)
14:14:37 <jcapitao[m]> until now it's ok https://trunk.rdoproject.org/centos10-master/report.html
14:15:02 <jcapitao[m]> but some tweak are required now as per https://review.rdoproject.org/r/c/openstack/oslo-config-distgit/+/56401
14:15:11 <jcapitao[m]> comparing to CS9 I mean
14:15:55 <jcapitao[m]> so I'm bootstrapping the centos10-master trunk (i.e building the RDO RPMs)
14:16:16 <jcapitao[m]> and in parallel, I'm checking and assessing the missing deps
14:16:36 <jcapitao[m]> ~100 deps to assess
14:19:14 <jcapitao[m]> I might start building the puppet deps https://issues.redhat.com/projects/RDO/issues/RDO-445
14:20:01 <spotz[m]> And these are both Epoxy?
14:20:32 <jcapitao[m]> only cs10-master for now
14:20:43 <jcapitao[m]> then centos10-epoxy will inherit from it
14:21:20 <jcapitao[m]> when we'll branch master to prepare Epoxy
14:22:00 <jcapitao[m]> we'll start in 2-3 weeks I think
14:23:15 <jcapitao[m]> hopefully we'll have glean supporting NetworkManager keyfiles by then
14:23:27 <spotz[m]> If there’s anything the volunteers can help with let them know
14:24:06 <jcapitao[m]> after the bootstrapping for sure
14:25:27 <spotz[m]> +1
14:25:37 <jcapitao[m]> karolinku: wrt glean patch, how is it going ?
14:26:04 <karolinku[m]> thaaats tricky, more than i thought
14:27:12 <karolinku[m]> keyfiles are network manager-oriented, so it is better to not write to them directely
14:27:50 <jcapitao[m]> there is a NM utility to convert ifcfg to keyfile
14:27:56 <karolinku[m]> so if using nmcli, it may be tproblem with sequencing
14:28:12 <karolinku[m]> oh, I though about it. but it would be awful
14:28:50 <karolinku[m]> there is not even ifcfg files in c10, it would have to be artificially written
14:29:46 <jcapitao[m]> yes but glean generates the ifcfg, it would be one additional step to convert it to ifcfg the way NM wants
14:30:38 <jcapitao[m]> dunno if there is a python API to interact with NM
14:31:42 <jcapitao[m]> https://fedoramagazine.org/using-python-and-networkmanager-to-control-the-network/
14:32:25 <spotz[m]> Do we need to maybe talk to the Fedora folks to bounce ideas off of?
14:33:27 <karolinku[m]> im talking with opendev folks about it
14:33:51 <spotz[m]> ok
14:35:09 <jcapitao[m]> ok good
14:35:33 <karolinku[m]> next topic
14:35:59 <karolinku[m]> #topic OpenInfra Foundation announcement
14:36:21 <spotz[m]> I just wanted to make sure the RDO community was aware of an announcement made by the OpenInfra Foundation
14:36:25 <spotz[m]> #link https://lists.openinfra.org/archives/list/foundation@lists.openinfra.org/thread/3B7OWPRXB4KD2DVX7SYYSHYYRNCKVV46/
14:37:10 <spotz[m]> They are looking at the possibility of perhaps moving to the Linux Foundation as a sub Foundation similar to the CNCF.
14:37:55 <spotz[m]> They are asking that any questions be sent in response to that message to kep everything together so if not subscribed to the list you would need to join
14:38:22 <spotz[m]> #link https://lists.openinfra.org/mailman3/lists/foundation.lists.openinfra.org/
14:38:40 <jcapitao[m]> thank you
14:38:46 <spotz[m]> More information including a meeting for today/tomorrow can be found
14:38:48 <spotz[m]> #link https://board.openinfra.org/en/strategic-consideration
14:39:04 <spotz[m]> Does anyone have any questions?
14:39:54 <jcapitao[m]> not from my side
14:41:25 <spotz[m]> I don't see anyone typing so that's it from me
14:41:36 <zaq> Hi
14:41:45 <spotz[m]> Hi Zaq
14:42:49 <zaq> I am new here, I wish to know how to get a list of packages in need of contributions/maintainers.
14:43:02 <zaq> How do I go about that?
14:43:43 <jcapitao[m]> hi zaq
14:44:04 <jcapitao[m]> you can find all the packages we are providing in https://github.com/redhat-openstack/rdoinfo/
14:44:13 <jcapitao[m]> or with rdopkg CLI
14:44:41 <jcapitao[m]> rdopkg reads remotely the rdoinfo repo
14:45:51 <jcapitao[m]> you can start by updating one of the dependencies
14:45:57 <jcapitao[m]> e.g https://review.rdoproject.org/r/q/topic:deps-uc-update+status:open
14:46:14 <zaq> Okay, thank you.
14:46:35 <jcapitao[m]> there is more info in our doc https://www.rdoproject.org/contribute/requirements/#adding-a-new-requirement-to-rdo
14:48:13 <spotz[m]> And keep in mind except if there's a meeting this channel is pretty async but if you have any questions you can tag someone and they'll respond when they can
14:48:24 <spotz[m]> There's also the rdo-dev mailing list
14:48:43 <jcapitao[m]> +1
14:50:44 <zaq> Noted.
14:51:17 <zaq> Thanks.
14:54:16 <karolinku[m]> who would like to chair next meeting?
14:54:46 <jcapitao[m]> I can take it
14:55:52 <karolinku[m]> #action jcapitao is chairing next week
14:56:07 <karolinku[m]> and you are also next watcher
14:56:22 <karolinku[m]> btw, im fixing swith FTBFS
14:58:03 <jcapitao[m]> ack
14:58:38 <karolinku[m]> do we have anything else for today?
14:59:03 <spotz[m]> Don't think so. I have put next weeks section up in case folks want to prepopulate:)
15:00:29 <jcapitao[m]> nothing else from me
15:00:46 <karolinku[m]> #endmeeting