22:03:22 <vipul> #startmeeting Reddwarf
22:03:23 <openstack> Meeting started Tue Nov 20 22:03:22 2012 UTC.  The chair is vipul. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:03:24 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:03:25 <openstack> The meeting name has been set to 'reddwarf'
22:03:46 <vipul> Don't have an official agenda link as of yet
22:04:13 <vipul> looks like there may be some stuff here
22:04:16 <vipul> #link http://wiki.openstack.org/Meetings/RedDwarfMeeting
22:05:10 <vipul> #topic Action Items
22:05:27 <vipul> So going off the agenda, let's review the action items from previous week
22:05:32 <hub-cap> vipul: i added that agenda
22:05:37 <SlickNik> sounds good.
22:05:56 <hub-cap> want to do action items by person or the list above?
22:06:04 <vipul> hub-cap: suer
22:06:22 <vipul> grapex: any update on the launchpad site?
22:06:39 <hub-cap> ive done all the necessaries for the 3 launchpad sites
22:06:52 <hub-cap> reddwarf, python-reddwarfclient and reddwarf-integration
22:07:07 <SlickNik> Sounds good, hub-cap.
22:07:23 <SlickNik> I've already started using the reddwarf-integration one.
22:07:30 <spiffxp> hub-cap: any reason to use you specifically for driver instead of reddwarf-drivers?
22:07:31 <hub-cap> sweet
22:07:38 <hub-cap> link plz
22:07:54 <spiffxp> https://launchpad.net/reddwarf
22:07:57 <hub-cap> there is likely not  agood reason
22:08:04 <hub-cap> just prolly forgot to change
22:08:09 <spiffxp> I'll do it now then
22:08:15 <hub-cap> changed
22:08:24 <vipul> sweet
22:08:25 <hub-cap> sry didnt see u were changing :P
22:08:42 <spiffxp> also, the futurestack designation for reddwarf, does that still make sense?  if so, does reddwarfclient need to be added?
22:08:46 <SlickNik> #info reddwarf-integration launchpad site: https://launchpad.net/reddwarf-integration
22:09:03 <hub-cap> spiffxp: im not sure what the futurestack thing is... jaypipes added it back in the day
22:09:13 <hub-cap> maybe he can chime in :D
22:09:36 <vipul> spiffxp - i don't think it matters that much, supposedly as long as it's a subproject of openstack then everything is cool
22:09:43 <cp16net> hub-cap: looks like the pre-incubating project area
22:09:45 <spiffxp> seems like ceilometer and heat aren't using it?
22:09:52 <hub-cap> ya its likely just old
22:09:52 <SlickNik> #info Reddwarf client binding launchpad site: https://launchpad.net/python-reddwarfclient
22:09:57 <hub-cap> that page was added a LONG time ago
22:10:01 <hub-cap> thx SlickNik for those infoz
22:10:18 <jaypipes> hub-cap: long time ago...
22:10:20 <vipul> the next item was for grapex to own CI - assume this means getting the integration tests in?
22:10:20 <spiffxp> ok I'm going to remove that if no objections
22:10:23 <hub-cap> if yall see any issues w/ them hit me up
22:10:27 <jaypipes> it's dead, AFAIK
22:10:32 <hub-cap> jaypipes: lol ya, do u know is tha tfuture....ok :)
22:10:35 <jaypipes> heh
22:10:39 <hub-cap> lets remove it then
22:11:23 <vipul> or should i refer to him as GrapeX2
22:11:42 <SlickNik> @hub-cap: np
22:11:53 <hub-cap> grapex, GrapeX2, GrapeX3, GrapeX4
22:12:00 <cp16net> grapes
22:12:01 <cp16net> lol
22:12:01 <hub-cap> depends on how many tiems hes logged in to irc
22:12:25 <cp16net> yeah hes away right now i think
22:12:33 <hub-cap> vipul: lets chat about that in a bit
22:12:38 <hub-cap> its one of the agenda items
22:12:52 <hub-cap> its big enough to warrant further discussion than a action item
22:13:03 <vipul> Yep, that's next, if we're done talking about the launchpad site
22:13:20 <hub-cap> thats all the action items?
22:13:31 <vipul> i'm going by person
22:13:34 <hub-cap> AH
22:13:44 <hub-cap> http://wiki.openstack.org/Meetings/RedDwarfMeeting
22:13:49 <hub-cap> that has the next item as CI
22:14:01 <hub-cap> lets skip it in the ActionItems portion and talk about it after all the action items have been done
22:14:16 <cp16net> sounds good
22:14:44 <SlickNik> sounds good, let's move on to the next item.
22:15:14 <hub-cap> yar. lets wait for GrapeXY
22:15:20 <hub-cap> whre Y is a number > 0
22:15:38 <vipul> k, so let's move on to the next action item
22:15:44 <vipul> hubcap: devstack integration status
22:15:52 <hub-cap> that got passed to jcooley
22:15:57 <hub-cap> see item #2
22:16:02 <hub-cap> :P
22:16:13 <hub-cap> 3 is done
22:16:14 <cp16net> haha
22:16:34 <hub-cap> 4 is done, and i havent been online to talk to lifeless or devananda about the image stuff, but its on my list
22:16:47 <rnirmal> Greetings
22:16:51 <hub-cap> #action hub_cap talk to lifeless or devananda about the image creation
22:16:51 <lifeless> hub-cap: o/
22:16:53 <spiffxp> jcooley was offline a good chunk of last week as well
22:17:00 <hub-cap> lifeless: im on paternity leave still :)
22:17:05 <vipul> ugh i should use the list on top
22:17:16 <hub-cap> vipul: likely thats the best way
22:17:26 <SlickNik> Yeah, I think 2 is still on jcooley's plate.
22:18:07 <jcooley> remind me of #2 and I'll give an update.
22:18:12 <hub-cap> to discuss devstack integration
22:18:20 <devananda> oh, hai
22:18:33 <hub-cap> as in configuration of reddwarf via devstack jcooley
22:18:36 <hub-cap> hai devananda
22:18:41 <jcooley> yes.  discussed with mordred, need to discuss with devstack folks.  still outstanding.
22:18:46 <SlickNik> hey devananda.
22:19:02 <hub-cap> #action jcooley to discuss reddwarf devstack integration w/ devstack folks
22:19:16 <SlickNik> Sweet, thanks jcooley!
22:19:27 <vipul> Ok, we're on 5 I believe.. Reddwarf-core completed
22:19:37 <vipul> 6 is related.. so done
22:19:43 <jcooley> np
22:20:03 <hub-cap> we did a great job w #7
22:20:05 <vipul> 7 - Make sure reviews have blueprints or bugs
22:20:11 <hub-cap> goodjob to everyone on that one
22:20:12 <vipul> yep - we're getting better
22:20:17 <spiffxp> yeah now that I've tripped over that twice I'm watching for it
22:20:21 <SlickNik> Nice. Thx.
22:20:35 <vipul> 8 - grapex to own CI and make sure it gets accomplished
22:20:40 <cp16net> oh yeah i mentioned that earlier :-P
22:20:41 <hub-cap> grapex is having connection issues
22:20:52 <cp16net> i didnt realize until today we had these meetings...
22:20:55 <vipul> ok we'll wait for his response offline
22:20:57 <hub-cap> so hes doing his best to connect up
22:21:12 <grapen> Sorry guys
22:21:33 <hub-cap> is that grapex? grapen?
22:21:37 <SlickNik> Ah, welcome! Np.
22:21:38 <vipul> lol
22:21:57 <grapen> We're traveling back from San Antonio today. I've been using Nirmal's cell phone with a pretty decent connection, but we got weird issues trying to join freenode just now.
22:22:09 <hub-cap> Oh ure on da bus
22:22:19 <yidclare> grape[n]
22:22:33 <hub-cap> rnirmal: thx for allowing grapeKERJ#H$#KXNK#J!@@#$%%%1223456 to use your cell
22:22:36 <grapen> Where "n" is the number of times I tried to connect.
22:22:43 <hub-cap> lol
22:22:48 <SlickNik> heh
22:22:49 <hub-cap> so youre up, CI status
22:23:07 <grapen> By the way, this is the real GrapeX and not a hacker. Now that I've assured you...
22:23:24 <grapen> hub-cap: Well we've got a huge chunk of tests running in CI.
22:23:36 <grapen> We still need to run tests in real mode somehow.
22:23:52 <hub-cap> awesome. so they are running as part of the jenkins gate job now?
22:24:19 <grapen> Yes, because its tox it naturally plugs into the Jenkins gate stuff.
22:24:38 <grapen> As part of this, the client is now in PyPi.
22:24:38 <vipul> hub-cap grapen - they are running currently as unit tests would
22:24:41 <hub-cap> awesome. so some work accomplished, def some more to go
22:24:43 <grapen> mordred and I co-own it. Apparently all the uploads to PyPi happen manually.
22:24:45 <esp1> anyone have a link to the jenkins box handy?
22:24:50 <grapen> Yeah
22:24:57 <grapen> HP has done a lot of work getting the public RDLI environment to run.
22:25:02 <vipul> #link jenkins.openstack.org
22:25:05 <spiffxp> #link https://jenkins.openstack.org/view/Stackforge/job/gate-python-reddwarfclient-python26/
22:25:06 <hub-cap> esp1: its in all the reviews in gerrit as well
22:25:23 <esp1> thx :)
22:25:36 <hub-cap> ok we are for sure falling behind :) grapen anythign more to add?
22:25:49 <esp1> hmm. pretty.
22:26:04 <vipul> 9 - hub_cap make sure the client launchpad page is up to date w/ the series like the reddwarf one
22:26:04 <esp1> well except the thunder clouds
22:26:11 <hub-cap> vipul: check
22:26:12 <grapen> The next thing we've got to do is find some way to get CI for the RDLI tests running in real mode on a Jenkins box that can plug into Gerrit.
22:26:29 <hub-cap> and we need to figure out the image creation for that too
22:26:30 <SlickNik> Yeah, a few of us here at HP were looking at running the tests in real mode. Will take that offline with grapex…
22:26:40 <spiffxp> hub-cap vipul fwiw I just went through and configured support and answers on that page to use launchpad too
22:26:47 <vipul> grapen: I think that's what the whole devstack integration work is going to turn into
22:26:49 <hub-cap> ok i guess that bleeds us in to the next section, and we can just summarize it then eh?
22:26:52 <hub-cap> spiffxp: sweet thx
22:27:01 <vipul> it will involve adding a redstack-gate job and run integration tests in real mode
22:27:38 <spiffxp> k, done w/ action items?
22:27:41 <vipul> ok anything more to add?
22:28:01 <hub-cap> not here
22:28:01 <vipul> #topic CI / Image Updates
22:28:03 <SlickNik> nay
22:28:27 <vipul> I can speak a bit to the image portion of this
22:28:33 <hub-cap> cool
22:28:52 <rnirmal> hub-cap: Nope, sorry. Getting those tests to run in the main repo with Tox took forever.
22:28:52 <vipul> We're currently working on building out a precise image with percona bits...
22:29:05 <hub-cap> ps we also have a script we might be able to adapt that sets up a bunch of the image stuff. i can find out internally
22:29:16 <grapen> hub-cap: I agree with this rnirmal character.
22:29:23 <hub-cap> vipul: are u using the same process that devananda is?
22:29:26 <hub-cap> :)
22:29:35 <vipul> we're going to fix the image buildling code in redstack as the first step - and eventually make it so that you can build hp/rax images
22:29:49 <hub-cap> ok great
22:29:51 <vipul> hub-cap - not yet.. this is the interim step to getting things working on precise
22:29:57 <hub-cap> that was a bit of a hack job :P
22:30:06 <hub-cap> vipul: what are u using then? i suggest debootstrap!
22:30:18 <vipul> we're also going to look at Devananda and tripleo's image builders and hook into those
22:30:29 <hub-cap> ok cool
22:30:29 <juice__> hub-cap we are in the process of creating something
22:30:50 <grapen> vipul: Quick question, do we want to stick with Ubuntu 12.4 or go to 12.10?
22:30:56 <hub-cap> juice__: cool. when i get back from paternity leave id like to help out
22:31:11 <juice__> we reviewed the image creation currently in the redstack scripts
22:31:27 <hub-cap> grapen vipul we shoudl stick to what nova uses dont u think? it seems funky to have diff version requirements for things that _could_ be deployed in the same env
22:31:27 <vipul> grapen: We are targetting 12.04 for now, we might want to consider jumping ahead
22:31:46 <spiffxp> 12.04 please
22:31:49 <hub-cap> waht does devstack target?
22:31:59 <spiffxp> we'd like to stick with LTS unless there's a strong reason not to
22:32:00 <vipul> 12.04 hub-cap
22:32:00 <esp1> I think you want a LTS which is 12.04
22:32:01 <hub-cap> cuz if we start usign diff versions / etc tis gonna be a nightmare
22:32:06 <hub-cap> 12.04 it is
22:32:14 <SlickNik> devstack targets 12.04, iirc since it is LTS
22:32:28 <hub-cap> good, lets target that too, i think we are mostly in agreement eh?
22:32:32 <SlickNik> yup
22:32:36 <vipul> yep
22:32:40 <vipul> #link https://github.com/tripleo/baremetal-initrd-builder
22:32:41 <grapen> Sounds good.
22:32:47 <hub-cap> grapen: did u have any reason for 12.10?
22:32:49 <vipul> this is the tripleo image builder that we want to target eventually
22:33:37 <juice__> hub-cap can I reach out to you with a couple questions on the current image building process?
22:33:38 <jcooley> also, i understand that 12.10 has the correct openstack clients
22:33:41 <grapen> hub-cap: No, I thought devstack targeted the latest one. My mistake.
22:34:25 <hub-cap> juice__: plz do, but grapen can help as well if im not very useful (ill be back officially monday)
22:34:28 <hub-cap> but i respond to emails for sure
22:34:43 <hub-cap> id say email us both
22:34:49 <yidclare> #info using Ubuntu 12.04 because it is LTS
22:34:56 <juice__> thanks hub-cap
22:35:19 <vipul> Ok moving on..
22:35:21 <hub-cap> #info need to work on image building / realmode tests
22:35:26 <vipul> any CI updates?
22:35:29 <hub-cap> i dont think we info'd much for that :P
22:35:43 <hub-cap> oh i thought u meant the next topic totally
22:35:53 <vipul> the second part of this topic
22:36:11 <hub-cap> anyone want to own this for the next wk? i think we need to make progress w/ ci
22:36:16 <hub-cap> grapen wink wink
22:36:48 <vipul> One thing i'll point out here is we are trying to get the redstack-gate stuff sorted out - an additional gate on Jenkins that would do real-mode tests
22:36:51 <spiffxp> hub-cap: I will try to help w/ devstack integration but I don't think I can own
22:36:58 <grapen> I'm setting up a VM for the rdli stuff, but getting the fake mode stuff to work in tox took forever.
22:37:10 <vipul> our guys can work with grapen on this
22:37:11 <grapen> Hopefully I'll have some progress made tomorrow.
22:37:13 <spiffxp> #linkhttps://github.com/openstack-ci/devstack-gate/blob/master/README.md
22:37:16 <spiffxp> err...
22:37:18 <spiffxp> #link https://github.com/openstack-ci/devstack-gate/blob/master/README.md
22:37:24 <SlickNik> I can work with grapen on this…
22:37:41 <spiffxp> ooo I one other thing in CI actually
22:37:45 <hub-cap> vipul: id like someone from each group to work together
22:37:54 <hub-cap> so SlickNik or spiffxp?
22:38:19 <spiffxp> I would say SlickNik, I can pester as appropriate
22:38:24 <hub-cap> kk
22:38:25 <vipul> #action SlickNik and grapen to work on redstack-gate
22:38:35 <SlickNik> okay, sounds good spiffxp.
22:38:37 <spiffxp> I knew enough to get reddwarf-integration into stackforge, but I don't think I have the bandwidth to own
22:38:46 <hub-cap> :D cool
22:38:52 <spiffxp> hub-cap: mind adding a "this is deprecated" commit to https://github.com/hub-cap/reddwarf_lite-integration?
22:39:10 <spiffxp> w/ pointer to https://github.com/stackforge/reddwarf-integration
22:39:11 <hub-cap> gonan do it
22:39:18 <hub-cap> if u check out the meeting notes
22:39:18 <hub-cap> Mod rax/reddwarf && hub-cap/reddwarf_lite to point to stackforge
22:39:21 <hub-cap> is on it :)
22:39:26 <spiffxp> ahh k
22:39:34 <vipul> ok let's move on, got a lot to cover
22:39:40 <vipul> #topic blueprinting
22:39:42 <hub-cap> and very little time!
22:39:45 <grapen> So when we say redstack-gate, I think the first job should be to just get any of us running the tests in a VM. After we do that, then lets look at incorporating it into Openstack CI.
22:40:02 <hub-cap> lol we moved on grapen!!!!!! youre too late for input!!
22:40:03 <vipul> grapen: yep, that's the idea, it would be part of the core CI process
22:40:20 <vipul> hub-cap what did you want to discuss aobut blueprinting
22:40:34 <hub-cap> 2 thinkgs
22:40:39 <SlickNik> grapen, let's discuss in #reddwarf after the meeting, when you have some time.
22:40:42 <grapen> vipul: Agreed, just wanted to set everyone's expectations.
22:40:49 <grapen> SlickNik: Ok
22:40:56 <hub-cap> 1) should we shoudl be using our own space or openstack's space? <-- gerrit reviews go to openstack, not reddwarf
22:41:12 <hub-cap> if u look @ grapens tox test commit, it cant find the blueprint
22:41:27 <cp16net> yeah i noticed that for robert's commit earlier
22:41:44 <hub-cap> gotta take dog out brb
22:41:53 <cp16net> i was wondering if there is some configuration we could do for gerrit that would make it point to reddwarf
22:41:57 <vipul> i wonder if that's just an issue with gerrit config
22:41:58 <grapen> I wonder if thats because its a StackForge process.
22:42:03 <grapen> *project*
22:42:11 <vipul> we all wondered the same thing
22:42:21 <spiffxp> might be, I say we action item someone to followup w/ #openstack-infra
22:42:25 <cp16net> i'll look into seeing if thats possible
22:42:38 <cp16net> i'll compare with some of the other proejcts like glance or swift
22:42:50 <vipul> #action cp16net to look into why blueprints in Reddwaf aren't closed with gerrit reviews
22:43:25 <vipul> anything else to add to this?
22:43:52 <vipul> #topic Stackforge
22:44:34 <SlickNik> #action hub-cap to Mod rax/reddwarf && hub-cap/reddwarf_lite to point to stackforge
22:44:35 <hub-cap> #action hub_cap to modify all rax resources to point to stackforge
22:44:38 <hub-cap> LOL
22:44:47 <SlickNik> oops, thought you were still away...
22:44:49 <SlickNik> wb. :)
22:44:54 <vipul> related to Stackforge move, there are a couple of reviews in the pipe that resolve some of the naming issues with RDL and D
22:44:57 <spiffxp> I've got two outstanding reviews to s/reddwarf_lite/reddwarf as well
22:44:57 <vipul> RD
22:45:13 <hub-cap> ya lets remove the lite thing
22:45:17 <hub-cap> all over
22:45:29 <hub-cap> i like reddwarf and reddwarf-integration
22:45:31 <spiffxp> k, just wanted to double-check that wouldn't mess anything up on your end
22:45:32 <vipul> along these lines, can the hub-cap repos be modified to be read-only?
22:45:48 <hub-cap> vipul: yup and as per the action above im going to point them to stackforge
22:45:59 <hub-cap> #action hub-cap also make them readonly
22:46:28 <vipul> Other resources may already point to stackforge
22:46:48 <hub-cap> i tried to mod everything i saw, but there may be others in regard to launchpad
22:46:54 <hub-cap> feel free to update anything i missed
22:47:12 <vipul> #action Look over all references (including launchpad) to reddwarf and ensure they point to stackforge
22:47:31 <hub-cap> who owns that, u?
22:47:46 <vipul> #action vipul owns updating references
22:48:08 <vipul> k.. next topic
22:48:12 <hub-cap> wait
22:48:16 <vipul> k
22:48:24 <hub-cap> #action hub_cap to talk to mordred about why gerrit wont search reddwarf blueprint space
22:48:26 <hub-cap> ok we can move on
22:48:27 <cp16net> hub-cap: i made comments to make the reddwarf-intergration PRs to gerrit instead
22:48:29 <hub-cap> wanted to get that in
22:48:39 <vipul> cp16net had a similar action
22:48:50 <hub-cap> cp16net: cool from the public repo? <3
22:48:51 <cp16net> hub-cap: yeah i have something simiar
22:48:51 <cp16net> "_
22:48:57 <cp16net> yeah
22:49:05 <vipul> #topic os_admin vs root
22:49:22 <hub-cap> vs is such a harsh word ;)
22:49:28 <hub-cap> so i had a question for yall
22:49:39 <vipul> #info background: os_admin user does not exist in public version of RD instances
22:49:43 <hub-cap> does your agent need to access the database?
22:49:48 <SlickNik> #link https://bugs.launchpad.net/reddwarf/+bug/1078981
22:49:59 <uvirtbot> Launchpad bug 1078981 in reddwarf/grizzly "The mysql user that the guest agent uses needs to be different for HP and RAX" [Undecided,New]
22:50:09 <hub-cap> nice :) i like that
22:50:20 <vipul> hub-cap: our implementation will not require login, n o
22:50:45 <hub-cap> ok so maybe we should widen the discussion to _do we need a default login user_ ?
22:50:56 <hub-cap> but im not sure thats good for the meeting
22:51:00 <hub-cap> maybe a ML thing
22:51:19 <vipul> yes - sounds like a larger discussion is needed
22:51:19 <cp16net> ML?
22:51:22 <hub-cap> rax wants one for the users/dbs/root portions but hp doesnt need. i think we need to figure it out
22:51:24 <hub-cap> mailing list cp16net
22:51:27 <cp16net> oh yeah
22:51:55 <hub-cap> #action hub-cap start discussion about the need for the extra actions that require login in reddwarf
22:52:02 <vipul> #info rax wants one for the users/dbs/root portions but hp doesnt need
22:52:03 <hub-cap> i miiiight not get on that for another wk
22:52:14 <hub-cap> but id like to work it out
22:52:28 <hub-cap> id like a nicer way to turn on/off those things that we dont necessarily both need
22:52:46 <cp16net> yeah i agree it could be done multiple ways
22:52:50 <vipul> hub-cap, yep, agreed, although for the public version, we may need to support both ways
22:52:58 <hub-cap> ya so that brings us to
22:52:58 <vipul> and when we deploy, we'd toggle a flag
22:53:07 <hub-cap> shoudl we default the public version to root?
22:53:09 <cp16net> yeah its an option
22:53:13 <hub-cap> and let our stuff flag os_admin
22:53:26 <SlickNik> One idea that was floating around was sone sort of conf toggle.
22:53:44 <hub-cap> grapen, rnirmal cp16net is there anything that would blow up if we default the user to root, and flag it to os_admin?
22:54:07 <hub-cap> i tihnk it might require a change in sneaky pete but i dont think thats a deal breaker or anything
22:54:16 <cp16net> not that i can think of off hand right now.
22:54:19 <hub-cap> specially since yall dont use it :D
22:54:36 <cp16net> yeah i am sure the same change will need to happen in sneaky
22:54:40 <grapen> hub-cap: The only thing is when we reset root we need to make sure the agent can use the updated password, if its also logging in as root.
22:54:51 <grapen> I think that's it, but I feel like I'm forgetting some important edge case.
22:55:09 <hub-cap> grapen, we will still use os_admin, it woudl be a flag that we set in the guest conf
22:55:20 <cp16net> grapen: yeah good thing for tests :)
22:55:27 <hub-cap> so sneaky woudl always still use os_admin for our needs
22:55:31 <hub-cap> or whatever we want to use
22:55:34 <vipul> #info os_admin can be a config so it works for rax/sneaky pete
22:55:47 <hub-cap> it seems that we shooudl do this anyway, cuz a 3rd company might not want to use either of those
22:56:38 <vipul> #action make user configurable in guest agent
22:56:38 <hub-cap> does anyone in particular want to own this?
22:56:59 <vipul> I can drive it on our end...
22:57:13 <hub-cap> #action grapen work w/ vipul to update sneaky once its been pushed
22:57:20 <hub-cap> kk, moving on then?
22:57:24 <juice__> I can look at this as part of building the image yes?
22:57:34 <juice__> must type faster :)
22:57:54 <juice__> I will work with vipul on it
22:57:55 <vipul> juice__ the config would likely be derived at runtime
22:58:01 <vipul> #topic bugchat
22:58:12 <juice__> ok so an orthogonal issue
22:58:16 <juice__> done moving on
22:58:23 <hub-cap> #info ive added milestones and series to all the bugs
22:58:38 <hub-cap> if i missed anything plz notify me or update it :)
22:58:52 <vipul> who owns attaching milestones? reddwarf-core?
22:58:55 <hub-cap> ive tried to put things that are smaller in g2 and that seem bigger in g3
22:59:12 <hub-cap> vipul: not sure i mgith have set myself as the triage, since nova has a single person doing as well
22:59:25 <hub-cap> i _thnk_ ttx only does that, but posssibly a whole team does?
22:59:39 <vipul> do we need to change the way we've been doiing bugs so far?
23:00:02 <cp16net> hub-cap: looks like nova bug team is the manager
23:00:08 <cp16net> or supervisor of the bugs
23:00:15 <hub-cap> hmmm we need to have a bug team then it seems
23:00:17 <spiffxp> I say we have reddwarf-core triage informally
23:00:22 <cp16net> yeah maybe so
23:00:22 <hub-cap> kk
23:00:24 <hub-cap> makes sense
23:00:33 <spiffxp> and take a formal policy up offline or next meeting
23:00:35 <hub-cap> we can mod to do the bug team in the future
23:00:37 <vipul> #info reddwarf-core to triage bugs
23:00:58 <hub-cap> i dont mind triaging as well, so if u dont get around to it, ill try to spend a hr or 2 each wk doing
23:01:01 <cp16net> right now it would be ok to just have the reddwarf-core do it
23:01:20 <vipul> #topic open-discussion
23:01:32 <hub-cap> im chiangin them to reddwarf-core now
23:01:33 <vipul> running out of time... any remaining out of band items?
23:01:35 <yidclare> is there a meeting after us?
23:01:42 <vipul> not sure..
23:01:45 * cp16net shrugs
23:01:51 <hub-cap> i dont think there is a meeting after
23:01:58 <hub-cap> but i dont really have any open items to add....
23:02:07 <spiffxp> hub-cap, grapen: waht's the best way to ping openstack-core when we want a RAX person to look at a review?
23:02:10 <hub-cap> i just add that _in case_ we mised something
23:02:29 <hub-cap> openstack-core? id say ping us in #reddwarf
23:02:30 <spiffxp> I've started add redstack-core to open reviews, but I'm not sure if that's too noisy
23:02:41 <hub-cap> spiffxp: im fine w/ that
23:02:50 <grapen> spiffxp: I'm not worried about the noise.
23:02:54 <vipul> if there is no meeting.. i'll give a quick status update on some things that were not part of action items
23:02:54 <spiffxp> k
23:02:57 <hub-cap> i did notice a review went in today? w/ vipul spiffxp review
23:03:19 <vipul> Work being done to get redstack on precise
23:03:21 <vipul> #link https://etherpad.openstack.org/reddstack-precise-12.04
23:03:32 <hub-cap> ok cool vipul
23:03:43 <cp16net> spiffxp: sounds good
23:03:44 <spiffxp> hub-cap: yah we missed that one I think, I think consensus in #openstack-infra is it's tough to customize that policy too much
23:03:45 <vipul> hp cloud precise images are a bit different from what rax may have -- outline some of teh tweaks we've had to make
23:04:00 <hub-cap> but lets still get some rax eyes on those since they affect our stuff too
23:04:21 <spiffxp> #link https://review.openstack.org/#/c/16552/
23:04:27 <hub-cap> mabye i was wrong tho
23:04:56 <vipul> We're also looking at unit testing holistically
23:05:21 <vipul> #info HP going to be adding tests for python-reddwarfclient and guestagent
23:05:33 <hub-cap> good we abandoned unit testing very quickly but id love to have them back in
23:05:59 <vipul> python-reddwarfclient doesn't seem to have any, so we're working on that
23:06:10 <vipul> and the guestagent probably is not well tested either
23:06:13 <spiffxp> hub-cap: here's the review that made it in w/o RAX eyes fwiw, if you want someone to look at it https://review.openstack.org/#/c/16551/
23:06:15 <grapen> vipul: I'm always for more tests, but we may want to check the code coverage for python-reddwarfclient from the current tox tests in reddwarf
23:06:30 <hub-cap> https://review.openstack.org/#/c/16573/ this one was reviewed by one of our guys but not one of our core
23:06:31 <grapen> vipul: I omitted that directory in the tox.ini file, but you can take that omission out
23:06:33 <hub-cap> id prefer them to be core
23:06:48 <hub-cap> ya spiffxp thats the one i saw today via email
23:06:53 <grapen> vipul: I noticed a lot of stuff in the client wasn't being hit, which kind of shocked me. We may have cruft we should just cut out.
23:06:59 <hub-cap> things like https://review.openstack.org/#/c/16573/ can change our api w/o notice
23:07:09 <vipul> grapen: i'd like some tests to live in its own repo, so we can gate the python-reddwarfclient patches as well
23:07:54 <cp16net> hub-cap: i agree seemed to be merged before i looked over it all
23:08:00 <hub-cap> cp16net:  it was :)
23:08:15 <hub-cap> LOL
23:08:18 <hub-cap> looks like i was wrong
23:08:21 <spiffxp> hub-cap: roger
23:08:23 <hub-cap> ive been informed it was by my team
23:08:28 <grapen> hub-cap: 16573 was by one of ours. :)
23:08:31 <hub-cap> but i havent met the new guy yet!
23:08:33 <cp16net> yes it was
23:08:35 <grapen> lol!
23:08:36 <cp16net> lol
23:08:37 <hub-cap> apoligies
23:08:57 <grapen> He ran it in real mode first, so we should be good.
23:09:10 <cp16net> yeah i walked him through submitting it to gerrit but it went through fast... :-P
23:09:13 <hub-cap> grapen: i just saw api changes so i got freaked out
23:09:27 <cp16net> to mgmt
23:09:52 <hub-cap> if it was something that we did then im not worried about it affecting our api, cuz we needed it done. and thats why i want the "other" team to look it over. like hp says its ok for them
23:09:54 <jcooley> re api changes -- hence the reason we need to get the api tests back online :)
23:10:03 <hub-cap> jcooley: +1billion
23:10:20 <spiffxp> one other testing q: looks like a bunch of tests from reddwarf-integration are now (back?) in reddwarf, do we need to be updating them in both places, or is there some overlap that can be removed from reddwarf-integration?
23:10:21 <cp16net> yeah !!!!
23:10:24 <hub-cap> we also need to come up w/ some api docs :) (i know rnirmal has a old crufty bluerpint about them)
23:10:40 <hub-cap> spiffxp: ill let grapen speak to that
23:11:03 <spiffxp> hub-cap: looks like reddwarf-integration has a maven project for docs?  or maybe it's out of date...
23:11:14 <grapen> spiffxp: We're going to remove them from RDLI, while still running them in the VM.
23:11:54 <spiffxp> k, still digesting the RD commit so I wasn't yet sure what it means for RDI as a devstack gate etc.
23:12:18 <vipul> grapen: I think it may be good to identify tests that are pure 'integration' tests and maybe leave then in RDI - these will be what get added to Tempest down the road
23:12:29 <cp16net> spiffxp: yeah there is a maven pom in there for docs
23:12:51 <grapen> vipul: Yes. There may be some duplication for awhile, but ultimately we'll separate them out.
23:12:55 <hub-cap> vipul: +1
23:13:26 <spiffxp> I get the sense that until we sort it out, if a test changes in one place, it needs to change in the other as well
23:13:45 <hub-cap> that does not sound fun
23:13:53 <hub-cap> can we attempt to sort it out sooner than later?
23:14:19 <grapen> That's my next commit. But I'd like to get the redstack VM set up first.
23:14:43 <vipul> i think the key dependency is the Devstack integration, if that work is completed sooner, then we can start looking at tempest
23:14:44 <hub-cap> okey, ETA?
23:15:02 <grapen> hub-cap: Sometime next week.
23:15:17 <SlickNik> Clarification: do we have a similar issue for tests between rd and python-rdclient?
23:16:27 <vipul> i think teh tests in python-rd client should only be unit tests, so i don't think those would be ever considered to move out to tempest, if that's what your asking
23:16:47 <grapen> So the RDI tests use python-rdclient, and as a result python-rdclient should work.
23:17:07 <hub-cap> vipul: +1 to unit tests for rdcli
23:17:14 <grapen> rdclient lacks coverage on the CLI though. That's a big pain.
23:17:18 <SlickNik> What's tempest?
23:17:41 <vipul> tempest is the openstack integration test suite - run against live destack
23:17:49 <SlickNik> okay, gotcha.
23:18:14 <vipul> ok anything else to discuss?
23:18:43 <SlickNik> I was asking if there are tests that test rd-client in Tempest that we want to move to the rd-client repo, because we might want to gate on them.
23:19:03 <spiffxp> tempest doesn't as yet do anything non-core-openstack to my knowledge?
23:19:43 <vipul> SlickNik: I think the tests in RD only 'use' the client, so probably not sufficient for gating rdclient repo
23:20:08 <SlickNik> okay, then that shouldn't be an issue; looks like we need to still write all the new rdclient tests.
23:20:08 <vipul> annashen and steveleon are looking at adding some tests separately into that repo to act as gates
23:20:12 <SlickNik> gotcha
23:20:12 <hub-cap> vipul: im done w/ discussion good sir
23:20:16 <SlickNik> cool, thanks
23:20:36 <vipul> cool, thanks everyone - ran _way_ over time
23:20:38 <spiffxp> done here too
23:20:53 <vipul> #endmeeting