#openstack-meeting-alt: Reddwarf

Meeting started by vipul at 22:01:23 UTC (full logs).

Meeting summary

    1. http://wiki.openstack.org/Meetings/RedDwarfMeeting (vipul, 22:01:36)

  1. Action Item Updates (vipul, 22:02:09)
    1. https://blueprints.launchpad.net/reddwarf/+spec/quotas (vipul, 22:03:03)
    2. https://blueprints.launchpad.net/reddwarf/+spec/testr-unit-tests (SlickNik, 22:04:46)
    3. https://github.com/openstack/nova/blob/master/tools/test-requires (hub_cap, 22:08:38)
    4. https://github.com/openstack/nova/tree/master/nova/tests/db (hub_cap, 22:08:38)
    5. ACTION: Discuss use of mock/sqllite/fixtures (vipul, 22:09:56)
    6. ACTION: dkehn, SlickNik to complete CI with devstack-vm-gate with blackbox tests (vipul, 22:12:50)
    7. ACTION: SlickNik to test on Rax Cloud Servers (vipul, 22:15:08)
    8. ACTION: Vipul hub_cap and grapex to debug int-tests on hpcloud (vipul, 22:17:16)
    9. ACTION: hub_cap to talk to heckj and bcwaldon about how they are doing their next gen specs (vipul, 22:20:31)
    10. https://github.com/stackforge/database-api (hub_cap, 22:23:26)
    11. ACTION: , link Reddwarf wiki area (create one if necessary) to http://wiki.openstack.org/Projects (vipul, 22:25:00)
    12. http://wiki.openstack.org/Heat (hub_cap, 22:25:00)
    13. http://wiki.openstack.org/Reddwarf (vipul, 22:25:31)
    14. http://wiki.openstack.org/Reddwarf (hub_cap, 22:25:45)
    15. ACTION: juice_ to push percona bits to Redddwarf-Int (vipul, 22:28:13)

  2. CI Updates (vipul, 22:28:45)
  3. Unit Test updates (vipul, 22:35:57)
    1. AGREED: grapex, we'll need your assistance in Identifying some of the cruft.. since we're in a 'scared to delete cuz we don't know enough about it yet' mode (vipul, 22:45:09)
    2. ACTION: grapex to look over guestagent unit test reviews, work with steveleon to get them merged (vipul, 22:48:14)

  4. Quota / Rate limiting (vipul, 22:48:35)
    1. https://github.com/openstack/nova/commits/master/nova/quota.py (hub_cap, 22:53:08)
    2. https://github.com/openstack/nova/commit/1cf475d7a135c1078cf7df11c261618af501dc37 :) (hub_cap, 22:53:41)
    3. https://github.com/openstack/cinder/blob/master/cinder/quota.py (vipul, 22:56:14)
    4. https://github.com/openstack/nova/commits/master/nova/quota.py (hub_cap, 22:56:51)
    5. ACTION: hub_cap and juice_ to talk to core nova/cinder/oslo about generic quota embedded vs external service (vipul, 22:58:30)

  5. Open Discussion (vipul, 23:02:00)
    1. AGREED: (vipul, 23:12:07)


Meeting ended at 23:13:03 UTC (full logs).

Action items

  1. Discuss use of mock/sqllite/fixtures
  2. dkehn, SlickNik to complete CI with devstack-vm-gate with blackbox tests
  3. SlickNik to test on Rax Cloud Servers
  4. Vipul hub_cap and grapex to debug int-tests on hpcloud
  5. hub_cap to talk to heckj and bcwaldon about how they are doing their next gen specs
  6. , link Reddwarf wiki area (create one if necessary) to http://wiki.openstack.org/Projects
  7. juice_ to push percona bits to Redddwarf-Int
  8. grapex to look over guestagent unit test reviews, work with steveleon to get them merged
  9. hub_cap and juice_ to talk to core nova/cinder/oslo about generic quota embedded vs external service


Action items, by person

  1. dkehn
    1. dkehn, SlickNik to complete CI with devstack-vm-gate with blackbox tests
  2. grapex
    1. Vipul hub_cap and grapex to debug int-tests on hpcloud
    2. grapex to look over guestagent unit test reviews, work with steveleon to get them merged
  3. hub_cap
    1. Vipul hub_cap and grapex to debug int-tests on hpcloud
    2. hub_cap to talk to heckj and bcwaldon about how they are doing their next gen specs
    3. hub_cap and juice_ to talk to core nova/cinder/oslo about generic quota embedded vs external service
  4. juice_
    1. juice_ to push percona bits to Redddwarf-Int
    2. hub_cap and juice_ to talk to core nova/cinder/oslo about generic quota embedded vs external service
  5. openstack
    1. , link Reddwarf wiki area (create one if necessary) to http://wiki.openstack.org/Projects
  6. SlickNik
    1. dkehn, SlickNik to complete CI with devstack-vm-gate with blackbox tests
    2. SlickNik to test on Rax Cloud Servers
  7. steveleon
    1. grapex to look over guestagent unit test reviews, work with steveleon to get them merged
  8. vipul
    1. Vipul hub_cap and grapex to debug int-tests on hpcloud


People present (lines said)

  1. hub_cap (154)
  2. vipul (126)
  3. grapex (50)
  4. SlickNik (34)
  5. esp1 (30)
  6. jcooley (29)
  7. juice_ (28)
  8. dkehn (9)
  9. lifeless (7)
  10. steveleon (5)
  11. openstack (3)


Generated by MeetBot 0.1.4.