22:00:32 <hub_cap> #startmeeting reddwarf
22:00:33 <openstack> Meeting started Tue Feb  5 22:00:32 2013 UTC.  The chair is hub_cap. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:00:35 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
22:00:37 <openstack> The meeting name has been set to 'reddwarf'
22:00:37 <cp16net> PARTAY time!
22:00:44 <hub_cap> lol
22:00:47 <hub_cap> #link
22:00:50 <hub_cap> #link http://wiki.openstack.org/Meetings/RedDwarfMeeting
22:00:55 <hub_cap> #link http://eavesdrop.openstack.org/meetings/reddwarf/2013/reddwarf.2013-01-29-21.59.html
22:01:02 <hub_cap> so lets start w/ the action items
22:01:05 <hub_cap> #topic action items
22:01:14 <steveleon> hello
22:01:34 <hub_cap> i have forwarded joes email to vipul, so he can distribute to the team. and we will chat about the api spec later as its on the list
22:01:43 <vipul> got it
22:01:46 <hub_cap> so has _everyone_ added content to the wiki?
22:01:46 <vipul> thanks!
22:01:48 <hub_cap> np dude
22:01:52 <SlickNik> sounds good.
22:01:58 <SlickNik> It's been growing.
22:02:00 <vipul> yup, checkout the wiki wiki.openstack.org/Reddwarf
22:02:04 <SlickNik> The Wiki, I mean...
22:02:13 <hub_cap> looks great whoever wrote that
22:02:21 <SlickNik> #link http://wiki.openstack.org/Reddwarf
22:02:40 <hub_cap> very nice team
22:02:45 <hub_cap> #kudos
22:02:52 <hub_cap> oh wait thats not a action
22:02:59 <SlickNik> haha, we need to make it one.
22:03:03 <hub_cap> SlickNik: youre up!
22:03:10 <cp16net> #agreed good job on wiki
22:03:11 <hub_cap> looks like u did doc it
22:03:17 <hub_cap> hence the nice pretty wiki
22:03:28 <SlickNik> Yup, added the install and testing info to the wiki
22:03:28 <hub_cap> can u link to your devstack/redstack stuff on the wiki
22:03:41 <SlickNik> #link http://wiki.openstack.org/reddwarf-installation
22:03:43 <cp16net> we should add a pretty picture of the arch to the doc
22:03:51 <hub_cap> thx SlickNik
22:03:52 <SlickNik> #link http://wiki.openstack.org/reddwarf-redstack-testing
22:04:07 <hub_cap> ok lets skip the kaganos bit since there is a percona topic
22:04:09 <hub_cap> sound good?
22:04:10 <SlickNik> Still a work in progress, so will keep refining it
22:04:26 <hub_cap> we can talk about percona in a few
22:04:48 <SlickNik> sounds good, kaganos is here too, I think...
22:04:50 <hub_cap> cool
22:04:52 <hub_cap> grapex: link your sqlite BP
22:05:08 <grapex> https://blueprints.launchpad.net/reddwarf/+spec/in-memory-sqlite
22:05:28 <grapex> #link https://blueprints.launchpad.net/reddwarf/+spec/in-memory-sqlite
22:05:35 <hub_cap> thx sir
22:05:58 <hub_cap> dj was supposed to give an us update but hes playing ping pong
22:06:00 <hub_cap> :P
22:06:11 <hub_cap> ill add repose to the topics
22:06:24 <hub_cap> as a sub of the quotas/limits
22:06:50 <hub_cap> ok so root remove
22:06:54 <hub_cap> lets do it.
22:07:00 <kaganos> i'm here
22:07:02 <vipul> heh..
22:07:02 <hub_cap> its valid, and we agree it should be in the api
22:07:16 <vipul> i laugh cuz i got some pushback from intrenally as well
22:07:25 <hub_cap> #info disable/delete root is good to have in the api
22:07:26 <hub_cap> LOL
22:07:42 <vipul> but if we wanna move forward.. let's leave the Blueprint in
22:07:42 <hub_cap> so then we shouldnt have it? maybe we should discuss offline vipul :)
22:07:42 <SlickNik> kaganos:  we are going to talk about the percona topic in a little bit, so stick around :)
22:07:49 <vipul> yes...
22:07:52 <hub_cap> kk
22:07:53 <vipul> needs further discussion
22:08:01 <hub_cap> ok the next one... i cant type
22:08:07 <hub_cap> so we will never learn
22:08:09 <djohnstone> doh
22:08:11 <hub_cap> err i will never learn
22:08:11 <hub_cap> see
22:08:18 <hub_cap> djohnstone: u have a subtopic in quotas stick around
22:08:23 <djohnstone> ok
22:08:41 <hub_cap> vipul: BP on additional roles
22:08:57 <vipul> was going to file done but didn't find an empty dummy
22:08:59 <hub_cap> did u get that squared away? the whole policy thing
22:09:00 <vipul> #action vipul to file BP on additional roles in reddwarf (user, superuser, admin)
22:09:05 <hub_cap> vipul: ill create u one now
22:09:15 <vipul> Yep, it will be based on policies
22:09:20 <vipul> thanks hub_cap
22:09:44 <hub_cap> ok well done team
22:09:51 <hub_cap> 10 min, all of the action items done
22:09:52 <hub_cap> WOOT
22:09:52 <SlickNik> sweet.
22:09:58 <vipul> that's some sort of a record
22:09:59 <SlickNik> Keep movin' :)
22:10:02 <hub_cap> yup it is
22:10:06 <esp1> awesome!
22:10:11 <steveleon> way what? did we talk about quotas?
22:10:11 <hub_cap> #topic Quotas / Limits Updates
22:10:11 <SlickNik> yeah, I think it is.
22:10:21 <SlickNik> We're talking about it now.
22:10:21 <hub_cap> steveleon: lol we arent done w/ teh whole meeting ;)
22:10:40 <hub_cap> ok do tell. then djohnstone will talk about repose
22:11:19 <steveleon> we have decided to implement the quota feature... and adapt the nova's implementation of it
22:11:21 <steveleon> https://github.com/openstack/nova/blob/master/nova/quota.py
22:11:37 <steveleon> the quota feature will be done as a filter/middleware...
22:11:42 <SlickNik> #link https://github.com/openstack/nova/blob/master/nova/quota.py
22:12:01 <steveleon> so that rax can disable it and use their own (repose)
22:12:11 <vipul> steveleon.. was going to mention this morning.. filter approach may not be complete correct
22:12:17 <vipul> since the instance is actually created by taskmanager
22:12:20 <vipul> is async
22:12:21 <steveleon> by doing it as a filter/middleware, we dont touch business logic
22:13:05 <steveleon> reservation will be made prior the action is performed and commit (or rollback) will be done after
22:13:28 <steveleon> yes vipul... im aware
22:13:50 <hub_cap> and if it breaks in the taskmgr... then its broken (i think servers is the same way WRT quotas)
22:13:51 <djohnstone> steveleon: with the being separate from the business logic this won't be able to assign different quota's to different customers?  Is that correct?
22:14:57 <vipul> ok cool, if we have basically guarantee that it will be created
22:15:18 <steveleon> we can assigned quota based on a tenant_id.... or a class
22:15:26 <steveleon> at least that is how nova does it
22:15:39 <hub_cap> cool
22:15:40 <djohnstone> steveleon: k
22:15:40 <steveleon> a class quota can be applied to a set of customers..
22:15:59 <hub_cap> class: api_abusers :P
22:16:16 <steveleon> vipul: i was thinking that... if the reservation is made and committed and the taskmanager comes back as error. The resources will still be committed
22:16:24 <SlickNik> class: people_who_cant_type :P
22:16:30 <hub_cap> DUDE THATS ME
22:16:32 <steveleon> so the user will have to remove the instance (for example) so that the resouces are released
22:16:47 <hub_cap> ya thats no diff from nova... if a server fails launch isint that ths same functionality? steveleon vipul
22:16:48 <cp16net> hub_cap never learned
22:16:52 <hub_cap> nope...
22:16:54 <cp16net> failed his action item...
22:17:04 <cp16net> oh wait we are not there yet
22:17:18 <vipul> hub_cap yea sounds ok now that you mention how it's implemented in onva
22:17:21 <vipul> nova
22:17:29 <hub_cap> word.
22:17:47 <hub_cap> thas great. have u started working on it steveleon?
22:17:53 <hub_cap> or still analyzing so to speak
22:17:56 <steveleon> so it seems that we might not even use rollback
22:18:06 <hub_cap> itll be nice to have that in the app
22:18:17 <SlickNik> #info steveleon implementing quota feature based on nova's quota implementation
22:18:36 <steveleon> yes. hub_cap. vipul put me up to it :P
22:18:47 <hub_cap> hehe nice :)
22:18:48 <cp16net> do it ! :)
22:18:50 <hub_cap> good man vipul
22:19:09 <hub_cap> ok we ready to move to repose?
22:19:11 <vipul> word
22:19:29 <vipul> sorry in a meeting concurrently.. may be a bit slow today
22:19:29 <SlickNik> sounds good, lay out the plan djohnstone...
22:19:36 <hub_cap> vipul: daz cool
22:19:44 <djohnstone> K.  So I got repose installed and configured on a local dev VM.
22:20:04 <djohnstone> It seems kinda heavy on the configuration side.  Lots of config files to tweak.
22:20:21 <datsun180b> right, and the sun is "kind of" bright at noon
22:20:27 <djohnstone> ha
22:20:30 <SlickNik> (heh)
22:20:56 <hub_cap> lol datsun180b
22:20:56 <djohnstone> rate limiting is really easy to get going.  and can be done on URI level for GET/POST...
22:21:29 <djohnstone> I'm just starting to look at the Quota's part, so I haven't delved into that too deep.
22:21:44 <esp1> datsun180b: sun is not usually a problem in Seattle :)
22:22:05 <steveleon> esp1: Today it is.. I had to close the blinds
22:22:10 <hub_cap> cool lets have a update next meeting too djohnstone
22:22:11 <grapex> datsun180b: There's a lot of config files, but when you dig into Repose it makes sense why (kind of like how in Java there are dozens more files than simialrly sized Python projects).
22:22:15 <esp1> lol
22:22:24 <hub_cap> #action djohnstone to update us with Quotas in repose
22:22:25 <cp16net> first world problems
22:22:25 <djohnstone> I've noticed that there is allot of documentation but that sometime it's lacking in the exact part that you are looking for.  So as one of the other devs put it.  It's really easy, but has a steep learning curve.
22:23:05 <grapex> That sounds like a canidate for an OpenStack project!
22:23:07 <hub_cap> ok we all done w/ quotas i assume?
22:23:11 <cp16net> :)
22:23:15 <djohnstone> :-)
22:23:26 <hub_cap> lulz grapex
22:23:31 <SlickNik> heh
22:23:36 <SlickNik> I think we're good with quotas
22:23:38 <hub_cap> #topic Percona Image Updates
22:23:44 <hub_cap> kaganos: batter up
22:24:00 <kaganos> i'm here ...
22:24:07 <kaganos> so, we've been having some issues ...
22:24:10 <hub_cap> tell us all your dark percona image secrets
22:24:29 <kaganos> well, as of now, still not working :)
22:24:42 <kaganos> we have some issues with the differences between the two deployments
22:24:53 <kaganos> like my.cnf and mysql.conf differences, as well as
22:25:07 <kaganos> some specific code assuming it's stock mysql installed
22:25:20 <hub_cap> ya that is somewhat annoying, the guest apt checks i assume
22:25:20 <kaganos> we're going through it one step at a time
22:25:24 <hub_cap> kaganos: GREAT!
22:25:31 <hub_cap> looking forward to seeing it
22:25:38 <kaganos> same here ...
22:25:39 <kaganos> ;)
22:25:40 <hub_cap> hehe
22:25:43 <vipul> looks like percona doesn't have upstart
22:25:57 <vipul> also doesn't behave the same way on first boot
22:25:57 <hub_cap> like it doesnt come w/ a upstart script? boo
22:26:00 <vipul> no
22:26:01 <SlickNik> yeah, that was the mysql.conf kaganos mentioned earlier.
22:26:06 <SlickNik> I think.
22:26:08 <vipul> so that might be something we have to stick in reddwarf and copy
22:26:10 <kaganos> yep
22:26:16 <dkehn> the upstart is actually add ed by the folks at Ubuntu
22:26:17 <hub_cap> sure vipul
22:26:22 <dkehn> not mysql
22:26:34 <hub_cap> dkehn: thats a good point yall arent using percona from a apt repo via ubuntu right?
22:26:41 <hub_cap> do they have their own apt repo?
22:26:45 <kaganos> yep
22:26:49 <SlickNik> They have their own apt-repo..
22:26:53 <kaganos> don't think they have one through ubuntu at all
22:27:01 <dkehn> they don't
22:27:05 <kaganos> there is this procedure with the gig keys
22:27:13 <hub_cap> yup debian ftw ;)
22:27:18 <kaganos> that's also part of the problem why the current design is difficult for percona
22:27:23 <kaganos> for stock mysql,
22:27:35 <kaganos> there is an assumption that the image might be clean,
22:27:41 <kaganos> and then the code will set mysql on the fly
22:28:00 <kaganos> with percona, it's not just a matter of using a different apt-get install command
22:28:11 <kaganos> there is a bunch of stuff that needs to be taken care of
22:28:13 <hub_cap> for sure
22:28:15 <kaganos> so basically,
22:28:21 <hub_cap> we just were elaborating on the init script wrt that :)
22:28:23 <kaganos> either we won't support that flow with percona
22:28:45 <kaganos> or we revise the whole mechanism to use some sort of extesability
22:29:04 <kaganos> so you pass in interface implementing a provider
22:29:10 <kaganos> so you'd have all there:
22:29:18 <kaganos> is_installed()
22:29:22 <kaganos> is_running()
22:29:29 <kaganos> install_yourself()
22:29:34 <kaganos> config_yourself()
22:29:35 <kaganos> etc.
22:29:51 <kaganos> that would take longer of course ...
22:29:55 <hub_cap> for sure
22:30:08 <kaganos> so currently we're trying to take the shortest path
22:30:10 <hub_cap> but would be nice once the entire oss community abandons stock mysql for maria for instance :P
22:30:12 <SlickNik> for right now, I think the plan is to assume the image is pre-baked with percona (in the percona-case).
22:30:13 <kaganos> possible just to make percona run
22:30:22 <hub_cap> cool
22:30:32 <kaganos> we assume that, but the code doesn't ....
22:30:35 <dkehn> hub_cap, http://www.itwire.com/opinion-and-analysis/open-sauce/58571-monty-has-last-laugh-as-distros-abandon-mysql?goback=.gde_3177671_member_211032261
22:30:41 <kaganos> so, the code needs to be modified somehow ...
22:31:01 * hub_cap reads the article
22:31:13 <dkehn> quicker than you thinbk
22:31:28 <hub_cap> kaganos: for sure, i dont doubt that. it was coded for 1 type, not assumign  > 1. but i welcome the code changes to make it more extensible
22:31:31 <hub_cap> ;)
22:31:47 <kaganos> we'll do our best
22:31:47 <SlickNik> #info percona work still in progress
22:32:02 <hub_cap> good good. time to move on?
22:32:07 <hub_cap> thx for the update kaganos
22:32:12 <SlickNik> #action kaganos still working on getting percona build working with guest agent.
22:32:22 <kaganos> sure
22:32:28 <kaganos> #agree
22:32:34 <kaganos> #aprove
22:32:37 <kaganos> #happy
22:32:37 <SlickNik> Thanks kaganos…good work!
22:32:42 <hub_cap> lol
22:32:43 <hub_cap> #topic Security Groups feature feedback
22:32:45 <SlickNik> heh
22:32:51 <vipul> yes
22:32:53 <vipul> I put that in there
22:32:55 <SlickNik> #tag happy
22:32:55 <hub_cap> so... ive thought about this a bit
22:32:57 <vipul> since I sent an email out friday
22:33:13 <vipul> hub_cap: go for it
22:33:21 <SlickNik> …and what are your thoughts?
22:33:25 <hub_cap> since its not in the core openstack api, id say we welcome security groups, but i dont htink we can put them in our core api... we can keep them an extension tho
22:33:53 <hub_cap> does that make sense? it seems _in general_ a bit of a stretch to have something in our core api that depends on a openstack extension
22:34:09 <vipul> Hmm yea, that's fair
22:34:19 <vipul> We can go with extensions..
22:34:26 <vipul> since not every deployment will need it
22:34:29 <SlickNik> wait, you can install Openstack without security groups?
22:34:34 <hub_cap> ok cool. but i think the api makes sense
22:34:39 <hub_cap> SlickNik:  technically yes
22:34:42 <hub_cap> since its not in the core api
22:34:53 <SlickNik> Wow, didn't know that. News to me…
22:35:05 <SlickNik> If so, I guess that makes sense.
22:35:06 <hub_cap> i mean, it comes w/ those extensions
22:35:36 <hub_cap> but they arent guaranteed
22:36:03 <hub_cap> so we good w/ that? can someone link the bp?
22:36:07 <vipul> #info Security Groups will be extension API
22:36:15 <hub_cap> or wait was it just a email? did u bp it vipul?
22:36:20 <SlickNik> I'm not sure we have a bp yet
22:36:23 <vipul> no bp yet, can you create nother dummy
22:36:32 <SlickNik> #action hub_cap to create bp_dummy
22:36:33 <vipul> sounds like i'm calling you dummy lol
22:36:35 <hub_cap> LOL
22:36:38 <hub_cap> i am
22:36:55 <SlickNik> lol, I added an underscore to make it clearer. :P
22:37:04 <hub_cap> hahaha
22:37:06 <vipul> nice
22:37:35 <hub_cap> LOL
22:37:48 <esp1> #link http://en.wikipedia.org/wiki/Eats,_Shoots_%26_Leaves
22:37:57 <esp1> punctuation woes...
22:38:06 <hub_cap> ok moving on then? i feel like we are all good w/ the api since it mirrors the openstack one
22:38:10 <hub_cap> nice esp1
22:38:34 <hub_cap> #topic API Spec General Update
22:38:39 <SlickNik> sounds good
22:38:47 <hub_cap> ok there is not much to report here. weve gotten together and got thru like 3 api calls
22:38:59 <hub_cap> ill be starting a markdown to keep track of them
22:39:06 <vipul> ok cool
22:39:10 <hub_cap> a la
22:39:11 <hub_cap> #link https://github.com/openstack/identity-api/blob/master/openstack-identity-api/src/markdown/identity-api-v3.md
22:39:26 <vipul> just wanted to give you another heads up.. we're going to be submitting an API in the BP for snapshots..
22:39:27 <hub_cap> and so we can start commenting on them now rather than having ot consume them _all_ at once
22:39:35 <hub_cap> vipul: very nice
22:39:39 <vipul> that BP will also be modified a bit to implement via xtrabackup
22:39:57 <vipul> we agree snapshots are core?
22:40:09 <hub_cap> DEF
22:40:12 <hub_cap> :)
22:40:13 <vipul> k
22:40:25 <vipul> hopefully have something to review next week
22:40:31 <hub_cap> so i dont really have much more to talk about on that... but i will action me
22:40:36 <dkehn> so is there any issues from rax using xtrabackup?
22:40:41 <hub_cap> #action hub_cap to start markdown on api
22:41:17 <hub_cap> well.... its not exactly standard :)
22:41:29 <dkehn> and....
22:41:36 <hub_cap> its free tho rigth?
22:41:45 <dkehn> yes
22:41:50 <hub_cap> if its the right tool for the job i have no issue w/ it
22:41:58 <dkehn> k
22:42:03 <SlickNik> …and open source too, I believe.
22:42:17 <hub_cap> ok im fine w/ it
22:42:23 <vipul> I thin dkehn you may want to call out the pluggability aspects in the BP
22:42:41 <vipul> because we may do xtrabackup now, but nothing should prevent another impl
22:42:48 <hub_cap> ya that would be smart, a pluggable interface. nice vipul
22:43:14 <dkehn> confirmed
22:43:17 <SlickNik> that would be neat.
22:43:27 <vipul> #action dkehn to modify Snapshots BP
22:44:06 <hub_cap> ok so im done w/ items, gen discuss time if thats a-ok
22:44:43 <SlickNik> sounds good..
22:44:44 <hub_cap> #topic Open Discussion
22:44:45 <SlickNik> open issues?
22:44:49 <hub_cap> GO!
22:45:05 <SlickNik> Point to note….
22:45:36 <hub_cap> haha
22:45:36 <SlickNik> dkehn got devstack-vm-gate script running, but hit a snag when he added swift back in...
22:45:41 * Esmute doesnt like to have his real name in the internet
22:46:01 <hub_cap> then def dont /whois you Esmute
22:46:10 <dkehn> we are close but there are a lot of hard coded things in there
22:46:20 <Esmute> crap.. i have to change that too
22:46:22 <SlickNik> there's likely some conflict with the local apt server on the host on 8080 and swift, so we're looking at that.
22:46:26 <vipul> hhe
22:46:39 <SlickNik> we being dkehn and I
22:46:49 <dkehn> I'm actually testing a fix at present
22:46:54 <dkehn> fingers crossed
22:47:19 <esp1> Esmute: it's the just the interweb what could possibly happen?
22:47:21 <SlickNik> sweet, dkehn…I'll probably have some time to look into it this evening, if that doesn't work.
22:47:30 <vipul> datsun180b weren't you working with esp1 on a grants fix?
22:47:30 <dkehn> k
22:47:32 <hub_cap> vewy cool guys
22:47:38 <dkehn> will  let u know
22:47:38 <vipul> do you guys have that sync'd up?
22:47:48 <Esmute> esp1: lol
22:48:10 <esp1> vipul: I think I have way I need from datsun at the moment.  It was very helpful to see what he's working on!
22:48:32 <esp1> I updated the BP as well.
22:48:45 <esp1> #link https://blueprints.launchpad.net/reddwarf/+spec/create-restricted-root-account
22:48:55 <SlickNik> thanks for the link, esp1
22:49:26 <SlickNik> that's pretty much all I had.
22:49:53 <vipul> cool
22:50:09 <SlickNik> anything else?
22:50:20 <SlickNik> If not, we might be poised for another record :)
22:51:00 <hub_cap> WOOT!!!!
22:51:08 <hub_cap> im gonna end it in 1 min if no one has anythign to say
22:51:11 <SlickNik> do it...
22:51:31 <hub_cap> lol
22:51:31 <SlickNik> w00t!
22:51:36 <hub_cap> #endmeeting