20:59:50 <SlickNik> #startmeeting reddwarf
20:59:51 <openstack> Meeting started Tue Apr 23 20:59:50 2013 UTC.  The chair is SlickNik. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:59:52 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:59:54 <openstack> The meeting name has been set to 'reddwarf'
20:59:58 <cp16net> hola
21:00:01 <robertmyers> hello
21:00:05 <imsplitb1t> greets
21:00:07 <SlickNik> hey there folks...
21:00:16 <datsun180b> howdy howdy
21:00:18 <SlickNik> #link https://wiki.openstack.org/wiki/Meetings/RedDwarfMeeting#Agenda_for_the_next_meeting
21:00:23 <cp16net> word
21:00:27 <SlickNik> #link http://eavesdrop.openstack.org/meetings/reddwarf/2013/reddwarf.2013-04-02-20.59.html
21:00:45 <SlickNik> #topic Action Items
21:00:46 <juice> hello
21:01:21 <SlickNik> Let's quickly run through action items...
21:01:24 <esp1> hey
21:01:33 <cp16net> doeet
21:01:50 <steveleon> hello
21:01:56 <SlickNik> I think Vipul's push is still in progress...
21:02:08 <SlickNik> #action Vipul to publish backup API to database-api
21:02:30 <SlickNik> I got the security groups information pushed to the API docs.
21:02:36 <cp16net> nice
21:02:36 <vipul> yup, still need to do that
21:02:52 <cp16net> i saw that today when i was running over the doc
21:02:52 <juice> vipul - can do that today
21:03:00 <SlickNik> Cool, thanks vipul…
21:03:13 <juice> I can do that today
21:03:14 <vipul> thanks juice :P
21:03:17 <vipul> oh
21:03:22 <cp16net> haha
21:03:33 <vipul> w00t, less work for me
21:03:35 <vipul> thanks!
21:03:39 <SlickNik> BackupRef vs BackupUUID, not sure about JorgeW, but steveleon had some discussions and I think we're going with backupUUID for now.
21:03:45 <SlickNik> anything to add steveleon?
21:03:56 <steveleon> yes
21:04:04 <robertmyers> backupID ?
21:04:19 <steveleon> but from the API, we will call it "backup"
21:04:23 <steveleon> it could be a ref or an UUID
21:04:33 <steveleon> for now it is an UUID
21:04:40 <robertmyers> ok
21:04:47 <SlickNik> yes, robertmyers 'backupId' (which is a UUID)
21:04:54 <SlickNik> sorry for the confusing nomenclature.
21:05:08 <juice> does any other api use UUID?
21:05:14 <steveleon> I have made changes in the client and API to use 'backup'...
21:05:23 <cp16net> juice: how about all the other apis?
21:05:25 <cp16net> lol
21:05:30 <juice> it would vote for sticking with backupId
21:05:39 <juice> no need to get technical :)
21:05:41 <steveleon> the UUID will be obtained from it whether it is a UUID or Ref
21:05:51 <vipul> i think backupId makes sense
21:05:59 <vipul> no need to explicity state that's it's a uuid
21:06:12 <cp16net> #agree with ev1
21:06:20 <steveleon> we'll just use 'backup'
21:06:31 <steveleon> we will decide later whether it will contain and ID or a ref URL
21:06:38 <juice> cp16net it was a rhetorical question :)
21:06:56 <cp16net> and i am providing the thetoric
21:06:57 <cp16net> :-P
21:07:00 <SlickNik> lol, let's move on to the next item.
21:07:10 <SlickNik> We have VM gate!
21:07:12 <cp16net> #action cp16net learn to speeel
21:07:31 <datsun180b> hooray
21:07:37 <cp16net> <3
21:07:44 <SlickNik> Vipul, Matty and I have been working on it.
21:08:26 <cp16net> anything else to add?
21:08:27 <SlickNik> There were still some rough edges with the plug-in, but according to Matty they should have been ironed out yesterday.
21:08:30 <cp16net> other than its working now?
21:08:41 <cp16net> oh is the recheck not working on reviews now?
21:08:51 <SlickNik> Ah wanted to bring that up...
21:09:15 <datsun180b> seems you have to mention a bug
21:09:24 <datsun180b> or "no bug"
21:09:25 <SlickNik> Basically the CI team changed it.
21:09:31 <SlickNik> yup datsun180b
21:09:41 <cp16net> oh ok
21:09:46 <SlickNik> #link https://wiki.openstack.org/wiki/GerritJenkinsGithub#Test_Failures
21:09:50 <cp16net> so you have to say recheck #####
21:09:51 <SlickNik> for more info.
21:10:23 <cp16net> ok and that will kick off the tox tests as well at the reddwarf vm tests?
21:10:31 <esp1> cp16net: I think the reddwarf-gate job is still glitch
21:10:35 <esp1> #link http://rdjenkins.dyndns.org:8080/job/Reddwarf-Gate/
21:11:39 <datsun180b> no i'm going to own up to the user tests
21:11:39 <cp16net> ok thats helpful
21:11:40 <steveleon> fake mode text has been failing for me
21:11:44 <SlickNik> The user tests there will fail until some of datsun180b's latest changes get merged...
21:11:48 <steveleon> tests*
21:12:06 <datsun180b> yeah, my latest repairs the compatibility that i broke a few weeks ago with the user hostname changes
21:12:09 <cp16net> yeah you can blame datsun180b
21:12:12 <steveleon> are the tox tests failures related to datsun180b's fix?
21:12:21 <cp16net> likely
21:12:23 <datsun180b> yes, because fake nova changes too
21:12:27 <SlickNik> So I guess we need to review those changes and get the tests running clean as soon as possible...
21:12:37 <datsun180b> YES
21:12:39 <esp1> k. will yell at datsun180b later :)
21:12:43 <SlickNik> datsun180b, can you post a link to the review?
21:12:44 <cp16net> #link https://review.openstack.org/#/c/26781/
21:12:54 <SlickNik> nice, thanks cp16net..
21:13:06 <SlickNik> Also, I don't eat skittles :)
21:13:21 <SlickNik> Is grapex out?
21:13:27 <cp16net> taste the rainbow
21:13:35 <datsun180b> atm i'm looking at something strange about the xml serializer but i'm not really certain if it's really a problem or me just being paranoid
21:13:36 <cp16net> i saw a double rainbow...
21:13:46 <SlickNik> #action SlickNik to learn how to eat skittles?
21:13:51 <djohnstone> grapex is on vacation today
21:14:04 <SlickNik> gotcha djohnstone...
21:14:09 <SlickNik> moving on...
21:14:18 <cp16net> but we had some conversations about the notifications with vipul
21:14:28 <SlickNik> esp1, any update on re-enabling the quota tests w/XML?
21:14:46 <esp1> that's complete.
21:14:51 <vipul> cp16net: were you able to sync up with robertmyers on that?
21:14:59 <datsun180b> got it!
21:15:04 <cp16net> i breifly mentioned it
21:15:13 <vipul> i put some comments on that review btw
21:15:16 <cp16net> but we are on the same page
21:15:17 <SlickNik> Sweet… nice work!
21:15:18 <robertmyers> I just looked at the wiki
21:15:23 <vipul> if you guys have questions, feel free to bug me or juice
21:15:32 <cp16net> for sure!
21:15:44 <robertmyers> if it is just adding fields it shouldn't be a problem
21:16:00 <vipul> there may be some renames.. but you could just to add them as duplicates ot make them work with internal
21:16:04 <robertmyers> cause we can ignore anything we don't want
21:16:25 <vipul> yup
21:16:25 <robertmyers> we already have a pre-processor
21:16:30 <cp16net> yeah most of them can be default config values
21:17:11 <SlickNik> Do you guys want to action anything related to the messages?
21:17:28 <robertmyers> sure, I'll update my pull request
21:17:40 <robertmyers> #action robertmyers update notifications
21:17:47 <juice> robertmyers: did you see any fields that vipul request that would be an issue?
21:17:48 <SlickNik> sweet, thanks...
21:17:59 <juice> request/requested
21:18:10 <SlickNik> #topic Backup Status
21:18:20 <robertmyers> juice: we may have to grab somem info from nova
21:18:34 <robertmyers> other than that no
21:18:38 <juice> coo
21:18:41 <cp16net> yeah i think its all good
21:19:02 <SlickNik> I've pulled all the changes from the shared repo we were all working on and have put up a review in gerrit…
21:19:15 <robertmyers> sweet
21:19:24 <steveleon> the client and API backup work awaits for your reviews too
21:19:41 <SlickNik> It's still a WIP wrt tests, but I wanted to get more eyes on it.
21:19:49 <cp16net> sounds good
21:19:50 <juice> kagan is working on a small change to the segment piece
21:20:04 <SlickNik> Since it is a big change.
21:20:10 <steveleon> jenkins and reddwarf didnt like the last patch but i think it is because of datsun180b's stuff
21:20:19 <cp16net> hahah
21:20:21 <datsun180b> right
21:20:25 <steveleon> haha
21:20:27 <steveleon> i swear
21:20:31 <datsun180b> hard to convey that the client and api changes were married
21:20:38 <SlickNik> There were a couple of questions kagan had for you robertmyers (regarding the swift streaming upload)...
21:20:42 <cp16net> yeah that sucks
21:20:44 <SlickNik> not sure if he's around.
21:21:10 <cp16net> i wish there was a way to make the 2 reviews from different projects related
21:21:17 <kagan> working on it ...
21:21:21 <kagan> almost done i think
21:21:22 <vipul> cp16net: holy shit yes!
21:21:28 <vipul> there has to be a way
21:21:29 <SlickNik> cp16net: Yeah no good way to do that as yet…
21:21:32 <datsun180b> There's dependency relationships but those are typically between patches to the same code
21:21:41 <datsun180b> I'll try screaming about it more often
21:21:49 <SlickNik> #link https://review.openstack.org/#/c/26288/
21:21:57 <juice> cp16net: you've just hit vipul favorite topic i guess
21:22:01 <SlickNik> #link https://review.openstack.org/#/c/27299/
21:22:12 <cp16net> hahah yeah sounds like it
21:22:14 <SlickNik> #link https://review.openstack.org/#/c/27291/
21:22:15 <datsun180b> If those failures are createuser then i'm to blame
21:22:17 <vipul> i'm just happy i'm not the only one that thinks about that
21:22:19 <vipul> lol
21:22:22 <cp16net> glad we share the same thoughts
21:22:33 <juice> vipul (be scared)
21:22:40 <SlickNik> Those are the reviews that need eyeballs — when you guys have a chance.
21:22:43 <vipul> heh
21:22:43 <imsplitb1t> very scared
21:22:50 <datsun180b> gah, that timeout thing in the rdjenkins jobs is a killer, these consoles are impossible to read
21:22:58 <cp16net> SlickNik: all reviews need eye balls
21:23:06 <cp16net> ;)
21:23:13 <datsun180b> but yeah those failures are because of the hostname changes looks like, i'm sorry
21:23:21 <SlickNik> cp16net: very true. I meant backup related. :)
21:23:46 <SlickNik> Anything else to add related to backups?
21:23:46 <vipul> everyone goes quiet at hub_cap enters
21:23:46 <datsun180b> best i can say is every verification method i have available short of rdjenkins has given the patch a clean bill of health
21:24:01 <cp16net> shhhhhh
21:24:04 <cp16net> hes here.
21:24:04 <cp16net> :-P
21:24:05 <hub_cap> Lol right :) I thought my phone was dorked up
21:24:32 <cp16net> sounds like we can move on
21:24:37 <cp16net> from the silence
21:24:43 <SlickNik> #topic Notifications Plan
21:24:53 <steveleon> https://review.openstack.org/#/c/26825/
21:24:54 <steveleon> as well
21:25:02 <cp16net> we covered this a little earlier
21:25:15 <SlickNik> vipul/robertmyers/juice: you guys were discussing this earlier.
21:25:25 <hub_cap> #action hub_cap actually start workin on reddwarf again ;)
21:25:25 <SlickNik> yeah…all good to move on?
21:25:35 <robertmyers> yes
21:25:37 <cp16net> sounds good
21:25:50 <SlickNik> #topic RootWrap
21:26:08 <SlickNik> I saw the bp created by hub_cap
21:26:29 <hub_cap> We should do it. That is all.
21:26:33 <imsplitb1t> lol
21:26:38 <SlickNik> But I don't think we've done anything more wrt this..
21:26:49 <SlickNik> I guess the first step is pulling it in from oslo?
21:26:53 <cp16net> #link https://blueprints.launchpad.net/reddwarf/+spec/parappa-the-rootwrappah
21:26:55 <cp16net> that?
21:27:00 <hub_cap> Hahahahah. Yup
21:27:01 <datsun180b> barf, that name
21:27:04 <cp16net> parappa rapper?
21:27:05 <SlickNik> lol, yeah…the very one...
21:27:28 <imsplitb1t> riddled with details...
21:27:32 <hub_cap> Grapex said that's the best bp name ever
21:27:56 <imsplitb1t> hub_cap: thats because he liked the game I'm sure.  he loves cheesy video games
21:28:10 <hub_cap> X triangle y y
21:28:15 <SlickNik> I think you're missing an 'h' at the end of 'parappa', hub_cap...
21:28:32 <imsplitb1t> so what is this?
21:28:46 <hub_cap> Guest using rootwrapper
21:28:52 <imsplitb1t> the description is so extensive, it's almost silly that I have to ask
21:28:59 <cp16net> oh for refguest
21:29:00 <vipul> lol
21:29:03 <vipul> gotta love bps
21:29:21 <hub_cap> Yup
21:29:30 <SlickNik> It's basically a way to manage sudo elevation without having "sudo this" and "sudo that" sprinkled all over the refguest...
21:29:34 <hub_cap> Hp brought it up. Vipul I think
21:29:59 <vipul> yea basically shouldn't be doing sudo all over
21:30:09 <vipul> better to have those commands / privileges in code
21:30:12 <cp16net> ok i updated the bp with a little context
21:30:17 <SlickNik> Yup. Gonna keep it in the backlog for now and move on….
21:30:20 <imsplitb1t> ok I'm behind that.  are we borrowing the nova implementation or writing our own?
21:30:23 <SlickNik> Thanks cp16net...
21:30:28 <cp16net> yeah...
21:30:32 * cp16net was so confused
21:30:33 <vipul> oslo impl which came from nova i suppose
21:30:34 <datsun180b> i'm guessing we're borrowing since it's already there
21:30:36 <juice> more granular control than what sudoers file gives you
21:30:39 <SlickNik> imsplitbit: oslo...
21:30:44 <imsplitb1t> right sorry thats what I meant
21:30:48 <juice> and easier to manage apparently
21:31:03 <cp16net> code reuse for the win
21:31:08 <SlickNik> #topic Need to ensure Quotas works with XML, avoid skipping tests if the Quota tests fails.
21:31:09 <imsplitb1t> def!
21:31:29 <SlickNik> I think we have this in already, right esp/steveleon?
21:31:31 <cp16net> esp1: ?
21:32:33 <esp1> yeah that was covered before I believe.
21:32:47 <esp1> as far as I know xml tests for quotas have been merged.
21:32:49 <SlickNik> sweet, let's move on then…
21:32:49 <steveleon> yup
21:32:56 <SlickNik> #topic Actions / Action Events
21:33:04 <SlickNik> and hub_cap is here!
21:33:22 <hub_cap> heh
21:33:33 <hub_cap> ya so ive got things working from a decorator perspective
21:33:39 <imsplitb1t> hub_cap: that was a perfect opportunity for you to log out
21:33:42 <hub_cap> and robertmyers had some awesome update suggestions
21:33:48 <hub_cap> imsplitb1t: did i log out?
21:33:55 <robertmyers> yes
21:34:29 <hub_cap> so i have to make the changes
21:34:42 <hub_cap> and then fix the tests
21:35:05 <SlickNik> sweet…sounds good.
21:35:17 <hub_cap> i had broken them cuz they didnt drop in anything to the local.store
21:35:21 <hub_cap> and i expect stuff in the local store
21:35:36 <hub_cap> where stuff is the action uuid
21:35:56 <hub_cap> https://gist.github.com/hub-cap/5374365
21:36:03 <hub_cap> thats the basics for what its displaying
21:36:11 <hub_cap> i fixed the time stuff already
21:36:14 <SlickNik> #link https://review.openstack.org/#/c/26386/
21:36:19 <hub_cap> https://gist.github.com/hub-cap/5374963
21:36:45 <hub_cap> so once i get some time ill fix er up
21:36:45 <hub_cap> its quite simple to use.... so, it shoudl be easy to put everywhere
21:37:00 <cp16net> hub_cap: looks like its coming along really well now
21:37:18 <hub_cap> yar
21:37:22 <SlickNik> Nice.
21:37:24 <hub_cap> its very close
21:37:40 <SlickNik> Sweet. Let's move on...
21:37:49 <hub_cap> aye
21:37:54 <SlickNik> #topic Open Discussion
21:38:01 <djohnstone> I have something.  robertmyers and I were having problems with our VM's when using Ubuntu 12.04.2  Instances would be stuck in build forever.  Once we moved back to Ubuntu 12.04 creating instances worked fine.
21:38:17 <datsun180b> Oh that
21:38:18 <djohnstone> Still looking at why this is.
21:38:24 <robertmyers> indeed, I lost of week of my life
21:38:26 <cp16net> anyone of you guys seen this?
21:38:26 <SlickNik> djohnstone - ouch...
21:38:27 <hub_cap> 12.04.2?
21:38:35 <datsun180b> robertmyers said something about updates to network-manager
21:39:01 <robertmyers> I just scanned the release notes and that popped out
21:39:02 <cp16net> what version we have running on the ci?
21:39:10 <SlickNik> I think we've all been using 12.04
21:39:20 <SlickNik> And that's the one running on the CI box as well.
21:39:21 <cp16net> yeah thats what i have been using locally as wel
21:39:23 <datsun180b> djohnstone and i locked ourselves in a conf room for the better part of this morning and built new vms step by step
21:39:31 <robertmyers> whatever you do don't upgrade
21:39:32 <juice> the disk image builder just states "precise"
21:39:44 <juice> I don't think it nails down a specific version
21:39:47 <datsun180b> i have 12.0.4.1 server 64 and no problems
21:39:57 <juice> are you speaking of the host os?
21:40:01 <cp16net> yes
21:40:01 <datsun180b> right
21:40:04 <juice> ah
21:40:11 <juice> ok thanks for the heads up ;)
21:40:12 <esp1> datsun180b: yeah that's all I've tried
21:40:25 <hub_cap> robertmyers: like, hangover style?
21:40:37 <esmute> I think it was really cool meeting the Rax guys last week
21:40:39 <robertmyers> I don't remember anythin
21:41:10 <SlickNik> Juice: I just checked and the guest instance is 12.04.1
21:41:10 <cp16net> #agreed esmute
21:41:12 <imsplitbit> robertmyers: we actually celebrated the fact that you *weren't* there
21:41:16 <cp16net> it was nice meeting myself
21:41:19 <esp1> I can try the latest 12.04.2 I guess were going to have to use it someday...
21:41:21 <cp16net> :-P
21:41:21 <datsun180b> well i should hope cp16net thinks meeting rax guys is cool
21:41:30 <juice> I don't know that craig guy was kind of a dick
21:41:34 <imsplitbit> no just himself
21:41:40 <datsun180b> this is on record man
21:41:40 <juice> is he on this thing?
21:41:45 <cp16net> juice: takes one to know one... :-P
21:41:57 <hub_cap> #agreed juice
21:42:02 <SlickNik> Yea, it was neat finally putting a face to an IRC nick...
21:42:09 <cp16net> <3 you guys
21:42:13 <datsun180b> well i added to the agenda that i wanted to mention that the hostname things are sort of a stick in the spokes
21:42:23 <datsun180b> but we seem to have covered that pretty well already
21:42:32 <juice> <3 you to cp16net
21:42:35 <juice> to/too
21:43:01 <SlickNik> sorry datsun180b, I didn't refresh the agenda page… ;(
21:43:11 <SlickNik> But I'm glad we covered it already.
21:43:11 <cp16net> wōōt
21:43:12 <datsun180b> no problem, we talked about it
21:43:38 <hub_cap> two?
21:43:38 <cp16net> last thing i would like to bring up
21:43:42 <SlickNik> I see there's an update on incubation/openvz as well…
21:43:55 <cp16net> please review :)
21:44:17 <cp16net> yeah i updated that
21:44:24 <datsun180b> you mean in general? or that one in particular?
21:44:48 <datsun180b> guess neither interpretation is bad advice
21:44:58 <imsplitbit> I've applied for stackforge access for the openvz driver as a separate entity
21:44:58 <hub_cap> weak the internet here went from awesome to on par w/ openstack conf
21:45:11 <imsplitbit> I'm sure that will get denied for some reason... :-)
21:45:19 <cp16net> lol
21:45:25 <hub_cap> lol nobody gets denied to stackforge imsplitbit
21:45:26 <cp16net> lets roll the dice imsplitbit
21:45:35 <imsplitbit> for sure
21:45:39 <imsplitbit> hub_cap: oh I will
21:45:39 <datsun180b> first time for everything
21:45:42 <imsplitbit> yep
21:45:43 <hub_cap> imsplitbit: can u post the review?
21:45:46 <robertmyers> well, to help things along I started on a Horizon dashboard: https://github.com/rmyers/reddwarf-dashboard
21:45:55 <cp16net> yeah i'd like to see it shared
21:45:58 <imsplitbit> #link https://bugs.launchpad.net/openstack-ci/+bug/1171594
21:45:59 <robertmyers> we can make it flashy
21:46:14 <cp16net> oh yeha robertmyers has a slick horizon intergration
21:46:19 <esp1> cool :)
21:46:23 <imsplitbit> now thats cool
21:46:29 <datsun180b> flashy GUIs? what is this, 1986?!?
21:46:30 <esmute> nice nice
21:46:30 <hub_cap> is ther code for it yet imsplitbit?
21:46:32 <imsplitbit> robertmyers is my hero
21:46:34 <robertmyers> please test/break it let me know
21:46:35 <SlickNik> Nice robertmyers! Will play around with it...
21:46:45 <cp16net> hub_cap: vipul you guys could show that off
21:46:46 <cp16net> :-P
21:46:51 <robertmyers> working on backups integration
21:46:54 <hub_cap> imsplitbit: u need to create the group https://launchpad.net/~openvz-nova-driver-core
21:47:01 <datsun180b> Wake me up when we can provision instances with the Lawnmower Man interface
21:47:01 <imsplitbit> if you really want to be my hero robertmyers you'll create an emacs mode for controlling reddwarf...
21:47:06 <juice> I haven't checked out rackspace public cloud yet
21:47:12 <juice> do you guys use horizon?
21:47:19 <imsplitbit> hub_cap: the instructions said to file a bug requesting it
21:47:20 <SlickNik> hub_cap: did you want to update on incubation status?
21:47:28 <imsplitbit> I was just going through the steps
21:47:31 <cp16net> juice: no its different
21:47:32 <hub_cap> imsplitbit: i just did
21:47:32 <robertmyers> imsplitbit: exercise left for the user
21:47:35 <hub_cap> https://launchpad.net/~openvz-nova-driver-core
21:47:36 <hub_cap> done and done
21:47:44 <imsplitbit> bah
21:47:52 <hub_cap> now yer a member
21:47:52 <imsplitbit> thats what I get for following instructions
21:48:00 <hub_cap> i got u babe... bah bah bah bah
21:48:04 <imsplitbit> lol
21:48:10 <hub_cap> yer cher, im sonny
21:48:17 <datsun180b> haha, now you're a core member! now you have to fix stuff!
21:48:19 * hub_cap goes skiing... oh wait
21:48:26 <cp16net> ok anything else?
21:48:42 <hub_cap> imsplitbit: lets chat offline after
21:48:44 <hub_cap> about this
21:48:47 <imsplitbit> sure
21:48:47 <SlickNik> Okay, I think we're good then… all other conversation to continue in #reddwarf...
21:48:53 <imsplitbit> ok!
21:48:55 <SlickNik> #endmeeting