19:00:20 <catherineD> #startmeeting refstack
19:00:21 <openstack> Meeting started Mon Jul 20 19:00:20 2015 UTC and is due to finish in 60 minutes.  The chair is catherineD. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:24 <openstack> The meeting name has been set to 'refstack'
19:00:40 <catherineD> Roll call
19:00:41 <sslypushenko__> o/
19:00:53 <pvaneck> o/
19:01:53 <catherineD> I guess a lot of people may attending OSCON today ..
19:02:12 <catherineD> #link meeting agenda and notes, please feel free to add items https://etherpad.openstack.org/p/refstack-meeting-15-07-20
19:03:32 <catherineD> #topic Relocate RefStack Project
19:05:50 <catherineD> #info David had contacted jeblair.  Next step is to submit patches to infra governance and projects.
19:06:25 <catherineD> David mentioned that he will submit the patches tomorrow
19:06:48 <catherineD> #info There are some stipulation to being adopted by the infra project.
19:07:08 <catherineD> #info 1 Infra cores would automatically core on refstack. 2 refstack-core memebrs would have voting rights on infra specs.
19:07:24 <catherineD> #info 3 Jim has final say on any new core adoption in refstack
19:07:52 <sslypushenko__> catherineD sounds reasonable
19:08:01 <catherineD> I think so
19:08:23 <catherineD> so we will go ahead to submit the patches this week ...
19:08:45 <pvaneck> you said there were a total of three that were needed?
19:09:01 <catherineD> I think 2 but we will find out ...
19:09:57 <catherineD> #action David/Cahterine to submit required patches to relocate Refstack project to Infra
19:10:11 <catherineD> ready for next topic?
19:10:15 <pvaneck> sure
19:10:24 <sslypushenko__> +1
19:10:30 <catherineD> #topic Infra Hosting
19:12:06 <catherineD> fungi 's patch  https://review.openstack.org/#/c/198869/
19:13:03 <catherineD> I have created a refstack.rst file and is ready to add to  https://review.openstack.org/#/c/198869/ ... fungi: are you OK with me adding the refstack.rst file?
19:13:37 <catherineD> I also see Paul submit a patch to puppet-refstack ...
19:14:31 <pvaneck> yea, to have puppet generate a config.json with the base api url
19:14:39 <pvaneck> small patch
19:15:06 <catherineD> other than waiting for  https://review.openstack.org/#/c/198869/ 's review ....
19:15:20 <catherineD> I will ping fungi: later ..
19:15:23 <catherineD> let's move on
19:15:41 <pvaneck> i think you should be good to take over that patch
19:15:49 <pvaneck> since last week he said anyone is welcome to take over that review
19:16:03 <pvaneck> makes sense for one of use to add refstack documentation
19:16:06 <pvaneck> us*
19:16:44 <catherineD> ok I will update the pacth after this meeting ...
19:16:50 <catherineD> #topic OpenStackID integration
19:17:32 <catherineD> sslypushenko__: I am testing the 2 patches ...
19:18:02 <sslypushenko__> pubkey's patches?
19:18:07 <catherineD> yes
19:18:51 <sslypushenko__> I'm working on final patch which allows users to see only their own tests
19:19:30 <sslypushenko__> I think, I will send it tomorrow of day after tomorrow
19:19:32 <catherineD> the public key patches seem to need rebase ... but it should be good for testing right?
19:19:59 <pvaneck> was trying the refstack patch this morning, for some reason hitting: "NetworkError: 401 Unauthorized - http://192.168.56.101:8000/v1/profile/pubkeys" on the profile UI page
19:20:08 <sslypushenko__> I can rebase it now, if it necessary
19:20:09 <pvaneck> will try to see why
19:21:08 <sslypushenko__> can you please provide some logs in refstack channel?
19:21:12 <catherineD> sslypushenko__: yes please try to revase ... maybe it will resolve what pvaneck: encountered ..
19:22:16 <catherineD> sslypushenko__: for this topic I think we are making progress ... let's discuss the detail in #refstack
19:22:23 <sslypushenko__> I don't think so, Only refstack client needs to be rebased
19:22:39 <sslypushenko__> catherineD agreed
19:22:47 <catherineD> moving on ...
19:23:01 <catherineD> #topic Tokyo Refstack  sessions
19:23:34 <catherineD> the only outstanding item here is that we wnat to schedule a room for refstack meeting at Tokyo ...
19:24:41 <catherineD> but according to Chris spcace is limited ... so I am not really pursuing this but will check with Chris next week ..
19:25:22 <catherineD> #topic  Bugs https://bugs.launchpad.net/refstack/+bug/1475407
19:25:25 <uvirtbot> Launchpad bug 1475407 in refstack "Mismatch between DefCore Test List and testr test list" [Undecided,Fix committed]
19:25:25 <openstack> Launchpad bug 1475407 in refstack "Mismatch between DefCore Test List and testr test list" [Undecided,Fix committed] - Assigned to Paul Van Eck (pvaneck-z)
19:26:37 <catherineD> sslypushenko__:  we used to use storyboard for refstack tasks ... but we had decided at one of the meeting that we willl  switch to use launchpad
19:27:01 <sslypushenko__> It will be great time when idemponent id works fine)
19:27:22 <catherineD> so right now as described in the bug ...
19:27:47 <sslypushenko__> catherineD I fully supported using launchpad)
19:28:33 <sslypushenko__> This bug is not related to refstack directly
19:28:48 <catherineD> practically people can not test with the DefCore required test list ... I put this as an item to raise it to hogepodge: attention ...
19:29:02 <sslypushenko__> I hitted it a couple weeks ago
19:29:26 <catherineD> sslypushenko__: it is because we claim that user can use refstack to test DefCore test list ...
19:29:46 <catherineD> yes me too ...
19:30:27 <sslypushenko__> tests FQNs have changed and  Defcore lists became outdated
19:30:41 <catherineD> so pvaneck: had added an option --test-list to refstack .... with this refstack should not be affected by any future changes in Tempest ...
19:31:44 <catherineD> sslypushenko__: agree that FQN changed then DefCore list is outdated ... this is why Refstack request for uuid ... but it does not work out for refstack yet ..
19:32:14 <sslypushenko__> sad but true(
19:32:24 <catherineD> yea
19:32:38 <catherineD> any other thoughts ... or we can move on ...
19:32:58 <sslypushenko__> move on
19:32:59 <catherineD> #topic subunit2sql evaluation and adoption
19:33:43 <sslypushenko__> subunit2sql contains a lof of usefull code
19:34:10 <sslypushenko__> but FQNs ruin ewerythins
19:34:25 <catherineD> I am still investigating to form the aspect that can we use just the API ... No conclusion yet ....
19:35:00 <sslypushenko__> Also dependency on mysql is not good for refstack-client purposes
19:35:46 <catherineD> yes ... that is what I keep reminding everyone that ... refstack client does not have mysql ...
19:35:53 <sslypushenko__> It can be solved but...
19:36:19 <catherineD> sslypushenko__: is it priority ? is my question ..
19:36:24 <Rockyg> o/
19:36:36 <catherineD> Rockyg: Hi are you at OSCON?
19:36:57 <sslypushenko__> I understand why Matthew use mysql in this project
19:38:07 <catherineD> sslypushenko__: I guess we should vote 2 weeks from now whether we will adopt it (or part of it) this cycle ... we may want to defer to the next cycle ..
19:38:41 <sslypushenko__> ok, I will think about it
19:39:11 <catherineD> #action vote on whether to defer adoption of subunit2sql to the next cycle
19:39:26 <catherineD> #topic Pending reviews
19:40:44 <catherineD> #link Refstack public key https://review.openstack.org/#/c/199755/  pvaneck: and I are reviewing ..
19:41:34 <catherineD> #link sslypushenko__: and Catherine to review     Paul'-->Schema version handling https://review.openstack.org/#/c/191610/
19:41:46 <sslypushenko__> It needs unit tests but I will be very glad to see some your reviews
19:42:29 <catherineD> sslypushenko__: please review https://review.openstack.org/#/c/191610/
19:42:39 <catherineD> now refstack-client
19:42:42 <sslypushenko__> Sure thing
19:43:11 <catherineD> #link pvaneck: and Catherine to review https://review.openstack.org/#/c/200589/
19:43:34 <catherineD> about  Mark; --> Tempest version update https://review.openstack.org/#/c/203077/
19:44:03 <catherineD> This Tempest release claim to fix the ssh problem ... I am verifying that ...
19:44:23 <pvaneck> that will await your approval then
19:44:32 <catherineD> #link Catherine to review  https://review.openstack.org/#/c/203077/
19:44:46 <catherineD> pvaneck:  yes please
19:45:13 <catherineD> ok we actually will have 15 for open discussion for the first time :-)
19:45:47 <catherineD> #topic Open discussions
19:46:03 <catherineD> anything you want to bring up?
19:46:54 <pvaneck> Regarding the results-report page and flagged tests. A statement like "This cloud passed 93/96 of non-flagged tests required" is okay?
19:47:44 <pvaneck> was working on making it clearer that a cloud doesnt have to pass flagged tests for compliance
19:49:35 <catherineD> yes not very clear to me ... we need something like excluding the flagged tests, this cloud passes ... but this may cause format inconsistency  ..
19:50:17 <catherineD> I think we are very familiar with the term flagged test ... not non-flagged test ;-)
19:50:46 <pvaneck> fair enough
19:51:24 <catherineD> I want to disucss the action items in the https://etherpad.openstack.org/p/refstack_f2f_may_2015
19:51:56 <catherineD> Please look at the "Action Items based on priorities" section ...
19:52:14 <catherineD> so far we have been operating base on the priority listed on this lissst
19:52:44 <catherineD> Most of the next item to work on is in section 5
19:53:26 <catherineD> sslypushenko__: I want to discuss section 5.2.1 I want to compare results without uploading tests (DefCore use case 3.1)
19:53:46 <sslypushenko__> hmmm...
19:53:49 <pvaneck> so that is a refstack-client addition?
19:54:02 <catherineD> sslypushenko__: you implement  something like this before right?
19:54:02 <sslypushenko__> compare with what?
19:54:17 <catherineD> compare test results ..
19:54:37 <sslypushenko__> I think we can preview test result page  on client side
19:55:06 <pvaneck> this is comparing old results with newer results?
19:55:06 <sslypushenko__> But comparison means that test results are uploaded
19:55:12 <catherineD> pvaneck: I think so because 5.2.1.1 say compare without upload
19:55:30 <pvaneck> hmm
19:55:41 <sslypushenko__> Lets implement online comparison
19:55:44 <catherineD> comapre 2 sets of resutls ...
19:55:49 <sslypushenko__> first
19:56:20 <sslypushenko__> after that we can think how to do it on client side
19:56:32 <pvaneck> +1
19:56:32 <catherineD> so we need to confirm with Rob about where the  comapreson should take place
19:56:44 <sslypushenko__> +!
19:56:48 <catherineD> ok good
19:57:21 <pvaneck> "I want to control tags that can be applied to test run against my cloud (DefCore use case 4.1)"
19:57:30 <pvaneck> tags as in arbitrary strings that a user gives?
19:57:40 <pvaneck> for identification purposes?
19:57:41 <catherineD> #action check with Rob on requirement of section 5.2.1 I want to compare results without uploading tests (DefCore use case 3.1)
19:58:27 <catherineD> #info need to check location (refstack or client side) to implement section 5.1.2
19:58:47 <catherineD> I think tag is for data ... like private, public ...
19:58:57 <catherineD> we are about out of time ...
19:58:57 <pvaneck> ah
19:59:14 <catherineD> at least we get one item in for further discussion next week ...
19:59:19 <catherineD> anything else?
19:59:22 <pvaneck> would it still be user defined?
19:59:49 <catherineD> sslypushenko__: pvaneck: please take a look at the f2f action items https://etherpad.openstack.org/p/refstack_f2f_may_2015
19:59:58 <pvaneck> sure
20:00:14 <catherineD> let me end the meeting ....
20:00:17 <catherineD> thank you
20:00:41 <catherineD> #endmeeting