19:00:41 <catherineD> #startmeeting refstack
19:00:41 <openstack> Meeting started Mon Apr  4 19:00:41 2016 UTC and is due to finish in 60 minutes.  The chair is catherineD. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:42 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:45 <openstack> The meeting name has been set to 'refstack'
19:02:00 <pvaneck> o/
19:03:10 <catherineD> pvaneck: hi
19:03:25 <catherineD> #link meeting agenda and notes, please feel free to add items https://etherpad.openstack.org/p/refstack-meeting-16-04-04
19:06:49 <catherineD> Let's start
19:07:04 <catherineD> #topic RefStack Newton summit discussion topics
19:07:07 <sslypushenko> o/
19:07:29 <catherineD> meeting agenda and notes, please feel free to add items https://etherpad.openstack.org/p/refstack-meeting-16-04-04
19:07:34 <catherineD> sslypushenko: hi
19:08:10 <catherineD> I create a link so we can put the refstack topics for discussion at Austin
19:08:20 <catherineD> #link  Please add your topics to https://etherpad.openstack.org/p/refstack-newton-summit
19:09:18 <catherineD> For the speaker session I create this https://goo.gl/S69Nte
19:09:29 <andrey-mp> hi!
19:09:58 <catherineD> andrey-mp: meeting agenda and notes, please feel free to add items https://etherpad.openstack.org/p/refstack-meeting-16-04-04
19:10:22 <catherineD> andrey-mp:  Hi, will you be at the summit?
19:11:03 <andrey-mp> catherineD: yeah, we will there with Alex
19:12:17 <catherineD> great so we have an overlaps between RefStack and EC2 at 11:00 - 11:40
19:13:20 <catherineD> if  you and Alex are planning to attend the RefStack ... we will have to move the topics that you are interesting in to RefStack earlier session
19:13:35 <andrey-mp> (I don't know the schedule yet)
19:14:32 <andrey-mp> I can talk with Alexabout our plans - but I think its very early to us to make such decisions )
19:14:43 <catherineD> I know EC2 has 2 working session on Wed from 11:00 - 12:30
19:15:12 <catherineD> RefStack has 3 sessions on Wed from 9:00 - 11:40
19:15:34 <catherineD> so we overlap  on 11:00 - 11:40 slots
19:15:48 <andrey-mp> I think that we will try to be on RefStack sessions
19:16:15 <catherineD> anyway could you add topics to https://etherpad.openstack.org/p/refstack-newton-summit
19:16:28 <catherineD> moving on
19:16:33 <andrey-mp> sure
19:16:42 <catherineD> #topic Make puppet pull releases from Pypi
19:16:52 <andrey-mp> review has merged
19:17:15 <pvaneck> finally merged yep :)
19:17:27 <catherineD> yup finally :-)
19:17:59 <catherineD> so the restack.openstack.org website is finally update to with the RefStack repository
19:18:09 <andrey-mp> really?
19:18:18 <catherineD> pvaneck: thanks for keeping working with infra on this
19:18:31 <catherineD> andrey-mp: yes we are at version 1.0.3
19:18:36 <andrey-mp> cool
19:18:36 <sslypushenko> pvaneck: Great job!
19:19:14 <andrey-mp> but do you have a link to pypi website to RefStack package?
19:19:36 <pvaneck> https://pypi.python.org/pypi/refstack
19:20:08 <andrey-mp> thanks! search didn't show me this package
19:20:10 <pvaneck> not sure why refstack doesnt show up when you search 'refstack' though
19:20:40 <pvaneck> yea, I wonder if there is a setting to make it searchable or something
19:21:01 <catherineD> pvaneck: let's look into that ..
19:21:45 <catherineD> pvaneck: thanks again for the pypi work .. this is an importnat milestone for RefStack
19:21:50 <catherineD> moving on ?
19:22:04 <pvaneck> yep
19:22:07 <catherineD> #topic Vendor registation
19:22:16 <andrey-mp> another question - why so many tags? :) I thought that we will implement/test some functionality and then tag the release
19:23:08 <catherineD> andrey-mp: 1.0.1 is the first test of tag ..
19:23:28 <andrey-mp> yes )
19:23:37 <catherineD> 1.0.2 is a tag that we want to release some of the user request features like get test list ...
19:23:46 <andrey-mp> ah, ok )
19:23:58 <catherineD> 1.0.3 is a test of the puppet patch
19:24:05 <andrey-mp> I'got your point
19:24:17 <andrey-mp> lt's move
19:25:35 <catherineD> andrey-mp: Alex said that you were busy until April ... do you have time for vendor registration implementation?  you have most of the code already ..
19:26:13 <andrey-mp> I think that I have some time to do it
19:26:42 <catherineD> andrey-mp: that is really great ... thank you ...
19:26:59 <andrey-mp> and I want to say you - can I extract code of vendors UI or its better to implement REST API of product/software registration?
19:27:14 <andrey-mp> ops - ask you )
19:27:19 <andrey-mp> not say, sorry )
19:27:39 <catherineD> I think it is best to implement the REST API for vendor registration first
19:28:00 <catherineD> pvaneck: sslypushenko: your thoughts?
19:28:36 <catherineD> for product registration we need the spec to merge first
19:28:48 <andrey-mp> yeah, you are right. we merged user management API but not vendors API
19:28:59 <catherineD> #link product registration spec https://review.openstack.org/#/c/292526/
19:29:14 <sslypushenko> catherineD:  agreed
19:29:23 <andrey-mp> ok, I'll make review for vendors API next days
19:29:44 <catherineD> the spec for vendor registration already merged
19:30:14 <catherineD> #link vendore registation spec https://review.openstack.org/#/c/274837/    merged Mar 3
19:30:32 <catherineD> so we can start the implementation of vendor registration
19:30:52 <andrey-mp> and then what we want more - vendors UI or product REST API?
19:31:15 <andrey-mp> (after approving the spec for products)
19:32:21 <catherineD> so I see 4 implementation patches 1) vendor registation 2) product registration 3) vendor UI 4) product UI
19:32:53 <catherineD> of course we have to do 1 first
19:32:59 <andrey-mp> in the same sequence?
19:33:12 <catherineD> not necessary ...
19:33:14 <andrey-mp> ok
19:34:45 <catherineD> UI may take a long time to discuss so I think after 1 ...  if you  can do 2 and 3 together (different patches)  if possible
19:35:06 <andrey-mp> I'll try :)
19:35:31 <catherineD> we need to have vendor registration so at least to on board funcdation member so we can start talking about archiveing data
19:36:16 <catherineD> we have more and more data now on the website that need to be removed or archive soon ..
19:36:29 <catherineD> andrey-mp: thank you very much!
19:36:37 <andrey-mp> my current UI implementation for vendors still there - http://52.49.129.72:8000/
19:37:05 <catherineD> andrey-mp: great !
19:37:49 <catherineD> #action catherineD: sslypushenko: pvaneck: to review UI on https://review.openstack.org/#/c/292526/  for next week discusion
19:38:10 <catherineD> sorry wron link
19:38:42 <catherineD> #action the UI link is http://52.49.129.72:8000/
19:39:12 <sslypushenko> heh, very reach UI), cool!
19:39:39 <catherineD> andrey-mp: it is good that we have a sample to review ...
19:39:43 <catherineD> moving on
19:39:55 <catherineD> #topic Pending reviews
19:40:12 <catherineD> #link     Handle the cases guideline download failure with Test list download  https://review.openstack.org/#/c/296985/
19:40:41 <catherineD> andrey-mp: sslypushenko: could you please review ... I think this patch is ready to be merged
19:41:04 <sslypushenko> merged)
19:41:26 <catherineD> sslypushenko: lightening fast !!!!!! :-)
19:41:33 <catherineD> sslypushenko: ++++
19:41:39 <catherineD> :-)
19:41:50 <catherineD> #link     Add/refactor functional API tests  https://review.openstack.org/#/c/300273/
19:42:11 <catherineD> this one is also ready for merging ...
19:42:48 <catherineD> next
19:42:52 <catherineD> #link     REST API spec to retrieve DefCore Guideline files and test lists https://review.openstack.org/#/c/296829/
19:43:18 <catherineD> andrey-mp: I answer to your question in https://review.openstack.org/#/c/296829/
19:43:33 <sslypushenko> I'll review last patch today
19:43:54 <sslypushenko> refactor patch looks ready to merge
19:44:25 <catherineD> sslypushenko: yep I think the refactor patch is ready to merge tooo
19:44:43 <andrey-mp> catherineD: yeah, I saw you answer.
19:44:58 <catherineD> andrey-mp: any input?
19:45:08 <catherineD> suggestion?
19:45:34 <andrey-mp> only +1 right now )
19:46:05 <catherineD> this patches is mostly for DefCore there are so many aliases tests names added ...so dynamically that a static list will require a lot of maintenant
19:46:15 <andrey-mp> I think that we will have bug discussion later - when we will add new guidelines
19:46:30 <catherineD> andrey-mp: yes agreed
19:46:42 <andrey-mp> bug->big
19:47:20 <catherineD> andrey-mp: it makes a good topic for the f-2-f at the summit ...
19:47:42 <andrey-mp> yeah :)
19:48:07 <catherineD> that is all the topics I have for today ...
19:48:17 <catherineD> #topic Open discussion
19:49:49 <catherineD> sslypushenko: are you OK with the topic arrangement of speaker in https://goo.gl/S69Nte
19:50:09 <sslypushenko> catherineD:  yeap) perfect)
19:50:34 <catherineD> great
19:51:04 <catherineD> anything else to discuss?
19:51:26 <sslypushenko> catherineD:  Do you know what time our presentation will take place?
19:52:03 <catherineD> It is Monday at 11:15 -- 11: 55
19:52:19 <sslypushenko> thx!
19:52:21 <pvaneck> right after the keynotes
19:52:47 <pvaneck> nice to get it out of the way the first day
19:52:54 <catherineD> pvaneck: ++
19:53:22 <catherineD> sslypushenko: andrey-mp: so glat that we will meet in person
19:54:02 <catherineD> that is all for today
19:54:14 <catherineD> we can end 5 mins early ...
19:54:56 <sslypushenko> +
19:54:58 <catherineD> Thank you all!
19:55:16 <catherineD> #endmeeting