19:00:21 <catherineD> #startmeeting refstack
19:00:22 <openstack> Meeting started Tue Jan 31 19:00:21 2017 UTC and is due to finish in 60 minutes.  The chair is catherineD. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:25 <openstack> The meeting name has been set to 'refstack'
19:02:12 <luzC> o/
19:02:43 <catherineD> #link meeting agenda and notes,  https://etherpad.openstack.org/p/refstack-meeting-17-01-31
19:02:51 <pvaneck> o/
19:04:26 <catherineD> let's wait for a few minutes ...
19:04:31 <sslypushenko_> o/ Hi, all!
19:04:59 <catherineD> let's start ... we have very few topics today .. so it should be a short one
19:05:30 <catherineD> #topic Move environment related packages out of requirements.txt
19:06:03 <catherineD> #link     See latest comment in https://review.openstack.org/#/c/410443/  ( Added tox target which checks requirements.txt )
19:06:45 <catherineD> so the PyMYSQL package is needed for unit test and envirment set up ...
19:07:43 <sslypushenko_> It is clear requiremet for env setup
19:07:44 <catherineD> if we put this package in the dev-requirements.txt ( or additional-requirements.txt ) and not in test-requirements.txt ... unit tests fail
19:08:15 <sslypushenko_> I guess we agreed having this package installed manually or in puppet script
19:08:38 <sslypushenko_> But unittests... It sounds pretty strange
19:08:43 <catherineD> if we put it in test-requirements.txt ... then env setup people need to install test-requirements.txt and that may not make sense
19:09:11 <sslypushenko_> Because we are not using real DB for unittesting
19:09:44 <luzC> can it be added in both places... I mean on additional_requirements (for the environment) and test-requirements (for the tests)??
19:10:19 <sslypushenko_> That sounds good to me
19:10:41 <pvaneck> both places is fine
19:11:08 <catherineD> luzC: it seems strange to me that it is in both places ( although technical it does not matter) but some people in the future may think that that is duplicate
19:11:23 <sslypushenko_> Yeap, it will work definitely
19:11:47 <sslypushenko_> Basically we can put it only in test-requirements
19:12:11 <sslypushenko_> because dev environment should also include testing tools
19:12:35 <catherineD> sslypushenko_: if we put it in test ... that means that env setup will need to install test-requirements which have a lot of extra packages
19:13:04 <sslypushenko_> not really
19:13:17 <catherineD> sslypushenko_: not only dev env ... some one may want to set up refstack server on premise
19:13:33 <sslypushenko_> Setup of real env should include PyMySQL as separate step
19:14:25 <sslypushenko_> That is why we agreed to update setup manuall
19:14:35 <catherineD> may be we do not add a dev-requirements at this time we just add installation of pymysql and gunicon on the readme?
19:14:37 <sslypushenko_> and refstack-puppet module
19:15:17 <catherineD> and also add pymysql on the test-requirement?
19:15:45 <sslypushenko_> it is also works for me
19:15:55 <catherineD> sslypushenko_: I think you and I say that samething in different ways ...
19:16:18 <sslypushenko_> while dev-requirements contains only gunicorn
19:16:37 <catherineD> ok ...
19:16:58 <sslypushenko_> we can live without dev-requirements.txt
19:17:04 <catherineD> sslypushenko_: do you think anyone would use gunicorn in real (low traffic) env?
19:17:57 <sslypushenko_> I'd say it is possible)
19:18:08 <sslypushenko_> But I don't know more
19:19:12 <catherineD> #agreed add pymysql to test-requirement .. update readme to add the enviroment required packages
19:19:16 <catherineD> sslypushenko_: thx
19:19:25 <catherineD> moving on ..
19:19:34 <catherineD> #topic Storyboard
19:19:51 <catherineD> should we move to Storyboard?
19:20:18 <catherineD> this is really a roundtrip for us ... since RefStack started from Storyboard and moved to launchpad
19:20:42 <sslypushenko_> I don't any opinion on it
19:20:53 <sslypushenko_> *don't have
19:21:18 <luzC> can I ask why we would want to go back?
19:22:01 <catherineD> luzC: there seems to be a moving of that from the mail list ... I am not sure whether that is the direction from the Foundation or not ...
19:22:22 <catherineD> I asked that question in DefCore and hope that Chris would know
19:22:51 <catherineD> I personal feeling is to wait for more project adoption before we move
19:23:15 <luzC> catherineD +1
19:23:24 <pvaneck> More info about storyboard i found on mailing list: http://lists.openstack.org/pipermail/openstack-dev/2016-December/109329.html
19:24:57 <catherineD> pvaneck: thanks ...
19:25:14 <catherineD> we were fast to use it last time ... but I think this time we will wait ..
19:25:30 <pvaneck> sounds good
19:25:33 <sslypushenko_> +1
19:26:24 <catherineD> #agreed RefStack will wait for more adoption from other projects before moving to Storyboard
19:26:28 <catherineD> great
19:26:49 <catherineD> #topic PTG
19:27:10 <catherineD> #link     Please add RefStack PTG topics to https://etherpad.openstack.org/p/RefStackInteropWGAtlantaPTG
19:28:46 <catherineD> any discussion on PTG?
19:29:31 <catherineD> hearing nothing.  I think we can move to the next topic
19:29:43 <catherineD> #topic Pending reviews
19:30:14 <catherineD> I think we are doing really good ...
19:30:34 <catherineD> #link https://review.openstack.org/#/c/390881/ ( Change doc references from DefCore to Interop Working Group )
19:30:55 <catherineD> luzC: will will hold this one until Defcore rename the github right?
19:31:08 <luzC> yes
19:31:24 <luzC> let me remove the workflow...
19:31:41 <catherineD> luzC: ok thx
19:32:31 <catherineD> sslypushenko_: it is greate that they merge https://review.openstack.org/#/c/410283/
19:32:49 <sslypushenko_> wow!
19:33:14 <sslypushenko_> I should thanks to Alex =)
19:33:20 <catherineD> yup
19:33:36 <catherineD> that bring us to the last topic
19:33:46 <catherineD> #topic Open discussion
19:34:52 <catherineD> anything else to discuss today ?
19:35:19 <luzC> no for me
19:35:26 <pvaneck> nothing from me as well
19:35:33 <sslypushenko_> +1
19:35:44 <catherineD> in that case, we can end early
19:36:02 <catherineD> luzC: sslypushenko_: pvaneck: thank you for attending ...
19:36:06 <sslypushenko_> I wish I could attend PTG
19:36:06 <catherineD> bye everyone
19:36:19 <sslypushenko_> But looks like maybe next  time
19:36:39 <catherineD> sslypushenko_: yea ...I think it is easier with summit and design together right?
19:36:51 <sslypushenko_> Not really
19:37:01 <catherineD> it is easier to jusitify for travel (with speaker session)
19:37:30 <sslypushenko_> Am I right that PTG now will happening only in US ?
19:38:16 <catherineD> sslypushenko_: no, from the email yesterday ... it seems like meeting (PTG, summit ) will be outside of US
19:38:38 <sslypushenko_> not good news =) but will see)
19:40:47 <catherineD> sslypushenko_: I  wish that you can join too ...
19:41:21 <sslypushenko_> will see, will see...
19:41:26 <catherineD> ok that is it for today ... bye everyone ...
19:41:31 <sslypushenko_> bye
19:41:38 <catherineD> #endmeeting