19:00:09 <hogepodge> #startmeeting refstack
19:00:10 <openstack> Meeting started Tue Sep 26 19:00:09 2017 UTC and is due to finish in 60 minutes.  The chair is hogepodge. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:00:13 <openstack> The meeting name has been set to 'refstack'
19:01:06 <hogepodge> #topic Agenda
19:01:09 <hogepodge> #link #link https://etherpad.openstack.org/p/refstack-meeting-17-09-26 agenda
19:01:18 <hogepodge> #link https://etherpad.openstack.org/p/refstack-meeting-17-09-26 agenda
19:01:53 <chandankumar> hogepodge: o/
19:01:56 <pvaneck> o/
19:02:02 <rockyg> o/
19:03:34 <mguiney> o/
19:03:40 <hogepodge> #topic Meeting times
19:04:45 <hogepodge> Picking up where we left off from last week on meeting scheduling we have two items. The first is setting this time to be earlier, the second it to establish a later time to allow for more contributions from the other side of the world.
19:05:12 <hogepodge> chandankumar so it would be easier for you if we found a meeting time at 1800 UTC?
19:05:40 <chandankumar> hogepodge: yes 1800 UTC would be good.
19:06:01 <mguiney> that would be ideal for me, I have a class at noon
19:06:26 <pvaneck> that is okay with me, and I believe catherineD said it was okay as well
19:06:54 <pvaneck> dont think anyone has the slot before us in this channel anyway
19:07:03 <rockyg> works better for me, too
19:07:10 <catherineD> o/
19:07:20 <chandankumar> hogepodge: currently many of the projects are doing meeting in their channel
19:07:40 <chandankumar> hogepodge: it also helps more people to participate and it also solves the slot issue.
19:08:01 <chandankumar> s/many/some
19:08:02 <hogepodge> chandankumar: typically it's frowned upon to not use the official openstack meeting channels
19:08:30 <hogepodge> I can schedule this meeting for earlier
19:08:45 <mguiney> excellent, that++
19:09:01 <chandankumar> hogepodge: that will work :-)
19:09:05 <hogepodge> Should I also be looking to schedule a meeting around 00:00 UTC? We can tick-tock. (that's 5 PM in Pacific Time)
19:10:37 <chandankumar> morning time in india : 5 AM.
19:10:56 <hogepodge> chandankumar: what city?
19:11:05 <chandankumar> hogepodge: pune
19:11:21 <chandankumar> sorry 5:30 A.M.
19:12:14 <mguiney> ooof that's early
19:12:14 <chandankumar> i think 1800 UTC would be better.
19:12:39 <chandankumar> or what about biweekly to see how it goes?
19:12:57 <chandankumar> one at 18:00 UTC and another at 00:00 UTC
19:13:04 <hogepodge> Yeah, thinking
19:13:13 <hogepodge> Do we have contributors in China?
19:13:31 <hogepodge> #link https://www.timeanddate.com/worldclock/meetingtime.html?month=10&day=3&year=2017&p1=202&p2=33&p3=1038&iv=0
19:13:43 <catherineD> 00:00 UTC is too early for chandankumar:
19:14:00 * chandankumar will be in dead sleep that time.
19:14:21 <hogepodge> We have five contributors in Pacific time, one in Pune. Where else?
19:15:37 <hogepodge> I guess my suggestion for now is to have one time at 18:00 and we can revisit if we need to
19:15:58 <chandankumar> +1
19:16:15 <hogepodge> 18 is still 11:30 PM your time chandankumar, we can try to do earlier too
19:16:29 <chandankumar> hogepodge: it is ok for me.
19:16:57 <catherineD> does 17:00 work for everyone?
19:16:59 <hogepodge> chandankumar: ok, I figure if we're going to move it we should make it as good for you and everyone else as possible
19:17:12 <catherineD> hogepodge: ++
19:17:21 <chandankumar> hogepodge: thanks :-)
19:17:34 <hogepodge> 17:00 works for me
19:17:37 <pvaneck> works for me
19:17:46 <chandankumar> me too
19:18:20 <catherineD> chandankumar: at least it ends before mid night with 17:00
19:18:40 <chandankumar> catherineD: yes.
19:18:53 <hogepodge> ok, hearing no objections I will update the calendar to 17:00 going forward. Thanks everyone, I'm really happy to be making this change.
19:19:15 <chandankumar> catherineD: hogepodge thanks :-)
19:19:23 <hogepodge> #action hogepodge to update RefStack meeting time to 17:00 weekly
19:19:44 <mguiney> 1700 works for me too
19:20:06 <hogepodge> #topic Tempest Autoconfig
19:20:36 <luzC1> hodgepodge: do we need to update the wiki too?
19:20:36 <hogepodge> #link https://review.openstack.org/#/c/489421/ RefStack Client Tempest Autoconfig Spec
19:21:12 <hogepodge> luzC1: probably :-) Thanks for reminding me of that too.
19:21:29 <chandankumar> hogepodge: i was discussing with tosky, one of the question came about moving to openstack namespace
19:21:37 <chandankumar> from ptg.
19:22:05 <hogepodge> chandankumar: yeah, I guess it's a bigger issue overall. It's one of the items addressed in the spec
19:23:02 <hogepodge> it shouldn't be difficult to add. in openstack namespace is distinct from being an official openstack project
19:23:44 <chandankumar> hogepodge: i will submit the review on project-config in order to import code from that rh-openstack/python-tempestconf to openstack/python-tempestconf
19:23:59 <chandankumar> s/code/repo
19:24:40 <hogepodge> chandankumar: excellent, when you make the submission can you be sure to attach the team on the review so we can give +1 feedback for the infra team?
19:25:33 <hogepodge> #action chandankumar submit project-config patch to import rh-openstack/python-tempestconf to openstack/python-tempestconf
19:25:35 <chandankumar> hogepodge: for becoming an official openstack project under governance it will go under here na https://github.com/openstack/governance/blob/master/reference/projects.yaml#L4004 ?
19:27:06 <hogepodge> It seems like a good start. If the community wants to classify it differently it would surface in the reviews. I'm happy to make it a RefStack sub-project. How do you think the dev team from Red Hat will feel about it? Would they want it somewhere else like under Triple-O or RDO?
19:28:12 <chandankumar> hogepodge: i will check with EmilienM, tosky and dmellado and RDO folks about the same and submit the review based on that
19:28:40 <hogepodge> Thank you
19:28:48 <chandankumar> we wanted to move it under openstack namespace but never thought where to keep
19:29:44 <hogepodge> Any other items on this topic?
19:29:54 <chandankumar> currently no.
19:30:47 <hogepodge> #topic Subunit Upload
19:31:06 <hogepodge> #link https://review.openstack.org/#/c/498735/ Alembic Table Change
19:31:37 <hogepodge> The first review looks mostly good, but I'd like to pass the non-voting code coverage gate
19:31:55 <hogepodge> #link https://review.openstack.org/#/c/506826/ (API Spec)
19:32:11 <hogepodge> mguiney: can comment on the proposed API Spec
19:32:45 <mguiney> yep! it's a bit lengthy, I know, but i wanted to get good coverage on some options we had for implementation
19:33:25 <hogepodge> luzC: Also, you were going to check out some tooling to help out with verification?
19:33:47 <mguiney> I am still in the process of getting subunit2sql testing done, there are some interesting version discrepancies that have caused me problems, but i'll find a way ti make it work
19:34:37 <mguiney> I should be able to add more detail on certain aspects of the proposed implelentation when I get a little farther into this
19:34:55 <hogepodge> everyone please review and leave comments
19:35:19 <mguiney> thank you much, your input would be very appreciated!
19:35:21 <luzC> hogepodge: yes, I looked briefly but everything involves processing/transforming the information on the file... I'll take a look again and also to the spec to add whatever is needed
19:35:34 <luzC> ** in regards of file verification
19:36:05 <hogepodge> mtreinish: might have some input on how to write a verification only script that wasn't transformative. It would be nice to not be a hack.
19:37:20 <luzC> ok, I'll ping him offline
19:38:08 <hogepodge> any other comments?
19:38:48 <hogepodge> #topic Result Verification Field and Update
19:39:22 <hogepodge> catherineD: pvaneck: yesterday mguiney and I were talking about the steps to do this, and we realized that part of the whole goal was to disable anonymous uploads
19:39:30 <mguiney> we have a patch for this that i'd love to get merged as soon as possbile
19:39:33 <mguiney> *possible
19:39:42 <hogepodge> we realized that you had the best idea of how to do that
19:39:48 <mguiney> given that it is 100% neccessary to make it functional
19:40:05 <hogepodge> #link https://review.openstack.org/#/c/499956/ (script update and fixes)
19:40:28 <mtreinish> hogepodge: ?
19:41:07 <hogepodge> mtreinish: a script to verify that candidate subunit input is valid
19:41:34 <hogepodge> (well, library method is more like it)
19:41:35 <mtreinish> hogepodge: in what way? like the results are from an authentic run, or that it's valid subunit?
19:41:45 <hogepodge> that it's valid
19:42:12 <hogepodge> mtreinish: luzC can catch up with you on it
19:42:15 <mtreinish> ok
19:42:30 <mtreinish> fwiw, it's not that hard
19:43:02 <hogepodge> mtreinish: good :-)
19:43:09 <hogepodge> catherineD:
19:43:29 <catherineD> yes
19:43:32 <hogepodge> catherineD: any advice on disabling anonymous uploads?
19:44:38 <catherineD> I think it is time to disable anonymous uploads ... I believe users should be familiar with private updload now
19:45:01 <hogepodge> is it difficult to do in code?
19:45:14 <catherineD> it should not
19:45:26 <hogepodge> We want to disable the upload so we can run the script and not have to worry about running it again
19:45:36 <hogepodge> (disable anonymous upload)
19:46:18 <catherineD> which script is that?
19:46:58 <hogepodge> catherineD: the one we're going to use to mark all results that have been used as results for the Marketplace and OpenStack Powered
19:47:43 <catherineD> That script should mostly dealing with historic data ...
19:48:01 <hogepodge> catherineD: the script mguiney wrote will take a list of results from our Marketplace database, do some sanity checking, then mark the results as having been used for validation
19:48:31 <hogepodge> catherineD: but going forward I don't want to have any more anonymous data uploaded, so I want to turn that feature off
19:48:43 <catherineD> for future data  .. API should be used to set the verification flag
19:49:05 <pvaneck> https://github.com/openstack/refstack/blob/master/refstack/api/controllers/results.py#L138 just have to change logic here to always require the X-Public-Key header I believe
19:49:07 <hogepodge> catherineD: we are using the API for that
19:49:13 <catherineD> agree on turining the anonymous feature off
19:49:29 <hogepodge> pvaneck: ah, good
19:50:06 <catherineD> I mean in the furture we do not need to run the script to set the verification flag ..
19:50:14 <hogepodge> pvaneck: probably return 401?
19:50:32 <hogepodge> catherineD: ok
19:50:54 <hogepodge> catherineD: yes, we need to think about what foundation does to automate the setting of that flag as results roll in.
19:51:07 <catherineD> yea
19:51:08 <pvaneck> hmm yeah, 401 works or 400 for request without proper headers
19:51:58 <catherineD> at that point .. foundation just need to deal with the new certificatio reuest .. maybe set the flag after fpudnatio nupdate hte marketplace with the new data
19:52:06 <hogepodge> Or maybe 403?
19:52:15 <mguiney> would it make sense to maybe get the script to the point at which it is run periodically on a cron?
19:52:30 <catherineD> mguiney: I don't think so ...
19:52:38 * mguiney nods
19:52:40 <hogepodge> catherineD: yeah, I just would need a little tool to wrap the API call, or make the call from our internal database (which would probably be better)
19:52:40 <catherineD> the script should be a one time even
19:52:56 <hogepodge> mguiney: I wouldn't want to do a cron
19:52:56 <mguiney> k, just wanted to make sure we shouldnt just be doing the sync automatically
19:53:23 <hogepodge> mguiney: but a trigger from marketplace update makes sense. we can talk with jimmy about it
19:53:30 * mguiney nods
19:53:50 <catherineD> hogepodge: ++
19:54:13 <mtreinish> catherineD, hogepodge: http://paste.openstack.org/show/621980/
19:54:14 <hogepodge> Good discussion on this, thanks everyone for your input.
19:54:24 <mtreinish> luzC: ^^^ sry, wrong tab replace
19:55:07 <hogepodge> ok, last topics before time runs out
19:55:22 <hogepodge> #topic Replace ostestr with tempest run
19:55:25 <luzC> mtreinish: thank you :-)
19:55:49 <hogepodge> I need to test this and may include a new gate job that runs RefStack Client against stable devstack
19:56:10 <hogepodge> or master, I don't know which would be better
19:56:25 <hogepodge> #link https://review.openstack.org/#/c/503209/ (hogepodge) WIP
19:56:26 <chandankumar> hogepodge: i think both would be better
19:56:47 <hogepodge> chandankumar: +1
19:56:52 <chandankumar> one with master and another with stable branches
19:56:57 <rockyg> ++
19:57:31 <hogepodge> chandankumar: I'll get cracking on it :-)
19:57:42 <hogepodge> #topic Open Discussion
19:57:45 <hogepodge> Any final thoughts?
19:58:05 <hogepodge> We have a work item for producing API docs but right it's backlogged until we free up some more cycles
19:58:52 <mguiney> we do kind of have a lot in the works right now :)
19:59:16 <hogepodge> Thanks everyone!
19:59:34 <hogepodge> See you all bright and early next week (or less late in some instances) ;-)
19:59:36 <rockyg> Thanks!  and yeah.  Lots of work on your plates
19:59:56 <rockyg> hogepodge: send a mail to the ML with new times
20:00:01 <catherineD> chandankumar: hope the new time works better for you !!
20:00:02 <hogepodge> #endmeeting