17:01:14 <hogepodge> #startmeeting refstack
17:01:15 <openstack> Meeting started Tue Jan 16 17:01:14 2018 UTC and is due to finish in 60 minutes. The chair is hogepodge. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:18 <openstack> The meeting name has been set to 'refstack'
17:01:34 <hogepodge> #link https://etherpad.openstack.org/p/refstack-meeting-18-01-16 agenda
17:01:58 <hogepodge> Hello everybody! Please add any additional items to the agenda. I'll give folks a few minutes to arrive.
17:03:34 <mguiney> o/
17:03:37 <tosky> o/
17:04:27 <hogepodge> ping luzC_
17:04:59 <hogepodge> ok, small crew today, but let's get started
17:05:15 <hogepodge> #topic upcoming meetings
17:05:48 <hogepodge> I will be at our staff offsite next week, so won't be available. We can either run the meeting or cancel it.
17:06:04 <hogepodge> (I would have mguiney host the meeting if we wanted to have it)
17:06:57 <hogepodge> With the light load, I'm inclined for us to just cancel it.
17:07:23 <mguiney> i may send out an email of pending patches/patches up for review, if we do
17:08:21 <hogepodge> does anyone want to have the meeting next week?
17:09:04 <hogepodge> tough crowd ;-)
17:09:29 <mguiney> i mean, i would, but as one of the people with patches up/incoming, i'm a bit biased
17:10:08 <hogepodge> mguiney: sounds great to me. I'll have you run the meeting and if I can drop in I will.
17:10:15 <tosky> you can always ping people around on the channel; no strong opinion on my side
17:10:19 * mguiney nods
17:10:22 <mguiney> ok
17:11:24 <hogepodge> #topic PTG
17:11:47 <hogepodge> #link https://etherpad.openstack.org/p/InteropDublin2018PTG Planninc Doc
17:12:03 <hogepodge> Reminder of the upcoming PTG.
17:12:22 <hogepodge> We'll be splitting time between InteropWG and RefStack, so drop your topics in.
17:13:09 <hogepodge> A few topics I'll want to cover will be dropping Python 2 support, and moving RefStack into more of a maintenance phase after some key features land.
17:13:45 <hogepodge> We'll also have space to talk about python-tempestconf and how it relates to the refstack-client
17:13:53 <tosky> dropping Python 2 for all projects, or "just" the RefStack server?
17:14:05 <hogepodge> Just the RefStack server.
17:14:21 <tosky> ah, ok - because if it applies to the client too, we should accelerate the py3 support for tempestconf too
17:14:29 <tosky> I mean, we should implement it anyway, but...
17:15:31 <hogepodge> In the last patch we landed, we uncovered some code that wasn't py3 compatible, and I personally feel that supporting two code-bases on a server with a very small deployment footprint doesn't warrant trying to support two versions. I'd rather chase down all the python2'isms and make it py3 clean.
17:16:00 <tosky> yes, for the server it definitely makes sense
17:16:08 <hogepodge> On the user facing side, we have so many users that are on systems like CentOS 7 and OS X (where py27 is default) that I don't want to make life harder for them.
17:17:52 <hogepodge> But, returning to the topic, please fill out the etherpad with your desired work items, and I'll start putting together a schedule (which we can adjust to account for conflicts with other project work)
17:18:17 * mguiney nods
17:19:11 <hogepodge> #topic PTL Elections
17:19:22 <tosky> uh, already that time
17:19:37 <hogepodge> It's PTL election season. Anyone want to take leadership of the team?
17:20:48 <hogepodge> I'm happy to keep managing it, but my vision is to get us to a more stable place and put us into official maintenance mode (on the server side at least). If someone has grander ambitions this would be your chance to step in.
17:21:18 <hogepodge> python-tempestconf would continue to be actively developed, because it's a young project and of broader interest to the community.
17:21:49 <tosky> well, the maintaince mode can always be revisited if new requirements/code/workload/TC decisions come
17:21:59 * mguiney nods
17:22:33 <hogepodge> :-)
17:23:14 <hogepodge> We still have features we need to develop, so it's not happening right now. But by mid year I'd like the server to just be chugging along and doing it's work
17:23:15 <mguiney> i'd be glad to run, but am also still new enough that i dont want to step on the toes of someone more experienced
17:24:30 <hogepodge> The additional responsibilities are mostly in organizing and running the meetings.
17:24:59 * mguiney nods
17:25:08 <hogepodge> We can chat about it later today :-)
17:25:08 <mguiney> i can definitely do that then
17:25:12 <mguiney> cool
17:25:37 <hogepodge> #topic current reviews
17:25:44 <hogepodge> Disable Anonymous Upload
17:26:05 <mguiney> merged, finally!
17:26:16 <hogepodge> Patch merged after one bit of testing (who would have guessed that u"False" evaluates to True?) Thanks mguiney for catching that.
17:26:44 <hogepodge> Work items to finish off that task are here
17:27:09 <hogepodge> #link https://etherpad.openstack.org/p/refstack-disable-anonymous-upload
17:27:21 <hogepodge> (oh wait, that etherpad is empty... I thought we had a list of work items)
17:27:42 <hogepodge> I'll dig through our meeting history and paste them into that therpad.
17:28:17 <hogepodge> Need to make the announcement that we're disabling uploads, make the switch on the server, then run mguiney's script for marking anonymous data that was used for validation.
17:28:29 <mguiney> was probably in some similarly named pad
17:28:59 <hogepodge> copy-paste left us with a dangling reference.
17:29:01 <mguiney> should we make one more check that the current dataset is up to date, as well?
17:29:50 <hogepodge> mguiney: yes, new test results have come in.
17:30:15 <hogepodge> We'll have to create a new dataset based once anonymous uploads have been disabled.
17:30:49 <hogepodge> #link https://review.openstack.org/#/c/528831/ npm4 -> npm6 documentation
17:31:22 <hogepodge> pvaneck has a patch to update documentation from npm4 -> npm6
17:31:55 <hogepodge> but he rightly states we need to switch the gate jobs over to npm6 to make sure the server actually works with it. So this is one of the work items we'll have to take
17:32:07 <hogepodge> #action update gate jobs to use npm6
17:32:24 <hogepodge> either mguiney or I could take that
17:33:18 <hogepodge> We can work it out this afternoon during our 1:1
17:33:28 <mguiney> can do!
17:34:22 <hogepodge> #link https://review.openstack.org/#/c/530681/ Subunit Upload API
17:34:51 <hogepodge> Major feature for RefStack. Hoping we'll be able to seriously turn our attentions on implementing this one.
17:35:14 <mguiney> this is coming along, though i am currently working with a small issue with getting it to use the proper conf
17:35:47 <mguiney> as soon as i can get that resolved, i should have a new chunk of code to upload
17:36:25 <hogepodge> ok, we should check in with mtreinish to see if he has any ideas on how to smoothly integrate the tooling
17:36:35 <mguiney> can do
17:37:15 <hogepodge> RefStack API documentation is deferred until the higher priority work has merged.
17:37:32 <hogepodge> And with that I'm going to turn it over to tosky for python-tempestconfig work
17:37:39 <hogepodge> #topic Python TempestConf
17:37:46 <hogepodge> #chair tosky
17:37:47 <openstack> Current chairs: hogepodge tosky
17:38:28 <tosky> so, first a note about a review *not* in the list: packstack and devstack tests are now running for each change
17:38:43 <tosky> the review was finally merged - with some extra kicking of zuul
17:38:52 <tosky> and now, about the open reviews...
17:39:14 <tosky> #link https://review.openstack.org/#/c/528380/ Make tempest setup image verification aware
17:39:44 <tosky> untouched since last week, I guess we need to ping the author again; there are some comment from arxcruz|off
17:40:28 <tosky> I'm going fast with the list, we can go back to any of them in case of questions
17:40:49 <tosky> #link https://review.openstack.org/#/c/519714/ Add EC2-API support
17:41:01 <tosky> the author removed +w, but there is a small final change requested
17:41:08 <tosky> I think/hope that it will be merged soon
17:41:56 <tosky> now two changes related to refactoring, I haven't checked them yet; the behavior should be unchanged, but they should make the evolution of the code easier
17:42:09 <tosky> #link https://review.openstack.org/#/c/533138/ Split main to smaller functions
17:42:15 <tosky> (the title says it all)
17:42:42 <tosky> #link https://review.openstack.org/#/c/533434/ Split ClientManager
17:42:52 <tosky> moves one class and related code to a different file
17:43:13 <tosky> I suspect that we may want to release a version before going with refactoring, even if limited
17:43:36 <tosky> chandankumar, who could not attend today, agreed that we could have a release now, around Queens-3
17:44:00 <tosky> and the final review from the list, just landed, a small but useful optimization
17:44:04 <tosky> #link https://review.openstack.org/#/c/533777/ Don't refetch same image over and over
17:44:20 <tosky> zuul timed out, but maybe it's related to the gates - let's see
17:44:36 <tosky> and that's all from my side for today, unless there are questions
17:44:59 <hogepodge> Yes, zuul is getting spectre/meltdown patches, and is being interrupted
17:45:07 <hogepodge> jobs in progress need to be rechecked
17:45:34 <hogepodge> last updates landed this morning, so the gate should be stable going forward
17:45:43 <tosky> there were different queue restarts in the last days
17:45:49 <tosky> hopefully stable :)
17:45:57 <clarkb> we are also upgrading to a bigger server
17:46:07 <hogepodge> I just need to get my hands on the code to review
17:46:12 <hogepodge> hi clarkb! :-)
17:47:34 <tosky> yep, I used the shorter queue during Saturday to merge a review for tempest (and Martin Kopec did the same for the python-tempestconf review that added the test jobs :)
17:48:28 <hogepodge> #topic open discussion
17:48:35 <hogepodge> Anything else anyone wanted to chat about?
17:51:00 <hogepodge> ok, have a great Tuesday!
17:51:04 <hogepodge> #endmeeting