13:01:04 <ttx> #startmeeting releaseteam
13:01:05 <openstack> Meeting started Mon Jun 15 13:01:04 2015 UTC and is due to finish in 60 minutes.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:06 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:01:08 <openstack> The meeting name has been set to 'releaseteam'
13:01:18 <pabelanger> o/
13:01:26 <ttx> Back to ful speed this week
13:01:32 <ttx> we have liberty-1 next week
13:01:42 <ttx> so we might need to complete a few things before then
13:01:55 <dhellmann> courtesy ping for dims and lifeless as library release team members
13:02:06 <ttx> ack
13:02:10 <dims> \o/
13:02:14 <ttx> #topic Things to do before liberty-1
13:02:31 <ttx> So for liberty-1 we'll need...
13:02:41 <ttx> - the script to retrieve completed blueprints
13:03:18 <ttx> - potentially the new preversioning (to tag X.Y.0b1)
13:03:24 <ttx> what else...
13:04:01 <dhellmann> I have a todo to make a list of what those versions should be
13:04:40 <ttx> dhellmann: Currently still hesitating to switch all tp 12 or all to <number-of-versions+1>.0.0
13:05:17 <ttx> If we opt for <number of versions+1> I would pick the number of integrated releases they have been here to simplify
13:05:39 <dhellmann> yeah, I was going to go through and count those for all of the projects, unless you already have a list like that somewhere?
13:05:57 <dhellmann> actually: https://review.openstack.org/191228
13:05:59 <ttx> I don't have such list, but there is a "since" in the integrated-reelase tag that carries the info
13:06:11 <dhellmann> oh, right, forgot about that :-)
13:06:19 <ttx> as official as it gets
13:06:32 <dhellmann> that will make it easier
13:07:22 <ttx> dhellmann: you think we have still time to carry that through before next week ? I think it would be better to not issue any 2015.2.0 tag
13:07:33 <ttx> but we still can if needed
13:08:10 <dhellmann> I'll make the list today
13:08:16 <ttx> I guess we should make it the top discussion at tomorrow's cross-project meeting
13:08:24 <ttx> to have closure on it
13:08:42 <dhellmann> you've convinced me we don't want to use 12 for everyone, so in my mind that is decided
13:08:56 <ttx> also preemptively engaging with most PTLs might be a good idea
13:09:32 <dhellmann> that's a good idea -- we're expecting them for office hours tomorrow, right?
13:09:52 <ttx> tomorrow's office hours is still pretty much opt-in
13:10:00 <ttx> but we can actively ping them before meeting
13:10:18 <dhellmann> ok, how about if I send an email with the proposed versions?
13:10:27 <ttx> heh, that's what I was writing
13:10:52 <ttx> then I can ping the EU/EMEA/APAC-based ones in Tuesday morning
13:10:58 <ttx> during my office hours
13:11:11 <ttx> and you can ping some of the others during yours
13:11:11 <dhellmann> ok, I'll start working on that after we're done with the meeting
13:11:21 <ttx> than we do a catch-all during the cross-project meeting
13:11:38 <ttx> and start pushing the resulting patches wednesday, in time for next week tags
13:12:01 <ttx> I'll take ownership of the Launchpad scripts side
13:12:16 <dhellmann> I can do the patches to update the pre-version values
13:12:25 <ttx> #action dhellmann to calculate and post proposed version numbers to ML
13:12:39 <ttx> #action shellmann and ttx to reach out to PTLs during office hours about next version
13:12:42 <ttx> arh
13:13:04 <ttx> #action ttx to write the new blueprint-grabbing script
13:13:38 <dims> dhellmann: are we going to release python-.*client(s) as well?
13:13:54 <ttx> dims: I don't think so
13:13:58 <dhellmann> no?
13:14:03 <dhellmann> we do have quite a backlog
13:14:14 <ttx> I mean, it's unrelated
13:14:16 <dhellmann> maybe after the milestone?
13:14:20 <dhellmann> ok
13:14:35 <ttx> Alright, anything else in the "must be completed before next week" bucket ?
13:14:54 <ttx> (adding new server versioning discussion to cross-project meeting agenda)
13:15:10 <ttx> Looks like I'll chair that meeting
13:16:42 <ttx> OK, moving on
13:16:43 <dhellmann> I can't think of anything else that has to be done by next week
13:16:54 <ttx> #topic Recentralize library release management
13:17:05 <ttx> This was also added to tomorrow's cross-project meeting agenda
13:17:26 <dhellmann> the patch is up to set the acls, but I haven't asked the infra team to prioritize it yet
13:17:37 <ttx> There doesn't seem to be much objection so far, but I suspect most PTLs missed it
13:17:49 <dhellmann> I think one more round of publicity would be good, so maybe we can target that change for wed, after we've discussed it again
13:17:53 <ttx> so with the discussion up tomorrow that will be a good heads-up
13:18:13 <dhellmann> so far the only comment was to point out a client lib I missed in the original draft of the patch
13:19:04 <ttx> I have the infra spec to review on my TODO list
13:19:09 <ttx> as well as the release-tools reviews
13:19:27 <dhellmann> ttx: there are some changes to the release scripts up for review still, can you put those on your priority review list, too? that will make it easier for dims and lifeless to use the same version I'm using
13:19:32 <dhellmann> heh
13:20:35 <dims> :) ++
13:20:45 <ttx> Anything more on that topic ?
13:21:31 <dhellmann> I haven't decided how proactive I want to be with releases
13:21:44 <dhellmann> for oslo I scanned the unreleased changes weekly to decide when we needed releases
13:21:48 <ttx> At this point I think we can wait and see
13:21:52 <dhellmann> we could do the same with the other libs, or -- yeah
13:22:05 <ttx> as the process gets more streamlined and we have more people to handle it, we can start being proactive
13:22:09 <ttx> one step at a time :)
13:22:29 * dhellmann takes a deep breath
13:22:33 <dims> dhellmann: ttx: i am running ./list_oslo_unreleased_changes.sh and putting it in front of the team in monday meeting
13:22:43 <dims> (oslo meeting)
13:23:16 <dhellmann> dims: sounds good
13:23:22 <ttx> ok; moving on
13:23:51 <ttx> #topic New PTL/RelMgt coordination
13:24:23 <ttx> We are left with building reusable checklists
13:24:43 <ttx> I think we can figure it out as we go during next week
13:24:54 <ttx> I'll have an etherpad ready during my end of the office hours
13:24:59 <ttx> with the points to cover
13:25:23 <ttx> by the time it comes to your side of the office hours it should already have a few critical steps to cover
13:25:29 <dhellmann> k
13:26:10 <ttx> Oh, about releasing in general -- do we want to more officially repurpose openstack-announce for all the announcements ?
13:26:30 <ttx> i.e. push there instead of dev with Reply-To set to dev
13:26:58 <dhellmann> I'm still waffling about that. I see the benefit, though.
13:27:11 <ttx> and communicate to -dev and openstack@lists.o.o that we won't cover annoucnements there anymore so they should subscribe to low-traffic announce)
13:27:30 <ttx> currently we do server release announces to -announce and openstack@
13:27:49 <dhellmann> ok, I guess we should be consistent with the libraries, then, too
13:28:21 <ttx> and lib announce to -dev only
13:28:36 <ttx> I think making them all post to -announce is a good middle way
13:28:42 <dhellmann> yes, that sounds good
13:28:43 <ttx> with reply to set to -dev for libs
13:28:52 <dhellmann> we should announce the change on the other lists
13:28:58 <ttx> Yep, I'll take that on
13:29:14 <ttx> #action ttx to announce convergence to -announce for all release announcements
13:29:27 <ttx> though we could wait for the library release takeover
13:29:30 <dhellmann> #action dhellmann update release note sending script to send to -announce list instead of -dev
13:29:49 <ttx> bah I'll find the rigth wording
13:30:07 <ttx> I need to take 5 min to get my youngest daughter off school apparently
13:30:20 <ttx> Feel free to cover another topic, like onboarding of new release team memebrs
13:30:24 <ttx> I'll brb
13:31:09 <dhellmann> dims: once we have all of the tools merged, I was planning to rely on you to deal with the oslo releases. That will let me concentrate on all of the clients and non-oslo libs.
13:31:47 <dhellmann> and we'll have lifeless to help as well, of course
13:32:23 <dims> dhellmann: sounds good. if i can shadow you to take notes at least one more time, i'll feel comfortable
13:32:52 <dhellmann> sure, we can work through the next batch of releases together
13:33:09 <dhellmann> you may also want to take a look at the spec for starting to automate some of this: https://review.openstack.org/#/c/191193/
13:33:23 <dhellmann> very much a WIP
13:34:30 <dims> ack starred it for later
13:36:16 <ttx> ok, back, sorry about that
13:36:25 <dhellmann> np
13:36:35 <dhellmann> dims: this one may be interesting, too: https://review.openstack.org/#/c/189858/2/release_many.sh,cm
13:37:03 <ttx> I think we have a clear plan for the coming week
13:37:25 <ttx> Let's pass on the release modeling (buckets) thing for this week until we are past l1
13:38:12 <dhellmann> k
13:38:18 <ttx> #topic Open discussion
13:38:40 <ttx> pabelanger, dims: we kind of track work using https://etherpad.openstack.org/p/liberty-release-mgmt
13:39:00 <ttx> I added a new "Onboarding new release team members" section
13:39:18 <pabelanger> ack
13:39:27 <dims> bookmarked
13:40:15 <ttx> dhellmann: see anything else we should discuss/coordinate for this week ?
13:40:48 <ttx> dhellmann: I'll chair the cross-project meeting tomorrow, but rely on you to introduce our two topics ?
13:40:50 <dhellmann> I just (re)noticed the comment about making release management opt-in -- did we mean that to apply to the libs, too? I wonder if my ACL changes includes more projects than it should
13:40:55 <dhellmann> ttx: sure
13:41:22 <ttx> dhellmann: that's a good question
13:41:41 <ttx> maybe we should align with the project teams we "cover"
13:42:00 <dhellmann> I basically updated everything currently under openstack/ that looked like a library
13:42:09 <dhellmann> https://review.openstack.org/#/c/189856/
13:42:13 <ttx> i.e. 5.1.2.1.1 and 5.1.2.1.2
13:42:38 <ttx> excluding things like magnum or magnetodb which we don't handle the server part of yet ?
13:43:19 <ttx> that seems weird to handle the libs of a project team we don't manage the main product of
13:43:19 <dhellmann> yes, I left them out
13:43:48 <ttx> that way we could actually apply the "managed" tag at the project team layer
13:43:55 <dhellmann> yeah, I'm still concerned with bad versioning practices, but as you say, "one step at a time"
13:44:13 <dhellmann> yeah
13:44:29 <ttx> which I think makes more sense
13:44:46 <dhellmann> speaking of tags, I'm going to propose one to indicate that a repo contains a library rather than a server project, so we can have tools that look at all of the library project repos
13:45:21 <ttx> dhellmann: you prefer a "lib" tag than a "server"/"mainthing" tag ?
13:45:31 <ttx> I agree that sidesteps the naming problem gracefully
13:45:40 <ttx> but that will result in more lines
13:45:58 <dhellmann> we could have both/all of those, but it seems easier to say "show me a list tagged with X" than "show me a list not tagged with Y"
13:47:18 <ttx> hmm, yeah, also some things will likely fall in-between
13:47:35 <ttx> so we could have a "service" and a "library" one
13:47:59 <dhellmann> should those be "release:X" or use some other prefix?
13:48:22 <dhellmann> type:service and type:library?
13:48:47 <ttx> On one hand they are generally useful so type: would be more appropriate
13:49:08 <ttx> on the other release:* will generate less questions (those are the tags driven by this team)
13:49:27 <ttx> maybe try type: and we can retreat to release:* if people complain
13:49:31 <dhellmann> ok
13:50:02 <ttx> type: service will be super useful to sort the grain from the chaff
13:50:23 <ttx> (in, say, the project navigation website)
13:50:34 <dhellmann> true
13:50:59 <ttx> and that lets "everything else" (like, say, zuul) be undetermined
13:51:16 <ttx> service means an openstack service as presented by the keystone catalog
13:51:24 <ttx> imho
13:51:53 <dhellmann> yes, that's how I was thinking of it, too
13:52:43 <ttx> ok, added a few notes under the "buckets" section
13:53:46 <ttx> Alright. anything else ?
13:54:01 <dhellmann> nothing from me
13:55:30 <ttx> Alright, have a good week!
13:55:32 <ttx> #endmeeting