13:04:26 <ttx> #startmeeting releaseteam
13:04:26 <openstack> Meeting started Mon Sep 28 13:04:26 2015 UTC and is due to finish in 60 minutes.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:04:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:04:30 <openstack> The meeting name has been set to 'releaseteam'
13:04:52 <ttx> Agenda @ https://wiki.openstack.org/wiki/Release_Cycle_Management#Meeting
13:05:11 <ttx> First item, two governance reviews requesting addition to release:managed
13:05:29 <ttx> https://review.openstack.org/#/c/226933/ is for Octavia
13:05:43 <ttx> a project under Neutron
13:06:07 <ttx> https://review.openstack.org/#/c/227741/ for gnocchiclient
13:06:50 <dhellmann> the gnocchiclient one is easy, since I think that was just an oversight from when the server project was added
13:06:54 <dhellmann> I've already RC+1 that
13:07:02 <ttx> except the server is not release:managed
13:07:17 <ttx> it's independent
13:07:19 <dhellmann> oh, I thought it was?
13:07:27 <dhellmann> I don't think we want to mix and match
13:07:37 <ttx> so that would be a release:independent + release:managed client lib, which would make it quite unique
13:07:52 <dhellmann> yeah, those are suppose to be mutually exclusive
13:08:03 <ttx> if gnocchi moves to release:cycle* then it surely makes sense
13:09:29 <ttx> for octavia... feels a bit weird to jump to release:cycle-with-milestones and release:managed in one go
13:09:47 <ttx> I'd prefer they prove that they can follow a milestone model first before having us onto them
13:09:49 <dhellmann> what did they do this cycle?
13:09:56 <ttx> independent
13:10:09 <dhellmann> do we know if they did milestones?
13:10:21 <ttx> they just did one tag 5 days ago
13:10:28 <ttx> so it's pretty rawa
13:10:30 <ttx> raw
13:10:42 <dhellmann> ok, I agree, let's get them onto the milestone system before we agree to manage them
13:11:01 <ttx> You going to comment on the reviews ? Or should I ?
13:11:02 <dhellmann> I've left feedback on the gnocchiclient request, do you want to respond to the octavia request?
13:11:22 <ttx> I'll leave it to you
13:11:25 <dhellmann> ok
13:11:36 <ttx> I can +1 you if it gets tough
13:11:58 <ttx> #topic Liberty release coordination
13:12:13 <ttx> #link https://etherpad.openstack.org/p/liberty-final-release
13:12:24 <ttx> We are at release week -2
13:12:44 <ttx> We caught up with the timeline over the last week
13:13:13 <ttx> This week is supposedly calm
13:13:30 <ttx> We should create the requirements branch and end the freeze, maybe today ?
13:13:43 <dhellmann> let me look at the open reviews...
13:14:03 <ttx> We may or may not have to disable the cross-check job
13:14:15 <ttx> We may start issuing early RC2s
13:14:29 <dhellmann> it looks like we don't have any requirements changes that we need, so we could go ahead and branch
13:14:31 <ttx> and we may have a Swift liberty release
13:14:44 <dhellmann> yes, we expect that by the end of the week
13:14:51 <ttx> I expect the bulk of RC2s to come next week when we can finalize the translations imports
13:15:19 <dhellmann> makes sense
13:15:26 <ttx> let me have a quick look at the cross-check thing, see if we need to disable anything
13:15:31 * dhellmann makes a note to document this release schedule in the project-team-guide
13:16:46 <ttx> I feel like we need to at least revert https://review.openstack.org/#/c/217300/2/zuul/layout.yaml
13:17:21 <dhellmann> I think you're right, but see lifeless' comment in https://etherpad.openstack.org/p/liberty-end-of-release-requirements-checklist
13:17:33 <ttx> yeah, that's what makes me pause
13:17:50 <dhellmann> we added tests, and now it seems those would be testing the same thing twice, so I think we can remove them, but his comment makes me doubt my reasoning
13:18:26 <ttx> we have a branch override defined there, and we want it to use stable/liberty instead
13:18:49 <ttx> Let's wait a bit
13:19:05 <ttx> I'll ask clarkb and you can ask lifeless
13:19:10 <dhellmann> ok
13:19:22 <ttx> no need to rush it, not eaxactly that much pressure to add deps yet
13:19:50 <dhellmann> yeah
13:19:59 <dhellmann> we've had a few requests, but no one complained too loudly about having to wait
13:20:10 <ttx> #action ttx to see with clarkb what (if anything) to do to disable the extra cross-check job
13:20:47 <ttx> #action dhellmann to check with lifeless what he meant re: disabling crosscheck
13:21:15 <ttx> #agreed wait until Tuesday morning to create teh requirements stable/liberty branch
13:21:55 <ttx> Otherwise the only big thing that emerged last week release-wide is the Cinder / NetAPP lib licensing issue
13:22:07 <ttx> I think it's under control now, but that may require a rush for a RC2
13:22:19 <ttx> since we don't want to keep that up for long
13:22:45 <dhellmann> yeah, that was a surprise
13:22:49 <ttx> I'll be syncing with PTLs tomorrow re: RC2s
13:23:08 <dhellmann> do you want me to assist with that?
13:23:09 <ttx> see which need an urgent one and which can wait until the end of translations
13:23:28 <ttx> dhellmann: sure, we'll see who I didn't get to by the end of the day
13:23:32 <dhellmann> k
13:23:51 <ttx> dhellmann: anything on your side ?
13:23:59 <dhellmann> if you have some notes for the questions to make sure I ask, please drop them in https://etherpad.openstack.org/p/liberty-final-release
13:24:25 <ttx> sure. I'll probably formulate the questions as I go, but I'll note them down there
13:25:01 <dhellmann> I'm going to spend some time this week pulling together my thoughts about moving off of the strictly synchronized milestone release model, so we can discuss it some before the summit
13:25:02 <ttx> #topic Mitaka release schedule
13:25:17 <ttx> #link https://wiki.openstack.org/wiki/Mitaka_Release_Schedule
13:25:35 <ttx> I'll communicate that today, unless you have a last-minute change for it
13:26:19 <dhellmann> I think I'm going to add a column with R-n countdown so we can document the general end-of-release week highlights in those terms, but that won't change the actual schedule
13:26:30 <ttx> ack, good idea
13:26:46 <ttx> makes teh whole thing a bit less experimental
13:27:22 <ttx> #action ttx to communicate proposed Mitaka release schedule
13:27:28 <ttx> #topic Release management session content brainstorming
13:27:35 <dhellmann> yeah, and having more of this written down is going to be more important, since I don't plan to do as much hand-holding next cycle :-)
13:27:41 <ttx> #link https://etherpad.openstack.org/p/mitaka-release-management
13:29:05 <ttx> I think the two themes are good. Worried we are packing a bit too much into that fishbowl, though
13:29:25 <dhellmann> hmm
13:29:36 <dhellmann> yeah, we might be
13:29:45 <dhellmann> how long are the sessions, 40 minutes?
13:29:50 <ttx> FOr the last point you just added, I don't expect we'll have enough of them in the room to be able to discuss that
13:29:53 <ttx> yeah, 40min
13:30:14 <ttx> maybe move it to the work room so that we prepare docs work
13:31:05 <ttx> The goal of that workroom is to come up with a document like https://etherpad.openstack.org/p/liberty-release-mgmt to outline the work we plan to do during the cycle
13:31:24 <ttx> if we have time left we can start working on it, but it's more to come up with a clear Mitaka plan
13:31:36 <dhellmann> ++
13:31:50 <ttx> I found that page very useful to try to organize and keep up with what we palnned to do, so I epxect you'll like it too :)
13:32:06 <ttx> except we kind of built it along the way, and it's easier to capture while it's hot
13:32:10 <dhellmann> yeah, I did, too
13:32:36 <ttx> so if we can go out of Tokyo with it already compiled, that would really help bootstrap the work afterwards
13:32:41 <dhellmann> this is normally the sort of thing a project team would use blueprints for, but in our case the etherpad worked really well for keeping notes as we went
13:33:18 <ttx> We can use the "contributors meetup" to do the heavy lifting on the tooling refactorig maybe
13:33:28 <dhellmann> I like that
13:33:43 <dhellmann> I have a bunch of the python rewrite started but not submitted for review
13:34:04 <dhellmann> I'm not sure those patches are in a good state for reviews, but I can take a look at them and clean them up before the summit
13:35:29 <ttx> #topic Open discussion
13:35:40 <ttx> OK, that is all I had for the meeting
13:35:46 <dhellmann> while I'm thinking of it, I'm probably taking the day of wed for my birthday
13:35:58 <ttx> great
13:36:22 <ttx> We could discuss the talk sometimes in the next 2 hours ?
13:36:42 <ttx> Like agree on the outline, split the work
13:36:54 <ttx> whenever you can in the next 2 hours I mean
13:37:08 <dhellmann> that's a good idea. I need a few minutes, but could do it more or less right after this meeting if you want
13:37:40 <ttx> ok, let's say in 23 min, I have a few pings I need to answer
13:37:49 <dhellmann> ok, sounds good
13:38:00 <ttx> ok, let's close this
13:38:04 <ttx> #endmeeting